Subject: [Dime] 3588 bis: recommended L4 protocol?

From: Sebastien Decugis <[email-masked]>
Date: Fri, 20 Feb 2009 15:28:10 +0900

Hello,

I think the latest 3588bis draft (-15) is a bit confusing for implementors.

>From RFC3539 and several references in the draft, SCTP seems to be the
recommended transport protocol.
On the other side, the recommended security mechanism is TLS, and in the
latest update TLS/SCTP is not considered at all. So what should be
preferably deployed, TLS/TCP or SCTP(/IPsec) ?

I guess a little clarification would be useful if any new revision is
made...

Best regards,
Sebastien.

-- 
Sebastien Decugis
Research fellow
Network Architecture Group
NICT (nict.go.jp)

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 20 Feb 2009 13:31:09 +0200

The mandatory to implement protocol (from an interoperability point of view)
is TCP (and TLS). 

Ciao
Hannes

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Sebastien Decugis
>Sent: 20 February, 2009 08:28
>To: [email-masked]
>Subject: [Dime] 3588 bis: recommended L4 protocol?
>
>Hello,
>
>On the other side, the recommended security mechanism is TLS, 
>and in the latest update TLS/SCTP is not considered at all. So 
>what should be preferably deployed, TLS/TCP or SCTP(/IPsec) ?
>
>I guess a little clarification would be useful if any new 
>revision is made...
>
>Best regards,
>Sebastien.
>
>--
>Sebastien Decugis
>Research fellow
>_______________________________________________
>DiME mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dime
>