Subject: [Dime] draft-ietf-dime-mip6-split-16.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 14 Apr 2009 11:48:10 +0200

I placed draft-ietf-dime-mip6-split-16.txt on the agenda of the telechat
on 4/23. My question is whether the issues raised by the IANA review
were answered and the actions confirmed. Specifically, Amanda Baber
asked in her review: 

- In the "MIP6 Authentication Mode (MIP6-Auth-Mode AVP)" registry, is
0 reserved or available for assignment? Also, does this registry have
an upper limit?

Thanks and Regards,

Dan

---

From: jouni korhonen <[email-masked]>
Date: Tue, 14 Apr 2009 13:25:34 +0300

Hi Dan,

Yes, I responded to that on March 13, 2009 2:00:32 AM GMT+02:00. See  
below:

> Good catch. The value 0 (zero) is reserved. The upper limit is  
> 4294967295 (i.e. 2^32-1).

I also spotted an error in the proposed IANA allocations:

>>
>> Action 6 (Section 9.5):
>>
>> Upon approval of this document, IANA will create the following
>> registry at
>> http://iana.org/assignments/aaa-parameters/aaa-parameters.xhtml
>>
>> Registry Name: MIP6 Authentication Mode (MIP6-Auth-Mode AVP)
>> Allocation Policy: Specification Required
>> Initial contents of this sub-registry will be:
>>
>> Value Token Reference
>> ---- ----- ---------
>> 1 MIP6_SPLIT [RFC-dime-mip6-split-16]
>
> The token is: MIP6_AUTH_MN_AAA
>
>
> Cheers,
> 	Jouni

Jouni

On Apr 14, 2009, at 12:48 PM, Romascanu, Dan (Dan) wrote:

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 14 Apr 2009 12:27:53 +0200

Thanks. 

Do we need any changes in text by RFC Editor notes? If we do please
recommend. 

Dan

> -----Original Message-----
> From: jouni korhonen [mailto:[email-masked]] 
> Sent: Tuesday, April 14, 2009 1:26 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [Dime] draft-ietf-dime-mip6-split-16.txt
> 
> Hi Dan,
> 
> >> Allocation Policy: Specification Required Initial contents of this 
> >> sub-registry will be:
> >>
> >> Value Token Reference
> >> ---- ----- ---------
> > I placed draft-ietf-dime-mip6-split-16.txt on the agenda of the 
> > telechat on 4/23. My question is whether the issues raised 
> by the IANA 
> > review were answered and the actions confirmed. 
> Specifically, Amanda 
> > Baber asked in her review:
> >

---

From: jouni korhonen <[email-masked]>
Date: Tue, 14 Apr 2009 15:00:27 +0300

Hi Dan,

The IANA considerations in the draft are correct (regarding the Action  
6). For the clarification on the "MIP6 Authentication Mode" registry I  
would replace the text in Section 9.5:

OLD:

    IANA is requested to create a new registry "MIP6 Authentication  
Mode"
    registry for use with the enumerated MIP6-Auth-Mode AVP.  The
    registry will initially contain the following values:

    Token                                        | Value    |  
Description
    ---------------------------------------------+---------- 
+------------
    MIP6_AUTH_MN_AAA                             | 1        | RFC TBD

NEW:

    IANA is requested to create a new registry "MIP6 Authentication  
Mode"
    registry for use with the enumerated MIP6-Auth-Mode AVP. The value
    0 (zero) is reserved and the maximum value is 4294967295 (i.e.  
2^32-1).
    The registry will initially contain the following values:

    Token                                        | Value    |  
Description
    ---------------------------------------------+---------- 
+------------
    MIP6_AUTH_MN_AAA                             | 1        | RFC TBD

Cheers,
	jouni

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 14 Apr 2009 14:01:09 +0200

OK, thanks - I will create the appropriate notes to the RFC Editor. 

Regards,

Dan

-----Original Message-----
From: jouni korhonen [mailto:[email-masked]]
Sent: Tue 4/14/2009 3:00 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]
Subject: Re: [Dime] draft-ietf-dime-mip6-split-16.txt

Hi Dan,

OLD:

    Token                                        | Value    |  
Description

NEW:

    Token                                        | Value    |  
Description

Cheers,
	jouni