Subject: [Dime] I-D Action:draft-ietf-dime-realm-based-redirect-01.txt

From: [email-masked]
Date: Thu, 30 Jul 2009 04:00:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Diameter Maintenance and Extensions Working Group of the IETF.

	Title           : Realm-Based Redirection In Diameter
	Author(s)       : T. Tsou, T. Taylor
	Filename        : draft-ietf-dime-realm-based-redirect-01.txt
	Pages           : 6
	Date            : 2009-07-30

RFC 3588 allows a Diameter redirect agent to specify one or more
individual hosts to which a Diameter message may be redirected by an
upstream Diameter node.  However, in some circumstances an operator
may wish to redirect messages to an alternate domain without
specifying individual hosts.  This document specifies the means by
which this can be achieved.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dime-realm-based-redirect-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Tom Taylor <[email-masked]>
Date: Thu, 30 Jul 2009 14:17:14 +0200

Changes from 00 to 01:

- Added Redirect-Realm-Usage based on meeting discussion.
- Added associated behaviour.
- Added mention that the receiving node will use normal discovery procedures to 
locate a host in the returned domain.
- Deleted mention of Redirect-Host in the receiving node behaviour.

---

From: "Victor Fajardo" <[email-masked]>
Date: Thu, 30 Jul 2009 08:56:19 -0400

Hi Tom,

It was not clear to me if we really wanted to add Redirect-Realm-Usage. I
don't mind adding it if there are real use cases that needs this. But
typically, adding a 'usage' constraint complicates routing decisions and
nodes have to keep extra state. So is there any use case that justifies
adding realm usage constraints ?

-- victor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom
Taylor
Sent: Thursday, July 30, 2009 8:17 AM
To: [email-masked]
Subject: Re: [Dime] I-D Action:draft-ietf-dime-realm-based-redirect-01.txt

Changes from 00 to 01:

- Added mention that the receiving node will use normal discovery procedures
to 

> which this can be achieved.
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Tom Taylor <[email-masked]>
Date: Thu, 30 Jul 2009 15:01:09 +0200

Wolfgang indicated he had some possible use cases in private conversation.

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Thu, 30 Jul 2009 16:09:37 +0300

Maybe Wolfgang can give us some more details about his thoughts then.  

>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Tom Taylor
>Sent: 30 July, 2009 16:01
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [Dime] I-D 
>Action:draft-ietf-dime-realm-based-redirect-01.txt
>
>> It was not clear to me if we really wanted to add 
>> Redirect-Realm-Usage. I don't mind adding it if there are real use 
>> cases that needs this. But typically, adding a 'usage' constraint 
>> complicates routing decisions and nodes have to keep extra state. So 
>> is there any use case that justifies adding realm usage constraints ?
>> 
>> -- victor
>> 
>> 
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of Tom Taylor
>> Subject: Re: [Dime] I-D 
>> Action:draft-ietf-dime-realm-based-redirect-01.txt
>> 
>> Changes from 00 to 01:
>> 
>> - Added mention that the receiving node will use normal discovery 
>> procedures to locate a host in the returned domain.

---

From: Sebastien Decugis <[email-masked]>
Date: Thu, 30 Jul 2009 15:16:59 +0200

Hi,

Just quickly going through the new draft revision, I did not find any
difference between Redirect-Host-Usage (RFC3588) and the new
Redirect-Realm-Usage being defined. I am just wondering if the content
is the same, if we cannot just re-use the Redirect-Host-Usage AVP?
Please let me know (and pardon me) if I did miss a subtle difference :)

My 2 cents,
Sebastien.

---

From: Tom Taylor <[email-masked]>
Date: Thu, 30 Jul 2009 15:20:47 +0200

No difference, but didn't we say in the meeting we preferred not to overload 
Redirect-Host-Usage?

> Please let me know (and pardon me) if I did miss a subtle difference :)
...

---

From: Sebastien Decugis <[email-masked]>
Date: Thu, 30 Jul 2009 15:24:32 +0200

Ok, I did not get that, sorry :) Just ignore my comment then.

Thanks,
Sebastien.

Tom Taylor a écrit :
> No difference, but didn't we say in the meeting we preferred not to
> overload Redirect-Host-Usage?
>
> Sebastien Decugis wrote:
>> Hi,
>>

---

From: Mark Jones <[email-masked]>
Date: Fri, 31 Jul 2009 04:38:48 -0400

The use case I had in mind when I made the comment in the DIME session was a wholesaler for AAA that was previously offering service for a given realm but the AAA service is now being provided by a new wholesaler.

So the old wholesaler would use the redirect realm AVPs with:
   Redirect-Realm = <realm of new wholesaler>
   Redirect-Realm-Usage = ALL_REALM

The other question I had on this draft was how one advertises support for the realm redirect functionality. I understand from Tom's presentation that nothing too bad happens on the client if it does not support these AVPs but the intended redirect did not happen either and the redirecting server is unaware of the error. The way new functionality (i.e. beyond base functionaltiy) is advertised in Diameter is through the use of application ids in CER/CEA exchanges. If new applications require redirect realm functionaltiy, I would expect the specifications for these new applications to state this dependency and include a normative reference to the redirect realm draft. I think the redirect realm draft should clarify this because redirect realm is not base functionality.

Regards
Mark

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Sebastien Decugis [[email-masked]]
Sent: Thursday, July 30, 2009 3:24 PM
To: Tom Taylor
Cc: [email-masked]
Subject: Re: [Dime] I-D Action:draft-ietf-dime-realm-based-redirect-01.txt

Thanks,
Sebastien.

---

From: "Victor Fajardo" <[email-masked]>
Date: Fri, 31 Jul 2009 08:33:15 -0400

Hi Mark,

ALL_REALM usage is reasonable. However, is there any other possible values
for 'usage' beyond all realm ? I'm trying to see if we can simplify things
and maybe not have a 'usage' value if we don't need to. Of course, I don't
mind having a 'usage' value if we really need it.

Regarding advertisement of this functionality, I agree the draft should
clarify this. 

Regards,
Victor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark
Jones
Sent: Friday, July 31, 2009 4:39 AM
To: [email-masked]
Subject: Re: [Dime] I-D Action:draft-ietf-dime-realm-based-redirect-01.txt

The use case I had in mind when I made the comment in the DIME session was a
wholesaler for AAA that was previously offering service for a given realm
but the AAA service is now being provided by a new wholesaler.

The other question I had on this draft was how one advertises support for
the realm redirect functionality. I understand from Tom's presentation that
nothing too bad happens on the client if it does not support these AVPs but
the intended redirect did not happen either and the redirecting server is
unaware of the error. The way new functionality (i.e. beyond base
functionaltiy) is advertised in Diameter is through the use of application
ids in CER/CEA exchanges. If new applications require redirect realm
functionaltiy, I would expect the specifications for these new applications
to state this dependency and include a normative reference to the redirect
realm draft. I think the redirect realm draft should clarify this because
redirect realm is not base functionality.

Regards
Mark

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Sebastien
Decugis [[email-masked]]
Sent: Thursday, July 30, 2009 3:24 PM
To: Tom Taylor
Cc: [email-masked]
Subject: Re: [Dime] I-D Action:draft-ietf-dime-realm-based-redirect-01.txt

Thanks,
Sebastien.