Subject: Re: [Dime] Review of draft-ietf-dime-diameter-base-protocol-mib-00

From: "Glen Zorn" <[email-masked]>
Date: Thu, 29 Oct 2009 17:08:19 +0700

Hi, Mark.  I've been reconstructing the latest (unpublished) version of
th8is draft & going through the archives to make sure that the new rev will
cover all the comments.  Anyway, at some point in the past you wrote "I have
reviewed this draft and only have one comment: The dbpPeerVendorId should be
Unsigned32 rather than enumerated INTEGER."  I see that I agreed to this
change, but I'm wondering what the rationale might be...

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 29 Oct 2009 11:24:42 +0100

What is the latest version of this document? Shouldn't we look at
draft-ietf-dime-diameter-base-protocol-mib-02.txt? 

In any case, it does not make to much sense for a vendorID object which
is always as I can understand a positive integer to be something else
than an Unsigned32. RFC 4181 actually says that INTEGER MUST NOT be used
in such cases.

I think draft-ietf-dime-diameter-base-protocol-mib-02 fixed this. 

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Glen Zorn
> Sent: Thursday, October 29, 2009 12:08 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Dime] Review of 
> draft-ietf-dime-diameter-base-protocol-mib-00
> 
> Hi, Mark.  I've been reconstructing the latest (unpublished) 
> version of th8is draft & going through the archives to make 
> sure that the new rev will cover all the comments.  Anyway, 
> at some point in the past you wrote "I have reviewed this 
> draft and only have one comment: The dbpPeerVendorId should be
> Unsigned32 rather than enumerated INTEGER."  I see that I 
> agreed to this change, but I'm wondering what the rationale 
> might be...
> 
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: Mark Jones <[email-masked]>
Date: Thu, 29 Oct 2009 10:07:46 -0400

Hi Glen,

> From: Glen Zorn [mailto:[email-masked]]
> Sent: October 29, 2009 6:08 AM
> To: Mark Jones
> Cc: [email-masked]
> Subject: RE: Review of draft-ietf-dime-diameter-base-protocol-mib-00
> 

I assumed this was just an oversight as the other vendorId in the MIB are Unsigned32. 

I understand that the INTEGER type is recommended for representing named-number enumerations but it struck me as strange that the ID would define just four enumeration values for IETF, Cisco, 3GPP and Vodafone. The vendor name/id list is potentially very long and it didn't seem like the appropriate use of the enumerated INTEGER type. I'm not a MIB designer so this comment is largely based on how I've seen enums used in other MIBs. I now await the counter examples from the MIB experts ;)

Regards
Mark