Subject: [Dime] draft-ietf-dime-rfc3588bis-26 Result-Code values

From: Sebastien Decugis <[email-masked]>
Date: Wed, 26 Jan 2011 11:31:50 +0900

Hello,

I just compared the Result-Code values described in rfc3588bis-26
section 7.1.x with existing IANA registry, and found several
differences, which are currently not reflected in the IANA
Considerations section -- I believe someone is already working on this
section (although I lost track of whom) so I thought I would write down
the differences I found to help in this work -- I hope this is not
redundant.

DIAMETER_COMMAND_UNSUPPORTED:
- value 3001 in IANA registry,
- value 5019 in 3588bis.

DIAMETER_INVALID_HDR_BITS:
- value 3008 in IANA,
- value 5020 in 3588bis
- also,

DIAMETER_INVALID_AVP_BITS:
- value 3009 in IANA,
- value 5021 in rfc3588bis

DIAMETER_UNKNOWN_PEER:
- value 3010 in IANA,
- value 5018 in rfc3588bis (conflicts with IANA)

DIAMETER_INVALID_BIT_IN_HEADER:
- 5013 in IANA,
- 3011 in rfc3588bis
- seems redundant with DIAMETER_INVALID_HDR_BITS.

DIAMETER_INVALID_MESSAGE_LENGTH:
- value 5015 in IANA,
- value 3012 in rfc3588bis

DIAMETER_INVALID_AVP_BIT_COMBO:
- value 5016 in IANA
- not defined in rfc3588bis
- is it deprecated? it seems redundant with DIAMETER_INVALID_AVP_BITS
anyway...

Hope this helps,
Sebastien.

-- 
Sebastien Decugis
Research fellow
Network Architecture Group
NICT (nict.go.jp)

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 26 Jan 2011 12:34:43 +0700

> the differences I found to help in this work -- I hope this is not

Actually, I think that the redundant things are the lists of values
themselves.  They made sense in 3588, since that doc was actually requesting
allocation of the values but should be replaced with references to the
relevant IANA registry in bis.

...

---

From: Sebastien Decugis <[email-masked]>
Date: Wed, 26 Jan 2011 15:30:26 +0900

Hi Glen,

> relevant IANA registry in bis.
I agree with regard to the values that are unchanged between 3588 & bis.

However, what about for example DIAMETER_COMMAND_UNSUPPORTED which was
defined as 3xxx (protocol error) in 3588, but is now in range 5xxx
(permanent failure) in bis ?

Best regards,
Sebastien.

---

From: "Glen Zorn" <[email-masked]>
Date: Sat, 29 Jan 2011 13:07:32 +0700

Sebastien Decugis [mailto://[email-masked]]

> (permanent failure) in bis ?

Good question.  I don't even remember discussing this, but it seems
inappropriate since it would change peer behavior...