Subject: [Dime] Clashing AVP codes

From: Naveen Kottapalli <[email-masked]>
Date: Fri, 10 Jun 2011 14:46:10 +0530

Hey!

There are two AVPs (Filter-Id, 3GPP-Session-Stop-Indicator) defined in 3GPP
specification 32.299 with same value 11.  Can anyone tell which one of them
is the correct one?

Yours,
Naveen.

---

From: <[email-masked]>
Date: Fri, 10 Jun 2011 11:52:45 +0200

Hi Naveen,

Both codes are correct! J

"Filter-Id" (Code 11) is an IETF standard AVP whereas "3GPP-Session-Stop-Indicator" is a vendor-specific AVP defined by 3GPP i.e. (defined with the code 11 under the Vendor-id= 10415).

The "V" bit is set and the vendor-id field is present in the header of vendor-specific AVP (that allows to distinguish them from standard AVP).

The Standard code value range is distinct from the vendor-specific code value range. So, you don't have to consider only the code value but also in which range the AVP is defined.

Best Regards,

Lionel

De : [email-masked] [mailto:[email-masked]] De la part de Naveen Kottapalli
Envoyé : vendredi 10 juin 2011 11:16
À : [email-masked]
Objet : [Dime] Clashing AVP codes

Hey!

There are two AVPs (Filter-Id, 3GPP-Session-Stop-Indicator) defined in 3GPP specification 32.299 with same value 11.  Can anyone tell which one of them is the correct one?

Yours,
Naveen.