Subject: Re: [Dime] draft-ietf-dime-rfc3588bis-26: circular definition?

From: jouni korhonen <[email-masked]>
Date: Thu, 18 Aug 2011 08:28:06 +0300

So.. folks happy if I word this:

            Diameter Peer

               If a Diameter Node shares a direct TCP or SCTP transport
               connection with another Diameter Node, it is a Diameter 
               Peer to that Diameter Node.

And then also remove the definition for Transport Connection.

- JOuni

On Jun 3, 2011, at 1:23 AM, Tom Taylor wrote:

> That looked good at first, but I think all you've done is add authorization to the existing definition. It's still circular. Or are you proposing to remove the definition of transport connection. I'd support that.
> 
> On 02/06/2011 8:18 AM, Igoe, Kevin M. wrote:
>> Glen Zorn&  I have been having a sidebar discussion on the circularity
>> 
>> of the following pair of definitions in draft-ietf-dime-rfc3588bis-26.
>> 
>> 
>> 
>> Existing definitions:
>> 
>> 
>> 
>>    Diameter Peer
>> 
>> 
>> 
>>       If a Diameter Node shares a direct transport connection with
>> 
>>       another Diameter Node, it is a Diameter Peer to that Diameter
>> 
>>       Node.
>> 
>> 
>> 
>> 
>> 
>>   Transport Connection
>> 
>>       A transport connection is a TCP or SCTP connection existing
>>       directly between two Diameter peers, otherwise known as a Peer-to-
>>       Peer Connection.
>> 
>> 
>> We propose the following change to the definition of Diameter Peer
>> 
>> that removes the circularity and emphasizes the need to verify the node
>> 
>> is properly authorized before accepting it as a peer and entering it
>> into
>> 
>> the Peer list (as discussed in section 5.2).
>> 
>> 
>> 
>> Proposed definition:
>> 
>> 
>> 
>>    Diameter Peer
>> 
>> 
>> 
>>                 Two Diameter Nodes are Peers if and only if a properly
>> 
>>       authorized transport (TCP or SCTP) connection exists between
>> 
>>       them.
>> 
>> 
>> 
>> 
>> 
>> Comments/discussion appreciated.
>> 
>> 
>> 
>> 
>> 
>> Kevin M. Igoe   |   "Everyone is entitled to their own
>> [email-masked]<mailto:[email-masked]>    |    opinions, but not to their
>> own facts."
>>                 |       - Daniel Patrick Moynihan -
>> 
>> 
>> 
>> 
>> 
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dime
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Thu, 18 Aug 2011 09:32:26 +0200

I understand this definition of the context of Diameter.
However for me, the notion of "peer" implicitly implies that the node is part of a peer-to-peer application architecture, opposed to the client-server model.
Is it only a bad assumption or is it the reason why we are dealing with Diameter peers instead of Diameter nodes?
If I'm right, we should reflect this point in the definition...

Sorry for this late comment.

Lionel  

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de jouni korhonen
Envoyé : jeudi 18 août 2011 07:28
À : Tom Taylor; Glen Zorn; Igoe, Kevin M.
Cc : [email-masked]
Objet : Re: [Dime] draft-ietf-dime-rfc3588bis-26: circular definition?

            Diameter Peer

- JOuni

---

From: Glen Zorn <[email-masked]>
Date: Thu, 18 Aug 2011 15:22:55 +0700

> However for me, the notion of "peer" implicitly implies that the node is part of a peer-to-peer application architecture, opposed to the client-server model.

I thought we talking about Diameter?  It is a p2p protocol.

>                Peer to that Diameter Node.

& what is "that Diameter node"?  Is it not a peer, as well?  I think
this unclear, preferring something like

             Diameter Peers

                Two Diameter Nodes sharing a direct TCP or SCTP
                transport connection are called Diameter Peers.

or

             Diameter Peer

                Two Diameter Nodes are Peers if and
                only if there is a direct TCP or SCTP
                transport connection between them.

---

From: <[email-masked]>
Date: Thu, 18 Aug 2011 10:53:31 +0200

Right! My point is just to say that the fact that any node can initiate a request was for me a characteristic of the notion of "peer" in the context of Diameter. And that specificity was not part of the definition.
In other words, for me, a peer-to-peer protocol identifies a protocol used between two peers that can initiate requests sent to each other i.e. it is an intrinsic characteristic of a "peer".
Again, it is just my personal assumption. If you folks think that the current proposed definition is accurate, forget my comment!

Lionel

-----Message d'origine-----
De : Glen Zorn [mailto:[email-masked]] 
Envoyé : jeudi 18 août 2011 10:23
À : MORAND Lionel RD-CORE-ISS
Cc : [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Objet : Re: [Dime] draft-ietf-dime-rfc3588bis-26: circular definition?

             Diameter Peers

or

             Diameter Peer

---

From: jouni korhonen <[email-masked]>
Date: Thu, 18 Aug 2011 14:51:28 +0300

>                transport connection are called Diameter Peers.

This sounds good. Thanks.

- JOuni