Subject: [Dime] re-chartering

From: jouni korhonen <[email-masked]>
Date: Wed, 23 Nov 2011 09:57:48 +0200

Folks,

The second stab on re-chartering text. Propose your changes and justify also *why*. Note there are bunch of unknown dates in milestones and such.

- Jouni & Lionel

---------------------------------------------------------

2011-xx-yy charter
Diameter Maintenance and Extensions (dime)
------------------------------------------

Charter

Current Status: Active

Chairs:
    Lionel Morand <[email-masked]>
    Jouni Korhonen <[email-masked]>

Operations and Management Area Directors:
    Dan Romascanu <[email-masked]>
    Ronald Bonica <[email-masked]>

Operations and Management Area Advisor:
    Dan Romascanu <[email-masked]>

Mailing Lists:
    General Discussion: [email-masked]
    To Subscribe:       https://www.ietf.org/mailman/listinfo/dime
    Archive:            http://www.ietf.org/mail-archive/web/dime/current/maillist.html

Description of Working Group:

 The Diameter Maintenance and Extensions WG will focus on maintenance
 and extensions to the Diameter protocol required to enable its use for
 authentication, authorization, accounting in network access, provisioning
 configuration information within the network, and using Diameter for
 other signaling purposes than authentication, authorization, accounting
 in network access.

 The DIME working group plans to address the following items:

 - Maintaining and/or progressing, along the standards track, the
 Diameter Base protocol and Diameter Applications. This includes
 extensions to Diameter Base protocol that can be considered as enhanced
 features or bug fixes.

 - Diameter application design guideline. This document will provide
 guidelines for design of Diameter extensions. It will detail when to
 consider reusing an existing application and when to develop a new
 application.

 - Protocol extensions for the management of Diameter entities. This work
 focuses on the standardization of Management Information Bases (MIBs)
 to configure Diameter entities (such as the Diameter Base protocol or
 Diameter Credit Control nodes). The usage of other management protocols
 for configuring Diameter entities may be future work within the group.

 - Protocol extension for a bulk and group signaling. The aim of this
 work is to study and standardize a solution for handling a group of
 sessions within the Diameter base protocol context. The solution would
 define how to identify and handle grouped sessions as a one combined
 entity for commands and operations.

 Additionally, AAA systems require interoperability in order to work.
 The working group, along with the AD, will need to evaluate
 any potential extensions and require verification that the proposed
 extension is needed. Coordination with other IETF working groups
 and other SDOs will be used to ensure this.

Goals and Milestones:
 Done     - Submit the following two Diameter Mobility documents to the IESG for consideration as a Proposed Standards:* 'Diameter Mobile IPv6: Support for Home Agent to Diameter Server Interaction' * 'Diameter Mobile IPv6: Support for Network Access Server to Diameter Server Interaction'
 Done     - Submit 'Diameter API' to the IESG for consideration as an Informational RFC
 Done     - Submit 'Quality of Service Parameters for Usage with Diameter' to the IESG for consideration as a Proposed Standard.
 Done     - Submit 'Diameter QoS Application' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Support for EAP Re-authentication Protocol' as DIME working group item
 Done     - Submit 'Diameter User-Name and Realm Based Request Routing Clarifications' as DIME working group item
 Done     - Submit 'Diameter Proxy Mobile IPv6' as DIME working group item
 Done     - Submit 'Quality of Service Attributes for Diameter' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Proxy Mobile IPv6' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter User-Name and Realm Based Request Routing Clarifications' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter NAT Control Application' as DIME working group item
 Done     - Submit 'Diameter Capabilities Update' as DIME working group item
 Done     - Submit ' Diameter Credit Control Application MIB' to the IESG for consideration as an Informational RFC
 Done     - Submit 'Diameter Base Protocol MIB' to the IESG for consideration as an Informational RFC
 Done     - Submit 'Diameter Capabilities Update' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Extended NAPTR' as DIME working group item
 Done     - Submit 'Realm-Based Redirection In Diameter' as DIME working group item
 Done     - Submit 'Diameter Support for Proxy Mobile IPv6 Localized Routing' as DIME working group item
 Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic Key Transport' as DIME working group item
 Done     - Submit 'Diameter Priority Attribute Value Pairs' as DIME working group item
 Done     - Submit 'Diameter IKEv2 PSK' as DIME working group item
 Done     - Submit Revision of 'Diameter Base Protocol' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic Key Transport' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Priority Attribute Value Pairs' to the IESG for consideration as a Proposed Standard
 Done     - Submit Revision of 'Diameter Network Access Server Application - RFC 4005bis' as DIME working group item
 Sep 201x - Submit 'Diameter Application Design Guidelines' to the IESG for consideration as a BCP document
 Done     - Submit 'Diameter NAT Control Application' to the IESG for consideration as a Proposed Standard
 Sep 201x - Submit 'Realm-Based Redirection In Diameter' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter IKEv2 PSK' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Extended NAPTR' to the IESG for consideration as a Proposed Standard
 Nov 2011 - Submit 'Diameter Support for Proxy Mobile IPv6 Localized Routing' to the IESG for consideration as a Proposed Standard
 Jul 201x - Submit 'Diameter Support for EAP Re-authentication Protocol' to the IESG for consideration as a Proposed Standard
 Sep 201x - Submit Revision of 'Diameter Network Access Server Application - RFC 4005bis' to the IESG for consideration as a Proposed Standard

---

From: Mark Jones <[email-masked]>
Date: Mon, 28 Nov 2011 11:49:19 -0500

Looks good to me. Some minor rewording suggestions for the consideration of
the group...

First paragraph:
   The Diameter Maintenance and Extensions WG will focus on maintenance
   and extensions to the Diameter protocol required to enable its use for
   authentication, authorization, accounting in network access, provisioning
   configuration information within the network, and other signaling
purposes.
Why?: The removed text is redundant.

Last paragraph:
   Additionally, Diameter-based systems require interoperability in order
to work.
   The working group, along with the AD, will need to evaluate
   any potential extensions and require verification that the proposed
   extension is needed and an appropriate use of the Diameter protocol.
   Coordination with other IETF working groups and other SDOs will be used
to ensure this.
Why?:
   - Generalize motherhood "interoperability" statement. I would also be ok
with removing it.
   - Added clause on "appropriate use of Diameter" since we do seem to
discuss this a lot.

/Mark

On Wed, Nov 23, 2011 at 2:57 AM, jouni korhonen <[email-masked]>wrote:

> Folks,
>
> The second stab on re-chartering text. Propose your changes and justify
> also *why*. Note there are bunch of unknown dates in milestones and such.
>
> - Jouni & Lionel
>
>    Archive:
> http://www.ietf.org/mail-archive/web/dime/current/maillist.html
>
>
>  Done     - Submit the following two Diameter Mobility documents to the
> IESG for consideration as a Proposed Standards:* 'Diameter Mobile IPv6:
> Support for Home Agent to Diameter Server Interaction' * 'Diameter Mobile
> IPv6: Support for Network Access Server to Diameter Server Interaction'
>  Done     - Submit 'Quality of Service Parameters for Usage with Diameter'
> to the IESG for consideration as a Proposed Standard.
>  Done     - Submit 'Diameter User-Name and Realm Based Request Routing
> Clarifications' as DIME working group item
>  Done     - Submit 'Quality of Service Attributes for Diameter' to the
> IESG for consideration as a Proposed Standard
>  Done     - Submit 'Diameter User-Name and Realm Based Request Routing
> Clarifications' to the IESG for consideration as a Proposed Standard
>  Done     - Submit ' Diameter Credit Control Application MIB' to the IESG
> for consideration as an Informational RFC
>  Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic Key
> Transport' to the IESG for consideration as a Proposed Standard
>  Done     - Submit Revision of 'Diameter Network Access Server Application
> - RFC 4005bis' as DIME working group item
>  Nov 2011 - Submit 'Diameter Support for Proxy Mobile IPv6 Localized
> Routing' to the IESG for consideration as a Proposed Standard
>  Jul 201x - Submit 'Diameter Support for EAP Re-authentication Protocol'
> to the IESG for consideration as a Proposed Standard
>  Sep 201x - Submit Revision of 'Diameter Network Access Server Application
> - RFC 4005bis' to the IESG for consideration as a Proposed Standard
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: "Reith, Lothar" <[email-masked]>
Date: Mon, 28 Nov 2011 19:22:13 +0100

Dear all,

I would like to suggest to change the term "accounting"  to "accounting
and online charging" in order to reflect in the first paragraph the
online charging capabilities supported by Diameter Credit Control
Application (RFC4006).

Best Regards, Lothar Reith

Detecon International GmbH (Deutsche Telekom Group)

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
Mark Jones
Gesendet: Montag, 28. November 2011 17:49
An: [email-masked]
Betreff: Re: [Dime] re-chartering

Looks good to me. Some minor rewording suggestions for the consideration
of the group...

First paragraph:

   The Diameter Maintenance and Extensions WG will focus on maintenance
   and extensions to the Diameter protocol required to enable its use
for
   authentication, authorization, accounting in network access,
provisioning
   configuration information within the network, and other signaling
purposes.

Last paragraph:

   Additionally, Diameter-based systems require interoperability in
order to work.
   The working group, along with the AD, will need to evaluate
   any potential extensions and require verification that the proposed
   extension is needed and an appropriate use of the Diameter protocol.

   Coordination with other IETF working groups and other SDOs will be
used to ensure this.

Why?: 

   - Generalize motherhood "interoperability" statement. I would also be
ok with removing it.

/Mark

On Wed, Nov 23, 2011 at 2:57 AM, jouni korhonen <[email-masked]>
wrote:

Folks,

The second stab on re-chartering text. Propose your changes and justify
also *why*. Note there are bunch of unknown dates in milestones and
such.

- Jouni & Lionel

2011-xx-yy charter

Charter

Current Status: Active

Chairs:

Mailing Lists:

 authentication, authorization, accounting in network access,
provisioning

 - Protocol extensions for the management of Diameter entities. This
work

Goals and Milestones:
 Done     - Submit the following two Diameter Mobility documents to the
IESG for consideration as a Proposed Standards:* 'Diameter Mobile IPv6:
Support for Home Agent to Diameter Server Interaction' * 'Diameter
Mobile IPv6: Support for Network Access Server to Diameter Server
Interaction'
 Done     - Submit 'Diameter API' to the IESG for consideration as an
Informational RFC
 Done     - Submit 'Quality of Service Parameters for Usage with
Diameter' to the IESG for consideration as a Proposed Standard.
 Done     - Submit 'Diameter QoS Application' to the IESG for
consideration as a Proposed Standard
 Done     - Submit 'Diameter Support for EAP Re-authentication Protocol'
as DIME working group item
 Done     - Submit 'Diameter User-Name and Realm Based Request Routing
Clarifications' as DIME working group item
 Done     - Submit 'Diameter Proxy Mobile IPv6' as DIME working group
item
 Done     - Submit 'Quality of Service Attributes for Diameter' to the
IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Proxy Mobile IPv6' to the IESG for
consideration as a Proposed Standard
 Done     - Submit 'Diameter User-Name and Realm Based Request Routing
Clarifications' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter NAT Control Application' as DIME working
group item
 Done     - Submit 'Diameter Capabilities Update' as DIME working group
item
 Done     - Submit ' Diameter Credit Control Application MIB' to the
IESG for consideration as an Informational RFC
 Done     - Submit 'Diameter Base Protocol MIB' to the IESG for
consideration as an Informational RFC
 Done     - Submit 'Diameter Capabilities Update' to the IESG for
consideration as a Proposed Standard
 Done     - Submit 'Diameter Extended NAPTR' as DIME working group item
 Done     - Submit 'Realm-Based Redirection In Diameter' as DIME working
group item
 Done     - Submit 'Diameter Support for Proxy Mobile IPv6 Localized
Routing' as DIME working group item
 Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic Key
Transport' as DIME working group item
 Done     - Submit 'Diameter Priority Attribute Value Pairs' as DIME
working group item
 Done     - Submit 'Diameter IKEv2 PSK' as DIME working group item
 Done     - Submit Revision of 'Diameter Base Protocol' to the IESG for
consideration as a Proposed Standard
 Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic Key
Transport' to the IESG for consideration as a Proposed Standard
 Done     - Submit 'Diameter Priority Attribute Value Pairs' to the IESG
for consideration as a Proposed Standard
 Done     - Submit Revision of 'Diameter Network Access Server
Application - RFC 4005bis' as DIME working group item
 Sep 201x - Submit 'Diameter Application Design Guidelines' to the IESG
for consideration as a BCP document
 Done     - Submit 'Diameter NAT Control Application' to the IESG for
consideration as a Proposed Standard
 Sep 201x - Submit 'Realm-Based Redirection In Diameter' to the IESG for
consideration as a Proposed Standard
 Done     - Submit 'Diameter IKEv2 PSK' to the IESG for consideration as
a Proposed Standard
 Done     - Submit 'Diameter Extended NAPTR' to the IESG for
consideration as a Proposed Standard
 Nov 2011 - Submit 'Diameter Support for Proxy Mobile IPv6 Localized
Routing' to the IESG for consideration as a Proposed Standard
 Jul 201x - Submit 'Diameter Support for EAP Re-authentication Protocol'
to the IESG for consideration as a Proposed Standard
 Sep 201x - Submit Revision of 'Diameter Network Access Server
Application - RFC 4005bis' to the IESG for consideration as a Proposed
Standard

---

From: jouni korhonen <[email-masked]>
Date: Tue, 29 Nov 2011 13:56:49 +0200

Lothar,

On Nov 28, 2011, at 8:22 PM, Reith, Lothar wrote:

> Dear all,
>  
> I would like to suggest to change the term “accounting”  to “accounting and online charging” in order to reflect in the first paragraph the online charging capabilities supported by Diameter Credit Control Application (RFC4006).

Are you referring to e.g. "..its use for authentication, authorization, accounting in network access.." ? There accounting is just part of the expanded AAA acronym. To be sure what you want, could you propose the actual text change?

- Jouni

> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Mark Jones
> Looks good to me. Some minor rewording suggestions for the consideration of the group...
>  
> First paragraph:
>    configuration information within the network, and other signaling purposes.
>    Additionally, Diameter-based systems require interoperability in order to work.
>    Coordination with other IETF working groups and other SDOs will be used to ensure this.
> Why?: 
>    - Generalize motherhood "interoperability" statement. I would also be ok with removing it.
>    - Added clause on "appropriate use of Diameter" since we do seem to discuss this a lot.
>  
> /Mark
>  
> On Wed, Nov 23, 2011 at 2:57 AM, jouni korhonen <[email-masked]> wrote:
> Folks,
>

---

From: jouni korhonen <[email-masked]>
Date: Wed, 30 Nov 2011 11:39:52 +0200

Folks,

The next revision of the new charter proposal. I added Mark's & Lothar's comments. I recall someone had concerns on the intended "extension for a bulk and group signaling" solution space the current text directs to. If so, just propose changes to the text.

- Jouni

2011-xx-yy charter

 Charter

 Current Status: Active

 Chairs:

 Mailing Lists:

  The Diameter Maintenance and Extensions WG will focus on maintenance
  and extensions to the Diameter protocol required to enable its use for
  authentication, authorization, accounting, charging in network access,
  provisioning configuration information within the network, and other
  signaling purposes.

  to work. The working group, along with the AD, will need to evaluate

Goals and Milestones:

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 30 Nov 2011 11:39:37 +0100

Thanks for the updated version. Two minor comments:

- typo: s/for a bulk/for bulk/

- On "and an appropriate use of the Diameter protocol".
  Do we have a clear description of what "an appropriate
  use of the Diameter protocol" is? Unless we have this,
  wouldn't the "require verification that the proposed
  extension is needed" provide the justification
  and evaluation that the extension would make sense?
  In which case wouldn't it make sense to drop
  "and an appropriate use of the Diameter protocol"?

Thoughts?

Thanks, Frank

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> jouni korhonen
> Sent: Wednesday, November 30, 2011 10:40 AM
> To: [email-masked]
> Subject: Re: [Dime] re-chartering
> 
> Folks,
> 
> The next revision of the new charter proposal. I added Mark's &
> Lothar's comments. I recall someone had concerns on the intended
> "extension for a bulk and group signaling" solution space the current
> text directs to. If so, just propose changes to the text.
> 
> - Jouni
> 
> 
> 
> 2011-xx-yy charter
> order
>   Done     - Submit the following two Diameter Mobility documents to
> the IESG for consideration as a Proposed Standards:* 'Diameter Mobile
> IPv6: Support for Home Agent to Diameter Server Interaction' *
> 'Diameter Mobile IPv6: Support for Network Access Server to Diameter
> Server Interaction'
>   Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic
> Key Transport' as DIME working group item
>   Done     - Submit 'Diameter Attribute-Value Pairs for Cryptographic
> Key Transport' to the IESG for consideration as a Proposed Standard
>   Done     - Submit 'Diameter Priority Attribute Value Pairs' to the
>   Jul 201x - Submit 'Diameter Support for EAP Re-authentication
> Protocol' to the IESG for consideration as a Proposed Standard

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 30 Nov 2011 11:33:06 +0000

Hi Jouni,
thanks for the updated charter proposal. Please find some minor comments
and proposals inline.

  The Diameter Maintenance and Extensions WG will focus on maintenance
  and extensions to the Diameter protocol required to enable its use for
  authentication, authorization, accounting, charging in network access,
  provisioning /+ of +/ configuration information within the network, and other
  signaling purposes.

..

Original text about the bulk operations work item: 

If we plan to look at bulk operation use cases also for NASREQ and Credit Control applications,
we may not refer to '..Diameter base protocol context', which I understand as RFC3588.

Also, the last sentence about '..as a one combined entity' is not so clear to me.

What about the following:

  - Protocol extension for /- a -/ bulk and group signaling. The aim of this
  work is to study and standardize a solution for handling /-a-/ group/+s+/ of
  sessions within /-the Diameter base protocol -/ /+ Diameter  applications' +/ context.
  The solution would define how to identify and handle grouped sessions 
  /-as a one combined entity for commands and operations-/
  /+and how to signal and perform Diameter operations on these groups+/. 

Thanks,
marco

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> jouni korhonen
> Sent: Mittwoch, 30. November 2011 10:40
> To: [email-masked]
> The next revision of the new charter proposal. I added Mark's & Lothar's
> comments. I recall someone had concerns on the intended "extension for a
> bulk and group signaling" solution space the current text directs to. If so, just
> propose changes to the text.
> 
> - Jouni
> 
> 
> 
> 2011-xx-yy charter
>   Done     - Submit 'Quality of Service Parameters for Usage with Diameter' to
> the IESG for consideration as a Proposed Standard.
>   Jul 201x - Submit 'Diameter Support for EAP Re-authentication Protocol' to
> the IESG for consideration as a Proposed Standard
>   Sep 201x - Submit Revision of 'Diameter Network Access Server Application -
> RFC 4005bis' to the IESG for consideration as a Proposed Standard
> 
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 01 Dec 2011 10:28:57 +0800

This version looks good to me. One minor comment:
It is not clear to what "one combined entity" is in the bulk and group sigaling item? functinality entity or physical entity?
How about change it into "one single association"?

Regards!
-Qin

---

From: Tina TSOU <[email-masked]>
Date: Thu, 01 Dec 2011 03:10:53 +0000

Some other candidate wording:
Group? Aggregation? Grouping? Compound?

Sent from my iPad