Subject: Re: [Dime] [dime] #16: Accounting-Request (ACR) Command

From: "dime issue tracker" <[email-masked]>
Date: Sat, 04 Feb 2012 11:39:11 -0000

#16: Accounting-Request (ACR) Command

Comment (by gwz@…):

 Since I've seen no responses, I'm assuming that it's OK to remove the
 Vendor-Specific- Application-Id AVP so I've done so.

-- 
-----------------------------+---------------------
 Reporter:  jouni.nospam@…   |       Owner:  dime@…
     Type:  defect           |      Status:  new
 Priority:  major            |   Milestone:
Component:  rfc4005bis       |     Version:
 Severity:  In WG Last Call  |  Resolution:
 Keywords:                   |
-----------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/16#comment:2>
dime <http://tools.ietf.org/wg/dime/>

---

From: "dime issue tracker" <[email-masked]>
Date: Sat, 04 Feb 2012 11:39:44 -0000

Changes (by gwz@…):

 * status:  new => closed
 * resolution:   => fixed

-- 
-----------------------------+---------------------
 Reporter:  jouni.nospam@…   |       Owner:  dime@…
     Type:  defect           |      Status:  closed
 Priority:  major            |   Milestone:
Component:  rfc4005bis       |     Version:
 Severity:  In WG Last Call  |  Resolution:  fixed
 Keywords:                   |
-----------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/16#comment:3>
dime <http://tools.ietf.org/wg/dime/>

---

From: Tina TSOU <[email-masked]>
Date: Sat, 04 Feb 2012 18:30:20 +0000

Sent from my iPad

> Vendor-Specific- Application-Id AVP so I've done so.
Why? For specs in ITU-T which used this AVP in ACR, what should they do?
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Glen Zorn <[email-masked]>
Date: Sun, 05 Feb 2012 14:05:52 +0700

On 2/5/2012 1:30 AM, Tina TSOU wrote:

> Why? 

Please see the original issue raised by Mark Jones:
http://trac.tools.ietf.org/wg/dime/trac/ticket/16

> For specs in ITU-T which used this AVP in ACR, what should they do?

Is ITU-T actually using _this_ command, which is derived in an
application-specific way from the base ACR message defined in RFC 3588?
 Or are they using the base command within a vendor-specific application
or a customized, application- & vendor-specific version of the base
command?  In the latter 2 cases, everything is fine...

...

---

From: Tina TSOU <[email-masked]>
Date: Sun, 05 Feb 2012 07:58:43 +0000

I cc Q5/11, the editors can check it out.

Tina

> -----Original Message-----
> From: Glen Zorn [mailto:[email-masked]]
> Sent: Saturday, February 04, 2012 11:06 PM
> To: Tina TSOU
> Cc: <[email-masked]>; [email-masked]; [email-masked]
> Subject: Re: [Dime] [dime] #16: Accounting-Request (ACR) Command
> 
> >> Comment (by gwz@...):

---

From: Michiaki Hayashi <[email-masked]>
Date: Mon, 06 Feb 2012 14:22:23 +0900

Tina and all,

In my understanding, the issue here is removing 
Vendor-Specific-Application-Id from ACR/ACA commands.

I believe current RFC3588-based protocols (e.g., Rs, Rw, Ri, Rt created 
by Q5/11) do not define ACR/ACA with Vendor-Specific-Application-Id.

But in 3GPP2, X.S0013-008-0(IMS Accounting Information Flows and 
Protocol) seems to have it in ACR/ACA.

Best regards,
Michiaki

(2012/02/05 16:58), Tina TSOU wrote:
>> Cc:<[email-masked]>; [email-masked]; [email-masked]
>> or a customized, application-&  vendor-specific version of the base

---

From: Glen Zorn <[email-masked]>
Date: Mon, 06 Feb 2012 15:29:19 +0700

> Vendor-Specific-Application-Id from ACR/ACA commands.

No, the question is whether or not to remove the
Vendor-Specific-Application-Id AVP from the specific version of the
ACR/ACA commands defined in RFC 4005; this would have no effect
whatsoever upon the commands defined in RFC 3588 or any other versions
derived therefrom.  Does that help?

...

---

From: Michiaki Hayashi <[email-masked]>
Date: Tue, 07 Feb 2012 09:22:42 +0900

If so, I don't see any problem.