Subject: [Dime] 3588bis Peer Discovery Questions

From: Ben Campbell <[email-masked]>
Date: Fri, 3 Feb 2012 16:36:08 -0600

Hi All,

I'm digesting the Peer Discovery section of 3588bis-29 (Section 5.2), and have some questions. I apologize in advance if these have been covered in past discussion.

1) paragraph 1 says that "… the later option (DNS) MAY be supported:

Does that mean supported "by the software implementation", or supported "by the network deployment"? That is, is the intent to say that DNS based peer discovery MAY be implemented, vs MAY be used?

2) Paragraph 2 talks about peer discovery by a client to find a next hop agent, or an agent to find another (next hop) agent. Is peer discovery limited to finding Diameter Agents? That is, can a Diameter client discover a Diameter server? (Perhaps the word "node" was intended rather than "agent"?)

3) The 4th paragraph from the end says that, when using a site certificate, _both_ the domain name in the initial query and the name in the replacement field must match the site certificate. Is that just the for initial query and the final result, or does it cover any intermediate steps? (e.g. if your query flow is NAPTR-->SRV-->AAAA, does the SRV step also need to match?) Is there an expectation that the client will actually validate against both the queried name and the resulting name, or is the point merely that the cert should include them because different clients may start their initial query at different places in the DDDS sequence?

Thanks!

Ben.

---

From: Ben Campbell <[email-masked]>
Date: Fri, 10 Feb 2012 15:33:24 -0600

Hi,

Any thoughts on the questions below?

Thanks!

Ben.

On Feb 3, 2012, at 4:36 PM, Ben Campbell wrote:

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Eric McMurry <[email-masked]>
Date: Mon, 13 Feb 2012 12:37:05 -0600

I'm curious about this also.  A required, non-static, option for peer discovery that includes agents makes sense in the core spec.

Is there a current goal date for the next round of 3588bis?

Thanks!

Eric