Subject: Re: [Dime] Diameter Overload Control Requirements

From: jouni korhonen <[email-masked]>
Date: Tue, 5 Jun 2012 09:38:00 +0300

Hi Eric,

Sorry for the delay.. I was occupied with other stuff.

On May 31, 2012, at 4:42 PM, Eric McMurry wrote:

> Hey Jouni,
> 
> On May 31, 2012, at 3:32 , jouni korhonen wrote:
> 
>> Hi Eric,
>> 
>> On May 31, 2012, at 12:11 AM, Eric McMurry wrote:
>> 
>>> 
>>> On May 30, 2012, at 16:01 , Jouni wrote:
>>> 
>>>> Hi,
>>>> 
>>>> On May 30, 2012, at 9:06 PM, Eric McMurry wrote:
>>>> 
>>>>> Thanks for the comments Jouni.  responses inline.
>>>>> 
>>>>> On May 30, 2012, at 10:21 , jouni korhonen wrote:
>>>> 
>>>>>> My reading of the solution requirements is that it is already decided that extending
>>>>>> base protocol is the way to go. Basically req-2 states this. I don't think this is
>>>>>> particularly good for a requirements document.
>>>>> 
>>>>> That part of req 2 was intended as an example and does not use requirement language, so I agree with you that it should not be a direct requirement.  That said, addressing this in the base makes sense to me and helps address several of the requirements.
>>>> 
>>>> Well, "MUST be useable with any existing or future.." and
>>>> "MUST NOT require specification changes for existing.." basically
>>>> rule out anything that you can stuff into CCF or existing commands
>>>> in specs world. So I am left only with base protocol level options.
>>>> Just language tweaking..
>>>> 
>>> 
>>> I think those requirements could be met without base level changes.  Perhaps I am misunderstanding your point though.  Do you think that working with existing and future
>>> applications and not requiring changes to existing applications are unreasonable requirements?
>> 
>> No. Definitely not. I was just saying, the req-2 does not, as written
>> now, give you any other choice than extend or leverage the base
>> protocol. I am not comfortable with that -- as a requirement to be
>> documented.
> 
> So if we take off the last sentence (the one that refers to the base protocol) would that allay your concern?

That is a change for better, although it still does not change the
outcome of the req-2 that much. However, if no one else sees an issue
with this, we can leave the changes to the deletion of the last sentence.
We can always revisit the text later ;)

- Jouni

> Thanks,
> Eric

---

From: Eric McMurry <[email-masked]>
Date: Tue, 5 Jun 2012 11:29:16 -0500

works for me.  Thanks!

Eric