Subject: [Dime] Regarding 'P' bit setting in Diameter Header

From: Arud Selvan Sundaramurthy <[email-masked]>
Date: Thu, 2 Aug 2012 09:08:20 +0200

Hi,
I  have a doubt in diameter proxy behaviour when routing  a request.

When diameter proxy receives a request with 'P' bit **NOT SET ** in header   , and having valid routing entry to route the request to next hop, will it route the request to next hop by setting the 'P' bit or will it reply will "DIAMETER_UNABLE_TO_DELIVER" as the 'P' bit is not set.  Will the proxy is allowed to modify the header in this case?

As per bis draft-ietf-dime-rfc3588bis-34.txt in section 6.1.9 , it states

"Relay and proxy agents are not required to perform full inspection of

   incoming messages.  At a minimum, validation of the message header

   and relevant routing AVPs has to be done when relaying messages.".

Does the "minimum header validation" includes checking the 'P' in header by Proxy agent also?
Kindly provide your suggestion on this.

Thanks,
Arud selvan.S.

---

From: Glen Zorn <[email-masked]>
Date: Thu, 02 Aug 2012 10:45:03 -0700

On Thu, 2012-08-02 at 09:08 +0200, Arud Selvan Sundaramurthy wrote:
> When diameter proxy receives a request with ‘P’ bit **NOT SET ** in
> header   , and having valid routing entry to route the request to next
> hop, will it route the request to next hop by setting the ‘P’ bit or
> will it reply will “DIAMETER_UNABLE_TO_DELIVER” as the ‘P’ bit is not
> set.  Will the proxy is allowed to modify the header in this case?

No; the value of the 'P' bit is part of the command definition and isn't
modifiable at run time.

> “Relay and proxy agents are not required to perform full inspection of
>    and relevant routing AVPs has to be done when relaying messages.”.
> 
> Does the “minimum header validation” includes checking the ‘P’ in
> header by Proxy agent also?

It actually says "At a minimum," which means 'At the very least'.

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime