Subject: [Dime] Charter update

From: jouni korhonen <[email-masked]>
Date: Sat, 11 Aug 2012 13:42:57 +0300

Folks,

Like discussed briefly during the Vancouver meeting there is a small
charter & milestone update required for the overload work. The topic
has already been brought up in IESG..

Here is the proposed charter update text:

- Diameter overload control. The aim of this work is to identify the
  limitations of the Diameter protocol level overload control provided
  by the current Diameter Base protocol. A set of requirements will be
  provided to define a new Diameter level overload control mechanisms.

..

Sep 2012 - Submit I-D ' Diameter Overload Control Requirements' as a
           working group document. To be Informational RFC.

Nov 2012 - Submit I-D ' Diameter Overload Control' as a working group document.
           To be Standards Track RFC.

Dec 2012 - Submit I-D ' Diameter Overload Control Requirements' to the IESG for
           consideration as a Informational RFC.

Mar 2013 - Submit I-D ' Diameter Overload Control' to the IESG for consideration
           as a Proposed Standard RFC.

- Jouni & Lionel

---

From: Ben Campbell <[email-masked]>
Date: Mon, 13 Aug 2012 16:45:44 -0500

Hi, Comments inline:

>  provided to define a new Diameter level overload control mechanisms.

Is this language intended to cover work on the mechanism as well as work on requirements? As written, it seems to cover identification of the limitations and the the set of requirements for a mechanism, but not the mechanism itself. From the Vancouver meeting, I can see that being a possible approach, but you did include milestones below that I assume to be for the mechanism.

That being said, I wonder why we need new charter text (as opposed to milestones) for this? The current charter contains the following text:

> - Maintaining and/or progressing, along the standards track, the
> Diameter Base protocol and Diameter Applications. This includes
> extensions to Diameter Base protocol that can be considered as enhanced
> features or bug fixes.

It seems to me that the proposed work falls squarely into the "enhanced features or bug fixes" language.

Don't get me wrong; I don't object to adding more specific charter language per se. My concern is that, if doing so delays having this work show up as a milestone, that may encourage other SDOs (e.g 3GPP) to pursue application-specific point solutions. Normally, I'm the first to say that doing something correctly should take priority over meeting an external deadline--but in this case I have trouble seeing why adding the milestone under the existing charter text wouldn't be equally correct.

>           as a Proposed Standard RFC.

I think the milestones look good in general, but I really hope it doesn't take us until November to be able to progress the requirements document. I guess that depends on whether we get any significant controversy on it as more people read it.

Thanks!

Ben.

---

From: jouni korhonen <[email-masked]>
Date: Tue, 14 Aug 2012 22:47:45 +0300

Ben,

On Aug 14, 2012, at 12:45 AM, Ben Campbell wrote:

> Is this language intended to cover work on the mechanism as well as work on requirements? As written, it 

Yes. Sloppy wording. Lets try tweaking the wording a bit:

- Diameter overload control. The aim of this work is to identify the
 limitations of the current Diameter base protocol overload control
 mechanisms and based on the identified limitations define a set of
 requirements for an overall Diameter overload control solution. The
 solution would need to fulfill the requirements.

> seems to cover identification of the limitations and the the set of requirements for a mechanism, but not the mechanism itself. From the Vancouver meeting, I can see that being a possible approach, but you did include milestones below that I assume to be for the mechanism.
> 

Just adding new milestones was the original intention. However, this got
changed in "upper layers" and thus the charter text modification as well.

> I think the milestones look good in general, but I really hope it doesn't take us until November to be able to progress the requirements document. I guess that depends on whether we get any signifi…

There is no reason to wait till the milestone timeline is met if a document
is ready. That said, the document can be advanced as soon as it is ready for
it.

- Jouni

---

From: Glen Zorn <[email-masked]>
Date: Fri, 17 Aug 2012 08:23:34 +0700

On 08/11/2012 05:42 PM, jouni korhonen wrote:

Since we're at this & given the fairly immanent publication of RFC 
4005bis, how about we add 
http://datatracker.ietf.org/doc/draft-zorn-dime-radia-gate/ to the charter?

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Ben Campbell <[email-masked]>
Date: Thu, 16 Aug 2012 23:56:00 -0500

> solution would need to fulfill the requirements.

I may be being overly pedantic, but I still don't see that language as saying to actually define the solution. Here's a suggested further tweak:

"- Diameter overload control. The aim of this work is to identify the
limitations of the current Diameter base protocol for overload control purposes. Based on the identified limitations 
the working group will specify a set of requirements for an overall Diameter overload control solution and define 
a solution that meets those requirements."

Thanks!

Ben.

---

From: Qin Wu <[email-masked]>
Date: Fri, 17 Aug 2012 13:58:51 +0800

Support.

Regards!
-Qin

---

From: jouni korhonen <[email-masked]>
Date: Fri, 17 Aug 2012 09:39:32 +0300

Hi,

> I may be being overly pedantic, but I still don't see that language as saying to actually define the solution. Here's a suggested further tweak:

I would day you are overly pedantic ;) However, the text you propose is
definitely better than mine!

- Jouni

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 17 Aug 2012 10:58:50 +0000

Support Ben's wording change.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: Friday, August 17, 2012 12:56 AM
To: jouni korhonen
Cc: [email-masked]; [email-masked]
Subject: Re: [Dime] Charter update

Thanks!

Ben.