Subject: [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)

From: Benoit Claise <[email-masked]>
Date: Wed, 05 Sep 2012 09:42:04 +0200

Dear all,

This errata has been submitted.
While this looks right me, I always prefer to have a confirmation from 
the experts...

Regards, Benoit.

-------- Original Message --------
Subject: 	Re: [Editorial Errata Reported] RFC4006 (3329)
Date: 	Thu, 23 Aug 2012 12:00:03 +0200
From: 	Kiran Jadhav <[email-masked]>
To: 	RFC Errata System <[email-masked]>
CC: 	[email-masked], [email-masked], 
[email-masked], [email-masked], 
[email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked]

Hello All,

I have reported an Editorial Errata for RFC4006.

This small editorial errata in the RFC4006 is causing issues in some 
call scenarios where the end user is given an option by the Service 
Provider to replenish his credit if it is found at the start of a call 
that the end-user's account balance is zero/insufficient. This is 
basically due to mis-interpretation of the sentence in the RFC by 
different vendors.

Please have a look at the suggested change which will help a common 
implementation of the behavior across all vendors.

Best Regards,
Kiran Jadhav

On Thu, Aug 23, 2012 at 11:13 AM, RFC Errata System 
<[email-masked] <mailto:[email-masked]>> wrote:

    The following errata report has been submitted for RFC4006,
    "Diameter Credit-Control Application".

    --------------------------------------
    You may review the report below and at:
    http://www.rfc-editor.org/errata_search.php?rfc=4006&eid=3329

    --------------------------------------
    Type: Editorial
    Reported by: Kiran Jadhav <[email-masked]
    <mailto:[email-masked]>>

    Section: 5.6.2

    Original Text
    -------------
    " Note that the credit-control server may already have initiated the
    above-described process for the first interrogation. However, the
    user's account might be empty when this first interrogation is
    performed. In this case, the subscriber can be offered a chance to
    replenish the account and continue the service. The credit-control
    client receives a Credit-Control-Answer or service specific
    authorization answer with the Final-Unit-Indication and Validity-Time
    AVPs but no Granted-Service-Unit. It immediately starts the graceful
    service termination without sending any message to the server. An
    example of this case is illustrated in Appendix A."

    Corrected Text
    --------------
    " Note that the credit-control server may already have initiated the
    above-described process for the first interrogation. However, the
    user's account might be empty when this first interrogation is
    performed. In this case, the subscriber can be offered a chance to
    replenish the account and continue the service. The credit-control
    client receives a Credit-Control-Answer or service specific
    authorization answer with the Final-Unit-Indication and Validity-Time
    AVPs but no Granted-Service-Unit AVP. It immediately starts the graceful
    service termination without sending any message to the server. An
    example of this case is illustrated in Appendix A."

    Notes
    -----
    In the sentence "The credit-control
    client receives a Credit-Control-Answer or service specific
    authorization answer with the Final-Unit-Indication and Validity-Time
    AVPs but no Granted-Service-Unit." it is important that we add the
    letters "AVP" after Granted-Service-Units as it is not clear whether
    the sentence refers to "Not sending Granted-Service-Unit AVP at all"
    or "sending GSU=0 (Granted-Service-Unit AVP with value 0".

    Different OCS vendors interpret the sentence above in a different
    way, some do not send the Granted-Service-Unit AVP at all, while
    some others send the Granted_Service-Unit=0. And this causes problem
    in the call scenario where FUI+Redirect is sent together with GSU=0.
    This causes the call to enter a loop and terminate with an error.

    Instructions:
    -------------
    This errata is currently posted as "Reported". If necessary, please
    use "Reply All" to discuss whether it should be verified or
    rejected. When a decision is reached, the verifying party (IESG)
    can log in to change the status and edit the report, if necessary.

    --------------------------------------
    RFC4006 (draft-ietf-aaa-diameter-cc-06)
    --------------------------------------
    Title               : Diameter Credit-Control Application
    Publication Date    : August 2005
    Author(s)           : H. Hakala, L. Mattila, J-P. Koskinen, M.
    Stura, J. Loughney
    Category            : PROPOSED STANDARD
    Source              : Authentication, Authorization and Accounting
    Area                : Operations and Management
    Stream              : IETF
    Verifying Party     : IESG

---

From: "Schendel, Jens (NSN - DE/Berlin)" <[email-masked]>
Date: Thu, 6 Sep 2012 16:19:04 +0200

Hi,

I agree with the proposed change. Actually, the Credit Control Server
may decide to apply immediate redirect for some other reason than zero
balance (which is given as explanation in the RFC text), i.e. for some
other advice like charge rate or so.

I also believe that the original wording (even if not completed) would
have been different if zero GSU were indented.

So, pretty clear to me.

Jens

From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Benoit Claise
Sent: Wednesday, September 05, 2012 9:42 AM
To: dime mailing list
Cc: [email-masked]
Subject: [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)

Dear all,

Regards, Benoit.

-------- Original Message -------- 

Subject: 

Re: [Editorial Errata Reported] RFC4006 (3329)

Date: 

Thu, 23 Aug 2012 12:00:03 +0200

From: 

Kiran Jadhav <[email-masked]> <mailto:[email-masked]> 

To: 

RFC Errata System <[email-masked]>
<mailto:[email-masked]> 

CC: 

[email-masked], [email-masked],
[email-masked], [email-masked],
[email-masked], [email-masked], [email-masked],
[email-masked], [email-masked]

Hello All, 

Best Regards,

Kiran Jadhav

On Thu, Aug 23, 2012 at 11:13 AM, RFC Errata System
<[email-masked]> wrote:

--------------------------------------
Type: Editorial
Reported by: Kiran Jadhav <[email-masked]>

Section: 5.6.2

Original Text
-------------

Corrected Text
--------------

Notes
-----
In the sentence "The credit-control
client receives a Credit-Control-Answer or service specific
authorization answer with the Final-Unit-Indication and Validity-Time
AVPs but no Granted-Service-Unit." it is important that we add the
letters "AVP" after Granted-Service-Units as it is not clear whether the
sentence refers to "Not sending Granted-Service-Unit AVP at all" or
"sending GSU=0 (Granted-Service-Unit AVP with value 0".

Different OCS vendors interpret the sentence above in a different way,
some do not send the Granted-Service-Unit AVP at all, while some others
send the Granted_Service-Unit=0. And this causes problem in the call
scenario where FUI+Redirect is sent together with GSU=0. This causes the
call to enter a loop and terminate with an error.

Instructions:
-------------

Author(s)           : H. Hakala, L. Mattila, J-P. Koskinen, M. Stura, J.
Loughney

---

From: <[email-masked]>
Date: Thu, 6 Sep 2012 15:37:18 +0000

Hi,

The EDITORIAL change is correct.

Regards,

Lionel

De : [email-masked] [mailto:[email-masked]] De la part de Schendel, Jens (NSN - DE/Berlin)
Envoyé : jeudi 6 septembre 2012 16:19
À : ext Benoit Claise; dime mailing list
Cc : [email-masked]
Objet : Re: [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)

Hi,

I agree with the proposed change. Actually, the Credit Control Server may decide to apply immediate redirect for some other reason than zero balance (which is given as explanation in the RFC text), i.e. for some other advice like charge rate or so.
I also believe that the original wording (even if not completed) would have been different if zero GSU were indented.
So, pretty clear to me.

Jens

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Benoit Claise
Sent: Wednesday, September 05, 2012 9:42 AM
To: dime mailing list
Cc: [email-masked]
Subject: [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)

Dear all,

This errata has been submitted.
While this looks right me, I always prefer to have a confirmation from the experts...

Regards, Benoit.

-------- Original Message --------
Subject:

Date:

From:

Kiran Jadhav <[email-masked]><mailto:[email-masked]>

To:

RFC Errata System <[email-masked]><mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Hello All,

This small editorial errata in the RFC4006 is causing issues in some call scenarios where the end user is given an option by the Service Provider to replenish his credit if it is found at the start of a call that the end-user's account balance is zero/insufficient. This is basically due to mis-interpretation of the sentence in the RFC by different vendors.

Please have a look at the suggested change which will help a common implementation of the behavior across all vendors.

Best Regards,
Kiran Jadhav
On Thu, Aug 23, 2012 at 11:13 AM, RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:

--------------------------------------
Type: Editorial
Reported by: Kiran Jadhav <[email-masked]<mailto:[email-masked]>>

Section: 5.6.2

Original Text
-------------

Corrected Text
--------------

Notes
-----
In the sentence "The credit-control
client receives a Credit-Control-Answer or service specific
authorization answer with the Final-Unit-Indication and Validity-Time
AVPs but no Granted-Service-Unit." it is important that we add the letters "AVP" after Granted-Service-Units as it is not clear whether the sentence refers to "Not sending Granted-Service-Unit AVP at all" or "sending GSU=0 (Granted-Service-Unit AVP with value 0".

Different OCS vendors interpret the sentence above in a different way, some do not send the Granted-Service-Unit AVP at all, while some others send the Granted_Service-Unit=0. And this causes problem in the call scenario where FUI+Redirect is sent together with GSU=0. This causes the call to enter a loop and terminate with an error.

Instructions:
-------------

Author(s)           : H. Hakala, L. Mattila, J-P. Koskinen, M. Stura, J. Loughney

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 10 Sep 2012 12:38:01 +0200

Thanks to all.
Accepted as "Hold for document update"

Regards, Benoit.
>
> Hi,
>
> Yes I agree with proposed change. Indeed the intention is that GSU AVP 
> is not sent at all, this was supposed to be clear looking at Flow VIII 
> (fro example) in Annex A.
>
> BR,
>
> Marco
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Schendel, Jens (NSN - DE/Berlin)
> *Sent:* Thursday, September 06, 2012 4:19 PM
> *To:* ext Benoit Claise; dime mailing list
> *Cc:* [email-masked]
> *Subject:* Re: [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)
> *Importance:* Low
>
> Hi,
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *ext Benoit Claise
> *Sent:* Wednesday, September 05, 2012 9:42 AM
> *To:* dime mailing list
> *Cc:* [email-masked]
> *Subject:* [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)
>
> Dear all,
>
> *Subject: *
> *Date: *
> *From: *
> *To: *
> *CC: *
> [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>
>
>
>
> Hello All,
>
> some do not send the Granted-Service-Unit AVP at all, while some 
> others send the Granted_Service-Unit=0. And this causes problem in the 
> call scenario where FUI+Redirect is sent together with GSU=0. This 
> causes the call to enter a loop and terminate with an error.
>
> Instructions:
> -------------

---

From: Kiran Jadhav <[email-masked]>
Date: Mon, 10 Sep 2012 12:46:34 +0200

Thank you every one for the consideration.

Best Regards,
Kiran

On Mon, Sep 10, 2012 at 12:38 PM, Benoit Claise <[email-masked]> wrote:

>  Hi,****
> ** **
> Yes I agree with proposed change. Indeed the intention is that GSU AVP is
> not sent at all, this was supposed to be clear looking at Flow VIII (fro
> example) in Annex A.****
>
> ** **
>
> BR,****
>
> Marco****
>
> ** **
>  ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Schendel, Jens (NSN - DE/Berlin)
> *Importance:* Low****
> ** **
> Hi,****
> ** **
> I agree with the proposed change. Actually, the Credit Control Server may
> decide to apply immediate redirect for some other reason than zero balance
> (which is given as explanation in the RFC text), i.e. for some other advice
> like charge rate or so.****
>
> have been different if zero GSU were indented.****
>
> So, pretty clear to me.****
>
> ** **
>
> Jens****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *ext Benoit Claise
> *Subject:* [Dime] Fwd: Re: [Editorial Errata Reported] RFC4006 (3329)****
>
> ** **
>
> Dear all,
>
> Regards, Benoit.****
> -------- Original Message -------- ****
>
> *Subject: *
>
> Re: [Editorial Errata Reported] RFC4006 (3329)****
>
> *Date: *
>
> Thu, 23 Aug 2012 12:00:03 +0200****
>
> *From: *
>
> Kiran Jadhav <[email-masked]> <[email-masked]>****
>
> *To: *
>
> RFC Errata System <[email-masked]> <[email-masked]>*
> ***
>
> *CC: *
>
> [email-masked], [email-masked]****
>
>
>
> Hello All, ****
>
> ** **
>
> I have reported an Editorial Errata  for RFC4006.****
>
> ** **
>
> This small editorial errata in the RFC4006 is causing issues in some call
> scenarios where the end user is given an option by the Service Provider to
> replenish his credit if it is found at the start of a call that the
> end-user's account balance is zero/insufficient. This is basically due to
> mis-interpretation of the sentence in the RFC by different vendors.****
>
> ** **
>
> implementation of the behavior across all vendors.****
>
> ** **
>
> Best Regards,****
>
> Kiran Jadhav****
>
> On Thu, Aug 23, 2012 at 11:13 AM, RFC Errata System <
> [email-masked]> wrote:****
>
>
> AVPs but no Granted-Service-Unit." it is important that we add the letters
> "AVP" after Granted-Service-Units as it is not clear whether the sentence
> refers to "Not sending Granted-Service-Unit AVP at all" or "sending GSU=0
> (Granted-Service-Unit AVP with value 0".
>
> Verifying Party     : IESG****
>
> ** **
>
> ** **
>
> ** **
>
>
>