Subject: [Dime] overload control req 16 is needed?

From: Eric McMurry <[email-masked]>
Date: Wed, 20 Feb 2013 13:38:47 -0600

It has been pointed out that Req 16 has some ambiguity to it, around the meaning of "without malfunction".  Looking at it a bit closer, along with the next couple of requirements, it does not seem to be adding anything.  I think Reqs 17 and 18 cover what this was trying to communicate, and it would make things more clear to just remove it.  Does this make sense?

Thanks,

Eric

---

From: Andrew Booth <[email-masked]>
Date: Wed, 20 Feb 2013 14:50:24 -0500

That works for me.

Thanks,
Andrew

On Wed, Feb 20, 2013 at 2:38 PM, Eric McMurry <[email-masked]> wrote:

> It has been pointed out that Req 16 has some ambiguity to it, around the
> meaning of "without malfunction".  Looking at it a bit closer, along with
> the next couple of requirements, it does not seem to be adding anything.  I
> think Reqs 17 and 18 cover what this was trying to communicate, and it
> would make things more clear to just remove it.  Does this make sense?
>
> Thanks,
>
> Eric
>
>
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: Ben Campbell <[email-masked]>
Date: Wed, 20 Feb 2013 13:52:27 -0600

> It has been pointed out that Req 16 has some ambiguity to it, around the meaning of "without malfunction".  Looking at it a bit closer, along with the next couple of requirements, it does not seem…

In retrospect, I'm not sure I agree with this one. 16 is the requirement that explicitly requires support for mixed environment. 17 and 18 further constrain that. If we remove 16, then 17 and 18 will still _imply_ the requirement to support mixed environments--but it's better to be explicit.

How about the following alternative text for 16:

"The overload control mechanism is likely to be deployed incrementally. The mechanism MUST support a mixed environment where some but, not all, nodes implement it."

---

From: Eric McMurry <[email-masked]>
Date: Wed, 20 Feb 2013 13:54:22 -0600

> "The overload control mechanism is likely to be deployed incrementally. The mechanism MUST support a mixed environment where some but, not all, nodes implement it."

wfm

---

From: Andrew Booth <[email-masked]>
Date: Wed, 20 Feb 2013 15:02:12 -0500

On Wed, Feb 20, 2013 at 2:54 PM, Eric McMurry <[email-masked]> wrote:

> >> It has been pointed out that Req 16 has some ambiguity to it, around
> the meaning of "without malfunction".  Looking at it a bit closer, along
> with the next couple of requirements, it does not seem to be adding
> anything.  I think Reqs 17 and 18 cover what this was trying to
> communicate, and it would make things more clear to just remove it.  Does
> this make sense?
> >
> > In retrospect, I'm not sure I agree with this one. 16 is the requirement
> that explicitly requires support for mixed environment. 17 and 18 further
> constrain that. If we remove 16, then 17 and 18 will still _imply_ the
> requirement to support mixed environments--but it's better to be explicit.
> >
> > "The overload control mechanism is likely to be deployed incrementally.
> The mechanism MUST support a mixed environment where some but, not all,
> nodes implement it."
> >
>
>
> wfm
>

I'm fine with either removing 16 or the alternate text proposed here, to me
they are about the same.

Thanks,
Andrew

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 22 Feb 2013 00:07:13 +0200

<as an individual>

The new wording works for me.

- Jouni