Subject: Re: [Dime] draft-ietf-dime-overload-reqs-03: answer/transport failure

From: Andrew Booth <[email-masked]>
Date: Thu, 21 Feb 2013 14:23:04 -0500

Hi Eric,

A while ago we discussed
>>
>>
>> 4.1.  Problems with Implicit Mechanism
>>
>>    "Diameter treats the failure to receive an answer as a transport failure."
>>
>>    I'm not clear on this... do you mean if you fail to receive a single answer?
>>    Or if a node is not providing any answers?  Perhaps a spec reference would make this clearer?
>
> generally, it's lack of an answer to a WDR after timer Tw.  Implementations may be more aggressive than this though.  Ben, do you recall if we were talking about > something other than that here?

Can we add a reference to the watchdog request?  "Diameter treats the
failure to receive an answer to a watchdog request as a transport
failure."?

Thanks for any info,
Andrew

---

From: Ben Campbell <[email-masked]>
Date: Thu, 21 Feb 2013 13:32:47 -0600

> failure to receive an answer to a watchdog request as a transport

DWR is part of the core Diameter protocol (RFC 6733). Do we need a separate reference for that?

---

From: Andrew Booth <[email-masked]>
Date: Thu, 21 Feb 2013 20:35:49 -0500

Comments inline.

Thanks,
Andrew

> DWR is part of the core Diameter protocol (RFC 6733). Do we need a separate reference for that?

I don't think we need a cross reference as long as we mention the
watchdog request.
Specifically, I'm wondering if we can say "Diameter treats the failure
to receive an answer to a watchdog request as a transport failure."
rather than "Diameter treats the failure to receive an answer as a
transport failure."