Subject: [Dime] Command re-use, implicit capability exchange

From: Marco Liebsch <[email-masked]>
Date: Tue, 19 Feb 2013 16:24:03 +0000

Hi,

the latest proposal to enable Diameter to signal group commands re-uses existing Diameter messages and adds new group-specific AVPs to the command.

Can such approach implicitly avoid conflicts with group signaling between a group-enabled Diameter node
and a Diameter node, which does *not* support group signaling? When the specification allows
each node to assign a session to a group and both sides agree to the group, it means
implicitly that at least these two nodes support group operations.

In such case, the new AVPs to assign a session to a group, could be informational, hence they do not
have the M-bit set. Group assignment could e.g. be done during AAR/AAA when the session ID is built.
In case a receive cannot understand the semantics of the AVPs that are meant to build the group,
the response must not include these AVPs. The originator of the AAR implicitly learns that the
remote peer does not support group operations. In case the remote peer does not want to
assign the session to a group for other reasons, this needs to be signaled explicitly.

It's more difficult if group assignment is being done only by the receiver of a message
and the receiver indicates the group in the response (i.e. AAA). The sender of the AAR
may not be able to interpret the group-specific AVPs.

Furthermore, changes in the support of group operations may be possible after one of the
Diameter nodes changed and the existing session context is transferred to the new
Diameter node. That could be after a handover or after a failover scenario. Here, group
re-assignment is needed anyhow, at least in case of handover. First handshakes after
such relocation of a Diameter node may require fallback to single session operations
e.g. to assign a session to a new group.

Any thoughts?

marco

---

From: <[email-masked]>
Date: Thu, 28 Feb 2013 10:41:29 +0000

Hi Marco,

Thank you for reactivating this discussion.

See below.

Lionel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Marco Liebsch
Envoyé : mardi 19 février 2013 17:24
À : [email-masked]
Objet : [Dime] Command re-use, implicit capability exchange

Hi,

[LM] ok

remote peer does not support group operations. 

[LM] ok

In case the remote peer does not want to
assign the session to a group for other reasons, this needs to be signaled explicitly.

[LM] ok.

[LM] The principle given above can be also applied in this case. The client can ask for group assignment and wait for the answer from the server. This could be done using a flag, an empty value in the Group-Session-ID AVP, or any other suitable solution.

[LM] For me there are two steps: the old node has to remove the "transferred" session from the group-session handled locally and the transferred session is assigned to a new Group-session in the new client (if supported). In such a case, the old client should notify the server of the change in the group assignment. After, there is a new group assignment mechanism between the new client and the server, which would be independent of the other one.

Any thoughts?

marco

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.