Subject: [Dime] Command re-use, M-bit of new group AVPs

From: Marco Liebsch <[email-masked]>
Date: Tue, 19 Feb 2013 15:20:29 +0000

Hi,

the latest proposal to enable Diameter to signal group commands re-uses
existing Diameter messages and adds new group-specific AVPs to the command.
Examples for new AVPs are a Group-Session-ID AVP and a Group-Session-Action AVP.
Let's dig into some technical details to assess the approach.

IMO, the M-bit of the new AVPs must be set and must result in an error response
at a receiver in case the receiver of the group command does not understand the
semantics of the new AVP, hence it does not support group operations. The sender
of the group command must then fall back to signal individual commands for
each session.

The only way to *not* set the M-bit and 'ignore' the new group AVP
at such receiver would be to include sufficient information according to
the standard application, including a single session's Session ID.
That could enable the receiver to process the command for at least
one single session of the group. This would require adding a
single session's Session-ID into the typically mandatory Session-ID AVP of the message.
The receiver may send a positive response to the sender of the group message
and indicate that solely for the included Session ID the command had been
processed successfully. This assumes a standard Diameter peer behaves like that.
If that works, the sender could omit sending an individual command at least for the
session that had been processed already.

Any comments?

marco

---

From: <[email-masked]>
Date: Thu, 28 Feb 2013 11:03:40 +0000

Hi Marco,

Please see below.

Regards,

Lionel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Marco Liebsch
Envoyé : mardi 19 février 2013 16:20
À : [email-masked]
Objet : [Dime] Command re-use, M-bit of new group AVPs

Hi,

[LM] that could be a guideline when defining a new application reusing existing commands.

[LM] Everything related to a single session should remain unchanged. For instance, creation/termination of each individual session will trigger a specific exchange between the client and the server. So for all these messages, the session id assigned to the current session will be used to populate the Session-Id AVP. Now, when a request is initiated to impact a group of sessions, the session-id AVP must be filled with one of the session-id values pertaining to the group. So at least, any node will be able to manage individual sessions. Between clients and servers, the way to discover that both sides support the group session management is discussed in another thread. But when both nodes have discovered that the other end-point supports the mechanism, all the information related to the group session management can be done using AVP with the M-bit cleared. This will ensure that this mechanism can be also reused over existing applications if required.

Any comments?

marco

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.