Subject: Re: [Dime] overload control requirement 7 on stability

From: Ben Campbell <[email-masked]>
Date: Mon, 11 Mar 2013 15:48:54 +0100

(Sorry for the late response--I just found Jouni's message when going back over threads to prep for the Orlando meeting)

HI Jouni, do you have any suggestions on how to improve it?

I don't usually think of "throughput" as indicating bandwith or bps. I think of it in terms of completed transactions, although I think both measures would qualify.

Other areas have used the word "goodput" when discussing overload and congestions. I gather the intent is to distinguish between "attempted work" and "successful work". I personally find that usage awkward and unnecessary.

On Feb 21, 2013, at 11:14 PM, Jouni Korhonen <[email-masked]> wrote:

> <as an individual>
> 
> 
> I would still argue that "..the mechanism MUST enable throughput.."
> could use some rewording. The load in the network might not be about
> 'throughput' as in bps but for example about transactions.
> 
> - Jouni
> 
> 
> On Feb 20, 2013, at 9:38 PM, Eric McMurry <[email-masked]> wrote:
> 
>> Req 7 reads:  The overload control mechanism and any associated default
>>           algorithm(s) MUST ensure that the system remains stable.
>>           When the offered load drops from above the overall capacity
>>           of the network to below the overall capacity, the throughput
>>           MUST stabilize and become equal to the offered load.  Note
>>           that this also requires that the mechanism MUST allow nodes
>>           to shed load without introducing oscillations.
>> 
>> 
>> It has been pointed out that the latter part of this implies requirements directly on nodes implementing the mechanism, instead of on the mechanism itself.  How does this alternate sound:
>> 
>> 
>>  The overload control mechanism and any associated default
>>           algorithm(s) MUST ensure that the system remains stable.
>>           When the offered load drops from above the overall capacity
>>           of the network to below the overall capacity, the mechanism
>>           MUST enable throughput to stabilize and become
>>           equal to the offered load.  Note
>>           that this also requires that the mechanism MUST allow nodes
>>           to shed load without introducing oscillations.
>> 
>> 
>> Thanks,
>> 
>> Eric
>> 
>> 
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dime
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: Eric McMurry <[email-masked]>
Date: Mon, 11 Mar 2013 21:20:11 +0100

Hi Ben,

That was changed after Jouni's comment.  It currently reads:

 The overload control mechanism and any associated default
            algorithm(s) MUST ensure that the system remains stable.  At
            some point after an overload condition has ended, the
            mechanism MUST enable capacity to stabilize and become equal
            to what it would be in the absence of an overload condition.
            Note that this also requires that the mechanism MUST allow
            nodes to shed load without introducing non converging
            oscillations during or after an overload condition.

As far as I know, this version addresses all of the comments it has received.  Does that match what you recall Jouni?

Thanks!

Eric

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 12 Mar 2013 19:42:21 +0200

WFM.