Subject: [Dime] comments on overload control requirements

From: Eric McMurry <[email-masked]>
Date: Mon, 15 Apr 2013 22:28:38 -0500

Discussions during the recent 3GPP CT4 meeting had some relevance to the last couple of discussions on the diameter overload requirements.  I am repeating the outcome of those discussions here to solicit dime feedback.  I think these are the last discussions left on this draft.  If folks think the proposals here make sense, we'll do a spin with those changes and it should be ready for its second WGLC.

The first one concerns requirement 2.  It has been proposed here (by Ben) that:

Diameter clients must be able to use the received load and overload information to support graceful behavior during an overload condition. Graceful behavior under overload conditions is best described by REQ 3

be added on the end of that requirement for clarification .  I think there was general consensus around that point and the feedback from CT4 was in agreement as well.  Any further comment?

On req 35, there has been much discussion here, and the last round of that was along the lines of changing it to a MUST with some qualification to account for the implications of making it a must.  There had been some counter discussion that a qualified MUST was not much different from the SHOULD that is currently in the draft.  While that point is debatable, I tend to agree that in this case they are close enough that it is unlikely to affect the outcome of the process.  That was also the feedback from CT4.  Some of the people in that discussion were also part of the discussion here on the dime list and in Orlando.  So, how does leaving that requirement alone (with the SHOULD) work for folks?

I'd like to do this spin of the requirements draft this week, assuming the changes (and not changes) make sense to everyone.  The chairs may also want to comment on the timing and impending WGLC.

Thanks!

Eric

---

From: <[email-masked]>
Date: Tue, 16 Apr 2013 08:02:21 +0000

Hi Eric,

Thank you for this round up!

About the discussion on the requirement 2, I think that the proposal for a new requirement reflects the common agreement reached just before the last IETF minutes and the final wording agreed during the Dime session for this new requirement is fine.

About the requirement 35, I'm fine with the "SHOULD" as it is. And the discussion has shown that the "SHOULD" here is understood as a strong recommendation given to the solution designer and this requirement will be used as one of the key criteria when evaluating the proposed technical solutions.

Regards,

Lionel

De : [email-masked] [mailto:[email-masked]] De la part de Eric McMurry
Envoyé : mardi 16 avril 2013 05:29
À : [email-masked]
Objet : [Dime] comments on overload control requirements

Thanks!

Eric

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Eric McMurry <[email-masked]>
Date: Tue, 16 Apr 2013 07:54:07 -0500

Hi Lionel,

Thanks for the clarifications.  Can you and/or Jouni comment on the timeframe for the WGLC?

Thanks!

Eric

---

From: Andrew Booth <[email-masked]>
Date: Tue, 16 Apr 2013 09:35:50 -0400

Works for me.  Thanks Eric.

Andrew

[email-masked] wrote: -----
To: "[email-masked]" <[email-masked]>
From: Eric McMurry 
Sent by: [email-masked]
Date: 04/15/2013 11:28PM
Subject: [Dime] comments on overload control requirements

Thanks!

Eric

_________________________
______________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Wed, 17 Apr 2013 23:01:06 +0000

(with my chair hat)

Hi,

Could we consider that the way forward proposed by Eric is acceptable for the rest of the WG?
Please send even a simple "Works for me" like Andrew. We need to move forward.
By the end of the week, I will ask to Eric and Ben to produce a last version of the draft for a new WGLC, as announced during the last IETF meeting.

Regards,

Lionel

De : [email-masked] [mailto:[email-masked]] De la part de Andrew Booth
Envoyé : mardi 16 avril 2013 15:36
À : Eric McMurry
Cc : [email-masked]
Objet : Re: [Dime] comments on overload control requirements

Andrew

[email-masked] wrote: -----
To: "[email-masked]" <[email-masked]>
From: Eric McMurry
Sent by: [email-masked]
Date: 04/15/2013 11:28PM
Subject: [Dime] comments on overload control requirements

Diameter clients must be able to use thereceived load and overload information to support graceful behavior during an overload condition. Graceful behavior under overload conditions is best described by REQ 3

Thanks!

Eric

_________________________ ______________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Thu, 18 Apr 2013 07:03:54 +0000

Hi

As I did for the Orlando meeting,  I confirm  my agreement for the new sentence to be added to REQ2 and reminded by Eric.

For Req 35, as Lionel , I agree on the "Should"  that here is understood as a strong recommendation given to the solution designer and this requirement will be used as one of the key criteria when evaluating the proposed technical solutions.

Best regards

JJacques

________________________________
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mardi 16 avril 2013 10:02
À : Eric McMurry; [email-masked]
Objet : Re: [Dime] comments on overload control requirements

Hi Eric,

Regards,

Lionel

Thanks!

Eric

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Fri, 19 Apr 2013 02:03:44 +0000

Hi Lionel and all,

The wording for REQ2 and REQ35 are ok for me.

Best Regards,
Susan

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2013年4月18日 7:01
收件人: [email-masked]
主题: Re: [Dime] comments on overload control requirements

(with my chair hat)

Hi,

Regards,

Lionel

Andrew

[email-masked] wrote: -----
To: "[email-masked]" <[email-masked]>
From: Eric McMurry
Sent by: [email-masked]
Date: 04/15/2013 11:28PM
Subject: [Dime] comments on overload control requirements

Thanks!

Eric

Thank you.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 19 Apr 2013 13:52:13 +0000

Greetings,

I agree Reqts, and proposed way forward

Regards,

Martin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shishufeng (Susan)
Sent: Thursday, April 18, 2013 10:04 PM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] comments on overload control requirements

Hi Lionel and all,

Best Regards,
Susan

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2013年4月18日 7:01
收件人: [email-masked]<mailto:[email-masked]>
主题: Re: [Dime] comments on overload control requirements

(with my chair hat)

Hi,

Regards,

Lionel

De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] De la part de Andrew Booth
Envoyé : mardi 16 avril 2013 15:36
À : Eric McMurry
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] comments on overload control requirements

Andrew

[email-masked]<mailto:[email-masked]> wrote: -----
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
From: Eric McMurry
Sent by: [email-masked]<mailto:[email-masked]>
Date: 04/15/2013 11:28PM
Subject: [Dime] comments on overload control requirements

Thanks!

Eric

_________________________ ______________________
DiME mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dime

Thank you.

---

From: Ben Campbell <[email-masked]>
Date: Fri, 19 Apr 2013 08:56:43 -0500

It's probably obvious since I'm a co-author with Eric, but for the sake of completeness:

+1

On Apr 19, 2013, at 8:52 AM, "DOLLY, MARTIN C" <[email-masked]> wrote:

> _______________________________________________
> DiME mailing list
> [email-masked]

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Fri, 19 Apr 2013 09:59:33 -0400

We support this way forward as well.

Regards,
Kalyani

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: Friday, April 19, 2013 9:57 AM
To: [email-masked]
Subject: Re: [Dime] comments on overload control requirements

+1

On Apr 19, 2013, at 8:52 AM, "DOLLY, MARTIN C" <[email-masked]> wrote:

> De : [email-masked] [mailto:[email-masked]] De la part 
> de Andrew Booth Envoyé : mardi 16 avril 2013 15:36 À : Eric McMurry Cc 
> : [email-masked] Objet : Re: [Dime] comments on overload control 
> requirements
>  
> Diameter clients must be able to use thereceived load and overload 
> information to support graceful behavior during an overload condition. 
> Graceful behavior under overload conditions is best described by REQ 3
>  
> _________________________ ______________________ DiME mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/dime
> ______________________________________________________________________
> ___________________________________________________
>  
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>  
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 23 Apr 2013 06:53:58 +0000

Yes, this works for Ericsson as well.

Regards
/MCruz 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bogineni, Kalyani
Sent: viernes, 19 de abril de 2013 16:00
To: 'Ben Campbell'; [email-masked]
Subject: Re: [Dime] comments on overload control requirements

Regards,
Kalyani

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: Friday, April 19, 2013 9:57 AM
To: [email-masked]
Subject: Re: [Dime] comments on overload control requirements

+1