Subject: [Dime] I-D Action: draft-ietf-dime-app-design-guide-17.txt

From: [email-masked]
Date: Wed, 29 May 2013 03:05:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Diameter Maintenance and Extensions Working Group of the IETF.

	Title           : Diameter Applications Design Guidelines
	Author(s)       : Lionel Morand
                          Victor Fajardo
                          Hannes Tschofenig
	Filename        : draft-ietf-dime-app-design-guide-17.txt
	Pages           : 21
	Date            : 2013-05-29

Abstract:
   The Diameter Base protocol provides facilities for protocol
   extensibility enabling to define new Diameter applications or modify
   existing applications.  This document is a companion document to the
   Diameter base protocol that further explains and clarifies the rules
   to extend the Diameter base protocol.  It is meant as a guidelines
   document and therefore it does not add, remove or change existing
   rules.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dime-app-design-guide

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dime-app-design-guide-17

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dime-app-design-guide-17

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 29 May 2013 10:11:12 +0000

In this version:

- small editorial corrections/id-nits
- update of the section 5.11 (Diameter security mechanisms) to clarify that IKEv2 is recommended instead of IKEv1.

Cheers,

Lionel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 29 mai 2013 12:05
À : [email-masked]
Cc : [email-masked]
Objet : [Dime] I-D Action: draft-ietf-dime-app-design-guide-17.txt

Abstract:

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 29 May 2013 10:12:20 +0000

It was the last required change and the draft is ready for publication.

Lionel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 29 mai 2013 12:11
À : [email-masked]
Objet : Re: [Dime] I-D Action: draft-ietf-dime-app-design-guide-17.txt

In this version:

Cheers,

Lionel

-----Message d'origine-----

Abstract:

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 30 May 2013 12:38:06 +0300

Folks,

Since the last revision includes some changes that are beyond editorials, there
will be another quick one week WGLC for the draft-ietf-dime-app-design-guide-17.
Specifically pay attention to Section 5.11 changed security recommendations.

The WGLC starts today and ends 6th June 2013 EOB.

- Jouni

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 31 May 2013 17:40:21 +0300

Hi Jouni, 

thanks for starting the working group last call. 
I re-read the entire document and made a couple of editorial changes here and there for improved clarity. 

Here is the updated draft: 
https://github.com/hannestschofenig/tschofenig-ids/blob/master/diameter-design-guide/draft-ietf-dime-app-design-guide-18.txt

In a discussion with Sebastien a few days ago we were wondering whether it would make sense to put a short section into the document that explains what a document authors needs to do to register various Diameter extensions (e.g., applications, command codes, AVPs). 

Ciao
Hannes