Subject: [Dime] origin-host scope for draft-roach-dime-overload-ctrl

From: Eric McMurry <[email-masked]>
Date: Wed, 26 Jun 2013 17:24:14 -0500

There are use cases for Diameter overload control where it would be useful for a server to be able to throttle traffic from a specific source.  When the source is adjacent to the server, this can be accomplished easily enough by the server just sending the overload control information directly to the source in question.

However, when there are intermediaries between the server and the source (client), the current proposed mechanism in draft-roach-dime-overload-ctrl does not have a way to do this.  Adding a scope for origin-host would solve this issue.  The way this would work would be for the server to construct the overload control information and attach the origin-host scope to it that matches the specific source of overload it wants to target.  The information would be ignored by any other recipients as they would not have an origin-host that matches that scope when sending messages.

I think this could be an optional scope as it wouldn't be needed for all applications that may use Diameter overload control.

Thoughts?

Thanks!

Eric

---

From: Ben Campbell <[email-masked]>
Date: Wed, 26 Jun 2013 22:45:44 -0500

> However, when there are intermediaries between the server and the source (client), the current proposed mechanism in draft-roach-dime-overload-ctrl does not have a way to do this.  Adding a scope f…

This could also be used by an agent to throttle traffic from a specific client, since it could match the actual origin-host value in a request to the origin-host scope value.

> I think this could be an optional scope as it wouldn't be needed for all applications that may use Diameter overload control.

I agree it should be optional for agents. I'm on the fence for clients, but optional is probably okay there. If people specify application specific behavior for certain applications, they could always mandate it there.

> Thoughts?
> 
> 
> 
> Thanks!
> 
> Eric
> 
> 
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime