Subject: [Dime] Scope refinement in draft-roach-dime-overload-ctrl

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 30 Jul 2013 05:23:04 +0000

Greetings,

AT&T recommendations the follow:

1. the Application-ID and Connection Scopes are the minimum set of scopes that are mandatory to support for interoperability

2. the Session-Group Scope is required to be supported for diameter Sessions, and mandatory for complex deployments, as in 3GPP PCC.

3. the Session and the Host Scopes are NOT needed and should be removed from the draft.

4. the Destination-Realm Scope is not needed in deployments with isolated (separate) realms, therefore is not mandatory

5. the Destination-Host Scope is useful in some (not all) deployment scenarios, and should be optional

6. the discussion on "implicit"/base Scope should be put on hold till we have consensus on the refinement of the Scopes needed.

Regards,

Martin

---

From: Ben Campbell <[email-masked]>
Date: Tue, 30 Jul 2013 09:17:39 +0200

Hi Martin,

One question, inline:

Thanks!

Ben.

> 2. the Session-Group Scope is required to be supported for diameter Sessions, and mandatory for complex deployments, as in 3GPP PCC.

Since you put these in separate line items, am I correct to assume you intend "required to be supported" in line 2  to be different from "mandatory to support" in line 1?

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 30 Jul 2013 08:29:59 +0000

Ben,

To be clear on item #2, we see the Session-Group Scope as mandatory to implement for equipment that support diameter sessions. WTS  not all session based diameter interfaces/Applications, as the 3GPP Charging Ro interface, would need to use the Session-Group Scope.

Regards,

Martin

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Tuesday, July 30, 2013 3:18 AM
To: DOLLY, MARTIN C
Cc: [email-masked]; Eric McMurry; TROTTIN, JEAN-JACQUES (JEAN-JACQUES) ([email-masked])
Subject: Re: Scope refinement in draft-roach-dime-overload-ctrl 

Hi Martin,

One question, inline:

Thanks!

Ben.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 30 Jul 2013 10:38:20 +0200

Paraphrasing to check my own understanding:

Session-Group scope would be optional to implement in general (i.e in the IETF specs), but might be made mandatory by 3GPP (or other customer SDOs) for certain interfaces?

Would it make sense to for the IETF spec to say MAY in general, and SHOULD for devices that support session-stateful applications?

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 30 Jul 2013 08:59:29 +0000

inline

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Tuesday, July 30, 2013 4:38 AM
To: DOLLY, MARTIN C
Cc: [email-masked]; Eric McMurry; TROTTIN, JEAN-JACQUES (JEAN-JACQUES) ([email-masked])
Subject: Re: Scope refinement in draft-roach-dime-overload-ctrl 

[MCD] - Yes

Would it make sense to for the IETF spec to say MAY in general, and SHOULD for devices that support session-stateful applications?
[MCD] - Yes, that is reasonable