Subject: Re: [Dime] origin-host scope for draft-roach-dime-overload-ctrl

From: Eric McMurry <[email-masked]>
Date: Tue, 2 Jul 2013 21:59:19 -0500

any other thoughts on this?

Right now, this, and the discussion that Ben started on non-supporting elements are the only open discussions on this draft.  I expect more when folks dig into it some more.  I can do another spin of this before Berlin and I'm interested in hearing thoughts on the discussion points raised on the list or any others people have upon review.

Thanks!

Eric

On Jun 26, 2013, at 22:45 , Ben Campbell <[email-masked]> wrote:

> 
> On Jun 26, 2013, at 5:24 PM, Eric McMurry <[email-masked]> wrote:
> 
>> There are use cases for Diameter overload control where it would be useful for a server to be able to throttle traffic from a specific source.  When the source is adjacent to the server, this can be accomplished easily enough by the server just sending the overload control information directly to the source in question.
>> 
>> However, when there are intermediaries between the server and the source (client), the current proposed mechanism in draft-roach-dime-overload-ctrl does not have a way to do this.  Adding a scope for origin-host would solve this issue.  The way this would work would be for the server to construct the overload control information and attach the origin-host scope to it that matches the specific source of overload it wants to target.  The information would be ignored by any other recipients as they would not have an origin-host that matches that scope when sending messages.
> 
> This could also be used by an agent to throttle traffic from a specific client, since it could match the actual origin-host value in a request to the origin-host scope value.
> 
>> 
>> I think this could be an optional scope as it wouldn't be needed for all applications that may use Diameter overload control.
>> 
> 
> I agree it should be optional for agents. I'm on the fence for clients, but optional is probably okay there. If people specify application specific behavior for certain applications, they could always mandate it there.
> 
>> Thoughts?
>> 
>> 
>> 
>> Thanks!
>> 
>> Eric
>> 
>> 
>> 
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dime
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sat, 6 Jul 2013 14:23:07 +0000

Eric
Ben,

I am assuming that understands their deployment needs. 

Ex: 
1. for deployments where a carrier does HSS pooling, the Agent needs to support Diameter OL, and deployment on an Agent must be first of the network elements.
2. for mid-to large PCC deployments, the Agent needs to support Diameter OL, and deployment on an Agent must be first of the network elements.

So, I do not see the value the origin-host scope, yet...

I do not see a need to support requirement/capabilities for " non-supporting elements", this will be addressed by deployments.

Regards,

Martin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric McMurry
Sent: Tuesday, July 02, 2013 10:59 PM
To: [email-masked]
Subject: Re: [Dime] origin-host scope for draft-roach-dime-overload-ctrl

Thanks!

Eric

---

From: Ben Campbell <[email-masked]>
Date: Sat, 6 Jul 2013 16:20:09 -0500

Hi Martin,

The origin-host scope is mostly orthogonal to the non-supporting agent issue. The use case for origin-host is when you have a single client that starts sending too much traffic, and you want to reduce messages from just that client. The actual throttling could occur in the client, or in an intervening agent.

Thanks!

Ben.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sun, 7 Jul 2013 00:02:38 +0000

Ben,

Thanks, that was not clear to me, but it is now.

I will look to see if it is this clear in the draft and if the reasons for the other scopes are simply explained.

Regards,

Martin

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Saturday, July 06, 2013 5:20 PM
To: DOLLY, MARTIN C
Cc: Eric McMurry; [email-masked]
Subject: Re: [Dime] origin-host scope for draft-roach-dime-overload-ctrl

Hi Martin,

Thanks!

Ben.