Subject: [Dime] Diameter Overload - Session Scope

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sun, 14 Jul 2013 12:44:18 +0000

Ben,

How useful is the Session Scope? Particularly, when Session-Group Scope is used?

Thanks,

Martin Dolly
Lead Member Technical Staff
Core & Government/Regulatory Standards
AT&T Labs
[email-masked]<mailto:[email-masked]>
+1-609-903-3360

---

From: Ben Campbell <[email-masked]>
Date: Sun, 14 Jul 2013 12:35:29 -0500

I don't think session scope useful for anything other than maybe very small  deployments. If the number of sessions you need to report on at any one time goes beyond a pretty small number, it will become unwieldy. I think it's inclusion might even violate our requirements about not adding significant work to an already overloaded node. The session group mechanism and associated scope are designed to handle the situation where you need to report on a large number of fate-shared sessions.

The one exception I can think of would be if you have a single (or small number) of sessions that are generating an inordinate amount of Diameter traffic. I have trouble imagining a use case that would drive that. Is that something you see happening? I can imagine a poorly behaved device causing lots of new session requests, but not lots of requests in the same session. (Obviously, sending too much user plane traffic can be a problem, but that shouldn't drive signaling).

On Jul 14, 2013, at 7:44 AM, "DOLLY, MARTIN C" <[email-masked]> wrote:

> [email-masked]

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Tue, 16 Jul 2013 09:19:51 +0000

Hi

About Session scope, I agree there is no real use cases, as Ben mentioned, so we may not consider it at this stage of the analysis.

Best regards

JJacques 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Ben Campbell
Envoyé : dimanche 14 juillet 2013 19:35
À : DOLLY, MARTIN C
Cc : [email-masked]
Objet : Re: [Dime] Diameter Overload - Session Scope

> Core & Government/Regulatory Standards

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime