Subject: Re: [Dime] Adopt draft-roach-dime-overload-ctrl as WG document

From: Eric McMurry <[email-masked]>
Date: Thu, 1 Aug 2013 15:58:44 +0200

Thanks for bringing that up Martin.  I know you have given some thought to deployment and your input is appreciated.  It is important for this to progress as quickly as possible in a way that will work for the use cases and requirements that have been agreed to by the group.  I think there is room to simplify aspects (such as mandatory to implement scopes as you pointed out, different use cases will need different scopes) to make sure that this makes sense for various diameter implementations.  This draft is not perfect, but it supports all but one requirement and will allow simple implementations for simple use cases (such as HSS), and still support complicated use cases (such as PCC) without requiring such a simple implementation that we don't improve on the current broken behavior, or devolving into point solutions that become an implementation and deployment nightmare.

Speed is important here and I agree with starting from a reasonably mature draft that has been receiving discussion from a number of interested stakeholders.  This will be the most rapid way forward as we whittle and tune this so it works for everyone, and forward is the direction we need to move.

All of that said, there are legitimate concerns about complexity and the difficulties that can result in implementation and deployment resulting from complexity. The path through this draft for simple implementations is not clear and we should fix that.  The data model is separated (in the form of avp definitions), but more of the semantic information (meanings of informational bits, not behavior) would be useful there and it can be made more clear.  These are fixable items.  Some of the remaining complexity can be removed, as has been deliberated in on and offline discussions.

So, as a way forward, I would suggest, as Martin has, we start with this and hack it up.  As is, it meets the great majority of the identified requirements and we can reorder, reword, and prune to make it easier to implement and more obvious as to what bits are needed for different use cases.  This will be significantly faster than starting over.

Let's discuss this more in the dime meeting.

Thanks,

Eric

On Jul 30, 2013, at 7:07 , "DOLLY, MARTIN C" <[email-masked]> wrote:

> Good day,
> 
> AT&T would like draft-roach-dime-overload-ctrl be adopted as a WG document to which WG consensus changes can be made, at this meeting.
> 
> I will be making recommendation on refinement of the scopes in a separate email.
> 
> Regards,
> 
> Martin

---

From: Benoit Claise <[email-masked]>
Date: Fri, 02 Aug 2013 10:02:39 +0200

Hi,
> AT&T would like draft-roach-dime-overload-ctrl be adopted as a WG document to which WG consensus changes can be made, at this meeting.
I believe that you meant: "Martin (who btw happened to be working for 
AT&T) would like ..."

Regards, Benoit
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>
>

---

From: Eric McMurry <[email-masked]>
Date: Fri, 2 Aug 2013 10:06:16 +0200

I think he had his legal name changed to AT&T Dolly ;-)

On Aug 2, 2013, at 10:02 , Benoit Claise <[email-masked]> wrote:

> I believe that you meant: "Martin (who btw happened to be working for AT&T) would like ..."
> 
> Regards, Benoit
>>