Subject: [Dime] Fwd: New Version Notification for draft-donovan-dime-agent-overload-00.txt

From: Steve Donovan <[email-masked]>
Date: Tue, 22 Oct 2013 07:32:52 -0500

All,

I have created a new draft addressing Diameter Agent Overload.  This is
an extension of the output from the Diameter Overload Control design
team and draft-docdt-dime-ovli-00.txt

Regards,

Steve

-------- Original Message --------
Subject: 	New Version Notification for
draft-donovan-dime-agent-overload-00.txt
Date: 	Mon, 21 Oct 2013 14:49:06 -0700
From: 	[email-masked]
To: 	Steve Donovan <[email-masked]>

A new version of I-D, draft-donovan-dime-agent-overload-00.txt
has been successfully submitted by Steve Donovan and posted to the
IETF repository.

Filename:	 draft-donovan-dime-agent-overload
Revision:	 00
Title:		 Diameter Agent Overload
Creation date:	 2013-10-21
Group:		 Individual Submission
Number of pages: 12
URL:             http://www.ietf.org/internet-drafts/draft-donovan-dime-agent-overload-00.txt
Status:          http://datatracker.ietf.org/doc/draft-donovan-dime-agent-overload
Htmlized:        http://tools.ietf.org/html/draft-donovan-dime-agent-overload-00

Abstract:
   This specification documents an extension to the Diameter Overload
   Control (DOC) base solution.  The extension addresses the handling of
   agent overload.

Requirements

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Steve Donovan <[email-masked]>
Date: Wed, 23 Oct 2013 12:01:52 -0500

Ulrich,

Thank you for the review.  I have added the DIME mailing list to my
response.  I have addressed your points below.

Regards,

Steve

-----

Section 3.4 - The interaction between end-point overload and agent
overload is a two step process.  The first step is to determine how much
traffic targeted for the end-point is actually sent.  The end-point
overload report is used for this purpose.  The second step is to
determine the route that traffic takes.  The agent overload report is
used for this purpose.

On capability negotiation -- The goal is to have a single negotiation
mechanism for Diameter overload.  Your suggestion of using CER/CEA for
the negotiation for the peer overload report type would work but it
requires splitting the negotiation mechanism in two.  This is something
that should be discussed further as there are pro's and con's to both
mechanisms.

Section 4.2 - Agent overload (or peer overload) is indeed hop-by-hop,
but the solution must also handle the case where there are hops that do
not support overload.

Section 5.2 - The comment on use of the loss algorithm can probably be
better worded but the point is that the same abatement
strategy/algorithm can be used by the reactor.  Agent overload does not
imply a different algorithm.

On 10/23/13 9:57 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:
>
> Steve,
>
>  
>
> please find my  comments attached.
>
>  
>
> Best regards
>
> Ulrich
>
>  
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf
> Of *ext Steve Donovan
> *Sent:* Tuesday, October 22, 2013 2:33 PM
> *To:* [email-masked]
> *Subject:* [Dime] Fwd: New Version Notification for
> I have created a new draft addressing Diameter Agent Overload.  This
> is an extension of the output from the Diameter Overload Control
> design team and draft-docdt-dime-ovli-00.txt
>
>
> Regards,
>
> Steve
>
> *Subject: *
> New Version Notification for draft-donovan-dime-agent-overload-00.txt
>
> *Date: *
>
> 	
>
> Mon, 21 Oct 2013 14:49:06 -0700
>
> *From: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> Steve Donovan <[email-masked]> <mailto:[email-masked]>
>
>  
>