Subject: [Dime] DOIC: Multiple instance of OC-OLR AVP (of the same type) within a response message

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 28 Nov 2013 09:33:17 +0000

Hi,

As I understand IETF will define the base overload control solution as part of DOIC. Then 3GPP would adopt the defined solution for each of its application.
When that happens, 3GPP might want to add 3GPP specific AVP within OC-OLR AVP. Based on the current definition of the OC-OLR AVP this should be allowed since it contains "* [AVP]" in its definition.
e.g. for a given application 3GPP decides to add information into OC-OLR which changes the scope of the OC-OLR from application level to the provided information level.
Additionally, the reporting may want to advertise the OC-OLR at the application level scope - i.e. the OC-OLR without any 3GPP specific info.

So if the above is allowed, we will have the possibility of the reporting node wanting to include two instances of OC-OLR with the Report-Type="host".
And then we need to define the handling of multiple instances of OC-OLR in the DOIC draft.

So the questions are,

-          Is 3GPP (or any other SDO) allowed to extend the definition of OC-OLR by adding information into it?

-          If no, can we guarantee that application level scope of OC-OLR (which is what we have defined currently) is sufficient (and not restricting) to all the applications of 3GPP?

Regards,
Nirav.

---

From: <[email-masked]>
Date: Thu, 28 Nov 2013 10:26:54 +0000

Hi Nirav,

Not sure to understand the proposal or question.
The OLR is significant per application (piggybacking principle). So if the 3GPP decides to add specific AVPs in the OLR (that will be possible), what would be the need to add the OLR without the specific 3GPP AVPs as the OLR will be anyway handle by 3GPP aware entities?

Lionel

De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot)
Envoyé : jeudi 28 novembre 2013 10:33
À : [email-masked]
Objet : [Dime] DOIC: Multiple instance of OC-OLR AVP (of the same type) within a response message

Hi,

So the questions are,

Regards,
Nirav.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 28 Nov 2013 11:59:57 +0000

Lionel,

3gpp may define an optional avp which can be included by the reporting node if it wishes to do so. E.g. APN can be additionally included by the reporting node to indicate APN specific overload within the given application.
In that case, the reporting node may also want to indicate application level overload without including the APN (e.g. this overload report is applicable to all other APNs).

And hence there is a possibility of including multiple instances of the overload report.

I am not suggesting that 3gpp will define APN (or any other avp) within overload report. But later, if 3gpp need to define the same, then corresponding handling needs to be defined within IETF now.

Regards,
Nirav.

On Nov 28, 2013 3:56 PM, "[email-masked]" <[email-masked]> wrote:
Hi Nirav,

Lionel

Hi,

As I understand IETF will define the base overload control solution as part of DOIC. Then 3GPP would adopt the defined solution for each of its application.
When that happens, 3GPP might want to add 3GPP specific AVP within OC-OLR AVP. Based on the current definition of the OC-OLR AVP this should be allowed since it contains "* [AVP]" in its definition.
e.g. for a given application 3GPP decides to add information into OC-OLR which changes the scope of the OC-OLR from application level to the provided information level.
Additionally, the reporting may want to advertise the OC-OLR at the application level scope – i.e. the OC-OLR without any 3GPP specific info.

So the questions are,

Regards,
Nirav.

---

From: <[email-masked]>
Date: Thu, 28 Nov 2013 14:09:24 +0000

Hi Nirav,

The Report Type should be able to differentiate such cases. In your example, I would define a specific Report type.
But difficult to appraise all the future use cases. But for me, the main use of the report type is to differentiate OC-OLR received in the same message.
And it is the reasons of my recommendation. Actually, the exact wording will be a "SHOULD" saying that it is recommended but you may have serious reasons to do otherwise.

Lionel

De : Nirav Salot (nsalot) [mailto:[email-masked]]
Envoyé : jeudi 28 novembre 2013 13:00
À : MORAND Lionel IMT/OLN
Cc : [email-masked]
Objet : RE: DOIC: Multiple instance of OC-OLR AVP (of the same type) within a response message

Lionel,

Regards,
Nirav.

Lionel

Hi,

So the questions are,

Regards,
Nirav.

Thank you.

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 28 Nov 2013 16:11:05 +0000

Hi Lionel,

I am not sure if defining new ReportType for every new AVP 3GPP would add for a specific application would be a good solution.
I thought ReportType would indicate if the corresponding OC-OLR should be used while sending the traffic towards the host or towards the realm.
So from that point of view, all the OC-OLR generated by the server should have ReportType=host. i.e. when the reacting node sends the traffic towards that host, it should make use of the corresponding OC-OLR. Now, this OC-OLR may contain the AVPs defined by DOIC draft as well as 3GPP application specific AVPs.

In general, I was just thinking that it may be good idea to define some of the principles such as

-          More than one instances of OC-OLR with ReportType=host may be present in the answer message if the OC-OLR definition is extended by the application using the same. In that case, it is the responsibility of the application to define the valid combination of OC-OLR instances in a given message

-          If the reporting node includes more than one instance of OC-OLR, the reporting node shall always include all the active instances of OC-OLR in a response message.

-          When the reacting node receives one or more instances of OC-OLR with the given ReportType and with new timestamp value, it should overwrite all the existing OC-OLR of the same ReportType.

Regards,
Nirav.

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, November 28, 2013 7:39 PM
To: Nirav Salot (nsalot)
Cc: [email-masked]
Subject: RE: DOIC: Multiple instance of OC-OLR AVP (of the same type) within a response message

Hi Nirav,

Lionel

Cc : [email-masked]<mailto:[email-masked]>

Lionel,

Regards,
Nirav.
On Nov 28, 2013 3:56 PM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Nirav,

Lionel

De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot)
Envoyé : jeudi 28 novembre 2013 10:33
À : [email-masked]<mailto:[email-masked]>
Objet : [Dime] DOIC: Multiple instance of OC-OLR AVP (of the same type) within a response message

Hi,

So the questions are,

Regards,
Nirav.

Thank you.

Thank you.