Subject: [Dime] OVLI: clarification in 4.2

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 3 Dec 2013 13:56:00 +0000

Hello,

I would like to propose a clarification on 4.2
                ....
   The OC-OLR AVP does not contain explicit information to which
   application it applies to and who inserted the AVP or whom the

   specific OC-OLR AVP concerns to. Both these information is

   implicitly learned from the encapsulating Diameter message/command.

   The application the OC-OLR AVP applies to is the same as the

   Application-Id found in the Diameter message header.  The identity

   the OC-OLR AVP concerns is determined from the Origin-Host AVP found

   from the encapsulating Diameter command.

My understanding is that "who inserted the AVP" cannot always be learned from the encapsulating Diameter message, since "origin-host" may not always contain the host that inserted the OLR.
A part from that, "whom the specific OC-OLR AVP concerns to", could be a bit misleading... "whom" may be host, realm, or any other future ReportType, or even any other "narrowed scope" within the OLR. Last sentence is affected by this ambiguity as well.

Some rephrasing may be considered:
   The OC-OLR AVP does not contain explicit information that may be

   implicitly learned from the encapsulating Diameter message/command.

   The application the OC-OLR AVP applies to is the same as the

   Application-Id found in the Diameter message header. When Report-Type is

   a Destination-Host, the identity

   the OC-OLR AVP concerns is determined from the Origin-Host AVP found

   from the encapsulating Diameter command.

Best regards
/MCruz

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Dec 2013 15:03:08 +0000

Hi MCruz,

isn't this clause 4.3?

I agree that clarification is needed.
But isn't it so that the OLR contains some explicit information (e.g. the Report-Type) that is not implicitly learned from the encapsulating Diameter message?

My proposal:
The OC-OLR AVP does not contain explicitly all information needed by the reacting node in order to decide whether a subsequent request must undergo a throttling process with the reported percentage. To take this decision the reacting node must check

a)      whether the subsequent request's Application-ID matches the Application-Id received in the OC-OLR AVP's encapsulating answer command;

b)      if the Report-Type received in the OC-ORL is "host"
b1)  whether the subsequent request's Destination Host is present and matches the Origin Host received in the OC-OLR AVP's encapsulating answer command;
if the Report-Type received in the OC-OLR is "realm"
b2) whether the subsequent request' Destination Host is absent and the Destination Realm matches the Origin Realm received in the OC-OLR AVP's  encapsulating answer command;

Best regards
Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Maria Cruz Bartolome
Sent: Tuesday, December 03, 2013 2:56 PM
To: [email-masked]
Subject: [Dime] OVLI: clarification in 4.2

Hello,

Best regards
/MCruz

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 3 Dec 2013 15:11:23 +0000

Hello Ulrich,

You are right, it is 4.3 in version under development:
https://github.com/jounikor/draft-docdt-dime-ovli/blob/master/draft-ietf-dime-ovli-01.txt

Your proposal looks fine.
Best regards
MCruz

From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: martes, 03 de diciembre de 2013 16:03
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] OVLI: clarification in 4.2

Hi MCruz,

isn't this clause 4.3?

My proposal:

Best regards
Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Maria Cruz Bartolome
Sent: Tuesday, December 03, 2013 2:56 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dime] OVLI: clarification in 4.2

Hello,

Best regards
/MCruz

---

From: <[email-masked]>
Date: Tue, 3 Dec 2013 17:26:02 +0000

The clarification is welcome but I think that we don't have to state what is missing in the OLR (because a lot of things could be added to the list) but what we can do with the OLR as defined in this document.

We could have something as simple as:

As defined in this document, the overload report contained in the OC-OLR AVP
applies to the application identified by the application-id used in the Diameter header
of the Diameter message. The value of the Report-Type AVP indicates the scope of
applicability of this overload report for this application, as described in section 4.6.

No need for extra info here as we have more details in section 4.6 e.g. "The reacting node learns the "host" implicitly from the Origin-Host AVP of the received message that contained the OC-OLR AVP"

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 3 décembre 2013 16:11
À : [email-masked]
Objet : Re: [Dime] OVLI: clarification in 4.2

Hello Ulrich,

Hi MCruz,

isn't this clause 4.3?

My proposal:

Best regards
Ulrich

Hello,

Best regards
/MCruz

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 4 Dec 2013 10:19:18 +0000

I prefer the more explicit description in the previous proposal.
Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: Tuesday, December 03, 2013 6:26 PM
To: Maria Cruz Bartolome; [email-masked]
Subject: Re: [Dime] OVLI: clarification in 4.2

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 3 décembre 2013 16:11
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] OVLI: clarification in 4.2

Hello Ulrich,

From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: martes, 03 de diciembre de 2013 16:03
To: Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>
Subject: RE: [Dime] OVLI: clarification in 4.2

Hi MCruz,

isn't this clause 4.3?

My proposal:

Best regards
Ulrich

Hello,

Best regards
/MCruz

Thank you.

---

From: <[email-masked]>
Date: Wed, 4 Dec 2013 11:21:40 +0000

In this section, we are only defining the Grouped AVP, not all the AVPs contained in the Grouped AVP.

Lionel

De : Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Envoyé : mercredi 4 décembre 2013 11:19
À : MORAND Lionel IMT/OLN; Maria Cruz Bartolome; [email-masked]
Objet : RE: [Dime] OVLI: clarification in 4.2

Regards,

Lionel

Hello Ulrich,

Hi MCruz,

isn't this clause 4.3?

My proposal:

Best regards
Ulrich

Hello,

Best regards
/MCruz

Thank you.