Subject: Re: [Dime] OVLI: comments to 4.5

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 6 Dec 2013 14:39:06 +0000

Dear all,

here is another comment to 4.5:

3. It may be worth to clarify the meaning of a validity duration of 0 seconds. In my understanding it does not mean that the encapsulating OC-OLR is invalid. It is valid (and therefore replaces any previous OLR with the same report-type), but it immediately expires and hence is a way to signal "end of overload".

Best regards
Ulrich
_____________________________________________
From: Wiehe, Ulrich (NSN - DE/Munich)
Sent: Thursday, December 05, 2013 5:05 PM
To: [email-masked]'
Subject: OVLI: comments to 4.5

Dear all,

here are comments to clause 4.5:

1. (linked to a previous comment to 4.3) The first sentence should be modified to read

   The OC-Validity-Duration AVP (AVP code TBD4) is type of Unsigned32
   and describes the number of seconds the OC-OLR AVP and its content is
   valid since the creation of the OC-OLR AVP (as indicated by the
   OC-TimeStamp AVP).

2. A default value of 5 seconds does not make much sense when the Reduction-Percentage is absent or takes the value 0. Proposal is to modify text as follows:

   The default value for the OC-Validity-Duration AVP value is 5 (i.e. 5 seconds).  When the OC-Validity-
   Duration AVP is not present in the OC-OLR AVP, the default value applies, unless the Reduction-Percentage AVP
   is absent or takes the value 0, in which cases the validity is unlimited.

Best regards
Ulrich

---

From: Ben Campbell <[email-masked]>
Date: Fri, 6 Dec 2013 15:57:30 -0600

On Dec 6, 2013, at 8:39 AM, Wiehe, Ulrich (NSN - DE/Munich) <[email-masked]> wrote:

> 3. It may be worth to clarify the meaning of a validity duration of 0 seconds. In my understanding it does not mean that the encapsulating OC-OLR is invalid. It is valid (and therefore replaces any previous OLR with the same report-type), but it immediately expires and hence is a way to signal “end of overload”.
> 

That's effectively the same thing as invalidating any pre-existing OLR.  I don't think we need the text to jump through hoops to try to make that invalidation sound like a side effect. (And I note that this approach is common in other protocols, e.g. SIP registrations and subscriptions.)

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 9 Dec 2013 10:56:23 +0200

Ulrich,

> 3. It may be worth to clarify the meaning of a validity duration of 0 seconds. In my understanding it does not mean that the encapsulating OC-OLR is invalid. It is valid (and therefore replaces any…

Validity duration of 0 causes an immediate timeout of OLR state
with an endpoint. I agree this should be clarified (it is actually
discussed in Section 5.5.2. but should be mentioned here as well).

- Jouni

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime