Subject: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

From: "dime issue tracker" <[email-masked]>
Date: Tue, 04 Feb 2014 08:48:45 -0000

#31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a
throttling

 It has been proposed to define an OC-Ongoing-Throttling-Info AVP that is
 to be included by the reacting DOIC endpoint in request messages that
 survived a throttling. This AVP would indicate the Sequence-Number
 (TimeStamp) of the OLR according to which the throttling (which was
 survived) is performed. Absence of this AVP indicates that currently no
 throttling is performed.  Reporting DOIC endpoints may use this
 information in order to detect whether there is a need to update the
 reacting DOIC endpoint with the latest OLR.
 Absence of this feedback mechanism would result in the need for the
 reporting node to send OC-OLR AVPs in every answer as the reporting DOIC
 endpoint cannot know whether the reacting DOIC endpoint is actually doing
 the right thing with regard to throttling/not throttling.
 The feedback mechanism improves robustness as it allows the reporting DOIC
 endpoint to detect and correct inappropriate throttling by the reacting
 DOIC endpoint (caused by whatever reason).
 The feedback mechanism also allows to address REQ 18 from RFC 7068.
 In summary it is proposed to define the OC-Ongoing-Throttling-Info AVP to
 be used in request messages that survived a throttling.

-- 
--------------------------------------+--------------------------
 Reporter:  [email-masked]  |      Owner:  Ulrich Wiehe
     Type:  defect                    |     Status:  new
 Priority:  major                     |  Milestone:
Component:  draft-docdt-dime-ovli     |    Version:
 Severity:  Active WG Document        |   Keywords:
--------------------------------------+--------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/31>
dime <http://tools.ietf.org/wg/dime/>

---

From: <[email-masked]>
Date: Tue, 4 Feb 2014 15:37:05 +0000

I understand that the real concern is when the reporting node DOES NOT insert the OLR in every answer. 
So the options would be:
1- OC-OLR AVP in every answer
2- OC-Ongoing-Throttling-Info AVP in every request + OC-OLR AVP in some answer when the current throttling performed by the client needs to be updated.

If there is no other criterion, the option 1 seems the best approach.

Lionel

-----Message d'origine-----
De : dime issue tracker [mailto:[email-masked]] 
Envoyé : mardi 4 février 2014 09:49
À : MORAND Lionel IMT/OLN
Cc : [email-masked]
Objet : [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Wed, 5 Feb 2014 04:27:04 +0000

I share the same opinion as Lionel.

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel

-----Message d'origine-----

#31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 It has been proposed to define an OC-Ongoing-Throttling-Info AVP that is  to be included by the reacting DOIC endpoint in request messages that  survived a throttling. This AVP would indicate the Sequence-Number
 (TimeStamp) of the OLR according to which the throttling (which was
 survived) is performed. Absence of this AVP indicates that currently no  throttling is performed.  Reporting DOIC endpoints may use this  information in order to detect whether there is a need to update the  reacting DOIC endpoint with the latest OLR.
 Absence of this feedback mechanism would result in the need for the  reporting node to send OC-OLR AVPs in every answer as the reporting DOIC  endpoint cannot know whether the reacting DOIC endpoint is actually doing  the right thing with regard to throttling/not throttling.
 The feedback mechanism improves robustness as it allows the reporting DOIC  endpoint to detect and correct inappropriate throttling by the reacting  DOIC endpoint (caused by whatever reason).
 The feedback mechanism also allows to address REQ 18 from RFC 7068.
 In summary it is proposed to define the OC-Ongoing-Throttling-Info AVP to  be used in request messages that survived a throttling.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 5 Feb 2014 13:57:04 +0000

Ok then let's state that reporting nodes MUST insert an OC-OLR AVP in all answer messages that correspond to request messages which contain an OC-Supported-Features AVP (even when no load reduction is requested).

Other criteria like REQ18 or REQ13 do not seem to matter.

For my clarification: I guess that the reacting node is not required to process every single OLR received (most will be replays anyway). What would be the procedure in the reacting node in order to minimize processing of replayed OLRs and at the same time minimize the risk too miss a new OLR?

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel

---

From: Steve Donovan <[email-masked]>
Date: Wed, 05 Feb 2014 08:29:34 -0600

inline

> Ok then let's state that reporting nodes MUST insert an OC-OLR AVP in all answer messages that correspond to request messages which contain an OC-Supported-Features AVP (even when no load reduction…
SRD> Why in every answer message?  Shouldn't lack of an OLR be
interpreted as not overloaded?
> Other criteria like REQ18 or REQ13 do not seem to matter.
SRD> Requiring an overload report in every answer does directly break
REQ13, but requiring an overloaded node to look for an
OC-Ongoing-Throttling-Info AVP in every message is also substantial
additional work, potentially more expensive than inserting OLRs.
> For my clarification: I guess that the reacting node is not required to process every single OLR received (most will be replays anyway). What would be the procedure in the reacting node in order to…
SRD> That is the purpose of the sequence number.

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Wed, 5 Feb 2014 15:19:33 +0000

I agree with Steve except the part "shouldn’t lack of OLR be interpreted as not overloaded?"

We had some discussion sometime back and thought that it is reasonable to not mandate the server to include the OLR in every answer message. E.g. when the server is capable of tracking what is sent to which client and hence wants to avoid sending information which is redundant. But this is optional implementation and at the same time need not be prohibited from protocol point of view.

So basically, the lack of OLR should not affect the previously received OLR at the reacting node. The reacting node can continue to react based on older OLR until the expiry of the validity-period or when the explicit OLR with "0" overload-metric is received.
In my view, this allows for flexible implementation at the reporting node and sound handling of OLR at the reacting node.

Regards,
Nirav.

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: Wednesday, February 05, 2014 8:00 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

inline

Ok then let's state that reporting nodes MUST insert an OC-OLR AVP in all answer messages that correspond to request messages which contain an OC-Supported-Features AVP (even when no load reduction is requested).
SRD> Why in every answer message?  Shouldn't lack of an OLR be interpreted as not overloaded?

Other criteria like REQ18 or REQ13 do not seem to matter.
SRD> Requiring an overload report in every answer does directly break REQ13, but requiring an overloaded node to look for an OC-Ongoing-Throttling-Info AVP in every message is also substantial additional work, potentially more expensive than inserting OLRs.

-----Original Message-----

To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Regards,

Nirav.

-----Original Message-----

From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>

To: [email-masked]<mailto:[email-masked]>

So the options would be:

Lionel

-----Message d'origine-----

Cc : [email-masked]<mailto:[email-masked]>

---

From: Steve Donovan <[email-masked]>
Date: Wed, 05 Feb 2014 09:35:20 -0600

Agreed.  To restate -- lack of an overload report does not change the
current overload state for the host or realm.  If there is a currently
active overload report then it continues to apply until it either times
out or is explicitly changed with a new overload report.  If there is no
currently active overload report then lack of an overload report implies
there is no overload for the host and realm.

Steve

On 2/5/14 9:19 AM, Nirav Salot (nsalot) wrote:
> We had some discussion sometime back and thought that it is reasonable
> to not mandate the server to include the OLR in every answer message.
> E.g. when the server is capable of tracking what is sent to which
> client and hence wants to avoid sending information which is
> redundant. But this is optional implementation and at the same time
> need not be prohibited from protocol point of view.
>
>  
>
> So basically, the lack of OLR should not affect the previously
> received OLR at the reacting node. The reacting node can continue to
> react based on older OLR until the expiry of the validity-period or
> when the explicit OLR with "0" overload-metric is received.
>
> In my view, this allows for flexible implementation at the reporting
> node and sound handling of OLR at the reacting node.
>
>  
>
> Regards,
>
> Nirav.
>
>  
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *Steve Donovan
> *Sent:* Wednesday, February 05, 2014 8:00 PM
> *To:* [email-masked]
> *Subject:* Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> AVP in request messages that survived a throttling
>
>  
>
> inline
>
> To: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> From: DiME [mailto:[email-masked]] On Behalf Of [email-masked] <mailto:[email-masked]>
> To: [email-masked] <mailto:[email-masked]>
> Cc : [email-masked] <mailto:[email-masked]>

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 5 Feb 2014 15:39:38 +0000

In-inline

From: DiME [mailto:[email-masked]] On Behalf Of ext Steve Donovan
Sent: Wednesday, February 05, 2014 3:30 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

inline
On 2/5/14 7:57 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:
Ok then let's state that reporting nodes MUST insert an OC-OLR AVP in all answer messages that correspond to request messages which contain an OC-Supported-Features AVP (even when no load reduction is requested).
SRD> Why in every answer message?  Shouldn't lack of an OLR be interpreted as not overloaded?
<Ulrich>lack of OLR implies lack of sequence number and lack or report type. How would the reacting node check whether this "implicit no overload indication" is in-sequence and whether the realm or the host is not overloaded? I would have thought that lack of OLR is interpreted as no change in the overload</Ulrich>

Other criteria like REQ18 or REQ13 do not seem to matter.
SRD> Requiring an overload report in every answer does directly break REQ13, but requiring an overloaded node to look for an OC-Ongoing-Throttling-Info AVP in every message is also substantial additional work, potentially more expensive than inserting OLRs.
<Ulrich>the proposal was not "requiring" but "allowing" the reporting node (especially when not overloaded) to check OC-Ongoing-Throttling-Info AVPs. </Ulrich>

For my clarification: I guess that the reacting node is not required to process every single OLR received (most will be replays anyway). What would be the procedure in the reacting node in order to minimize processing of replayed OLRs and at the same time minimize the risk too miss a new OLR?
SRD> That is the purpose of the sequence number.  
<Ulrich> however, "checking the sequence number" actually means "processing the OLR"; "not processing the OLR" means "not even checking the sequence number"</Ulrich>

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 6 Feb 2014 08:53:05 +0000

Actually we seem to agree on two principles:
1. Lack of OLR means "no change"
2. the reporting node (no matter whether overloaded or not) MAY decide not to return an OLR in response to requests which contained an OC-Supported-Feature AVP if it is aware that the reacting node already has got the latest OLR (which may be an OLR requesting traffic reduction or an OLR indicating "no overload"); otherwise (i.e. if it is not aware...) the reporting node (no matter whether overloaded or not) MUST return an OLR in responses to requests which contained an OC-Supported-Feature AVP.

Can people please confirm.

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Steve Donovan
Sent: Wednesday, February 05, 2014 4:35 PM
To: Nirav Salot (nsalot); [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Agreed.  To restate -- lack of an overload report does not change the current overload state for the host or realm.  If there is a currently active overload report then it continues to apply until it either times out or is explicitly changed with a new overload report.  If there is no currently active overload report then lack of an overload report implies there is no overload for the host and realm.

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 6 Feb 2014 09:08:16 +0000

Ulrich,

I am not sure about forcing this behavior on reporting node "otherwise (i.e. if it is not aware...) the reporting node (no matter whether overloaded or not) MUST return an OLR in responses to requests which contained an OC-Supported-Feature AVP."
The reporting node may simply not include OLR assuming that the earlier provided OLR will expire and the reacting node will stop throttling the traffic.

As we had discussed earlier, there is no need for the reporting node to explicitly stop throttling at each reacting node at the same time. In other words, the reporting node can allow the natural expiry of the OLR to facilitate slow ramp of the signaling traffic towards it.

There may be other cases, e.g. when the reporting node knows that the last overload situation ended long time back in the past, there is no need for it to include OLR if currently there is no overload condition.

Rest of the principles below are fine with me.

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: <[email-masked]>
Date: Thu, 6 Feb 2014 09:19:56 +0000

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot)
Envoyé : jeudi 6 février 2014 10:08
À : Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

[LM] Agree. In other words, it is not deemed required for the default mechanism described in this draft. How and when the reporting node decides to include the OLR in the answer may depend on the application or on the implementation. At least, it is my current understanding.

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 6 Feb 2014 10:27:03 +0000

Nirav, Lionel,

I can understand Nirav's concern (although violating REQ10) and hop it is addressed by the modified principle 2':

2'. the reporting node (no matter whether overloaded or not) MAY decide not to return an OLR in response to requests which contained an OC-Supported-Feature AVP if it is aware that the reacting node already has got reasonable overload control information (e.g. the latest OLR, which may be an OLR requesting traffic reduction or an OLR indicating "no overload", or an old  but soon expiring OLR when the reporting node is not overloaded); otherwise (i.e. if it is not aware...) the reporting node (no matter whether overloaded or not) MUST return an OLR in responses to requests which contained an OC-Supported-Feature AVP.

I don't agree with Lionels do-what-you-want approach. Overload control will not work when we allow the reporting node not to update reacting nodes, which are not (sufficiantly) aware of the current overload status, with up to date OLRs.

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 6 Feb 2014 15:49:06 +0000

Ulrich,

It seems we all are on same page but probably the proposed wording below is not the best.
How about the following.

When the reporting node wants to provide new overload report or wants to update the earlier provided overload report towards a reacting node, it shall include OLR in the response, to the request containing OC-Supported-Feature AVP, towards the corresponding reacting node. Additionally, in other cases, e.g. when the reporting node is not aware if the overload report is already provided to the reacting node, the reporting node may include the OLR in the response, to the request containing OC-Supported-Feature AVP.

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 7 Feb 2014 09:59:19 +0000

Nirav,

I'm afraid your proposed text does not reflect the intention.

"when it wants to provide/update....it shall include..." translates to "...it may include...".

"in other cases" in the given context translates to "when it does not want to provide/update..."

We have the following cases:
a) the reporting node knows that the reacting node has already got the latest OLR
b) the reporting node is not overloaded (i.d. does not want a throttling) and knows that the reacting node has got an OLR that will soon expire
c) otherwise

in case a) the reporting node may or may not replay the OLR
in case b) the reporting node may or may not upddate the reacting node with the latest OLR
in case c) the reporting node MUST include the OLR in the answer (the reporting node does not know whether this is a replay or an update)

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 7 Feb 2014 15:26:50 +0000

Hello Ulrich, Nirav,

I agree with Ulrich that the text provided by Nirav is just a MAY, and whether or not the server sends an OLR in all answers shall not be just a MAY.

On the other hand, criteria provided by Ulrich on when OLR has to be sent requires the server has some knowledge:
a) the reporting node knows that the reacting node has already got the latest OLR
b) the reporting node is not overloaded (i.d. does not want a throttling) and knows that the reacting node has got an OLR that will soon expire
c) otherwise

Reporting node must have some knowledge about OLR reception/status in reacting node. How does server acquire this knowledge? 
Take into account as well that a "reacting" node may be both an Agent (in case it provides service to a realm or acting on behalf of a non-supporting client)  and a Client. In the case of Agents, in fact the Server may not even know if this is going to act as a reacting node or just transparently, in fact, the server does not need to have any knowledge about what agents in the chain to the final Client.

Therefore, I definitely think that sending OLR in ALL answers has some important advantages:
-	state-less implementation (transaction or session) is simpler,
-	the server does not need to determine whether or not to send an OL to a reacting node
-	the server does not need to bother whether an reacting node has already received an OLR or whether this OLR is still valid (has not expired).
-	sending an additional AVP is not processing consuming, in comparison with required above checks (if this is not sent). 
	In fact, in an overload situation, the easiest and least complex is to send information out to all affected/applicable nodes, 
	and the latter should take care to take appropriate actions  
-	more robust solution, as no need to cater for all the checks on the need to send information,  for situations where an answer message is lost,  …

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

in case a) the reporting node may or may not replay the OLR in case b) the reporting node may or may not upddate the reacting node with the latest OLR in case c) the reporting node MUST include the OLR in the answer (the reporting node does not know whether this is a replay or an update)

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Mon, 10 Feb 2014 09:05:15 +0000

Ulrich,

The case "c", i.e. "otherwise" is the whole problem.
You assume that "otherwise" it shall include the OLR in the answer message.
While I already pointed out a valid case (which is neither "a" nor "b") - i.e. the last overload condition ended long time ago - where the reporting node need not/will not include OLR.

So it is not correct that "otherwise" the reporting node shall include OLR in answer message.

To be honest, we need not nail down the exact condition on when the OLR is included by the reporting node and it can be a bit lose as well.
I do not see any issue on Lionel's interpretation - i.e. let reporting node do what it thinks is the best to do to mitigate its own overload condition. Instead of nailing down all the use cases from the protocol point of view (which I think is not needed and secondly not possible).
So I still think the text below is reasonable. But I am fine for other alternative based on the above line of thinking.

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Friday, February 07, 2014 3:29 PM
To: Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]] 
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Mon, 10 Feb 2014 09:11:47 +0000

Maria-Cruz,

I fully agree with you on "sending OLR in ALL answers has some important advantages".
And we are not trying to prevent it - at least that is my intention. 
But the main question is, are we trying to prevent any other possible implementation, which may be smarter and can avoid including redundant OLR in all the answer message?

Most probably, the very first implementation of overload control will include OLR in all the answer messages.
But at the same time, I do not want to restrict the developers which can come up with some nice tweaks and tricks to avoid sending the same information in every message. And this is where we need to be careful and avoid putting such restrictions in protocol definition. 
What do you think?

This also the reason I was suggesting loose description of when to include OLR (from the reporting node point of view).

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot) Envoyé : jeudi 6 février 2014 10:08 À : Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Mon, 10 Feb 2014 09:32:47 +0000

Nirav, all,

I think we should define an accurate and robust solution, as efficient and simple as possible.
I understand your proposal as a pure "may", but leaving it up to implementation does not assure reacting node has valid OLR information, what is basic for this mechanism to work. 

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]] 
Sent: lunes, 10 de febrero de 2014 10:12
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Mon, 10 Feb 2014 09:41:37 +0000

But Maria-Cruz,

How can we say that "including the OLR in all the answer messages is simple and efficient?"
It is simple for sure but not efficient. 

A slightly different wording from what I proposed earlier is,
When the reporting node has a new overload report that needs to be provided to a reacting node (by updating the earlier provided overload report or by providing the overload report for the first time), it shall include OLR in the response, to the request containing OC-Supported-Feature AVP, towards the corresponding reacting node. Additionally, in other cases, e.g. when the reporting node is not aware if the overload report is already provided to the reacting node, the reporting node may include the OLR in the response, to the request containing OC-Supported-Feature AVP.

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Monday, February 10, 2014 3:03 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, all,

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]] 
Sent: lunes, 10 de febrero de 2014 10:12
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Mon, 10 Feb 2014 09:52:56 +0000

Hello Nirav,

Any solution should balance different factors, efficiency could be discussed from different perspectives, but first we need to assure the mechanism we are defining is providing valid OLR to reacting nodes.

Your proposed text  
" Additionally, in other cases, e.g. when the reporting node is not aware if the overload report is already provided to the reacting node, the reporting node may include the OLR in the response, to the request containing OC-Supported-Feature AVP."

If the reporting is not aware about whether or not overload report is provided to the reacting node, and it decides (since it is a "may") to do not send the OLR again, then overload mitigation mechanism will not work in case OLR was not properly received by corresponding potential reacting nodes. And we need to note that "reacting nodes" could be not only the client, but ANY agent used for routing (not only when the agent is providing service to a Realm, but when it is reacting on behalf of a non-supporting client). 
Then, on one hand it is not simple to know when reacting nodes have valid OLR info (as explained below), but if OLR is not sent again (as per your proposed "may") then one or multiple reacting nodes do not have the required OLR, then overload mitigation will not work.

Therefore, in my opinion, the simplest way to provide required information is to provide OLR in ALL answers.

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]] 
Sent: lunes, 10 de febrero de 2014 10:42
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

But Maria-Cruz,

A slightly different wording from what I proposed earlier is, When the reporting node has a new overload report that needs to be provided to a reacting node (by updating the earlier provided overload report or by providing the overload report for the first time), it shall include OLR in the response, to the request containing OC-Supported-Feature AVP, towards the corresponding reacting node. Additionally, in other cases, e.g. when the reporting node is not aware if the overload report is already provided to the reacting node, the reporting node may include the OLR in the response, to the request containing OC-Supported-Feature AVP.

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Monday, February 10, 2014 3:03 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, all,

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: lunes, 10 de febrero de 2014 10:12
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: Steve Donovan <[email-masked]>
Date: Mon, 10 Feb 2014 10:20:35 -0600

I agree with both Maria Cruz and Nirav. :-)

I suggest that we have wording saying the recommended approach is to
include the overload report in all response messages for the reasons
listed by Maria Cruz. 

I also suggest that we include Nirav's proposal that if a reporting node
knows that a reacting node has already received an overload report then
it may choose to not send it again.  I don't think we need to including
anything about how the reporting node knows but we should include
wording about networks architectures that make it difficult to know. 
The case of agents acting as reacting nodes for non supporting clients
being one example.

We also need to make sure that the recommended approach is not precluded
by Nirav's proposal.

I propose the following normative wording, which can be supplemented by
Maria Cruz's reasons for recommending that the overload report is always
included.

-----

A reporting node MUST ensure that all reacting nodes receive new
overload reports.

It is recommended that a reporting node include overload reports in all
answer messages sent to reacting nodes. 

Note - the reporting node may also include the overload report in answer
messages sent to non reacting nodes if that is more efficient.  The
overload report will just be ignored by a Diameter node that does not
support DOIC.

A reporting node MAY choose to not send an overload report to a reacting
node if it can guarantee that the reacting node already has received the
overload report.

Note - the only sure way, without proprietary mechanisms, to know that a
reacting node has received an overload report is when the reacting node
is a client and there is no agent between the client and the reporting node.

---

From: <[email-masked]>
Date: Mon, 10 Feb 2014 16:42:52 +0000

I'm fine with a recommendation.

But I have a general comment: when a MAY or even a SHOULD apply, it does not mean that it is NOT up to the node to do or not to do something. It does not mean that it is only an implementation option.
For instance, over a given interface, the related specification can say that some states are maintained by the server. And it could be decided to add some overload related info in such states. For instance again, the node can use this state to know if a remote node have been notified or not for instance. And in such a case, the server does not need to include an OLR in each message. It is just for illustration. The point is that you may have some cases for which the OLR in every answer might not be required.

I agree that having the OLR in every answer is fine… but it should be not mandatory in all cases I think. So OK for a "SHOULD" or "RECOMMENDED".

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : lundi 10 février 2014 17:21
À : [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

I suggest that we have wording saying the recommended approach is to include the overload report in all response messages for the reasons listed by Maria Cruz.

I also suggest that we include Nirav's proposal that if a reporting node knows that a reacting node has already received an overload report then it may choose to not send it again.  I don't think we need to including anything about how the reporting node knows but we should include wording about networks architectures that make it difficult to know.  The case of agents acting as reacting nodes for non supporting clients being one example.

We also need to make sure that the recommended approach is not precluded by Nirav's proposal.

I propose the following normative wording, which can be supplemented by Maria Cruz's reasons for recommending that the overload report is always included.

-----

A reporting node MUST ensure that all reacting nodes receive new overload reports.

It is recommended that a reporting node include overload reports in all answer messages sent to reacting nodes.

Note - the reporting node may also include the overload report in answer messages sent to non reacting nodes if that is more efficient.  The overload report will just be ignored by a Diameter node that does not support DOIC.

A reporting node MAY choose to not send an overload report to a reacting node if it can guarantee that the reacting node already has received the overload report.

Note - the only sure way, without proprietary mechanisms, to know that a reacting node has received an overload report is when the reacting node is a client and there is no agent between the client and the reporting node.

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

To: Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

To: Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

To: ext Nirav Salot (nsalot); ext [email-masked]<mailto:[email-masked]>; ext Steve Donovan; [email-masked]<mailto:[email-masked]>

Nirav,

c) otherwise

Ulrich

-----Original Message-----

To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]<mailto:[email-masked]>; ext Steve Donovan; [email-masked]<mailto:[email-masked]>

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

To: ext [email-masked]<mailto:[email-masked]>; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]<mailto:[email-masked]>

Nirav, Lionel,

Ulrich

-----Original Message-----

From: ext [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]<mailto:[email-masked]>

-----Message d'origine-----

De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot) Envoyé : jeudi 6 février 2014 10:08 À : Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]<mailto:[email-masked]> Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]<mailto:[email-masked]>

Ulrich

To: Nirav Salot (nsalot); [email-masked]<mailto:[email-masked]>

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

[email-masked]<mailto:[email-masked]>

Thank you.

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Tue, 11 Feb 2014 10:20:29 +0000

I am also fine with Steve's proposed wording to recommend the inclusion of OLR but to not mandate it.

I am not sure about the following text, if it is absolutely necessary to add it.
Note - the only sure way, without proprietary mechanisms, to know that a reacting node has received an overload report is when the reacting node is a client and there is no agent between the client and the reporting node.

I prefer to remove it since I do not see as value addition.

Regards,
Nirav.

From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 10, 2014 10:13 PM
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : lundi 10 février 2014 17:21
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 11 Feb 2014 10:23:43 +0000

Hello,

I think it is important to highlight complexity for the server to  “guarantee that the reacting node already has received the overload report.”
I think this is the purpose of the sentence added by Steve.

Cheers
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Nirav Salot (nsalot)
Sent: martes, 11 de febrero de 2014 11:20
To: [email-masked]; Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.

From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Monday, February 10, 2014 10:13 PM
To: Steve Donovan; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Tue, 11 Feb 2014 10:25:38 +0000

I do not agree regarding the complexity since it is highly implementation specific.
Lets not make any assumption in the protocol design.

Regards,
Nirav.

From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Tuesday, February 11, 2014 3:54 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello,

Cheers
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Nirav Salot (nsalot)
Sent: martes, 11 de febrero de 2014 11:20
To: [email-masked]<mailto:[email-masked]>; Steve Donovan; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 11 Feb 2014 10:30:59 +0000

Fine Nirav, I agree this is implementation specific.
My intention is that any reader realizes what this knowledge in the server implies when we talk about agents in the path. This is why I think this note is helpful.

Regards
/MCruz

From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: martes, 11 de febrero de 2014 11:26
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: <[email-masked]>
Date: Tue, 11 Feb 2014 10:35:46 +0000

At least, it is not "the only sure way".
For instance, subsequent messages part of the same session (or pseudo-session) could also be used as indication for the reporting node that the OLR has been received by the reacting node (besides the reception of the OC-Supported-Features in the request).
It is why I was saying that this can be fixed per application/system.

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 11 février 2014 11:31
À : [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 11 Feb 2014 13:59:44 +0000

Lionel, Nirav, all,

Maybe the note could be modified:

Note –the reacting node could be any agent in the path, and that in some error situations overload reports may be discarded by reacting nodes.

I added the case OLR could be discarded by reacting nodes, since it highlights a situation where the server will not know whether or not a valid OLR is received by reacting node.

Best regards
/MCruz

From: [email-masked] [mailto:[email-masked]]
Sent: martes, 11 de febrero de 2014 11:36
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Tue, 11 Feb 2014 15:35:18 +0000

At least, it is correct! ☺

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 11 février 2014 15:00
À : [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 12 Feb 2014 10:12:56 +0000

Hi

On this topic, my view is that the reacting node shall  receive “enough” OLRs per period of time to ensure the efficiency of the traffic  reduction mechanism . A way to achieve  the “enough” is to have an OLR in all  answer  messages as proposed and this can the recommended way. Now as Nirav said, there may be protocol design that will behave differently and send “enough” OLRs  but not in all messages.

As also Nirav noted,  I do not well see the need to write additional notes as many situations can occur and  are not limited to the example of the reacting  node  discarding OLRs.

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mardi 11 février 2014 16:35
À : Maria Cruz Bartolome; [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel, Nirav, all,

Best regards
/MCruz

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: martes, 11 de febrero de 2014 11:36
To: Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 13 Feb 2014 09:01:04 +0000

Dear all,

I think then we agree on the proposed text:

But still there are some discrepancies about the note.
My proposal is to keep it just as an indication of potential (maybe not all) situations that should be taken into account if ever any implementation may consider to do not follow the recommendation that a reporting node include overload reports in all answer messages.
Being a recommendation and not a must, at least I think we need to indicate what may imply to do not follow the recommendation.
Then my proposal is the following, that includes a modification to last sentence above:

A reporting node MAY choose to not send an overload report to a reacting node if it can guarantee that this overload report is already active in the reacting node.

Note –the reporting node may need to take into account network deployment and potential errors in order to be able to guarantee that sent overload report is active in the reacting node, e.g. there may be one or multiple agents in the path between reporting and reacting nodes; overload reports may be discarded by reacting nodes…

From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: miércoles, 12 de febrero de 2014 11:13
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hi

Best regards

JJacques

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Thu, 13 Feb 2014 06:19:10 -0600

I'm ok with the suggestion.

Steve

On 2/13/14 3:01 AM, Maria Cruz Bartolome wrote:
> It is recommended that a reporting node include overload reports in
> all answer messages sent to reacting nodes. 
>
> Note - the reporting node may also include the overload report in
> answer messages sent to non reacting nodes if that is more efficient. 
> The overload report will just be ignored by a Diameter node that does
> not support DOIC.
>
> A reporting node MAY choose to not send an overload report to a
> reacting node if it can guarantee that the reacting node already has
> received the overload report.
>
>  
>
> My proposal is to keep it just as an indication of potential (maybe
> not all) situations that should be taken into account if ever any
> implementation may consider to do not follow the recommendation that a
> reporting node include overload reports in all answer messages.
>
> Being a recommendation and not a must, at least I think we need to
> indicate what may imply to do not follow the recommendation.
>
> A reporting node MAY choose to not send an overload report to a
> reacting node if it can guarantee that this overload report is already
> active in the reacting node.
>
>
> Note --the reporting node may need to take into account network
> deployment and potential errors in order to be able to guarantee that
> sent overload report is active in the reacting node, e.g. there may be
> one or multiple agents in the path between reporting and reacting
> nodes; overload reports may be discarded by reacting nodes...
>
>  
>
>  
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *TROTTIN,
> JEAN-JACQUES (JEAN-JACQUES)
> *Sent:* miércoles, 12 de febrero de 2014 11:13
> *To:* [email-masked]
> On this topic, my view is that the reacting node shall  receive
> "enough" OLRs per period of time to ensure the efficiency of the
> traffic  reduction mechanism . A way to achieve  the "enough" is to
> have an OLR in all  answer  messages as proposed and this can the
> recommended way. Now as Nirav said, there may be protocol design that
> will behave differently and send "enough" OLRs  but not in all messages.
>
>  
>
> As also Nirav noted,  I do not well see the need to write additional
> notes as many situations can occur and  are not limited to the example
> of the reacting  node  discarding OLRs.
>
>  
>
> Best regards
>
>  
>
> JJacques
>
>  
>
>  
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de*
> [email-masked]
> *Envoyé :* mardi 11 février 2014 16:35
> *À :* Maria Cruz Bartolome; [email-masked]
> *Objet :* Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> At least, it is correct! J
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Maria Cruz
> Bartolome
> *Envoyé :* mardi 11 février 2014 15:00
> *À :* [email-masked] <mailto:[email-masked]>
> *Objet :* Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> Note --the reacting node could be any agent in the path, and that in
> some error situations overload reports may be discarded by reacting nodes.
>
>  
>
> I added the case OLR could be discarded by reacting nodes, since it
> highlights a situation where the server will not know whether or not a
> valid OLR is received by reacting node.
>
>  
>
> Best regards
>
> /MCruz
>
>  
>
>  
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]]
> *Sent:* martes, 11 de febrero de 2014 11:36
> *To:* Maria Cruz Bartolome; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> For instance, subsequent messages part of the same session (or
> pseudo-session) could also be used as indication for the reporting
> node that the OLR has been received by the reacting node (besides the
> reception of the OC-Supported-Features in the request).
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Maria Cruz
> Bartolome
> *Envoyé :* mardi 11 février 2014 11:31
> *À :* [email-masked] <mailto:[email-masked]>
> *Objet :* Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> My intention is that any reader realizes what this knowledge in the
> server implies when we talk about agents in the path. This is why I
> think this note is helpful.
>
>  
>
> Regards
>
> /MCruz
>
>  
>
> *From:*Nirav Salot (nsalot) [mailto:[email-masked]]
> *Sent:* martes, 11 de febrero de 2014 11:26
> *To:* Maria Cruz Bartolome; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *Maria Cruz
> Bartolome
> *Sent:* Tuesday, February 11, 2014 3:54 PM
> *To:* [email-masked] <mailto:[email-masked]>
> I think it is important to highlight complexity for the server to
>  "guarantee that the reacting node already has received the overload
> report."
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *Nirav Salot
> (nsalot)
> *Sent:* martes, 11 de febrero de 2014 11:20
> *To:* [email-masked] <mailto:[email-masked]>;
> Steve Donovan; [email-masked] <mailto:[email-masked]>
> Note - the only sure way, without proprietary mechanisms, to know that
> a reacting node has received an overload report is when the reacting
> node is a client and there is no agent between the client and the
> reporting node.
>
>  
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of
> [email-masked] <mailto:[email-masked]>
> *Sent:* Monday, February 10, 2014 10:13 PM
> *To:* Steve Donovan; [email-masked] <mailto:[email-masked]>
> But I have a general comment: when a MAY or even a SHOULD apply, it
> does not mean that it is NOT up to the node to do or not to do
> something. It does not mean that it is only an implementation option.
>
> For instance, over a given interface, the related specification can
> say that some states are maintained by the server. And it could be
> decided to add some overload related info in such states. For instance
> again, the node can use this state to know if a remote node have been
> notified or not for instance. And in such a case, the server does not
> need to include an OLR in each message. It is just for illustration.
> The point is that you may have some cases for which the OLR in every
> answer might not be required.
>
>  
>
> I agree that having the OLR in every answer is fine... but it should
> be not mandatory in all cases I think. So OK for a "SHOULD" or
> "RECOMMENDED".
>
>  
>
> Regards,
>
>  
>
> Lionel
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Steve Donovan
> *Envoyé :* lundi 10 février 2014 17:21
> *À :* [email-masked] <mailto:[email-masked]>
> *Obj**et :*Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info
> I also suggest that we include Nirav's proposal that if a reporting
> node knows that a reacting node has already received an overload
> report then it may choose to not send it again.  I don't think we need
> to including anything about how the reporting node knows but we should
> include wording about networks architectures that make it difficult to
> know.  The case of agents acting as reacting nodes for non supporting
> clients being one example.
>
> I propose the following normative wording, which can be supplemented
> by Maria Cruz's reasons for recommending that the overload report is
> always included.
>
> -----
>
> It is recommended that a reporting node include overload reports in
> all answer messages sent to reacting nodes. 
>
> Note - the reporting node may also include the overload report in
> answer messages sent to non reacting nodes if that is more efficient. 
> The overload report will just be ignored by a Diameter node that does
> not support DOIC.
>
> A reporting node MAY choose to not send an overload report to a
> reacting node if it can guarantee that the reacting node already has
> received the overload report.
>
> Note - the only sure way, without proprietary mechanisms, to know that
> a reacting node has received an overload report is when the reacting
> node is a client and there is no agent between the client and the
> reporting node.
>
>     To: Maria Cruz Bartolome; [email-masked] <mailto:[email-masked]>
>
>     To: Maria Cruz Bartolome; [email-masked] <mailto:[email-masked]>
>
>     - more robust solution, as no need to cater for all the checks on the need to send information,  for situations where an answer message is lost,  ...
>
>      
>
>      
>
>     Best regards
>
>     /MCruz
>
>      
>
>     To: ext Nirav Salot (nsalot); ext [email-masked] <mailto:[email-masked]>; ext Steve Donovan; [email-masked] <mailto:[email-masked]>
>
>     To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked] <mailto:[email-masked]>; ext Steve Donovan; [email-masked] <mailto:[email-masked]>
>
>     To: ext [email-masked] <mailto:[email-masked]>; Nirav Salot (nsalot); ext Steve Donovan; [email-masked] <mailto:[email-masked]>
>
>     From: ext [email-masked] <mailto:[email-masked]> [mailto:[email-masked]]
>
>     To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked] <mailto:[email-masked]>
>
>     De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot) Envoyé : jeudi 6 février 2014 10:08 À : Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked] <mailto:[email-masked]> Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling
>
>      
>
>     Ulrich,
>
>      
>
>     To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked] <mailto:[email-masked]>
>
>     To: Nirav Salot (nsalot); [email-masked] <mailto:[email-masked]>
>
>     I agree with Steve except the part "shouldn't lack of OLR be interpreted as not overloaded?"
>
>      
>
>     [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 13 Feb 2014 12:58:23 +0000

Maria-Cruz,

Reporting note may use very simple mechanism – as pointed out by Lionel – to conclude that report has reached the reacting node, i.e. all the intra-session messages need not contain the same overload report, if the session establishment message contains the overload report.

So your note regarding the reporting node to take into account the network deployment etc. is not 100% correct.
Let me simplify, hoping it will satisfy your concern.

Note – In some cases, e.g. when there are one or multiple agents in the path between reporting and reacting nodes; overload reports may be discarded by reacting nodes, the reporting node may not be able to guarantee that the reacting node has received the report.
Regards,
Nirav.

From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Thursday, February 13, 2014 2:31 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Dear all,

Hi

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de [email-masked]<mailto:[email-masked]>
Envoyé : mardi 11 février 2014 16:35
À : Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 13 Feb 2014 13:19:42 +0000

Nirav,

Do you consider that overload reports can only be discarded by reacting nodes when there are agents in the path?

From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: jueves, 13 de febrero de 2014 13:58
To: Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

Dear all,

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Thu, 13 Feb 2014 14:55:59 +0000

Maria-Cruz,

May be following formatting of the note helps?
A reporting node MAY choose to not send an overload report to a reacting node if it can guarantee that this overload report is already active in the reacting node.

Note – In some cases (e.g. when there are one or multiple agents in the path between reporting and reacting nodes, overload reports may be discarded by reacting nodes) the reporting node may not be able to guarantee that the reacting node has received the report.

Regards,
Nirav.

From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Thursday, February 13, 2014 6:50 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 13 Feb 2014 15:07:32 +0000

Nirav,

Let me know if following rephrasing still conveys the meaning you want to cover:

Note – In some cases (e.g. when there are one or multiple agents in the path between reporting and reacting nodes, or when overload reports are discarded by reacting nodes) the reporting node may not be able to guarantee that the reacting node has received the report.

From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: jueves, 13 de febrero de 2014 15:56
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 13 Feb 2014 13:17:58 +0000

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

Hi

Best regards

JJacques

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel

-----

Hello Nirav,

Your proposed text

Best regards

/MCruz

-----Original Message-----

But Maria-Cruz,

Regards,

Nirav.

-----Original Message-----

Nirav, all,

Best regards

/MCruz

-----Original Message-----

Maria-Cruz,

What do you think?

Regards,

Nirav.

-----Original Message-----

Hello Ulrich, Nirav,

c) otherwise

Best regards

/MCruz

-----Original Message-----

Nirav,

c) otherwise

Ulrich

-----Original Message-----

Ulrich,

How about the following.

Regards,

Nirav.

-----Original Message-----

Nirav, Lionel,

Ulrich

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,

Nirav.

-----Original Message-----

Ulrich

Steve

Regards,

Nirav.

inline

-----Original Message-----

Regards,

Nirav.

-----Original Message-----

So the options would be:

Lionel

-----Message d'origine-----

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Thu, 13 Feb 2014 16:04:34 +0000

To change the format :)

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : jeudi 13 février 2014 14:18
À : [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

Hi 

Best regards

JJacques 

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel 

-----

Your proposed text  

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]] 
Sent: lunes, 10 de febrero de 2014 10:42
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

But Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Monday, February 10, 2014 3:03 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, all,

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: lunes, 10 de febrero de 2014 10:12
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 13 Feb 2014 16:12:23 +0000

I have received mails out of order... 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: jueves, 13 de febrero de 2014 17:05
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

To change the format :)

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome Envoyé : jeudi 13 février 2014 14:18 À : [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

Hi 

Best regards

JJacques 

De : DiME [mailto:[email-masked]] De la part de [email-masked] Envoyé : mardi 11 février 2014 16:35 À : Maria Cruz Bartolome; [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome Envoyé : mardi 11 février 2014 15:00 À : [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome Envoyé : mardi 11 février 2014 11:31 À : [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel 

De : DiME [mailto:[email-masked]] De la part de Steve Donovan Envoyé : lundi 10 février 2014 17:21 À : [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----

Your proposed text

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: lunes, 10 de febrero de 2014 10:42
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

But Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Monday, February 10, 2014 3:03 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, all,

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: lunes, 10 de febrero de 2014 10:12
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: <[email-masked]>
Date: Thu, 13 Feb 2014 16:13:42 +0000

Because your emails are too heavy... and blocked :)
Please use text format.

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : jeudi 13 février 2014 17:12
À : [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: jueves, 13 de febrero de 2014 17:05
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

To change the format :)

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

Hi 

Best regards

JJacques 

Lionel, Nirav, all,

Best regards
/MCruz

Lionel

Regards
/MCruz

Regards,
Nirav.

Hello,

Cheers
/MCruz

Regards,
Nirav.

Regards,

Lionel 

-----

Your proposed text

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: lunes, 10 de febrero de 2014 10:42
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

But Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Monday, February 10, 2014 3:03 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, all,

Best regards
/MCruz

-----Original Message-----
From: Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: lunes, 10 de febrero de 2014 10:12
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: Friday, February 07, 2014 8:57 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hello Ulrich, Nirav,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: viernes, 07 de febrero de 2014 10:59
To: ext Nirav Salot (nsalot); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Ulrich

-----Original Message-----
From: ext Nirav Salot (nsalot) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 4:49 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext [email-masked]; ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich,

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 3:57 PM
To: ext [email-masked]; Nirav Salot (nsalot); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav, Lionel,

Ulrich  

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 10:20 AM
To: Nirav Salot (nsalot); Wiehe, Ulrich (NSN - DE/Munich); ext Steve Donovan; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

-----Message d'origine-----

Ulrich,

[LM] Agree

[LM] Agree

[LM] Agree

Regards,
Nirav.

-----Original Message-----
From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Sent: Thursday, February 06, 2014 2:23 PM
To: ext Steve Donovan; Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Ulrich

Steve

 
Regards,
Nirav.

inline

 

 

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext Nirav Salot (nsalot)
Sent: Wednesday, February 05, 2014 5:27 AM
To: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Regards,
Nirav.
 
-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 04, 2014 9:07 PM
To: [email-masked]
Subject: Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

 
Lionel

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 13 Feb 2014 16:16:15 +0000

Lionel... have you called my emails "heavy"!!! you dare!! :-)

I simply replied... 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: jueves, 13 de febrero de 2014 17:14
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Because your emails are too heavy... and blocked :) Please use text format.

Lionel

---

From: "Nirav Salot (nsalot)" <[email-masked]>
Date: Fri, 14 Feb 2014 09:05:43 +0000

Maria-Cruz,

I am fine with the proposal below.

Regards,
Nirav.

From: Maria Cruz Bartolome [mailto:[email-masked]]
Sent: Thursday, February 13, 2014 8:38 PM
To: Nirav Salot (nsalot); [email-masked]
Subject: RE: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Nirav,

Maria-Cruz,

Regards,
Nirav.

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

---

From: <[email-masked]>
Date: Fri, 14 Feb 2014 09:22:57 +0000

Hi all,

I don't think that a reporting node may/can/would like to ensure/choose/guarantee anything :)
I'm ok with the intention of the text but we may probably word it in a different way.

Moreover, the first sentence is somehow incorrect. Not all the reacting nodes need to be aware of the new status. Only those which have received a previous OLR are targeted. I think that the requirement is that reporting and reacting nodes share the most up-to-date info and therefore it is recommended to send the OLR in every answer.

I have a comment anyway on the following note:

This is contradicting the statement given in 5.3.2:

   The answer message initiating endpoint MUST NOT include any overload
   control solution defined AVPs into its answer messages if the request
   message initiating endpoint has not indicated support at the
   beginning of the created session (or transaction in a case of non-
   session state maintaining applications).  The same also applies if
   none of the announced capabilities match between the two endpoints.

Regards,

Lionel

***********************

De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot)
Envoyé : vendredi 14 février 2014 10:06
À : Maria Cruz Bartolome; [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

Nirav,

Maria-Cruz,

Regards,
Nirav.

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Fri, 14 Feb 2014 10:07:04 +0000

Hi all

I have another remark to add to Lionel's one on 5.3.2.

If a reacting node does not indicate OC-Supported features in the creation request of session 1(resulting, as according to 5.3.2, in no OLR in the answers bound to this session) but puts OC-Supported features in  the creation request of session 2, would it mean that Overload control (throttling) in the reacting node applies only to Session 2 requests but not to session1? I thought we decided that the question of OLR per session or group of session was not for this draft but for further study. Clarification seems needed.

Best regards

JJacques   

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de [email-masked]
Envoyé : vendredi 14 février 2014 10:23
À : Nirav Salot (nsalot); Maria Cruz Bartolome; [email-masked]
Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Hi all,

I don't think that a reporting node may/can/would like to ensure/choose/guarantee anything :) I'm ok with the intention of the text but we may probably word it in a different way.

Regards,

Lionel

***********************

De : DiME [mailto:[email-masked]] De la part de Nirav Salot (nsalot) Envoyé : vendredi 14 février 2014 10:06 À : Maria Cruz Bartolome; [email-masked] Objet : Re: [Dime] [dime] #31: Sending OC-Ongoing-Throttling-Info AVP in request messages that survived a throttling

Maria-Cruz,

Regards,
Nirav.

Nirav,

Maria-Cruz,

Regards,
Nirav.

Nirav,

Maria-Cruz,

Regards,
Nirav.

Dear all,