Subject: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

From: "dime issue tracker" <[email-masked]>
Date: Wed, 12 Feb 2014 14:25:39 -0000

#54: OC-Report-Type as mandatory AVP

 Now in chapter 4.6:

    The default value of the OC-Report-Type AVP is 0 (i.e. the host
    report).

 This AVP is always required, right? Then, I think it is more precise that
 we define this AVP as mandatory.

-- 
-----------------------------------------------+---------------------------
 Reporter:  [email-masked]  |      Owner:  MCruz
     Type:  defect                             |  Bartolomé
 Priority:  major                              |     Status:  new
Component:  draft-docdt-dime-ovli              |  Milestone:
 Severity:  Active WG Document                 |    Version:  1.0
                                               |   Keywords:
-----------------------------------------------+---------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/54>
dime <http://tools.ietf.org/wg/dime/>

---

From: <[email-masked]>
Date: Wed, 12 Feb 2014 14:45:46 +0000

Hi Maria Cruz,

I'm assuming that you mean "required" instead of "mandatory", right?

So instead of:

   OC-OLR ::= < AVP Header: TBD2 >
              < OC-Sequence-Number >
              [ OC-Report-Type ]
              [ OC-Reduction-Percentage ]
              [ OC-Validity-Duration ]
            * [ AVP ]

You would prefer:

   OC-OLR ::= < AVP Header: TBD2 >
              < OC-Sequence-Number >
              { OC-Report-Type }
              [ OC-Reduction-Percentage ]
              [ OC-Validity-Duration ]
            * [ AVP ]

And I'm fine with this proposal.

Cheers,

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de dime issue tracker
Envoyé : mercredi 12 février 2014 15:26
À : [email-masked]
Cc : [email-masked]
Objet : [Dime] [dime] #54: OC-Report-Type as mandatory AVP

 Now in chapter 4.6:

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Thu, 13 Feb 2014 08:55:40 +0000

Hi Mcruz

The current description indicates that when not present the OLR is of type Host, which was fine for me and keeps my preference. 
We may have  deployments where Realm OLR is not used, or where statistically the HOST type is the most frequent, so to have the grouped OLR-AVP containing a minimum of AVPs minimizes parsing. I agree it is a small optimization.

Best regards

JJacques 

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 12 février 2014 15:46
À : [email-masked]; [email-masked]
Objet : Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Maria Cruz,

So instead of:

You would prefer:

Cheers,

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de dime issue tracker Envoyé : mercredi 12 février 2014 15:26 À : [email-masked] Cc : [email-masked] Objet : [Dime] [dime] #54: OC-Report-Type as mandatory AVP

 Now in chapter 4.6:

 This AVP is always required, right? Then, I think it is more precise that  we define this AVP as mandatory.

-- 
-----------------------------------------------+------------------------
-----------------------------------------------+---
 Reporter:  [email-masked]  |      Owner:  MCruz
     Type:  defect                             |  Bartolomé
 Priority:  major                              |     Status:  new
Component:  draft-docdt-dime-ovli              |  Milestone:
 Severity:  Active WG Document                 |    Version:  1.0
                                               |   Keywords:
-----------------------------------------------+------------------------
-----------------------------------------------+---

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 13 Feb 2014 14:05:24 +0200

Agree that it is a small optimization, which I put there
because at the beginning there seemed to be a lot of worry
on every extra AVP ;-)

I prefer having the AVP optional but with a default value
just like it is now. We have the same for the reduction
percentage and the validity time as well.

- Jouni

---

From: Steve Donovan <[email-masked]>
Date: Thu, 13 Feb 2014 06:46:28 -0600

Jouni,

Which optimization, defining a default value or Lionel's proposal to
make it a required AVP?

Steve

---

From: Ben Campbell <[email-masked]>
Date: Fri, 14 Feb 2014 16:12:32 -0600

I actually prefer making it mandatory. The cost of adding it is trivial--even more so for a reporting node that only supports the default. The value of having it is less opportunity for interop errors.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 21 Feb 2014 09:47:46 +0000

Hello all,

I understand JJ point of view, but I still tend to prefer to make it mandatory, since I think this is less error-prone, since the only node that knows the requested Report-Type is the reporting, if for any reason a reporting is omitting it (since it is optional), it will be always interpreted as HOST, but this type may be wrong.

I think DEFAULT values should never be error-prone, but used in "general cases", as a simplification, like e.g. a default for the Validity-Duration. Default Validity-Duration will never be an "error", it could be not the best value (compared with another value perfectly tuned to reporting node overload situation) but never the use of a Default value should lead to an erroneous behavior.

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: viernes, 14 de febrero de 2014 23:13
To: Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

On Feb 13, 2014, at 6:05 AM, Jouni Korhonen <[email-masked]> wrote:

> 
> Agree that it is a small optimization, which I put there because at 
> the beginning there seemed to be a lot of worry on every extra AVP ;-)
> 
> I prefer having the AVP optional but with a default value just like it 
> is now. We have the same for the reduction percentage and the validity 
> time as well.
> 
> - Jouni
> 
>> De : DiME [mailto:[email-masked]] De la part de 
>> [email-masked] Envoyé : mercredi 12 février 2014 15:46 À : 
>> [email-masked]; [email-masked] Objet : Re: [Dime] 
>> [dime] #54: OC-Report-Type as mandatory AVP
>> 
>> Hi Maria Cruz,
>> 
>> De : DiME [mailto:[email-masked]] De la part de dime issue 
>> tracker Envoyé : mercredi 12 février 2014 15:26 À : 
>> [email-masked] Cc : [email-masked] Objet : [Dime] 
>> [dime] #54: OC-Report-Type as mandatory AVP
>> 
>> -----------------------------------------------+---------------------
>> -----------------------------------------------+---------------------
>> _____________________________________________________________________
>> ____________________________________________________
>>

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 28 Feb 2014 18:10:51 +0200

Steve,

Optimization as having the optional OC-Report-Type and when not present
using the default value. This was there to reduce the amount of transported
AVPs.

- JOuni

On Feb 13, 2014, at 2:46 PM, Steve Donovan <[email-masked]> wrote:

> Jouni,
> 
> Which optimization, defining a default value or Lionel's proposal to make it a required AVP?
> 
> Steve
> 
>> On Feb 13, 2014, at 10:55 AM, "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" 
>> <[email-masked]>
>>  wrote:
>> 
>> 
>>> Hi Mcruz
>>> 
>>> De : DiME [
>>> mailto:[email-masked]] De la part de [email-masked]
>>> 
>>> À : 
>>> [email-masked]; [email-masked]
>>> 
>>> De : DiME [
>>> mailto:[email-masked]] De la part de dime issue tracker Envoyé : mercredi 12 février 2014 15:26 À : [email-masked] Cc : [email-masked]
>>> Reporter:  
>>> [email-masked]
>>>   |      Owner:  MCruz
>>>     Type:  defect                             |  Bartolomé
>>> Ticket URL: 
>>> <http://trac.tools.ietf.org/wg/dime/trac/ticket/54>
>>> 
>>> dime

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 28 Feb 2014 18:27:12 +0200

Hi,

How having the AVP could be less error prone if it has a default
value and the receiver knows exactly how to proceed when the AVP
is not present?

If a node does not include it when it should, the implementation
is broken. Wouldn't a broken node be able to put wrong report
type into the AVP even if the AVP is mandatory?

Anyway, if it is my statement keeping issue #54 still open, consider
it resolved from my side. I am OK making the OC-Report-Type AVP as
required/mandatory AVP. Should we also consider it having a fixed
position just after the OC-Sequence-Number AVP as well since it is
going to in every OC-OLR?

- Jouni