Subject: [Dime] [dime] #44: Incorrect sequence number behavior

From: "dime issue tracker" <[email-masked]>
Date: Fri, 07 Feb 2014 21:49:01 -0000

#44: Incorrect sequence number behavior

 section 4.3 says that the receiver should discard an OLR with a sequence
 number less than the most recent. That should be less than or equal.
 Technically, re-applying the same OLR should make no difference, but it's
 never needed, and could be error prone if the sender screwed something up.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-docdt-dime-
  [email-masked]        |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  trivial      |  Milestone:
Component:  draft-       |    Version:
  docdt-dime-ovli        |   Keywords:
 Severity:  Active WG    |
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/44>
dime <http://tools.ietf.org/wg/dime/>

---

From: <[email-masked]>
Date: Sat, 8 Feb 2014 16:53:59 +0000

Hi Ben,

The case "equal" is discussed in the previous sentence.

Check the following:

   The received OC-Supported-Features AVP does not change the existing
   overload condition and/or traffic abatement algorithm settings if the
   OC-Sequence-Number AVP contains a value that is equal to the
   previously received/recorded one.  If the OC-Supported-Features AVP
   is received for the first time for the reporting node or the OC-
   Sequence-Number AVP value is less than the previously received/
   recorded one (and is outside the valid overflow window), then either
   the sequence number is stale (e.g. an intentional or unintentional
   replay) and SHOULD be silently discarded.

The first sentence implies that the received OLR is ignored. 

And actually, there is something wrong in the last sentence. At the end, 

   recorded one (and is outside the valid overflow window), then either
   the sequence number is stale or replay (e.g. an intentional or unintentional
   replay) and SHOULD be silently discarded.

The "either" in the first line should be removed.

Regards,

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de dime issue tracker
Envoyé : vendredi 7 février 2014 22:49
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Dime] [dime] #44: Incorrect sequence number behavior

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Mon, 24 Feb 2014 15:24:10 -0600

Lionel,

I believe that Ben's issue was with the following wording in section 4.3

   The Sequence-Number AVP indicates the "freshness" of the OC-OLR AVP.
   It is possible to replay the same OC-OLR AVP multiple times between
   the overload control endpoints, however, when the OC-OLR AVP content
   changes or sending endpoint otherwise wants the receiving endpoint to
   update its overload control information, then the OC-Sequence-Number
   AVP MUST contain a new greater value than the previously received.
   The receiver SHOULD discard an OC-OLR AVP with a sequence number that
   is less than previously received one.

The wording you reference is in section 5.5.2.

The above wording can be improved by changing the last sentence to "The
reacting node SHOULD discard an OC-OLR AVP with a sequence number that
is less than or equal to the previously received sequence number."

Steve

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 28 Feb 2014 20:15:00 +0200

I am ok with the proposed wording here.

- Jouni

On Feb 24, 2014, at 11:24 PM, Steve Donovan <[email-masked]> wrote:

> The above wording can be improved by changing the last sentence to "The reacting node SHOULD discard an OC-OLR AVP with a sequence number that is less than or equal to the previously received sequence number."
> 
> Steve
> 
>> De : DiME [
>> mailto:[email-masked]
>> ] De la part de dime issue tracker
>> À : 
>> [email-masked]; [email-masked]
>> 
>> Cc : 
>> [email-masked]
>>