Subject: [Dime] I have a doubt in Failover and Fallback mechanisms present under DIAMETER.

From: Kevin Peterson <[email-masked]>
Date: Wed, 19 Feb 2014 11:24:55 +0000

Hi, 

Failover and Fallback procedures we know very well.

Suppose initial message was supposed to send to primary peer, but peer went down and message has been forwarded to Secondary peer i.e. Failover. Now suppose if Primary Peer has come up and according to DIAMETER theory the message should go to primary peer. So the next message will be Update message. Which will have the same session id which was used with the initial message. 

Now my doubt is how the primary peer will recognize the session-id of update message. Because it has no info for that session. The session was created with the secondary peer. 

Thanks,
Kevin Peterson

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 28 Feb 2014 16:12:27 +0200

Kevin,

Are you now referring to Diameter applications that maintain state or not?
In case of the former, your client has learned the identity of the server
and will continue sending messages to it (i.e. the secondary) during the
lifetime of the entire session.

In case of latter, each request would have a different session-id.

- Jouni

On Feb 19, 2014, at 1:24 PM, Kevin Peterson <[email-masked]> wrote:

> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime