Subject: [Dime] [dime] #47: reduction percentages greater than 100 should be ignored

From: "dime issue tracker" <[email-masked]>
Date: Fri, 07 Feb 2014 22:05:25 -0000

#47: reduction percentages greater than 100 should be ignored

 Section 4.7 says " [Reduction-Percentage] Values greater than 100 are
 interpreted as 100."

 An OLR with an invalid value should be ignored. An invalid value indicates
 incorrect behavior on the part of the sender. In this case, it's not safe
 to assume we know what the sender really intended.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-docdt-dime-
  [email-masked]        |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  minor        |  Milestone:
Component:  draft-       |    Version:  1.0
  docdt-dime-ovli        |   Keywords:
 Severity:  Active WG    |
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/47>
dime <http://tools.ietf.org/wg/dime/>

---

From: <[email-masked]>
Date: Sat, 8 Feb 2014 16:37:14 +0000

Hi Ben,

OK with this statement.
But if it is agreed, would it mean that the same consideration should apply for the OC-Validity-Duration AVP values?

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de dime issue tracker
Envoyé : vendredi 7 février 2014 23:05
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Dime] [dime] #47: reduction percentages greater than 100 should be ignored

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Mon, 10 Feb 2014 10:43:18 -0600

I would think this would be a general policy.

Steve

---

From: Ben Campbell <[email-masked]>
Date: Mon, 10 Feb 2014 10:50:14 -0600

> But if it is agreed, would it mean that the same consideration should apply for the OC-Validity-Duration AVP values?

I'm not sure I follow the question. Is it possible to send an invalid OC-Validity-Duration value?

---

From: Steve Donovan <[email-masked]>
Date: Mon, 10 Feb 2014 10:59:23 -0600

It is possible, the range defined is zero to 24 hours.  I think the text
is correct as it says that a value out of this range should be ignored.

Steve

---

From: <[email-masked]>
Date: Mon, 10 Feb 2014 17:29:30 +0000

Hi Steve,

About the OC-Validity-Reduction AVP values greater than 24 hours, it is said that the default value 5s applies.

I was therefore wondering if it should be also considered as an error and therefore discarded. It is a real open question. Not an issue per se as I'm fine with the existing text. I was reacting on the reason for change explained by Ben.

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : lundi 10 février 2014 17:59
À : [email-masked]
Objet : Re: [Dime] [dime] #47: reduction percentages greater than 100 should be ignored

It is possible, the range defined is zero to 24 hours.  I think the text is correct as it says that a value out of this range should be ignored.

Steve

On Feb 8, 2014, at 10:37 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Ben,

OK with this statement.

Lionel

-----Message d'origine-----

À : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Cc : [email-masked]<mailto:[email-masked]>

interpreted as 100."

--

 [email-masked]<mailto:[email-masked]>        |  [email-masked]<mailto:[email-masked]>

Severity:  Active WG    |

 Document               |

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/47><http://trac.tools.ietf.org/wg/dime/trac/ticket/47>

dime <http://tools.ietf.org/wg/dime/><http://tools.ietf.org/wg/dime/>

DiME mailing list

[email-masked]<mailto:[email-masked]>

Thank you.

DiME mailing list

[email-masked]<mailto:[email-masked]>

---

From: Steve Donovan <[email-masked]>
Date: Mon, 10 Feb 2014 11:58:44 -0600

I agree that a clarification is needed on what it means to be "treated
as is the OC-Validity-Duration AVP was not present".  It would e better
to say:

  "Invalid validity duration values are given the default value". Steve

On 2/10/14 11:29 AM, [email-masked] wrote:
>
> Hi Steve,
>
>  
>
> About the OC-Validity-Reduction AVP values greater than 24 hours, it
> is said that the default value 5s applies.
>
>  
>
> I was therefore wondering if it should be also considered as an error
> and therefore discarded. It is a real open question. Not an issue per
> se as I'm fine with the existing text. I was reacting on the reason
> for change explained by Ben.
>
>  
>
> Regards,
>
>  
>
> Lionel
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Steve Donovan
> *Envoyé :* lundi 10 février 2014 17:59
> *À :* [email-masked]
> *Objet :* Re: [Dime] [dime] #47: reduction percentages greater than
> 100 should be ignored
>
>  
>
> It is possible, the range defined is zero to 24 hours.  I think the
> text is correct as it says that a value out of this range should be
> ignored.
>
> Steve
>
>     On Feb 8, 2014, at 10:37 AM, [email-masked] <mailto:[email-masked]> wrote:
>
>      
>
>         Hi Ben,
>
>          
>
>         OK with this statement.
>
>         À : [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
>
>         Cc : [email-masked] <mailto:[email-masked]>
>
>          [email-masked] <mailto:[email-masked]>        |  [email-masked] <mailto:[email-masked]>
>
>         Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/47> <http://trac.tools.ietf.org/wg/dime/trac/ticket/47>
>
>         dime <http://tools.ietf.org/wg/dime/> <http://tools.ietf.org/wg/dime/>
>
>          
>
>         [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Ben Campbell <[email-masked]>
Date: Fri, 14 Feb 2014 16:29:52 -0600

On Feb 10, 2014, at 11:58 AM, Steve Donovan <[email-masked]> wrote:

> I agree that a clarification is needed on what it means to be "treated as is the OC-Validity-Duration AVP was not present".  It would e better to say:
> 
>   "Invalid validity duration values are given the default value".
> 
> 

+1.

I recognize this is different from what I said about reduction percentage. My reasoning is, if the sender includes an invalid duration, we don't know the intended duration. But since there is a default duration, we can assume it. Reduction-Percentage, however, has no such default (nor should it.). If we get an invalid reduction percentage, we really have no idea what the sender intended us to do.

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 28 Feb 2014 16:07:39 +0200

<as a chair>

We seem to have reached a conclusion that invalid reduction percentages
should be ignored.

@ben could you update the ticket and close it?

- JOuni