Subject: [Dime] [dime] #51: OC-Supported-Features in requests

From: "dime issue tracker" <[email-masked]>
Date: Wed, 12 Feb 2014 07:51:41 -0000

#51: OC-Supported-Features in requests

 Now:
 The OC-Supported-Features AVP SHOULD be included into every Diameter
 message a DOIC
 supporting node sends (and intends to use for DOIC purposes).

 Why is "should" used?

 Proposal: replace SHOULD by MUST

-- 
-----------------------------------------------+---------------------------
 Reporter:  [email-masked]  |      Owner:  MCruz
     Type:  defect                             |  Bartolomé
 Priority:  major                              |     Status:  new
Component:  draft-docdt-dime-ovli              |  Milestone:
 Severity:  Active WG Document                 |    Version:  1.0
                                               |   Keywords:
-----------------------------------------------+---------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/51>
dime <http://tools.ietf.org/wg/dime/>

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 12 Feb 2014 09:16:46 +0000

I agree.

Absence of OC-Supported-Features AVP from a request means "DOIC not supported".
Ulrich

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext dime issue tracker
Sent: Wednesday, February 12, 2014 8:52 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Dime] [dime] #51: OC-Supported-Features in requests

 Now:

 Why is "should" used?

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 12 Feb 2014 11:22:52 +0200

Also in answer messages now? The text quoted below does not differentiate
whether it is answer or request.

- Jouni

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 12 Feb 2014 10:34:21 +0000

Jouni,
Thank you for the hint.

This depends on the outcome of issue #30.

For now I would agree to say "...MUST be included in every Diameter request...."

Ulrich

-----Original Message-----
From: ext Jouni Korhonen [mailto:[email-masked]] 
Sent: Wednesday, February 12, 2014 10:23 AM
To: Wiehe, Ulrich (NSN - DE/Munich)
Cc: [email-masked]; [email-masked]
Subject: Re: [Dime] [dime] #51: OC-Supported-Features in requests

- Jouni