Subject: [Dime] #52: Throttling not needed to be based on previous history - conclusion

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 21 Feb 2014 08:40:23 +0000

#52: Throttling not needed to be based on previous history
 
Following agreement is reached:

 Now (chapter 4.7):
    The OC-Reduction-Percentage AVP (AVP code TBD8) is type of Unsigned32
    and describes the percentage of the traffic that the sender is
    requested to reduce, compared to what it otherwise would have sent.
 
 Proposal:
   The OC-Reduction-Percentage AVP (AVP code TBD8) is type of Unsigned32  
   and describes the percentage of the traffic that the sender is  
   requested to reduce, compared to what it otherwise would send.                  <----

 Now (chapter 5.5.2):
      Indicates that the reporting node urges the reacting node to
      reduce its traffic by a given percentage.  For example if the
      reacting node has been sending 100 packets per second to the
      reporting node, then a reception of OC-Reduction-Percentage value
      of 10 would mean that from now on the reacting node MUST only send
      90 packets per second.  How the reacting node achieves the "true
      reduction" transactions leading to the sent request messages is up
      to the implementation.  The reacting node MAY simply drop every
      10th packet from its output queue and let the generic application
      logic try to recover from it.0 < value < 100

  Proposal:
 Indicates that the reporting node urges the reacting node to reduce 
 its traffic by a given percentage. For example if the
 reacting node would send 100 packets to the				<---
 reporting node, then a reception of OC-Reduction-Percentage value of 
 10 would mean that from now on the reacting node MUST only send
 90 packets instead of 100. How the reacting node achieves the "true       <---
 reduction" transactions leading to the sent request messages is up to 
 the implementation. The reacting node MAY simply drop every 10th 
 packet from its output queue and let the generic application logic try 
 to recover from it.

---

From: Steve Donovan <[email-masked]>
Date: Fri, 21 Feb 2014 09:36:48 -0600

Maria Cruz,

I support your suggested changes.  I have one further suggested change
below.

Steve

>  packet from its output queue and let the generic application logic try 
SRD> Replace "from now on" in the above with "for the period that the
overload report is active"
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: <[email-masked]>
Date: Fri, 21 Feb 2014 17:33:14 +0000

+1 (including Steve comment)

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : vendredi 21 février 2014 16:37
À : [email-masked]
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Maria Cruz,

I support your suggested changes.  I have one further suggested change below.

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.
SRD> Replace "from now on" in the above with "for the period that the overload report is active"

DiME mailing list

[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Fri, 21 Feb 2014 18:11:05 +0000

Hi MCruz, Steve

I also agree on the "would send " instead of the "would have sent"  for sure.  But I have  a small concern/ clarification  about the Steve comment on   "for the period that the overload report is active" and the example to which it refers.

During the time the OLR is active, which may be rather long,  the traffic the reacting node would send may be 100 packet  when it has just received the OLR. A bit later, the traffic it would send could be 120 (or 80), and from the OLR definition,   it would send 120x0,9 (or 80* 0,9) packets, on  which I agree. This is in line  with the every 10th packet dropping  on which I also agree.

As the text   would  be written with the Steve modification , we may understand it is  80 Packet during all the time  the OLR is active. Not yet think to an alternative text, but first to see if you agree with my remark.

JJacques

De : DiME [mailto:[email-masked]] De la part de [email-masked]
Envoyé : vendredi 21 février 2014 18:33
À : Steve Donovan; [email-masked]
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : vendredi 21 février 2014 16:37
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.

DiME mailing list

Thank you.

---

From: <[email-masked]>
Date: Fri, 21 Feb 2014 18:27:45 +0000

Hi JJ,

I think that the condition here is "if the reacting node would send 100 packets, 90 is sent" and this is true as long as the OLR is valid, right?

Or did I miss something in your question?

Lionel

De : DiME [mailto:[email-masked]] De la part de TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Envoyé : vendredi 21 février 2014 19:11
À : [email-masked]
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi MCruz, Steve

  
 
JJacques 

 
 
Maria Cruz,

Steve

 Now (chapter 4.7):
 
 Proposal:

 Now (chapter 5.5.2):
 
  Proposal:

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Fri, 21 Feb 2014 18:56:36 +0000

Hi Lionel

The proposed text would be now:  
"For example if the  reacting node would send 100 packets to the reporting node, then a reception of OC-Reduction-Percentage value of 10 would mean that, for the period that the overload report is active on, the reacting node MUST only send  90 packets instead of 100"

I do not feel comfortable with this wording. The reacting node does not know the period for which  the overload report is active, as it may at any time receive  another OLR overriding the previous one. The new reading means 90 packets for a period we don't k now.  The existing text was mentioning packet/seconds, that Mcruz wanted also to avoid as it could   have been understood that 10 packet are removed for each period of one second, which is not fully accurate,  if I remember well.

Best regards

JJacques 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : vendredi 21 février 2014 19:28
À : TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
Objet : RE: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi JJ,

Lionel

De : DiME [mailto:[email-masked]] De la part de TROTTIN, JEAN-JACQUES (JEAN-JACQUES) Envoyé : vendredi 21 février 2014 19:11 À : [email-masked] Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi MCruz, Steve

  
 
JJacques 

De : DiME [mailto:[email-masked]] De la part de [email-masked] Envoyé : vendredi 21 février 2014 18:33 À : Steve Donovan; [email-masked] Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

De : DiME [mailto:[email-masked]] De la part de Steve Donovan Envoyé : vendredi 21 février 2014 16:37 À : [email-masked] Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion
 
Maria Cruz,

Steve

 Now (chapter 4.7):
 
 Proposal:

 Now (chapter 5.5.2):
 
  Proposal:
 Indicates that the reporting node urges the reacting node to reduce
 its traffic by a given percentage. For example if the  reacting node would send 100 packets to the                          <---  reporting node, then a reception of OC-Reduction-Percentage value of
 10 would mean that from now on the reacting node MUST only send  90 packets instead of 100. How the reacting node achieves the "true       <---  reduction" transactions leading to the sent request messages is up to
 the implementation. The reacting node MAY simply drop every 10th
 packet from its output queue and let the generic application logic try
 to recover from it.
SRD> Replace "from now on" in the above with "for the period that the overload report is active"

 

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
 
This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 21 Feb 2014 19:13:58 +0000

Valid means till the validity duration expires or a fresh OLR is received. So the reacting node will behave according to the latest OLR received.

So no pb for me. But feel free to propose a new text if needed.

Lionel

Envoyé depuis mon Sony Xperia SP d'Orange

"TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]> a écrit :

Hi Lionel

Best regards

JJacques

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]]
Envoyé : vendredi 21 février 2014 19:28
À : TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
Objet : RE: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi JJ,

Lionel

Hi MCruz, Steve

JJacques

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

---

From: Steve Donovan <[email-masked]>
Date: Fri, 21 Feb 2014 17:55:52 -0600

+1 on Lionel's point.

Steve

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 24 Feb 2014 09:45:47 +0000

I share JJacques concern. Replacing "from now on" with "for the period that the overload report is active"
is misleading. May be its better to simply remove "from now on".

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: Friday, February 21, 2014 7:11 PM
To: [email-masked]
Subject: Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi MCruz, Steve

JJacques

De : DiME [mailto:[email-masked]] De la part de [email-masked]<mailto:[email-masked]>
Envoyé : vendredi 21 février 2014 18:33
À : Steve Donovan; [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.

DiME mailing list

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Mon, 24 Feb 2014 13:12:39 +0000

Hello,

I agree with Ulrich's proposal
Cheers
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: lunes, 24 de febrero de 2014 10:46
To: ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
Subject: Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: Friday, February 21, 2014 7:11 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi MCruz, Steve

JJacques

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.

DiME mailing list

Thank you.

---

From: <[email-masked]>
Date: Mon, 24 Feb 2014 13:26:28 +0000

I don't see the issue, as explained in my mail but OK to remove it. 

If "for now" is removed, the resulting text would be:

  For example if the reacting node has been sending
  100 packets per second to the reporting node, then
  a reception of OC-Reduction-Percentage value of 10
  would mean that from now on the reacting node MUST
  only send 90 packets per second.

Maybe it would be even easier to reverse the sentence as follow:

 For example if an OC-Reduction-Percentage value of 
 10 has been received, the reacting node which 
 would normally send 100 packets MUST only send 90 
 packets to the reporting node.

But I'm fine if the initial proposed revised text is kept.

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : lundi 24 février 2014 14:13
À : [email-masked]
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hello,

 
 
Ulrich

 
Hi MCruz, Steve

  
 
JJacques 

 
 
Maria Cruz,

Steve

 Now (chapter 4.7):
 
 Proposal:

 Now (chapter 5.5.2):
 
  Proposal:

---

From: Steve Donovan <[email-masked]>
Date: Mon, 24 Feb 2014 09:59:33 -0600

I'm with Lionel.  I don't understand why the proposed wording is
confusing.  Reacting nodes always only apply the reduction percentage
for the period of time that the specific overload report is active. 
That period either ends when a new overload report is received or when
the overload report expires.

That said, I'm happy with just removing the words "from no on" as
proposed by Lionel below.

Steve

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 26 Feb 2014 07:43:16 +0000

Hi

Remove "from now on" is acceptable for me, but  I have a preference for the reverse wording Lionel proposes, which is shorter and brings the clarification I was looking for,:

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : lundi 24 février 2014 17:00
À : [email-masked]
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

I'm with Lionel.  I don't understand why the proposed wording is confusing.  Reacting nodes always only apply the reduction percentage for the period of time that the specific overload report is active.  That period either ends when a new overload report is received or when the overload report expires.

That said, I'm happy with just removing the words "from no on" as proposed by Lionel below.

Steve

On 2/24/14 7:26 AM, [email-masked]<mailto:[email-masked]> wrote:

Lionel

Hello,

Cheers

/MCruz

To: ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]<mailto:[email-masked]>

Ulrich

Hi MCruz, Steve

JJacques

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.

DiME mailing list

Thank you.

Thank you.

DiME mailing list

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Wed, 26 Feb 2014 12:55:44 +0000

Fine

From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: miércoles, 26 de febrero de 2014 8:43
To: [email-masked]
Subject: Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Hi

Best regards

JJacques

Steve

Lionel

Hello,

Cheers

/MCruz

Ulrich

Hi MCruz, Steve

JJacques

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.

DiME mailing list

Thank you.

Thank you.

DiME mailing list

---

From: <[email-masked]>
Date: Fri, 28 Feb 2014 13:58:52 +0000

Jouni, I'm assuming that you are OK with the conclusion given here too, right? :)

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mercredi 26 février 2014 13:56
À : [email-masked]
Objet : Re: [Dime] #52: Throttling not needed to be based on previous history - conclusion

Fine

Hi

Best regards

JJacques

Steve

Lionel

Hello,

Cheers

/MCruz

Ulrich

Hi MCruz, Steve

JJacques

Maria Cruz,

Steve

 Now (chapter 4.7):

 Proposal:

 Now (chapter 5.5.2):

  Proposal:

 to recover from it.

DiME mailing list

Thank you.

Thank you.

DiME mailing list