Subject: [Dime] [dime] #53: 5.5.2 chapter typo? - conclusion

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 21 Feb 2014 08:51:30 +0000

#53: 5.5.2 chapter typo?

Following text will be deleted:

    .........  If the OC-Supported-Features AVP
    is received for the first time for the reporting node or the OC-
    Sequence-Number AVP value is less than the previously received/
    recorded one (and is outside the valid overflow window), then either
    the sequence number is stale (e.g. an intentional or unintentional
    replay) and SHOULD be silently discarded.

 As long as, the situations that it refers are covered later in the same chapter.

---

From: Steve Donovan <[email-masked]>
Date: Fri, 21 Feb 2014 09:32:54 -0600

Maria Cruz,

I think we need to see the replacement text before concluding this ticket.

Steve

On 2/21/14 2:51 AM, Maria Cruz Bartolome wrote:
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 21 Feb 2014 15:42:22 +0000

Steve,

Extracted text is duplicated now, this paragraph I referred is simply wrong.
But I agree duplicated text should be revised due to issue#29, but this is up to this ticket to provide the alternative text.

Cheers
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: viernes, 21 de febrero de 2014 16:33
To: [email-masked]
Subject: Re: [Dime] [dime] #53: 5.5.2 chapter typo? - conclusion

Maria Cruz,

Steve

#53: 5.5.2 chapter typo?

DiME mailing list

[email-masked]<mailto:[email-masked]>

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Fri, 21 Feb 2014 17:24:53 +0000

Hi MCruz

The text  you propose to remove deals with the Seq number within  OC-Supported features, because of duplication with another text, but this other text text relates to the seq number handling within the OC-OLR AVP.
I think we can keep two texts, one for the seq number  within OC-Supported features  and another one for  the seq number  within OC-OLR AVP,. We will then see how the text  for seq number  within OC-Supported features evolves with the #29  outputs.

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : vendredi 21 février 2014 16:42
À : [email-masked]
Objet : Re: [Dime] [dime] #53: 5.5.2 chapter typo? - conclusion

Steve,

Cheers
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: viernes, 21 de febrero de 2014 16:33
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #53: 5.5.2 chapter typo? - conclusion

Maria Cruz,

Steve

#53: 5.5.2 chapter typo?

DiME mailing list

---

From: Steve Donovan <[email-masked]>
Date: Mon, 24 Feb 2014 16:06:42 -0600

There is still an issue with the text Maria Cruz points out.  This part
-- If the OC-Supported-Features AVP is received for the first time for
the reporting node -- is erroneous and should be removed from the sentence.

Steve

On 2/21/14 11:24 AM, TROTTIN, JEAN-JACQUES (JEAN-JACQUES) wrote:
>
> Hi MCruz
>
>  
>
> The text  you propose to remove deals with the Seq number within
>  OC-Supported features, because of duplication with another text, but
> this other text text relates to the seq number handling within the
> OC-OLR AVP.
>
> I think we can keep two texts, one for the seq number  within
> OC-Supported features  and another one for  the seq number  within
> OC-OLR AVP,. We will then see how the text  for seq number  within
> OC-Supported features evolves with the #29  outputs.
>
>  
>
> Best regards
>
>  
>
> JJacques  
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Maria Cruz
> Bartolome
> *Envoyé :* vendredi 21 février 2014 16:42
> *À :* [email-masked]
> *Objet :* Re: [Dime] [dime] #53: 5.5.2 chapter typo? - conclusion
>
>  
>
> Steve,
>
>  
>
> But I agree duplicated text should be revised due to issue#29, but
> this is up to this ticket to provide the alternative text.
>
>  
>
> Cheers
>
> /MCruz
>
>  
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *Steve Donovan
> *Sent:* viernes, 21 de febrero de 2014 16:33
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Dime] [dime] #53: 5.5.2 chapter typo? - conclusion
>
>  
>
> Maria Cruz,
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 28 Feb 2014 21:07:44 +0200

Taking #29 agreed part also into account some proposed text to 5.5.2:

OLD:
   The received OC-Supported-Features AVP does not change the existing
   overload condition and/or traffic abatement algorithm settings if the
   OC-Sequence-Number AVP contains a value that is equal to the
   previously received/recorded one.  If the OC-Supported-Features AVP
   is received for the first time for the reporting node or the OC-
   Sequence-Number AVP value is less than the previously received/
   recorded one (and is outside the valid overflow window), then either
   the sequence number is stale (e.g. an intentional or unintentional
   replay) and SHOULD be silently discarded.

   The OC-OLR AVP contains the necessary information of the overload
   condition on the reporting node.  Similarly to the OC-Supported-
   Features's sequence numbering, the OC-OLR AVP also has the OC-
   Sequence-Number AVP and its handling is similar to the one in the OC-
   Supported-Features AVP.  The reacting node MUST update its overload
   condition state whenever receiving the OC-OLR AVP for the first time
   or the OC-Sequence-Number sub-AVP indicates a change in the OC-OLR
   AVP.
NEW:
   The received OC-Supported-Features AVP does not change the existing
   traffic abatement algorithm settings if the AVP contains a value that
   is equal to the previously received/recorded one.

- Jouni

On Feb 25, 2014, at 12:06 AM, Steve Donovan <[email-masked]> wrote:

> There is still an issue with the text Maria Cruz points out.  This part -- If the OC-Supported-Features AVP is received for the first time for the reporting node -- is erroneous and should be removed from the sentence.
> 
> Steve
>