Subject: [Dime] [dime] #36: OC-Validity-Duration AVP

From: "dime issue tracker" <[email-masked]>
Date: Thu, 06 Feb 2014 10:44:52 -0000

#36: OC-Validity-Duration AVP

 In draft-ietf-dime-ovli-01 chapter 4.5, the statement that describes when
 the OC-Validity-Duration AVP needs to be updated is ambiguous.

 Now:
    The OC-Validity-Duration AVP (AVP code TBD4) is type of Unsigned32
    and describes the number of seconds the OC-OLR AVP and its content is
    valid since the reception of the new OC-OLR AVP (as indicated by the
    OC-Sequence-Number AVP).

 Proposal:
    The OC-Validity-Duration AVP (AVP code TBD4) is type of Unsigned32
    and describes the number of seconds the OC-OLR AVP and its content is
    valid in relation to the reception of the first OC-OLR AVP with a
    specific sequence number. For a given sequence number, the
    OC-Validity-Duration shall always carry the same value.

-- 
-----------------------------------------------+---------------------------
 Reporter:  [email-masked]  |      Owner:  MCruz
     Type:  enhancement                        |  Bartolomé
 Priority:  major                              |     Status:  new
Component:  draft-docdt-dime-ovli              |  Milestone:
 Severity:  Active WG Document                 |    Version:
                                               |   Keywords:
-----------------------------------------------+---------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/36>
dime <http://tools.ietf.org/wg/dime/>

---

From: Steve Donovan <[email-masked]>
Date: Thu, 06 Feb 2014 09:35:01 -0600

This change looks pretty straight forward to me.  I'll add it to the -02
version of the draft unless I hear objections soon.

Steve

---

From: <[email-masked]>
Date: Thu, 6 Feb 2014 18:07:02 +0000

Hi Maria Cruz,

Hi Maria Cruz, Steve,

Be careful! The reference you are using seems to be odd.

The current text in the draft says:

4.5. OC-Validity-Duration AVP

   The OC-Validity-Duration AVP (AVP code TBD4) is type of Unsigned32
   and describes the number of seconds the "new and fresh" OC-OLR AVP
   and its content is valid since the reception of the new OC-OLR AVP.
   The default value for the OC-Validity-Duration AVP value is 5 (i.e.,
   5 seconds).  When the OC-Validity-Duration AVP is not present in the
   OC-OLR AVP, the default value applies.  Validity duration values 0
   (i.e., 0 seconds) and above 86400 (i.e., 24 hours) MUST NOT be used.
   Invalid validity duration values are treated as if the OC-Validity-
   Duration AVP were not present.

   A timeout of the overload report has specific concerns that need to
   be taken into account by the endpoint acting on the earlier received
   overload report(s).  Section 4.7 discusses the impacts of timeout in
   the scope of the traffic abatement algorithms.

   As a general guidance for implementations it is RECOMMENDED never to
   let any overload report to timeout.  Following to this rule, an
   overload endpoint should explicitly signal the end of overload
   condition and not rely on the expiration of the validity time of the
   overload report in the reacting node.  This leaves no need for the
   reacting node to reason or guess the overload condition of the
   reporting node.

I think that the definition of the OC-Validity-Duration AVP should remain independent of the notion of Sequence-Number.
The sequence number does not change the value of the OC-Validity-Duration AVP. It indicates that the OLR has to be updated or not. And if it is, a new duration will be there (either implicit or explicit with the OC-Validity-Duration AVP).

So if something needs to be clarified (I haven't checked), it should be in the handling of the OLR.

Regards,

Lionel 

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : jeudi 6 février 2014 16:35
À : [email-masked]
Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

This change looks pretty straight forward to me.  I'll add it to the -02 version of the draft unless I hear objections soon.

Steve

 Now:

 Proposal:

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 7 Feb 2014 07:13:44 +0000

Thanks Lionel,
The comment equally applies in order to clarify when the Validity-Duration should include a new value. 

Now:

 Proposal:

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: jueves, 06 de febrero de 2014 19:07
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi Maria Cruz,

Hi Maria Cruz, Steve,

Regards,

Lionel 

De : DiME [mailto:[email-masked]] De la part de Steve Donovan Envoyé : jeudi 6 février 2014 16:35 À : [email-masked] Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Steve

 In draft-ietf-dime-ovli-01 chapter 4.5, the statement that describes when  the OC-Validity-Duration AVP needs to be updated is ambiguous.

 Now:

 Proposal:

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Fri, 7 Feb 2014 07:32:53 +0000

Hi,

My point is just to say that we should make the difference between the definition and the use of the AVP.

And about the clarification, I would say that it is rather about how to populate the OC-OLR AVP or when a new sequence number should be used.

Regards,

Lionel

Envoyé depuis mon Sony Xperia SP d'Orange

Maria Cruz Bartolome <[email-masked]> a écrit :

Thanks Lionel,

Now:

 Proposal:

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: jueves, 06 de febrero de 2014 19:07
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi Maria Cruz,

Hi Maria Cruz, Steve,

Regards,

Lionel

Steve

 Now:

 Proposal:

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 7 Feb 2014 07:38:16 +0000

Hello Lionel, all,

I would like to clarify what  "new and fresh", or even only "new" OC-OLR AVP mean in the text.
It should be understood that it does not refer to the new (latest) received AVP, but just the one that contains (potentially) new values, what only happens for a new Sequence Number. In that line is the proposed text I provided.

Best regards
/MCruz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: viernes, 07 de febrero de 2014 8:33
To: [email-masked]; Maria Cruz Bartolome
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi,

Regards,

Lionel

Thanks Lionel,

Now:

 Proposal:

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: jueves, 06 de febrero de 2014 19:07
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi Maria Cruz,

Hi Maria Cruz, Steve,

Regards,

Lionel

Steve

 Now:

 Proposal:

---

From: <[email-masked]>
Date: Fri, 7 Feb 2014 10:19:23 +0000

Hi Maria Cruz,

I'm fine with the proposed clarification.
My point is that some parts belong to the handling of the OLR itself and some other to the definition of the Validity duration.

Here is a proposal for clarification. Let me know if it covers your concern.

Regards,

Lionel

*******************

4.3. OC-OLR AVP

[skip]

   The Sequence-Number AVP indicates the "freshness" of the OC-OLR AVP.
   It is possible to replay the same OC-OLR AVP multiple times between
   the overload control endpoints, however, when the OC-OLR AVP content
   changes or sending endpoint otherwise wants the receiving endpoint to
   update its overload control information, then the OC-Sequence-Number
   AVP MUST contain a new greater value than the previously received.
   The receiver SHOULD discard an OC-OLR AVP with a sequence number that
   is less than previously received one.

[New]

   The OC-Validity-Duration AVP indicates the validity time of the overload
   report associated with a specific sequence number, measured after reception
   of the OC-OLR AVP. The validity time MUST NOT be updated after reception 
   of subsequent OC-OLR AVPs with the same sequence number. The default value
   for the OC-Validity-Duration AVP value is 5 (i.e., 5 seconds).  When the 
   OC-Validity-Duration AVP is not present in the OC-OLR AVP, the default value
   applies.

[Skip]

OLD:

NEW:
   The OC-Validity-Duration AVP (AVP code TBD4) is type of Unsigned32
   and indicates in seconds the validity time of the overload report.
   The number of seconds is measured after reception of the first 
   OC-OLR AVP with a given value of OC-Sequence-Number AVP. 
   The default value for the OC-Validity-Duration AVP is 5 (i.e.,
   5 seconds).  When the OC-Validity-Duration AVP is not present in the
   OC-OLR AVP, the default value applies. OC-Validity-Duration AVP values 0
   (i.e., 0 second) and above 86400 (i.e., 24 hours) MUST NOT be used.
   When invalid values are used, the default value for the OC-Validity-Duration
   AVP applies.

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : vendredi 7 février 2014 08:38
À : [email-masked]
Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hello Lionel, all,

Best regards
/MCruz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: viernes, 07 de febrero de 2014 8:33
To: [email-masked]; Maria Cruz Bartolome
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi,

Regards,

Lionel

Thanks Lionel,

Now:

 Proposal:

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: jueves, 06 de febrero de 2014 19:07
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi Maria Cruz,

Hi Maria Cruz, Steve,

Regards,

Lionel

Steve

 Now:

 Proposal:

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 7 Feb 2014 12:52:42 +0200

OK by me.

- JOuni

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Mon, 10 Feb 2014 08:58:40 +0000

Hi all

I agree to enhance the wording so by starting  from the new Lionel's wording.

My comment is that we have  to clearly distinguish the "validity duration" given  by the OC-Validity-Duration AVP (eg 10 s) from the "validity time" (absolute value) at the end of which  the received OLR is no more applicable.
- If the reacting node receives a new sequence number at T1 and a validity duration of 10s, this will determine a validity time eg of T1+ 10s where the received OLR is applicable.
- If later at T2, it receives another OLR with the Same sequence number,  the validity time remains unchanged at  T1+10s (as stated in Lionel's proposal), this allows to ignore the OLRs with the same sequence number.
- If at T3, the reacting node receives another OLR with a new  sequence number and with the same value, 10 s, (or a new value, eg 15s)  for validity duration,  the validity time becomes  T3+10s (or T3+15s). So we can have situations where the sequence number is changed but the other content of OC-OLR AVP (reduction%, validity duration) itself has not changed: the effect is only to shift the validity time in the reacting node.
Do you share  all this understanding? 

So in the description, to be careful between validity duration and validity time that  may confuse.

Best regards

JJacques 

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Jouni Korhonen
Envoyé : vendredi 7 février 2014 11:53
À : [email-masked]
Cc : [email-masked]
Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

OK by me.

- JOuni

On Feb 7, 2014, at 12:19 PM, <[email-masked]> wrote:

> De : DiME [mailto:[email-masked]] De la part de Maria Cruz 
> Bartolome Envoyé : vendredi 7 février 2014 08:38 À : [email-masked] 
> Envoyé : jeudi 6 février 2014 16:35 À : [email-masked] Objet : Re: 
> [Dime] [dime] #36: OC-Validity-Duration AVP
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Mon, 10 Feb 2014 09:25:46 +0000

Hello Lionel, all,

Proposal is fine for me.
Thanks
/MCruz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: viernes, 07 de febrero de 2014 11:19
To: Maria Cruz Bartolome; [email-masked]
Subject: RE: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi Maria Cruz,

Regards,

Lionel

*******************

4.3. OC-OLR AVP

[skip]

[New]

[Skip]

OLD:

NEW:

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome Envoyé : vendredi 7 février 2014 08:38 À : [email-masked] Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hello Lionel, all,

Best regards
/MCruz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: viernes, 07 de febrero de 2014 8:33
To: [email-masked]; Maria Cruz Bartolome
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi,

Regards,

Lionel

Thanks Lionel,

Now:

 Proposal:

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: jueves, 06 de febrero de 2014 19:07
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi Maria Cruz,

Hi Maria Cruz, Steve,

Regards,

Lionel

Steve

 Now:

 Proposal:

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Mon, 10 Feb 2014 09:35:47 +0000

Hello Jean-Jacques, et all,

I share your interpretation.
But, do you find this is still misleading in proposed text?

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: lunes, 10 de febrero de 2014 9:59
To: [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi all

Best regards

JJacques 

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Jouni Korhonen Envoyé : vendredi 7 février 2014 11:53 À : [email-masked] Cc : [email-masked] Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

OK by me.

- JOuni

---

From: <[email-masked]>
Date: Mon, 10 Feb 2014 09:41:51 +0000

Hi JJ,

Just on the definition of "time".... It could be a period/moment and not only a absolute time.
Validity time can be used for both and it is why it is important each time to clarify its meaning.

For the rest, I think that the proposed text is clear enough to avoid ambiguity.

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : lundi 10 février 2014 10:36
À : [email-masked]
Objet : Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: lunes, 10 de febrero de 2014 9:59
To: [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi all

Best regards

JJacques 

-----Message d'origine-----

OK by me.

- JOuni

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Mon, 10 Feb 2014 09:46:01 +0000

Hi MCruz

I have not yet thought to some wording enhancement, I wanted first to check is we have the same understanding.

I have noted in the proposal:
"The OC-Validity-Duration AVP (AVP code TBD4) is type of Unsigned32 and indicates in seconds the validity time of the overload report"
So I would prefer to use "validity duration", as the OC-Validity-Duration AVP indicates a duration, not a time. But elsewhere, what is important is the update of the validity time  when a new sequence number. 
Best regards

JJacques  

-----Message d'origine-----

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: lunes, 10 de febrero de 2014 9:59
To: [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi all

Best regards

JJacques 

-----Message d'origine-----

OK by me.

- JOuni

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 11 Feb 2014 10:13:07 +0000

Let's use "validity duration" and "expiry time", and avoid "validity time"

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: Monday, February 10, 2014 9:59 AM
To: [email-masked]
Subject: Re: [Dime] [dime] #36: OC-Validity-Duration AVP

Hi all

Best regards

JJacques 

-----Message d'origine-----

OK by me.

- JOuni