Subject: Re: [Dime] Issue#29 proposed conclusion

From: Steve Donovan <[email-masked]>
Date: Mon, 17 Mar 2014 12:55:55 -0500

All,

I believe we have consensus on this ticket.

I had put the following into my issue status document:

Agreed – Removed OC-Sequence-Number from OC-Supported-Features AVP.

Agreed – The scope of an OC-Supported-Features AVP is a single transaction.

Agreed – Diameter nodes that support DOIC must include the
OC-Supported-Features AVP in all requests.

I believe that this translates into the text changes outlined below.  If
we have agreement on the text below we can close the issue and I'll
update the text in the -02 draft accordingly.

Regards,

Steve

-----

Section 4.1:

Remove < OC-Sequence-Number >  from OC-Supported-Features syntax
description.

Remove paragraph 3 that starts "OC-Sequence-Number AVP is used..."

Section 4.4, Paragraph 1:

Remove reference to section 4.1.

Section 5.3.1, Paragraph 1:

Change:

It is RECOMMENDED that the
   request message initiating endpoint includes the capability
   announcement into every request regardless it has had prior message
   exchanges with the give remote endpoint. In a case of a Diameter
   session maintaining application, sending the OC-Supported-Features
   AVP in every message is not really necessary after the initial
   capability announcement or until there is a change in supported
   features. To: The lifetime of a capability announcement is limited to
a single transaction. As a result, the reacting node MUST include the
capability announcement in all request messages.

On 2/24/14 5:02 PM, Ben Campbell wrote:
> On Feb 24, 2014, at 1:52 PM, Steve Donovan <[email-masked]> wrote:
>
>> I agree.
>>
>> I also think that we agreed that the lifetime of the OC-Supported-Features AVP is a single transaction and that the OC-Supported-Features AVP must be included in all requests originated by a Diameter node supporting DOIC.
> +1, and my previous agreement was based on that assumption.
>
>
>> Steve
>>
>> On 2/20/14 4:31 PM, Ben Campbell wrote:
>>> I concur with removing the sequence number from OC-Supported-Features.
>>>
>>>
>

---

From: Steve Donovan <[email-masked]>
Date: Fri, 21 Mar 2014 08:19:50 -0500

Having seen no additional discussion on this I will close the issue with
the suggested text.

Regards,

Steve

On 3/17/14 12:55 PM, Steve Donovan wrote:
> Agreed -- Removed OC-Sequence-Number from OC-Supported-Features AVP.
>
> Agreed -- The scope of an OC-Supported-Features AVP is a single
> transaction.
>
> Agreed -- Diameter nodes that support DOIC must include the
> I believe that this translates into the text changes outlined below. 
> If we have agreement on the text below we can close the issue and I'll
>    features. To: The lifetime of a capability announcement is limited
> to a single transaction. As a result, the reacting node MUST include
> the capability announcement in all request messages.
>
>
>
>
>
>
>
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Fri, 21 Mar 2014 13:26:59 +0000

Hi Steve

I agree on the proposal

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : vendredi 21 mars 2014 14:20
À : [email-masked]
Objet : Re: [Dime] Issue#29 proposed conclusion

Having seen no additional discussion on this I will close the issue with the suggested text.

Regards,

Steve

Agreed - Removed OC-Sequence-Number from OC-Supported-Features AVP.
Agreed - The scope of an OC-Supported-Features AVP is a single transaction.
Agreed - Diameter nodes that support DOIC must include the OC-Supported-Features AVP in all requests.

I believe that this translates into the text changes outlined below.  If we have agreement on the text below we can close the issue and I'll update the text in the -02 draft accordingly.

Regards,

Steve

-----

Section 4.1:

Remove < OC-Sequence-Number >  from OC-Supported-Features syntax description.

Change:

   features.

To:

The lifetime of a capability announcement is limited to a single transaction.  As a result, the reacting

node MUST include the capability announcement in all request messages.

On Feb 24, 2014, at 1:52 PM, Steve Donovan <[email-masked]><mailto:[email-masked]> wrote:

I agree.

Steve

DiME mailing list

[email-masked]<mailto:[email-masked]>