Subject: Re: [Dime] Issue#35 conclusion

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Tue, 4 Mar 2014 13:34:31 +0000

Hi all

Hereafter several points  about some collateral consequences of the Ticket #35 proposal

1)      Besides the commented  point 3, I have a similar comment for point 1. I have a client A with a per client type  (0) active OLR having a high reduction % (90%) , then the  DA receives an OLR client (1) to update % for all nodes with a small % (10%). According to  rule 1 , client A has now  10% reduction:  this will create  a burst of traffic.   I assume that very soon after  it will receive  a new OLR type (0) with 90% but this rule is something creating transient  traffic  bursts in an overload situation which is not our aim. So, we may modify the rule 1 eg by stating  "A fresh OLR of type (1) makes all old type (1) OLRs  invalid and leave unchanged clients with a OLR type(0)". But not sure the story is finished., if later the specific peak vanishes and the server wants to handle client A as other nodes,  what does the server do? Due to my new rule, server  sending an OLR type (1) does not solve this point, but we would like to avoid a server to continue to send OLR type (0),to this client as there is no more specificity

-          We may use  the validity period of 0, but  it means no more overload

-          the other way is first  to use a OLR type(0) with short validity expiration period (and a value of 10% to align)) and to add a new  rule: "if an OLR(0) expires for a client, , and if an OLR type (1) exist for other clients, the OLR type(1) applies to this client.

2)      A clarification if I have the right understanding
When DA receives the first OLR type (1) with a new seq number in an answer to a client A , this OLR type (1) immediately applies to all nodes (apart those with a OLR type(0) active, cf above), taking into account that DA will then receives  other answers to client B, C... with the same OLR type (1) and the same seq number should be the same, as long as there is no modif brought to OLR type(1). May be also some text to avoid misunderstanding would be need to avoid a wrong seq numbr handling  Do you agree?

3)      Another point: when I consider the target network in the future where there are only DOIC clients, why to continue to send a mandatory OLR which  shall always be ignored.... I would prefer to have  no such OLR at all, meaning to introduce a non mandatory OLR AVP with a default value when no present. As in the target network, the Host OLR is  per client, default value would be (0). Views?

4)      Regarding DOIC association, here we have an information (OLR with type (1)  exchanged inside  a DOIC association that applies to many DOIC associations.  It is possible but it should be highlighted .

5)      I also saw Mcruz had a preferencee for another OLR type and not a new AVP, have  we concluded on this .

What are your views? These are not blocking points, there is always some solution by adding new rules. Nevertheless I am always cautious when a new AVP is introduced, as it always creates new combinational cases, that we have to analyse . So is this optimization actually needed. If yes, we need to add the right rules to avoid unexpected  situations and  misunderstanding

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : jeudi 27 février 2014 21:11
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] Issue#35 conclusion

I think if you change number three to the following then it works better.

  3. A fresh OLR of type (0) makes an old OLR of type (1) invalid for the client to which the answer message is being routed.  The agent shall apply the OLR or type (0) for traffic from that client. The old OLR of type (1) continues to apply for all clients that do not have a "per client" overload report.

I think it is important for a reporting node to be able to start with an "all clients" overload report and then transition to "per client" reports for chatty clients.

Steve

On 2/27/14 11:47 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:
Dear MCruz,

certainly a valid point. I don't have a strong view but I wanted to avoid the mixture to keep things simple.
Maybe we should forbid the change from 1 to 0 during an ongoing overload.

Anyway, I don't think this is a blocking point for the proposal to add the new AVP.

Best regards
Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Maria Cruz Bartolome
Sent: Thursday, February 27, 2014 5:13 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] Issue#35 conclusion

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Some comments on the interactions you mentioned:

1.      A fresh OLR of type (1) makes all old OLRs of any type invalid

2.      A fresh OLR of type (0) makes an old OLR of type (0) bound to the same client invalid

3.      A fresh OLR of type (0) makes an old OLR of type (1) invalid

I do not think 3) is right. Why an OLR per one specific client shall invalidate OLRs for rest of clients? This will imply that rest of clients will not have any overload mitigation on until they receive a new value of (1), or (0) for each of them.

Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)
Sent: miércoles, 26 de febrero de 2014 12:23
To: ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] Issue#35 conclusion

Hi JJacques,

thank you for the summary.

I think it does not matter whether we call

A)     "OLR per client" the base solution and "OLR for all clients" the optimization or

B)    "OLR for all clients" the base solution and "OLR per client" the (3GPP) extension
as long as we cover both.

I don't think there are impacts on sequence number handling, report types or DOIC associations.

My proposal then is to add a new mandatory AVP of type enumerated to OC-OLR with values

(0)   OLR per client

(1)   OLR for all clients

Reporting nodes that better like A) could allways send (0) unless they support the "optimization" and want to use it;
Reporting nodes that better like B) could allways send (1) unless they support the "(3GPP) extension" and want to use it.
Clients can safely ignore the new AVP.
Agents taking the role of the reacting node on behalf of a client must do the binding when receiving (0).

We also need to say something on interactions e.g.:
A fresh OLR of type (1) makes all old OLRs of any type invalid
A fresh OLR of type (0) makes an old OLR of type (0) bound to the same client invalid
A fresh OLR of type (0) makes an old OLR of type (1) invalid

(i.e. change of type is allowed, mixture is not allowed)

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: Wednesday, February 26, 2014 8:07 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] Issue#35 conclusion

Hi Steve, MCruz and all

On my side,  I agree with Lionel.

I  have not the  same reading of the draft where I have  not found the Steve's default case.
I agree with Lionel that the OLR for a DOIC association relates to this DOIC association  and the OLR can be different  for another DOIC association. The basic (or "default") principle is that each DOIC association has its "own life".

Then,  a server (local policy) can decide  to send  the same OLR to all its clients (so for all its DOIC associations) , or it can define  particular OLR values for   certain clients.
Another  interest  is that  when the server wants to update the OLR values towards  clients, it is  not obliged to send the new values  simultaneously  to all the clients : it may  (local server policy) progressively  change  the  value  over a certain duration  to minimize  sharp transitions.

So for DOIC supporting clients, the current text allows these possibilities, and in particular it satisfies the 3GGP client mitigation requirement.

A second step is to address DAs supporting non DOIC clients. Over time,  we may expect that clients will be more and more DOIC supporting; so, this is the main target. DAs with non DOIC client would be more for   a transition (to be considered  nevertheless and which may be long).

The current text says that DA is acting on behalf of "A" client; so principle  with host OLR per DOIC association also applies, and there is no difference for the server, as this does not make a difference  between a DOIC supporting client and a DA supporting non DOIC clients.
Nevertheless, and here I come to Steve's point,   this has a cost implying the DA to manage OLRs per client. Steve  introduces an optimization where in fact a set of clients are considered for me as a pool regarding  DOIC where only one OLR applies and where throttling  applies  to the requests of this  pool of clients.  I am not against to optimization process   but this pool concept is new and needs some further study. First about the concept of DOIC association which evolves , as now linked to a pool .

There was a MCruz remark about sequence number, a new AVP or a  new report type.  I see that  we may have to review  the processing of the seq number  handling as also dependent of the new AVP or the OLR type; so   a "collateral " effect of the optimization. I would also think that, instead of introducing a single node indication in the OLR (AVP or report type) , it should be a global indication as the optimization   is to support a global DOIC association.  To also see if there are not other collateral effects to analyze.

Ulrich  also mentioned that for realm OLRs we may also have  a different realm  OLR sent to different clients, so this is the same principle as Lionel  for  a realm OLR per DOIC association, on which I agree.

The current text due to the DOIC association principle,  allows this realm OLR per DOIC association for both  DOIC  supporting clients and  DAs acting on behalf of A client. Then I expect Steve  to do the same remark, with the same reason  to have  an optimization  where all clients receives  the  same realm OLR, but to also see the collateral effects.

As a conclusion, I think we should remain with the current text as the baseline, following the DOIC association principle that Lionel mentions, and after more investigation to assess the  optimization  for host and realm OLRs with DA supporting non DOIC,  this optimization being optional.

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 25 février 2014 10:09
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] Issue#35 conclusion

Yes, I agree with Steve.

Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: lunes, 24 de febrero de 2014 20:24
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] Issue#35 conclusion

Lionel,

The question is whether the reporting node is sending the overload report per client or it is sending a global overload report that applies to all clients.

I still believe that the default behavior of a reporting node will be to have a single overload reduction value for the application and that that overload reduction value will apply to all clients.  If this is the case then there is little benefit (and significant overhead) to requiring an agent to maintain state per non-supporting client.

I also agree that there is value to the reporting node being able to have a different reduction value for specific reacting nodes.  If this is the case then the reporting node should indicate that it only applies to the origin-host in the request and only then should agents be required to maintain state for the non-supporting client.

Steve
On 2/24/14 12:57 PM, [email-masked]<mailto:[email-masked]> wrote:
I really don't understand but it is not the first time :)

What about the DOIC association? What about my assumption about agent maintaining overload control state for non-DOIC enabled client?
So for me, the proposal from Ulrich is a clarification on the agent behavior that was implicit if you consider the comments above.

For me, the option for the server is only to send a specific OLR for a specific client. So over two different DOIC association with the same server/reporting node, you can have two different OLRs.
But it does not change the way the OLR is handled by reacting nodes.

Lionel

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : lundi 24 février 2014 19:50
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] Issue#35 conclusion

Maria Cruz,

To the degree possible we should minimize the per application overload logic required.  To this end, it would be better to have this as part of the base specification, as it is likely that most/all applications will want the same behavior.

Whether a reporting node uses per Origin-Host reports is an implementation detail of the reporting node.  How reacting nodes respond to per Origin-Host reports should be specified in a common way.

Steve
On 2/24/14 12:40 PM, Maria Cruz Bartolome wrote:
Hello again,

I forgot to mention something else in this thread, that I already mentioned in related thread #56.

This is all in order to take into account 3GPP requirement on overload mitigation differentiation per client. But this is a server option:

TR 29809 ch. 6.4.7.1 states "It may be up to the server/agent implementations to decide when and whether overload mitigation differentiation per client is used".

Therefore, we can even consider this new OLR out of the base draft, and be considered by 3GPP applications when required.

Best regards

/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Maria Cruz Bartolome
Sent: lunes, 24 de febrero de 2014 19:19
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] Issue#35 conclusion

Steve, all,

I agree with Steve.

However, I would like to share one concern. We need to avoid that existing (if any) host OLR ("all-client") in the reacting node is replaced by new host OLR (per client).
Host OLR (per client) with the new AVP requires that the server uses a new sequence number, but existing host OLR (all) shall not be replaced, on the contrary both Host OLR (all) and new Host OLR (per client) should remain.
In order to achieve this, it could be more convenient to use a dedicated OLR type (host per client), instead of a new AVP.

Let me know your opinions.
Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: lunes, 24 de febrero de 2014 16:56
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] Issue#35 conclusion

Adding an AVP to indicate that a report applies just to the Origin-Host in the request is not just an optimization for agents.

It had been my assumption all along that the default behavior of a reporting node (server) would be to report a single overload value to all reacting nodes, be they clients or agents.  If this is the default behavior then it would be best to have the default, implicit, meaning of an overload report to be "applies to all reacting nodes".  The real value of this new feature is to allow a server to further throttle a specific, overly active, reacting node when then global reduction percentage doesn't do the job.

In addition, if the normal case is that reporting nodes have a single global reduction percentage then requiring agents to bind an overload report to each non supporting clients pushes a lot of extra work on agents when it adds no value.

My proposal is the following:

- Add an optional AVP (call it something like Single-Node???) to overload reports that indicate when an overload report applies to a specific reacting node.

- Absence of the AVP indicates that the report applies to all reacting nodes (clients and agents acting on behalf of non-DOIC clients).

- Reporting nodes should only include the Single-Node AVP if the overload report contents are different from the global overload report.

- DOIC-supporting agents receiving an OLR without the Single-Node AVP must do the following:
  - For transactions from DOIC-supporting clients the agent must not act on the OLR.
  - For transactions from non-DOIC-supporting clients the agent must apply the OLR to traffic from the set of non supporting clients.   This implies that when making throttling decisions, the agent does not differentiate which non supporting client originated the request.

- DOIC-supporting agents receiving an OLR with the Single-Node AVP for a transaction originated by a non supporting client must bind that OLR to that single client.

Note that the agent behavior is currently something that is missing from the -01 version of the draft.  We will need something like this wording independent of the resolution of this issue.

Steve
On 2/24/14 8:06 AM, [email-masked]<mailto:[email-masked]> wrote:

Is it implicit?

If the agent detects that a client is not supporting DOIC, this agent will have to store the corresponding overload control state on behalf of this client and only this client (saying that other clients may support DOIC). I'm assuming then that any agent will have to store somewhere the origin-host of this client. And therefore, I don't see what would be the added-value of this AVP saying that this OLR is only for this client.

Even if this AVP is present, it would not preclude a reporting node to always put this AVP in every answer, even if the OLR is the same for all the clients.

Regards,

Lionel

-----Message d'origine-----

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome

Envoyé : lundi 24 février 2014 14:27

À : [email-masked]<mailto:[email-masked]>

Objet : Re: [Dime] Issue#35 conclusion

Hello Ulrich,

I haven't proposed to limit this to host type OLR, I just wanted to clarify if this is what JJ got in mind.

I agree it could be done as you explained in the example below, but the open question is whether it is better to add an AVP when OLR is just meant for one single client, or on the contrary the agent _always_ need to bind OLR to one specific client, even if the server simply requires same OLR for any client.

I think having a new AVP simplifies agent behavior.

Best regards

/MCruz

-----Original Message-----

From: Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]

Sent: lunes, 24 de febrero de 2014 14:19

To: Maria Cruz Bartolome; [email-masked]<mailto:[email-masked]>

Subject: RE: [Dime] Issue#35 conclusion

Hi MCruz,

there is no reason to limit this to host type OLRs.

If we have an agent A that is configured to take the role of the reporting node for realm-type reports for realm R, A could receive host type OLRs from servers S1 and S2 (e.g. S1 requesting 10% reduction from C1 and 20% reduction from C2, S2 requesting 30% reduction from C1 and 40% reductin from C2); A then would aggregate these info and return realm type OLRs to C1 requesting 20% reduction of traffic from C1 to R, and to C2 requesting 30% reduction of traffic from C2 to R.

Best regards

Ulrich

-----Original Message-----

From: DiME [mailto:[email-masked]] On Behalf Of ext Maria Cruz Bartolome

Sent: Monday, February 24, 2014 2:02 PM

To: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] Issue#35 conclusion

Hello JJ and all,

As per email thread, the latest proposal is:

"When an agent takes the role of a reacting node, the agent needs to bind a received OLR to the origin host of the client that initiated the request which corresponds to the answer containing the OLR."

An Ulrich comments on this:

"This would cover not only the case where an agent takes the role of the reacting node on behalf of a (or several) non supporting client, but also the case where an agent is configured to take the role of a reporting node (for realm-type reports) towards the client and at the same time the role of a reacting node towards the server."

Is your proposal limited to Host-OLR, i.e. Realm OLR is excluded?

Best regards

/MCruz

-----Original Message-----

From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)

Sent: lunes, 24 de febrero de 2014 13:43

To: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] Issue#35 conclusion

Hi Mcruz and all

I think that you are  mixing the case of the DA that is the "reporting" node which wants to indicate a realm OLR to clients, and for which will use various (non standardized ) ways to determine among which it can reuse the Host-OLR AVPs received from various servers. But in this case, clients receiving realm OLRs are supporting DOIC.

Here I understand the on going  discussion is about the DA behavior when  clients is not supporting DOIC and to reuse the Host-OLR received for one client for other clients  .

For me I remain on  my previous mail, with a baseline solution. We may always study new extensions, optimizations, but priority should be on the baseline.

Best regards

Jacques

-----Message d'origine-----

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome Envoyé : lundi 24 février 2014 13:21 À : [email-masked]<mailto:[email-masked]> Objet : Re: [Dime] Issue#35 conclusion

Hello all,

Not sure we all have the same understanding here.

Let me try to explain my concerns.

The original 3GPP requirement we want to cover is the need for a server to reduce traffic for one specific client, i.e. traffic identified by "Origin-Host" in the request.

Then, two options are under analysis about whether or not the OLR in the server answer shall be marked:

a) OLR does not need to include anything else Receiver of the answer (and OLR) is the client that sends the request, identified by "Origin-Host" in the request.

Then, as long as the reacting node=="Origin-Host", the expected reduction is performed and requirement fulfilled.

But, when an agent is acting on behalf of a client as the reacting node, then the "Origin-Host" identifies final client, but not the reacting node.

Then, this is why the proposal is to add following clarification about agent behavior (possible clause 5.5):

"When an agent takes the role of a reacting node, the agent needs to bind a received OLR to the origin host of the client that initiated the request which corresponds to the answer containing the OLR."

But this will imply that _always_ the reacting node applies this OLR to one specific client, what is not what we need to achieve.

How will this impact the case where the agent is providing access to a Realm? E.g. C1 and C2 accesses RealmX (S1 + S2) via Agent1. Let's consider following example:

- C1 sends a Realm request via Agent, that finally reaches S1

- S1 answers with OLR (Host:50%).

- Agent is acting as reacting node on behalf of C1, if it considers this OLR only bind to C1... then... should it consider S1-OLR only as relevant for requests coming from C1? Should agent do not use this S1-OLR to calculate aggregated Realm overload?

In my opinion, in this case it does not make sense to consider OLR was only meant to C1. And this problem could be solved adding explicit information, as in b) below.

b) OLR needs to be extended (new AVP) that identifies the client ("Origin-Host" in the request) from which traffic reduction shall apply.

With this new AVP, reacting node will easy be able to identify when OLR shall be applied to any client or just to the Origin-Host identified by new AVP.

Let me know your opinions please

Best regards

/MCruz

-----Original Message-----

From: DiME [mailto:[email-masked]] On Behalf Of Wiehe, Ulrich (NSN - DE/Munich)

Sent: lunes, 24 de febrero de 2014 12:28

To: ext Steve Donovan; [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] Issue#35 conclusion

Steve,

please see inline.

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Steve Donovan

Sent: Friday, February 21, 2014 4:53 PM

To: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] Issue#35 conclusion

Ulrich,

I have a couple of concerns with this approach, as currently outlined.

First, how do we handle the case where there are multiple DOIC supporting agents between the non supporting client and the reporting node.  This, I guess, is a general question, not just applying to this proposal.  I suggest we capture in the agent behavior section that is currently missing wording indicating that the first supporting agent that receives the request must be the reacting node for that non-supporting client.  Subsequent DOIC supporting agents must not be the reacting node for the non-supporting client.

<Ulrich>I fully agree</Ulrich>

We need to think through the ramifications of having multiple agents being the reacting node for the same non supporting clients, as this could easily happen in networks where multiple agents are involved in a single transaction.  On the surface it doesn't seem to be an issue for the loss algorithm, but this might not be the case with other algorithms.

<Ulrich>I agree that this is not an issue for loss; it is an issue e.g. for rate (i.e. for draft-donovan-dime-doc-rate-control)</Ulrich>

My other concern is that this puts a lot of extra onus on the agent even for the case where the reporting node does not want to differentiate overload reports.

<Ulrich> I agree </Ulrich>

To this end I suggest we add an indication in the OLR marking the reports that are specific to just the Origin-Host in the request.  Absence of the "single-client-only" AVP would mean that the report applies to all clients.  Presence of the AVP would indicate that the OLR applies to the Origin-Host.

<Ulrich>I understand that the proposal is an optimization for agents. Therefore the semantics of the marking should be reverse: unmarked OLRs are client specific, marked OLRs indicate that the reporting node does not want to differentiate, and therefore allow agents not to do the binding to the client.</Ulrich>

Steve

On 2/21/14 4:48 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:

Ben,

the proposed conclusion was based on comments received so far (from Lionel, Nirav, Steve, MCruz, JJ).

Now you seem to address two points:

a) There is no dependency to DOIC support of the client.

To address this I would like to propose rewording of the clarifying text for 5.5. as follows:

When an agent takes the role of a reacting node, the agent needs to bind a received OLR to the origin host of the client that initiated the request which corresponds to the answer containing the OLR.

This would cover not only the case where an agent takes the role of the reacting node on behalf of a (or several) non supporting client, but also the case where an agent is configured to take the role of a reporting node (for realm-type reports) towards the client and at the same time the role of a reacting node towards the server.

b) There is no binding of the OLR to the orig-host of the client Here I disagree. We have the 3GPP requirement to allow requesting different amount of reduction from different clients, and I think we have 3 options:

1. ignore the 3GPP requirement

2. introduce new report types as originally proposed in #35 3. introduce the binding between OLR and orig-host of the client.

So far I understood that people favoured option 3.

See also inline.

Ulrich

-----Original Message-----

From: ext Ben Campbell [mailto:[email-masked]]

Sent: Thursday, February 20, 2014 11:55 PM

To: Wiehe, Ulrich (NSN - DE/Munich)

Cc: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] Issue#35 conclusion

On Feb 20, 2014, at 6:41 AM, Wiehe, Ulrich (NSN - DE/Munich) <[email-masked]><mailto:[email-masked]> wrote:

#35: additional report types are proposed

Dear all,

I believe we can conclude, not to add additional report types. However, we agreed to add clarifying text to clause 5.5 as follows:

When an agent received an OLR in response to a request initiated by a client not supporting DOIC, this agent needs to bind the received OLR to the origin-host of the client.

I do not agree.

You proposal implies that the server's OLR only applies to that client.

<Ulrich>exactly, that was the intention</Ulrich>  If there's an intervening DOIC agent, then the agent, not the client, is the reacting node from the server's perspective.

<Ulrich> the server's perspective is agnostic. The server does not know whether it's the client or an agent on the path that takes the role of the reacting node</Ulrich>  But, short of adding an origin-host type, nothing binds the OLR to a particular client, regardless of DOIC support at the clients.

<Ulrich> the binding is always there, regardless of DOIC support at the client</Ulrich>

 Whether or not the client also supports DOIC doesn't change that. For DOIC-supporting clients, the agent has the additional option of reducing traffic by asking the clients to reduce traffic (making them reacting nodes from the perspective of the _agent_, but not the server.)  It doesn't have that option for non-DOIC clients.

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 4 Mar 2014 15:44:20 +0000

Hello JJ,

Interesting analysis.

In relation to points 2 and 4, now we have uniqueness of Sequence Number defined as:
"The sequence number is only
   required to be unique between two overload control endpoints"

If we keep this, it means that for each endpoint (i.e. for each answer to clients B, C...) sequence number may be different, and if the answer is meant for "all-clients", then reacting node will need to read every new answer (that corresponds to a request from a different client), even if OLR is not modified. I presume this is acceptable, since default case is meant to be "one-client", what fits our endpoint definition.

About 1, I think that if we define that both "one-client" and "all-client" reports can coexist, and if so "one-client" takes precedence over "all-client" it solves the issue you highlighted.

About 3, I agree that taking into account endpoint definition, default value is "per client". I would agree on your proposal.

About 5, having new report types or new AVP, I think requires same cases to be studied. I cannot see a clear advantage of one of them over the other.

Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: martes, 04 de marzo de 2014 14:35
To: [email-masked]
Subject: Re: [Dime] Issue#35 conclusion

Hi all

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)  OLR per client

(1)  OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)  OLR per client

(1)  OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

---

From: <[email-masked]>
Date: Tue, 4 Mar 2014 17:06:50 +0000

Hi,

Can someone explain to me what would be the added-value to create two types of OLR if any reporting node can freely use one or the other?
The agent in the middle will have to expect to store OLR for specific non-supporting DOIC nodes anyway. So OK, with the new type, time to time, you will be able to optimize a little bit.
But this comes with some extra cost as you have now to manage possible interactions between two flavors of the same OLR.

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 4 mars 2014 16:44
À : TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
Objet : Re: [Dime] Issue#35 conclusion

Hello JJ,

Interesting analysis.

Best regards
/MCruz

Hi all

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)   OLR per client

(1)   OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 5 Mar 2014 07:35:36 +0000

Hi

I share the Lionel's view about the added value this optimization may  bring  versus  the extra  costs it has.  I also feel  uncomfortable when we break the  principle of the independency of the DOIC associations. When we break it, this  has  consequences (cf my mail), but in the future it may have some unexpected others.

Best regards

JJacques

De : [email-masked] [mailto:[email-masked]]
Envoyé : mardi 4 mars 2014 18:07
À : Maria Cruz Bartolome; TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
Objet : RE: [Dime] Issue#35 conclusion

Hi,

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : mardi 4 mars 2014 16:44
À : TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] Issue#35 conclusion

Hello JJ,

Interesting analysis.

Best regards
/MCruz

Hi all

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)   OLR per client

(1)   OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Wed, 05 Mar 2014 09:27:07 +0000

JJacques,

See my comments inline.

Steve

On 3/4/14 1:34 PM, TROTTIN, JEAN-JACQUES (JEAN-JACQUES) wrote:
> 1)      Besides the commented  point 3, I have a similar comment for
> point 1. I have a client A with a per client type  (0) active OLR
> having a high reduction % (90%) , then the  DA receives an OLR client
> (1) to update % for all nodes with a small % (10%). According to  rule
> 1 , client A has now  10% reduction:  this will create  a burst of
> traffic.   I assume that very soon after  it will receive  a new OLR
> type (0) with 90% but this rule is something creating transient 
> traffic  bursts in an overload situation which is not our aim. So, we
> may modify the rule 1 eg by stating  "A fresh OLR of type (1) makes
> all old type (1) OLRs  invalid and leave unchanged clients with a OLR
> type(0)". But not sure the story is finished., if later the specific
> peak vanishes and the server wants to handle client A as other nodes, 
> what does the server do? Due to my new rule, server  sending an OLR
> type (1) does not solve this point, but we would like to avoid a
> server to continue to send OLR type (0),to this client as there is no
> more specificity
>
> -          the other way is first  to use a OLR type(0) with short
> validity expiration period (and a value of 10% to align)) and to add a
> new  rule: "if an OLR(0) expires for a client, , and if an OLR type
> (1) exist for other clients, the OLR type(1) applies to this client.   
>
SRD> It doesn't need to be this complex.  The rule should be that when a
reporting node starts to use a per client report for an individual
client then the reporting node must continue to use per client reports
for the duration of the occurrence of overload.  This removes any
confusion about what the reacting node should do.
> When DA receives the first OLR type (1) with a new seq number in an
> answer to a client A , this OLR type (1) immediately applies to all
> nodes (apart those with a OLR type(0) active, cf above), taking into
> account that DA will then receives  other answers to client B, C...
> with the same OLR type (1) and the same seq number should be the same,
> as long as there is no modif brought to OLR type(1). May be also some
> text to avoid misunderstanding would be need to avoid a wrong seq
> numbr handling  Do you agree?
>
SRD> I guess I don't understand.  The type 1 report will have a sequence
number.  Each type 0 report will have its own sequence number.  As long
as those follow the defined behavior for sequence numbers then there
should be no issue.
>
>  
>
> 3)      Another point: when I consider the target network in the
> future where there are only DOIC clients, why to continue to send a
> mandatory OLR which  shall always be ignored.... I would prefer to
> have  no such OLR at all, meaning to introduce a non mandatory OLR AVP
> with a default value when no present. As in the target network, the
> Host OLR is  per client, default value would be (0). Views?
>
SRD> Again, I don't understand.  What mandatory OLR?  An OLR is only
sent when the reacting node is actually in an overload state.  It will
send no OLR when it is no longer overloaded. 
>
>  
>
> 4)      Regarding DOIC association, here we have an information (OLR
> with type (1)  exchanged inside  a DOIC association that applies to
> many DOIC associations.  It is possible but it should be highlighted .
>
SRD> What is the issue?
>
>  
>
> 5)      I also saw Mcruz had a preferencee for another OLR type and
> not a new AVP, have  we concluded on this .
>
SRD> I don't have a strong preference but adding a scope or type AVP to
the OLR AVP seems to work.
>
>  
>
> What are your views? These are not blocking points, there is always
> some solution by adding new rules. Nevertheless I am always cautious
> when a new AVP is introduced, as it always creates new combinational
> cases, that we have to analyse . So is this optimization actually
> needed. If yes, we need to add the right rules to avoid unexpected 
> situations and  misunderstanding
>
SRD> I don't see this as an optimization.  Adding per client reports is
a new feature.
>
>  
>
> Best regards
>
>  
>
> JJacques
>
>  
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Steve Donovan
> *Envoyé :* jeudi 27 février 2014 21:11
> *À :* [email-masked] <mailto:[email-masked]>
> *Objet :* Re: [Dime] Issue#35 conclusion
>
>  
>
>   3. A fresh OLR of type (0) makes an old OLR of type (1) invalid for
> the client to which the answer message is being routed.  The agent
> shall apply the OLR or type (0) for traffic from that client. The old
> OLR of type (1) continues to apply for all clients that do not have a
> "per client" overload report.
>
> I think it is important for a reporting node to be able to start with
> an "all clients" overload report and then transition to "per client"
> reports for chatty clients.
>
> Steve
>
>     certainly a valid point. I don't have a strong view but I wanted
>     to avoid the mixture to keep things simple.
>
>     *From:*DiME [mailto:[email-masked]] *On Behalf Of *ext
>     Maria Cruz Bartolome
>     *Sent:* Thursday, February 27, 2014 5:13 PM
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Dime] Issue#35 conclusion
>
>      
>
>     Dear Ulrich,
>
>      
>
>     Being:
>
>     (0)   OLR per client
>
>     (1)   OLR for all clients
>
>      
>
>     I do not think 3) is right. Why an OLR per one specific client
>     shall invalidate OLRs for rest of clients? This will imply that
>     rest of clients will not have any overload mitigation on until
>     they receive a new value of (1), or (0) for each of them.
>
>      
>
>     Best regards
>
>     /MCruz
>
>      
>
>      
>
>     *From:*DiME [mailto:[email-masked]] *On Behalf Of *Wiehe,
>     Ulrich (NSN - DE/Munich)
>     *Sent:* miércoles, 26 de febrero de 2014 12:23
>     *To:* ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
>     <mailto:[email-masked]>
>     *Subject:* Re: [Dime] Issue#35 conclusion
>
>      
>
>     Hi JJacques,
>
>      
>
>     Reporting nodes that better like A) could allways send (0) unless
>     they support the "optimization" and want to use it;
>
>     Reporting nodes that better like B) could allways send (1) unless
>     they support the "(3GPP) extension" and want to use it.
>
>     *From:*DiME [mailto:[email-masked]] *On Behalf Of *ext
>     TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
>     *Sent:* Wednesday, February 26, 2014 8:07 AM
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Dime] Issue#35 conclusion
>
>      
>
>     Hi Steve, MCruz and all
>
>      
>
>     I agree with Lionel that the OLR for a DOIC association relates to
>     this DOIC association  and the OLR can be different  for another
>     DOIC association. The basic (or "default") principle is that each
>     DOIC association has its "own life".
>
>      
>
>     Then,  a server (local policy) can decide  to send  the same OLR
>     to all its clients (so for all its DOIC associations) , or it can
>     define  particular OLR values for   certain clients.
>
>     Another  interest  is that  when the server wants to update the
>     OLR values towards  clients, it is  not obliged to send the new
>     values  simultaneously  to all the clients : it may  (local server
>     policy) progressively  change  the  value  over a certain duration
>      to minimize  sharp transitions.
>
>      
>
>     So for DOIC supporting clients, the current text allows these
>     possibilities, and in particular it satisfies the 3GGP client
>     mitigation requirement.
>
>      
>
>     A second step is to address DAs supporting non DOIC clients. Over
>     time,  we may expect that clients will be more and more DOIC
>     supporting; so, this is the main target. DAs with non DOIC client
>     would be more for   a transition (to be considered  nevertheless
>     and which may be long).
>
>      
>
>     The current text says that DA is acting on behalf of "A" client;
>     so principle  with host OLR per DOIC association also applies, and
>     there is no difference for the server, as this does not make a
>     difference  between a DOIC supporting client and a DA supporting
>     non DOIC clients.
>
>     Nevertheless, and here I come to Steve's point,   this has a cost
>     implying the DA to manage OLRs per client. Steve  introduces an
>     optimization where in fact a set of clients are considered for me
>     as a pool regarding  DOIC where only one OLR applies and where
>     throttling  applies  to the requests of this  pool of clients.  I
>     am not against to optimization process   but this pool concept is
>     new and needs some further study. First about the concept of DOIC
>     association which evolves , as now linked to a pool .
>
>      
>
>     There was a MCruz remark about sequence number, a new AVP or a
>      new report type.  I see that  we may have to review  the
>     processing of the seq number  handling as also dependent of the
>     new AVP or the OLR type; so   a "collateral " effect of the
>     optimization. I would also think that, instead of introducing a
>     single node indication in the OLR (AVP or report type) , it should
>     be a global indication as the optimization   is to support a
>     global DOIC association.  To also see if there are not other
>     collateral effects to analyze.
>
>      
>
>     Ulrich  also mentioned that for realm OLRs we may also have  a
>     different realm  OLR sent to different clients, so this is the
>     same principle as Lionel  for  a realm OLR per DOIC association,
>     on which I agree.
>
>      
>
>     The current text due to the DOIC association principle,  allows
>     this realm OLR per DOIC association for both  DOIC  supporting
>     clients and  DAs acting on behalf of A client. Then I expect Steve
>      to do the same remark, with the same reason  to have  an
>     optimization  where all clients receives  the  same realm OLR, but
>     to also see the collateral effects.
>
>      
>
>     As a conclusion, I think we should remain with the current text as
>     the baseline, following the DOIC association principle that Lionel
>     mentions, and after more investigation to assess the
>      optimization  for host and realm OLRs with DA supporting non
>     DOIC,  this optimization being optional.
>
>      
>
>     Best regards
>
>      
>
>     JJacques
>
>      
>
>     *De :*DiME [mailto:[email-masked]] *De la part de* Maria
>     Cruz Bartolome
>     *Envoyé :* mardi 25 février 2014 10:09
>     *À :* [email-masked] <mailto:[email-masked]>
>     *Objet :* Re: [Dime] Issue#35 conclusion
>
>      
>
>     Yes, I agree with Steve.
>
>      
>
>     Best regards
>
>     /MCruz
>
>      
>
>     *From:*DiME [mailto:[email-masked]] *On Behalf Of *Steve
>     Donovan
>     *Sent:* lunes, 24 de febrero de 2014 20:24
>     *To:* [email-masked] <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Dime] Issue#35 conclusion
>
>      
>
>     Lionel,
>
>     The question is whether the reporting node is sending the overload
>     report per client or it is sending a global overload report that
>     applies to all clients. 
>
>     I still believe that the default behavior of a reporting node will
>     be to have a single overload reduction value for the application
>     and that that overload reduction value will apply to all clients. 
>     If this is the case then there is little benefit (and significant
>     overhead) to requiring an agent to maintain state per
>     non-supporting client.
>
>     I also agree that there is value to the reporting node being able
>     to have a different reduction value for specific reacting nodes. 
>     If this is the case then the reporting node should indicate that
>     it only applies to the origin-host in the request and only then
>     should agents be required to maintain state for the non-supporting
>     client.
>
>     Steve
>
>         I really don't understand but it is not the first time J
>
>          
>
>         What about the DOIC association? What about my assumption
>         about agent maintaining overload control state for non-DOIC
>         enabled client?
>
>         So for me, the proposal from Ulrich is a clarification on the
>         agent behavior that was implicit if you consider the comments
>         above.
>
>          
>
>         For me, the option for the server is only to send a specific
>         OLR for a specific client. So over two different DOIC
>         association with the same server/reporting node, you can have
>         two different OLRs.
>
>         *De :*DiME [mailto:[email-masked]] *De la part de*
>         Steve Donovan
>         *Envoyé :* lundi 24 février 2014 19:50
>         *À :* [email-masked] <mailto:[email-masked]>
>         *Objet :* Re: [Dime] Issue#35 conclusion
>
>          
>
>         Maria Cruz,
>
>         To the degree possible we should minimize the per application
>         overload logic required.  To this end, it would be better to
>         have this as part of the base specification, as it is likely
>         that most/all applications will want the same behavior.
>
>         Whether a reporting node uses per Origin-Host reports is an
>         implementation detail of the reporting node.  How reacting
>         nodes respond to per Origin-Host reports should be specified
>         in a common way.
>
>         Steve
>
>             This is all in order to take into account 3GPP requirement
>             on overload mitigation differentiation per client. But
>             this is a server option:
>
>             TR 29809 ch. 6.4.7.1 states "It may be up to the
>             server/agent implementations to decide when and whether
>             overload mitigation differentiation per client is used".
>
>              
>
>             Therefore, we can even consider this new OLR out of the
>             base draft, and be considered by 3GPP applications when
>             required.
>
>              
>
>             Best regards
>
>             /MCruz
>
>              
>
>             *From:*DiME [mailto:[email-masked]] *On Behalf Of
>             *Maria Cruz Bartolome
>             *Sent:* lunes, 24 de febrero de 2014 19:19
>             *To:* [email-masked] <mailto:[email-masked]>
>             *Subject:* Re: [Dime] Issue#35 conclusion
>
>              
>
>             Steve, all,
>
>
>             I agree with Steve.
>
>              
>
>             However, I would like to share one concern. We need to
>             avoid that existing (if any) host OLR ("all-client") in
>             the reacting node is replaced by new host OLR (per client).
>
>             Host OLR (per client) with the new AVP requires that the
>             server uses a new sequence number, but existing host OLR
>             (all) shall not be replaced, on the contrary both Host OLR
>             (all) and new Host OLR (per client) should remain.
>
>             In order to achieve this, it could be more convenient to
>             use a dedicated OLR type (host per client), instead of a
>             new AVP.
>
>              
>
>             *From:*DiME [mailto:[email-masked]] *On Behalf Of
>             *Steve Donovan
>             *Sent:* lunes, 24 de febrero de 2014 16:56
>             *To:* [email-masked] <mailto:[email-masked]>
>             *Subject:* Re: [Dime] Issue#35 conclusion
>
>              
>
>             Adding an AVP to indicate that a report applies just to
>             the Origin-Host in the request is not just an optimization
>             for agents.
>
>             It had been my assumption all along that the default
>             behavior of a reporting node (server) would be to report a
>             single overload value to all reacting nodes, be they
>             clients or agents.  If this is the default behavior then
>             it would be best to have the default, implicit, meaning of
>             an overload report to be "applies to all reacting nodes". 
>             The real value of this new feature is to allow a server to
>             further throttle a specific, overly active, reacting node
>             when then global reduction percentage doesn't do the job.
>
>             In addition, if the normal case is that reporting nodes
>             have a single global reduction percentage then requiring
>             agents to bind an overload report to each non supporting
>             clients pushes a lot of extra work on agents when it adds
>             no value.
>
>             - Add an optional AVP (call it something like
>             Single-Node???) to overload reports that indicate when an
>             overload report applies to a specific reacting node.
>
>             - Absence of the AVP indicates that the report applies to
>             all reacting nodes (clients and agents acting on behalf of
>             non-DOIC clients).
>
>             - Reporting nodes should only include the Single-Node AVP
>             if the overload report contents are different from the
>             global overload report.
>
>               - For transactions from non-DOIC-supporting clients the
>             agent must apply the OLR to traffic from the set of non
>             supporting clients.   This implies that when making
>             throttling decisions, the agent does not differentiate
>             which non supporting client originated the request.
>
>             - DOIC-supporting agents receiving an OLR with the
>             Single-Node AVP for a transaction originated by a non
>             supporting client must bind that OLR to that single client.
>
>             Note that the agent behavior is currently something that
>             is missing from the -01 version of the draft.  We will
>             need something like this wording independent of the
>             resolution of this issue.
>
>             Steve
>
>                 À : [email-masked] <mailto:[email-masked]>
>
>                 To: Maria Cruz Bartolome; [email-masked] <mailto:[email-masked]>
>
>                 To: [email-masked] <mailto:[email-masked]>
>
>                 To: [email-masked] <mailto:[email-masked]>
>
>                 De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome Envoyé : lundi 24 février 2014 13:21 À : [email-masked] <mailto:[email-masked]> Objet : Re: [Dime] Issue#35 conclusion
>
>                  
>
>                 Hello all,
>
>                  
>
>                 To: ext Steve Donovan; [email-masked] <mailto:[email-masked]>
>
>                 To: [email-masked] <mailto:[email-masked]>
>
>                 Cc: [email-masked] <mailto:[email-masked]>
>
>                 On Feb 20, 2014, at 6:41 AM, Wiehe, Ulrich (NSN - DE/Munich) <[email-masked]> <mailto:[email-masked]> wrote:
>
>                  
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>             [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>
> [email-masked]

---

From: Steve Donovan <[email-masked]>
Date: Wed, 05 Mar 2014 09:30:29 +0000

Hi,

Well, first, the new functionality being proposed is to allow the loss
reports to apply to a single client. 

The use of global (type 1) reports will generally be most of the time,
as it is likely that a reporting node will send the same overload level
to all clients the vast majority of the time.  And, while there will
clearly be a transition period when there are both supporting and non
supporting reacting nodes that will require special agent processing,
this will reasonably quickly stabilize into all reacting nodes
supporting DOIC. 

Changing the meaning of the loss report to be per client forces agents
into tracking overload state per client 100% of the time.  That is not
an insignificant impact.

Next, the interaction between per client and global report types is
trivially simple -- use the more specific version received.

And finally, I don't understand JJacques point about breaking the
principle of independency of the DOIC associations. 

Steve

On 3/5/14 7:35 AM, TROTTIN, JEAN-JACQUES (JEAN-JACQUES) wrote:
>
> Hi
>
>  
>
> I share the Lionel's view about the added value this optimization may 
> bring  versus  the extra  costs it has.  I also feel  uncomfortable
> when we break the  principle of the independency of the DOIC
> associations. When we break it, this  has  consequences (cf my mail),
> but in the future it may have some unexpected others.
>
>  
>
> Best regards
>
>  
>
> JJacques
>
>  
>
>  
>
> *De :[email-masked] [mailto:[email-masked]]
> *Envoyé :* mardi 4 mars 2014 18:07
> *À :* Maria Cruz Bartolome; TROTTIN, JEAN-JACQUES (JEAN-JACQUES);
> [email-masked]
> *Objet :* RE: [Dime] Issue#35 conclusion
>
>  
>
> Hi,
>
>  
>
> Can someone explain to me what would be the added-value to create two
> types of OLR if any reporting node can freely use one or the other?
>
> The agent in the middle will have to expect to store OLR for specific
> non-supporting DOIC nodes anyway. So OK, with the new type, time to
> time, you will be able to optimize a little bit.
>
> But this comes with some extra cost as you have now to manage possible
> interactions between two flavors of the same OLR.
>
>  
>
> Regards,
>
>  
>
> Lionel
>
>  
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Maria Cruz
> Bartolome
> *Envoyé :* mardi 4 mars 2014 16:44
> *À :* TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]
> <mailto:[email-masked]>
> If we keep this, it means that for each endpoint (i.e. for each answer
> to clients B, C...) sequence number may be different, and if the
> answer is meant for "all-clients", then reacting node will need to
> read every new answer (that corresponds to a request from a different
> client), even if OLR is not modified. I presume this is acceptable,
> since default case is meant to be "one-client", what fits our endpoint
> definition.
>
>  
>
> About 1, I think that if we define that both "one-client" and
> "all-client" reports can coexist, and if so "one-client" takes
> precedence over "all-client" it solves the issue you highlighted.
>
>  
>
> About 3, I agree that taking into account endpoint definition, default
> value is "per client". I would agree on your proposal.
>
>  
>
> About 5, having new report types or new AVP, I think requires same
> cases to be studied. I cannot see a clear advantage of one of them
> over the other.
>
>  
>
> Best regards
>
> /MCruz
>
>  
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *TROTTIN,
> JEAN-JACQUES (JEAN-JACQUES)
> *Sent:* martes, 04 de marzo de 2014 14:35

---

From: <[email-masked]>
Date: Wed, 5 Mar 2014 16:08:28 +0000

Clarification: I'm not changing the meaning from global OLR to per client OLR.
I'm just saying that we can live without in the base solution. The reporting node is sending an OLR in response to the request. End of story.

Lionel

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : mercredi 5 mars 2014 10:30
À : [email-masked]
Objet : Re: [Dime] Issue#35 conclusion

Hi,

Well, first, the new functionality being proposed is to allow the loss reports to apply to a single client.

The use of global (type 1) reports will generally be most of the time, as it is likely that a reporting node will send the same overload level to all clients the vast majority of the time.  And, while there will clearly be a transition period when there are both supporting and non supporting reacting nodes that will require special agent processing, this will reasonably quickly stabilize into all reacting nodes supporting DOIC.

Changing the meaning of the loss report to be per client forces agents into tracking overload state per client 100% of the time.  That is not an insignificant impact.

Next, the interaction between per client and global report types is trivially simple -- use the more specific version received.

And finally, I don't understand JJacques point about breaking the principle of independency of the DOIC associations.

Steve

Best regards

JJacques

De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Envoyé : mardi 4 mars 2014 18:07
À : Maria Cruz Bartolome; TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]<mailto:[email-masked]>
Objet : RE: [Dime] Issue#35 conclusion

Hi,

Regards,

Lionel

Hello JJ,

Interesting analysis.

Best regards
/MCruz

Hi all

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)   OLR per client

(1)   OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

Thank you.

DiME mailing list

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 5 Mar 2014 20:16:48 +0000

Hi Steve and all
See my comments in line
Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : mercredi 5 mars 2014 10:27
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] Issue#35 conclusion

JJacques,

See my comments inline.

Steve

-          the other way is first  to use a OLR type(0) with short validity expiration period (and a value of 10% to align)) and to add a new  rule: "if an OLR(0) expires for a client, , and if an OLR type (1) exist for other clients, the OLR type(1) applies to this client.
SRD> It doesn't need to be this complex.  The rule should be that when a reporting node starts to use a per client report for an individual client then the reporting node must continue to use per client reports for the duration of the occurrence of overload.  This removes any confusion about what the reacting node should do. Then for ypur suggestion,

JJacques > I started from the assumption OLR applying to "all nodes", in fact the rule should  be to "all nodes" except those having an  OLR of type (0) active.  Then we can effectively use the rule you mentionned:  "when a reporting node starts to use a per client report for an individual client then the reporting node must continue to use per client reports for the duration of the occurrence of overload". So the introduction of the AVP generates two rules .

2)      A clarification if I have the right understanding
When DA receives the first OLR type (1) with a new seq number in an answer to a client A , this OLR type (1) immediately applies to all nodes (apart those with a OLR type(0) active, cf above), taking into account that DA will then receives  other answers to client B, C... with the same OLR type (1) and the same seq number should be the same, as long as there is no modif brought to OLR type(1). May be also some text to avoid misunderstanding would be need to avoid a wrong seq numbr handling  Do you agree?
SRD> I guess I don't understand.  The type 1 report will have a sequence number.  Each type 0 report will have its own sequence number.  As long as those follow the defined behavior for sequence numbers then there should be no issue.

JJacques> my point is to clarify if we have a  seq number per DOIC association, or one seq number common to all nodes, according the single or all node AVP value(except nodes with a type (0) active). It also  has  an impact on the expiry timer  that  will have the same value  for all nodes (except nodes with a type (0) active). To note this may create simultaneous traffic bursts at timer expiration.  If decision to introduce all node case, it would ay require clarification text.

3)      Another point: when I consider the target network in the future where there are only DOIC clients, why to continue to send a mandatory OLR which  shall always be ignored.... I would prefer to have  no such OLR at all, meaning to introduce a non mandatory OLR AVP with a default value when no present. As in the target network, the Host OLR is  per client, default value would be (0). Views?
SRD> Again, I don't understand.  What mandatory OLR?  An OLR is only sent when the reacting node is actually in an overload state.  It will send no OLR when it is no longer overloaded.

JJacques> sorry for the wording error, I was addressing  the new AVP (single, All node) in the OLR, please replace "OLR" by "new AVP in the OLR". This new AVP was described  as mandatory in the proposal, so raising my comment

4)      Regarding DOIC association, here we have an information (OLR with type (1)  exchanged inside  a DOIC association that applies to many DOIC associations.  It is possible but it should be highlighted .
SRD> What is the issue?
JJacques> I do not say that the All node approach does not work, I only draw some consequences. On point 4 the principle to have independent DOIC associations was for me a good principle. With the all node introduction, we have some common handling to all DOIC associations  (except those with a type (0) active OLR), atshould be highlighted.

5)      I also saw Mcruz had a preferencee for another OLR type and not a new AVP, have  we concluded on this .
SRD> I don't have a strong preference but adding a scope or type AVP to the OLR AVP seems to work.

What are your views? These are not blocking points, there is always some solution by adding new rules. Nevertheless I am always cautious when a new AVP is introduced, as it always creates new combinational cases, that we have to analyse . So is this optimization actually needed. If yes, we need to add the right rules to avoid unexpected  situations and  misunderstanding
SRD> I don't see this as an optimization.  Adding per client reports is a new feature.
JJacques> If we do not introduce the new AVP, the solution works. Then by introducing  this new AVP it allows the DA acting on behalf of all the non supporting DOIC clients, to have a more simple processing in the DA by doing a  global  throttling applied to all the requests of these nodes. So  this is an optimization of the solution without the new AVP and is optional.

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)   OLR per client

(1)   OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

DiME mailing list

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 5 Mar 2014 20:09:50 +0000

Hi Steve and all
See my comments in line
Best regards

JJacques

JJacques,

See my comments inline.

Steve

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)   OLR per client

(1)   OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Wed, 5 Mar 2014 22:01:30 +0000

Choose and move on.... It is not that difficult

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: Wednesday, March 05, 2014 4:30 AM
To: [email-masked]
Subject: Re: [Dime] Issue#35 conclusion

Hi,

Steve

Best regards

JJacques

Hi,

Regards,

Lionel

Hello JJ,

Interesting analysis.

Best regards
/MCruz

Hi all

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)   OLR per client

(1)   OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)   OLR per client

(1)   OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

Thank you.

DiME mailing list

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 6 Mar 2014 07:57:26 +0000

Dear all,

This mail thread started proposing new OLR reports to request reduction for one specific client.
However, the discussion clarified that as it is the draft today, Host-report is sent from a reporting node towards the client from where it receives the request. Then, reduction is requested per client in all cases already.
There is one special case here, when the agent is acting on behalf of the client (i.e. for a non-supporting client or for an agent SFE with topology hiding). In this case, the reporting node sends host-report to agent. Here we have two options:

a)     We expect the agent to apply the host-report received in an answer to specifically the client that sent the corresponding request

This requires some extra complexity at agent side.

But here we have one more option: allow the reporting node to choose whether it prefers to apply this host-report to "all-client" vs "one-client". That increases again the complexity (at reporting node, protocol-wise, and at agent).

b)     We expect the agent to apply this host-report to any client that is sending a request towards this agent

In my opinion, this is the best approach, it reduces complexity and increases robustness.

Therefore, I will be in favor of option b), which does not require any changes to the actual draft.

From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: miércoles, 05 de marzo de 2014 21:10
To: [email-masked]
Subject: Re: [Dime] Issue#35 conclusion

Hi Steve and all
See my comments in line
Best regards

JJacques

JJacques,

See my comments inline.

Steve

Best regards

JJacques

Steve

Best regards
Ulrich

Dear Ulrich,

Being:

(0)  OLR per client

(1)  OLR for all clients

Best regards
/MCruz

Hi JJacques,

(0)  OLR per client

(1)  OLR for all clients

Ulrich

Hi Steve, MCruz and all

Best regards

JJacques

Yes, I agree with Steve.

Best regards
/MCruz

Lionel,

Steve

Lionel

Maria Cruz,

Steve

Best regards

/MCruz

Steve, all,

I agree with Steve.

Steve

Is it implicit?

Regards,

Lionel

-----Message d'origine-----

Hello Ulrich,

Best regards

/MCruz

-----Original Message-----

Hi MCruz,

Best regards

Ulrich

-----Original Message-----

Hello JJ and all,

Best regards

/MCruz

-----Original Message-----

Hi Mcruz and all

Best regards

Jacques

-----Message d'origine-----

Hello all,

Best regards

/MCruz

-----Original Message-----

Steve,

please see inline.

Ulrich

Ulrich,

Steve

Ben,

See also inline.

Ulrich

-----Original Message-----

Dear all,

I do not agree.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

---

From: <[email-masked]>
Date: Thu, 6 Mar 2014 08:11:45 +0000

I agree on the approach proposed below.

About the "any change to the actual draft", I think that draft needs anyway to reflect this clarification on the agent behavior :)

Lionel

De : DiME [mailto:[email-masked]] De la part de Maria Cruz Bartolome
Envoyé : jeudi 6 mars 2014 08:57
À : [email-masked]
Objet : Re: [Dime] Issue#35 conclusion

Dear all,