Subject: [Dime] Tentative agreements from DIME meeting in IETF #89

From: Steve Donovan <[email-masked]>
Date: Sat, 08 Mar 2014 11:09:06 +0000

All,

The following were tentative agreements reached during the meeting in
London.

-----

Overload report types:

Agreed - Support two report types -- host as currently defined (requests
with a destination-host AVP) and realm (all requests). 

Proposal - Remove Realm-Routed-Request (requests without a
destination-host) report type.  Still an open issue.

Need to define the interaction between host and realm report types.

---

Client specific reports:

Agreed - Remove explicit ability of reporting node to send client
specific reports.  It was agreed that this feature should be treated as
a new report type that needs to be addressed as a separate extension.

---

OC-Supported-Features handling:

Agreed: OC-Supported-Features AVP MUST be included in all answer
messages (we had already agreed that it must be included in all request
messages).
Agreed: Reacting node advertises all supported algorithms;
Agreed: Reporting node responds with the single algorithm it will be using;
Agreed: Handling of other feature bits is defined in the extension drafts

---

OC-OLR handling:

Agreed: Single OC-OLR AVP used by all abatement algorithms with the
meaning of the overload report indicated in the OC-Supported-Features AVP.
Agreed: Put text in the draft to recommend that algorithms should not be
changed on the fly.

Regards,

Steve

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Sat, 8 Mar 2014 11:34:15 +0000

Hello Steve,

See comments below
Thanks for the updates and summary
Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: sábado, 08 de marzo de 2014 12:09
To: [email-masked]
Subject: [Dime] Tentative agreements from DIME meeting in IETF #89

All,

The following were tentative agreements reached during the meeting in London.

-----

Overload report types:

Agreed - Support two report types -- host as currently defined (requests with a destination-host AVP) and realm (all requests).

Proposal - Remove Realm-Routed-Request (requests without a destination-host) report type.  Still an open issue.

---

Client specific reports:

Agreed - Remove explicit ability of reporting node to send client specific reports.  It was agreed that this feature should be treated as a new report type that needs to be addressed as a separate extension.
[MCruz] It was pre-agreed that it could be considered as an extension. In my opinion, we do not reach an agreement on the way to do it, we simply presented what has already been discussed in the list till this moment.
---

Agreed: OC-Supported-Features AVP MUST be included in all answer messages (we had already agreed that it must be included in all request messages).
Agreed: Reacting node advertises all supported algorithms;
Agreed: Reporting node responds with the single algorithm it will be using;
Agreed: Handling of other feature bits is defined in the extension drafts

---

OC-OLR handling:

Agreed: Single OC-OLR AVP used by all abatement algorithms with the meaning of the overload report indicated in the OC-Supported-Features AVP.
Agreed: Put text in the draft to recommend that algorithms should not be changed on the fly.

Regards,

Steve

---

From: Steve Donovan <[email-masked]>
Date: Mon, 17 Mar 2014 12:25:31 -0500

Maria Cruz,

Please see comments inline.

Steve

On 3/8/14 5:34 AM, Maria Cruz Bartolome wrote:
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *Steve Donovan
> *Sent:* sábado, 08 de marzo de 2014 12:09
> *To:* [email-masked]
> *Subject:* [Dime] Tentative agreements from DIME meeting in IETF #89
>
>  
>
> All,
>
> Agreed - Support two report types -- host as currently defined
> (requests with a destination-host AVP) and realm (all requests). 
>
> specific reports.  It was agreed that this feature should be treated
> as a new report type that needs to be addressed as a separate extension.
> [MCruz] It was pre-agreed that it could be considered as an extension.
> In my opinion, we do not reach an agreement on the way to do it, we
> simply presented what has already been discussed in the list till this
> moment.
>
srd> I agree that we did not discuss the actual mechanism as suggested
above.  The last sentence should be "It was agreed that this feature
should be addressed in a separate extension to DOIC.
> messages (we had already agreed that it must be included in all
> request messages).