Subject: [Dime] DOIC Default Algorithm Specification

From: Ben Campbell <[email-masked]>
Date: Mon, 17 Mar 2014 13:18:55 -0500

Hi,

In re-reading dime-ovli, I noticed that the procedures for the "default" abatement algorithm are spread through several parts of the text. That's going to make life difficult down the road for a couple of reasons:

1) There's no easily referenced section that fully defines the algorithm. That will be a problem for other docs that want to talk about the algorithm (e.g. 3GPP specs), or even other sections in dime-ovli that want to mention the default algorithm by reference.

2) It makes extensibility harder, as it will be more difficult to define new algorithms, if they need to modify behavior that is spread throughout dime-ovli, rather than simply supersede a specific section of dime-ovli.

I propose that we move all algorithm-specific behavior to its own section, and have any other sections that need to talk about the default algorithm reference that section rather than attempt to describe the behavior.

Thanks!

Ben.

---

From: Jouni Korhonen <[email-masked]>
Date: Sat, 22 Mar 2014 01:46:12 +0800

> I propose that we move all algorithm-specific behavior to its own section, and have any other sections that need to talk about the default algorithm reference that section rather than attempt to de…

That would work for me.

- Jouni

> 
> Thanks!
> 
> Ben.
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Tue, 25 Mar 2014 09:02:34 +0000

Hi

I agree with Ben to differentiate general statements which are algorithm independent from the ones particular to the default algorithm, otherwise it may be a source of ambiguities/ misinterpretations . Now is this statement grouping into a referenced section easy? I do not know. I hope this will not have a too large impact on the draft.

Best regards

JJacques 

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Jouni Korhonen
Envoyé : vendredi 21 mars 2014 18:46
À : Ben Campbell
Cc : [email-masked] list
Objet : Re: [Dime] DOIC Default Algorithm Specification

That would work for me.

- Jouni

---

From: Steve Donovan <[email-masked]>
Date: Tue, 25 Mar 2014 07:10:02 -0500

JJ,

I agree, when we do this, we will try to minimize impact to the draft, 
but there will be changes in the overall structure.  It will definitely 
be done in a way that does not change any of the normative requirements 
in the draft.

This will likely be the primary focus of the -03 version of the draft.

Regards,

Steve

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 25 Mar 2014 15:56:08 +0000

Agreed

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: martes, 25 de marzo de 2014 13:10
To: [email-masked]
Subject: Re: [Dime] DOIC Default Algorithm Specification

JJ,

Regards,

Steve