Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

From: Steve Donovan <[email-masked]>
Date: Tue, 18 Mar 2014 11:47:15 -0500

All,

Do we have consensus that the OC-Report-Type AVP is required?

If so then one change would be as indicated in the syntax definition
proposed by Lionel.  We would also remove wording on the default value.

Jouni,

How do we indicate a fixed position for an AVP? 

I presonally don't see this as critical but we can add this requirement
if there is consensus.

Regards,

Steve

On 2/28/14 10:27 AM, Jouni Korhonen wrote:
> Hi,
>
> How having the AVP could be less error prone if it has a default
> value and the receiver knows exactly how to proceed when the AVP
> is not present?
>
> If a node does not include it when it should, the implementation
> is broken. Wouldn't a broken node be able to put wrong report
> type into the AVP even if the AVP is mandatory?
>
> Anyway, if it is my statement keeping issue #54 still open, consider
> it resolved from my side. I am OK making the OC-Report-Type AVP as
> required/mandatory AVP. Should we also consider it having a fixed
> position just after the OC-Sequence-Number AVP as well since it is
> going to in every OC-OLR?
>
> - Jouni
>
>
>
> On Feb 21, 2014, at 11:47 AM, Maria Cruz Bartolome <[email-masked]> wrote:
>
>> Hello all,
>>
>> I understand JJ point of view, but I still tend to prefer to make it mandatory, since I think this is less error-prone, since the only node that knows the requested Report-Type is the reporting, if for any reason a reporting is omitting it (since it is optional), it will be always interpreted as HOST, but this type may be wrong.
>>
>> I think DEFAULT values should never be error-prone, but used in "general cases", as a simplification, like e.g. a default for the Validity-Duration. Default Validity-Duration will never be an "error", it could be not the best value (compared with another value perfectly tuned to reporting node overload situation) but never the use of a Default value should lead to an erroneous behavior.
>>
>> Best regards
>> /MCruz
>>
>> -----Original Message-----
>> From: DiME [mailto:[email-masked]] On Behalf Of Ben Campbell
>> Sent: viernes, 14 de febrero de 2014 23:13
>> To: Jouni Korhonen
>> Cc: [email-masked]
>> Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP
>>
>> I actually prefer making it mandatory. The cost of adding it is trivial--even more so for a reporting node that only supports the default. The value of having it is less opportunity for interop errors.
>>
>> On Feb 13, 2014, at 6:05 AM, Jouni Korhonen <[email-masked]> wrote:
>>
>>> Agree that it is a small optimization, which I put there because at 
>>> the beginning there seemed to be a lot of worry on every extra AVP ;-)
>>>
>>> I prefer having the AVP optional but with a default value just like it 
>>> is now. We have the same for the reduction percentage and the validity 
>>> time as well.
>>>
>>> - Jouni
>>>
>>> On Feb 13, 2014, at 10:55 AM, "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]> wrote:
>>>
>>>> Hi Mcruz
>>>>
>>>> The current description indicates that when not present the OLR is of type Host, which was fine for me and keeps my preference. 
>>>> We may have  deployments where Realm OLR is not used, or where statistically the HOST type is the most frequent, so to have the grouped OLR-AVP containing a minimum of AVPs minimizes parsing. I agree it is a small optimization.
>>>>
>>>> Best regards
>>>>
>>>> JJacques
>>>>
>>>>
>>>>
>>>>
>>>> -----Message d'origine-----
>>>> De : DiME [mailto:[email-masked]] De la part de 
>>>> [email-masked] Envoyé : mercredi 12 février 2014 15:46 À : 
>>>> [email-masked]; [email-masked] Objet : Re: [Dime] 
>>>> [dime] #54: OC-Report-Type as mandatory AVP
>>>>
>>>> Hi Maria Cruz,
>>>>
>>>> I'm assuming that you mean "required" instead of "mandatory", right?
>>>>
>>>> So instead of:
>>>>
>>>> OC-OLR ::= < AVP Header: TBD2 >
>>>>            < OC-Sequence-Number >
>>>>            [ OC-Report-Type ]
>>>>            [ OC-Reduction-Percentage ]
>>>>            [ OC-Validity-Duration ]
>>>>          * [ AVP ]
>>>>
>>>> You would prefer:
>>>>
>>>> OC-OLR ::= < AVP Header: TBD2 >
>>>>            < OC-Sequence-Number >
>>>>            { OC-Report-Type }
>>>>            [ OC-Reduction-Percentage ]
>>>>            [ OC-Validity-Duration ]
>>>>          * [ AVP ]
>>>>
>>>> And I'm fine with this proposal.
>>>>
>>>> Cheers,
>>>>
>>>> Lionel
>>>>
>>>> -----Message d'origine-----
>>>> De : DiME [mailto:[email-masked]] De la part de dime issue 
>>>> tracker Envoyé : mercredi 12 février 2014 15:26 À : 
>>>> [email-masked] Cc : [email-masked] Objet : [Dime] 
>>>> [dime] #54: OC-Report-Type as mandatory AVP
>>>>
>>>> #54: OC-Report-Type as mandatory AVP
>>>>
>>>> Now in chapter 4.6:
>>>>
>>>>  The default value of the OC-Report-Type AVP is 0 (i.e. the host
>>>>  report).
>>>>
>>>> This AVP is always required, right? Then, I think it is more precise that  we define this AVP as mandatory.
>>>>
>>>> --
>>>> -----------------------------------------------+---------------------
>>>> -----------------------------------------------+---
>>>> -----------------------------------------------+---
>>>> Reporter:  [email-masked]  |      Owner:  MCruz
>>>>   Type:  defect                             |  Bartolomé
>>>> Priority:  major                              |     Status:  new
>>>> Component:  draft-docdt-dime-ovli              |  Milestone:
>>>> Severity:  Active WG Document                 |    Version:  1.0
>>>>                                             |   Keywords:
>>>> -----------------------------------------------+---------------------
>>>> -----------------------------------------------+---
>>>> -----------------------------------------------+---
>>>>
>>>> Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/54>
>>>> dime <http://tools.ietf.org/wg/dime/>
>>>>
>>>> _______________________________________________
>>>> DiME mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/dime
>>>>
>>>> _____________________________________________________________________
>>>> ____________________________________________________
>>>>
>>>> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>>>>
>>>> This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
>>>> If you have received this email in error, please notify the sender and delete this message and its attachments.
>>>> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
>>>> Thank you.
>>>>
>>>> _______________________________________________
>>>> DiME mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/dime
>>>> _______________________________________________
>>>> DiME mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/dime
>>> _______________________________________________
>>> DiME mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dime
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dime
>>
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dime
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Tue, 18 Mar 2014 17:16:27 +0000

Hello,
I think the agreement tendency is the contrary: OC-Report-Type is not required, while default value is Host. i.e. it will remain as it is now in the draft.
This may be of some advantage for some applications that may only use Host, as long as they may never generate Realm reports.
If there is consensus on this, I will go with this.
Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: martes, 18 de marzo de 2014 17:47
To: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

All,

If so then one change would be as indicated in the syntax definition proposed by Lionel.  We would also remove wording on the default value.

Jouni,

I presonally don't see this as critical but we can add this requirement if there is consensus.

Regards,

Steve

Hi,

is not present?

- Jouni

On Feb 21, 2014, at 11:47 AM, Maria Cruz Bartolome <[email-masked]><mailto:[email-masked]> wrote:

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

Cc: [email-masked]<mailto:[email-masked]>

On Feb 13, 2014, at 6:05 AM, Jouni Korhonen <[email-masked]><mailto:[email-masked]> wrote:

time as well.

- Jouni

On Feb 13, 2014, at 10:55 AM, "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]><mailto:[email-masked]> wrote:

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

[email-masked]<mailto:[email-masked]> Envoyé : mercredi 12 février 2014 15:46 À :

[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]> Objet : Re: [Dime]

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

[email-masked]<mailto:[email-masked]> Cc : [email-masked]<mailto:[email-masked]> Objet : [Dime]

Now in chapter 4.6:

 report).

--

Reporter:  [email-masked]<mailto:[email-masked]>  |      Owner:  MCruz

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/54><http://trac.tools.ietf.org/wg/dime/trac/ticket/54>

dime <http://tools.ietf.org/wg/dime/><http://tools.ietf.org/wg/dime/>

DiME mailing list

[email-masked]<mailto:[email-masked]>

Thank you.

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

DiME mailing list

[email-masked]<mailto:[email-masked]>

---

From: Steve Donovan <[email-masked]>
Date: Tue, 18 Mar 2014 12:29:40 -0500

I'm ok with either direction but generally lean toward being explicit.

Do we have other opinions? 

Steve
On 3/18/14 12:16 PM, Maria Cruz Bartolome wrote:
>
> Hello,
>
> I think the agreement tendency is the contrary: OC-Report-Type is not
> required, while default value is Host. i.e. it will remain as it is
> now in the draft.
>
> This may be of some advantage for some applications that may only use
> Host, as long as they may never generate Realm reports.
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *Steve Donovan
> *Sent:* martes, 18 de marzo de 2014 17:47
> *To:* [email-masked]
> *Subject:* Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP
>
>  
>
> All,
>
>     On Feb 21, 2014, at 11:47 AM, Maria Cruz Bartolome <[email-masked]> <mailto:[email-masked]> wrote:
>
>      
>
>          
>
>         Hello all,
>
>          
>
>         Cc: [email-masked] <mailto:[email-masked]>
>
>         On Feb 13, 2014, at 6:05 AM, Jouni Korhonen <[email-masked]> <mailto:[email-masked]> wrote:
>
>          
>
>              
>
>             On Feb 13, 2014, at 10:55 AM, "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]> <mailto:[email-masked]> wrote:
>
>              
>
>                 Hi Mcruz
>
>                  
>
>                 [email-masked] <mailto:[email-masked]> Envoyé : mercredi 12 février 2014 15:46 À : 
>
>                 [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]> Objet : Re: [Dime] 
>
>                 [email-masked] <mailto:[email-masked]> Cc : [email-masked] <mailto:[email-masked]> Objet : [Dime] 
>
>                 Reporter:  [email-masked] <mailto:[email-masked]>  |      Owner:  MCruz
>
>                   Type:  defect                             |  Bartolomé
>
>                 Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/54> <http://trac.tools.ietf.org/wg/dime/trac/ticket/54>
>
>                 dime <http://tools.ietf.org/wg/dime/> <http://tools.ietf.org/wg/dime/>
>
>                  
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>                 [email-masked] <mailto:[email-masked]>
>
>             [email-masked] <mailto:[email-masked]>
>
>         [email-masked] <mailto:[email-masked]>
>
>         [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Jouni Korhonen <[email-masked]>
Date: Sat, 22 Mar 2014 10:38:19 +0800

Lets have it explicit then. Use '<' and '>' to make the position
fixed.

- Jouni

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Mon, 24 Mar 2014 03:56:28 +0000

Hello all,

I totally agree with MCruz. For some applications or deployments, the OC-Report-Type is not required at all, I don't see the benefit to always have such an AVP in those cases.

Best Regards,
Susan

From: Maria Cruz Bartolome [mailto:[email-masked]]
Sent: Wednesday, March 19, 2014 1:16 AM
To: Steve Donovan; [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello,

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: martes, 18 de marzo de 2014 17:47
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

All,

Jouni,

Regards,

Steve

Hi,

is not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

 report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Mon, 24 Mar 2014 03:59:51 +0000

Hello Jouni,

I assume we had a lot of discussion on this and reached consensus to keep it as it is in the draft. 

Best Regards,
Susan

-----Original Message-----
From: Jouni Korhonen [mailto:[email-masked]] 
Sent: Saturday, March 22, 2014 10:38 AM
To: Steve Donovan
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Lets have it explicit then. Use '<' and '>' to make the position fixed.

- Jouni

On Mar 19, 2014, at 1:29 AM, Steve Donovan <[email-masked]> wrote:

>> value and the receiver knows exactly how to proceed when the AVP is 
>> not present?
>>  
>> If a node does not include it when it should, the implementation is 
>> broken. Wouldn't a broken node be able to put wrong report type into 
>> the AVP even if the AVP is mandatory?
>>  
>> I prefer having the AVP optional but with a default value just like 
>> it is now. We have the same for the reduction percentage and the 
>> validity time as well.
>>  
>> - Jouni
>>

---

From: Steve Donovan <[email-masked]>
Date: Mon, 24 Mar 2014 07:25:42 -0500

Susan,

We are in the middle of the discussion and have not yet reached consensus.

I agree with Jouni on making it explicit.  Either way, we should try to
make a decision quickly.

Steve

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Mon, 24 Mar 2014 13:51:31 +0000

Hi all

I am also in line with the agreement tendency as that OC-Report-Type is not required (so to keep the text as it is in the draft); I expressed this  preference a while ago.

Best regards

JJacques

________________________________
De : DiME [[email-masked]] de la part de Steve Donovan [[email-masked]]
Date d'envoi : lundi 24 mars 2014 13:25
À : Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]
Objet : Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Susan,

I agree with Jouni on making it explicit.  Either way, we should try to make a decision quickly.

Steve

Hello Jouni,

Best Regards,
Susan

-----Original Message-----
From: Jouni Korhonen [mailto:[email-masked]]
Sent: Saturday, March 22, 2014 10:38 AM
To: Steve Donovan
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

- Jouni

On Mar 19, 2014, at 1:29 AM, Steve Donovan <[email-masked]><mailto:[email-masked]> wrote:

Steve

Hello,

All,

Jouni,

Regards,

Steve

Hi,

- Jouni

Hello all,

Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: viernes, 14 de febrero de 2014 23:13
To: Jouni Korhonen
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Agree that it is a small optimization, which I put there because at
the beginning there seemed to be a lot of worry on every extra AVP
;-)

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

You would prefer:

Cheers,

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de dime issue
tracker Envoyé : mercredi 12 février 2014 15:26 À :

Now in chapter 4.6:

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 24 Mar 2014 16:30:17 +0000

+1

From: DiME [mailto:[email-masked]] On Behalf Of ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: Monday, March 24, 2014 2:52 PM
To: Steve Donovan; Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi all

Best regards

JJacques

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

---

From: <[email-masked]>
Date: Mon, 24 Mar 2014 16:51:02 +0000

IMHO it is a lot of fuse for something not so critical!
Session-id is for no use at all in a lot of Diameter applications and no one complains :)

Here it is even simpler: there is a clear use of this AVP. This info (the explicit AVP or the default value) needs to be taken into account in the process of the received OLR and any compliant implementation needs to be able to understand the OLR-Report-Type.
So except "optimization", what is the rational not to make it required in the OLR?

Lionel

De : DiME [mailto:[email-masked]] De la part de Wiehe, Ulrich (NSN - DE/Munich)
Envoyé : lundi 24 mars 2014 17:30
À : ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); Steve Donovan; Shishufeng (Susan); Jouni Korhonen
Cc : [email-masked]
Objet : Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

+1

Hi all

Best regards

JJacques

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Mon, 24 Mar 2014 13:42:38 -0500

I agree.  We need to find a way to stop circling around many of these
issues or we will never get the document finished.

In my opinion, focusing on trivial optimizations is not where we should
be spending our time.  However, if people think it is that important to
be able to not include the report-type AVP in some of the messages then
by all means, let's make it optional, with a default of host, and let's
move on to issues that matter.

Steve

On 3/24/14 11:51 AM, [email-masked] wrote:
> Session-id is for no use at all in a lot of Diameter applications and
> no one complains J
>
>  
>
> Here it is even simpler: there is a clear use of this AVP. This info
> (the explicit AVP or the default value) needs to be taken into account
> in the process of the received OLR and any compliant implementation
> needs to be able to understand the OLR-Report-Type.
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Wiehe,
> Ulrich (NSN - DE/Munich)
> *Envoyé :* lundi 24 mars 2014 17:30
> *À :* ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); Steve Donovan;
> Shishufeng (Susan); Jouni Korhonen
> *Cc :* [email-masked]
> *Objet :* Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP
>
>  
>
> +1
>
>  
>
> *From:*DiME [mailto:[email-masked]] *On Behalf Of *ext TROTTIN,
> JEAN-JACQUES (JEAN-JACQUES)
> *Sent:* Monday, March 24, 2014 2:52 PM
> *To:* Steve Donovan; Shishufeng (Susan); Jouni Korhonen
> *Cc:* [email-masked]
> I am also in line with the agreement tendency as that OC-Report-Type
> is not required (so to keep the text as it is in the draft); I
> expressed this  preference a while ago.
>
>  
>
>  
>
> Best regards
>
>  
>
> JJacques
>
>  
>
> ------------------------------------------------------------------------
>
> *De :*DiME [[email-masked]] de la part de Steve Donovan
> [[email-masked]]
> *Date d'envoi :* lundi 24 mars 2014 13:25
> *À :* Shishufeng (Susan); Jouni Korhonen
> *Cc:* [email-masked] <mailto:[email-masked]>
> *Objet :* Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP
>
> Susan,
>
>     On Mar 19, 2014, at 1:29 AM, Steve Donovan <[email-masked]> <mailto:[email-masked]> wrote:
>
>      
>
>             To: [email-masked] <mailto:[email-masked]>
>

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Tue, 25 Mar 2014 07:00:06 +0000

Hi Steve,

As I know, majority companies expressed preference to keep the AVP as optional and keep the texts as they are. You have preference to have it explicitly but ok with either way. That's how I assumed we reached consensus.

Best Regards,
Susan

From: Steve Donovan [mailto:[email-masked]]
Sent: Monday, March 24, 2014 8:26 PM
To: Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Tue, 25 Mar 2014 07:05:01 +0000

Hello Lionel,

That's because we have no chance to change the situation with Session-id, which is already there for many years. This does not mean it is correct. :)

As I clarified many times, OLR-Report-Type is not useful for some Diameter applications or deployment, this could justify its optionality.

If everyone can live with the texts as they are, maybe we can close the discussion on it and move on.

Best Regards,
Susan

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, March 25, 2014 12:51 AM
To: Wiehe, Ulrich (NSN - DE/Munich); ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES); Steve Donovan; Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]
Subject: RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Lionel

Cc : [email-masked]<mailto:[email-masked]>

+1

Hi all

Best regards

JJacques

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Tue, 25 Mar 2014 07:38:37 -0500

Susan,

We have not been following a process of determining consensus based on a 
majority of companies expressing a preference.  It is also the case 
that, in the IETF, companies do not contribute, individuals contribute.

In addition, if we did take a "vote" on this one, I'm not sure which 
side would actually have a majority.

We might need to change our process to speed things up, but right now we 
have been striving for true consensus where everyone agrees. Note that 
this doesn't mean everyone agrees with the technical reasoning behind 
the decision.  There have been many cases where agreement is reached 
because it was more important to get something finished then to win a 
technical argument.

If we can't start moving a little faster then we will likely need to 
change to rough consensus, where the measure is that most everyone 
agrees.  However, in the IETF, even this is not a voting process. If 
things are close to 50-50 in opinions then the correct process is to 
continue to discuss the technical merits of each alternative until rough 
consensus is reached.

Regards,

Steve

On 3/25/14, 2:00 AM, Shishufeng (Susan) wrote:
>
> Hi Steve,
>
> As I know, majority companies expressed preference to keep the AVP as 
> optional and keep the texts as they are. You have preference to have 
> it explicitly but ok with either way. That's how I assumed we reached 
> consensus.
>
> Best Regards,
>
> Susan
>
> *From:*Steve Donovan [mailto:[email-masked]]
> *Sent:* Monday, March 24, 2014 8:26 PM
> *To:* Shishufeng (Susan); Jouni Korhonen
> *Cc:* [email-masked]
>     Cc:[email-masked]  <mailto:[email-masked]>
>
>     On Mar 19, 2014, at 1:29 AM, Steve Donovan<[email-masked]>  <mailto:[email-masked]>  wrote:
>
>       
>
>             To:[email-masked]  <mailto:[email-masked]>
>
>             On Feb 21, 2014, at 11:47 AM, Maria Cruz Bartolome<[email-masked]>  <mailto:[email-masked]>  wrote:
>
>               
>
>               
>
>             Hello all,
>
>               
>
>             Cc:[email-masked]  <mailto:[email-masked]>
>
>             On Feb 13, 2014, at 6:05 AM, Jouni Korhonen<[email-masked]>  <mailto:[email-masked]>  wrote:
>
>               
>
>               
>
>             On Feb 13, 2014, at 10:55 AM, "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)"<[email-masked]>  <mailto:[email-masked]>  wrote:
>
>               
>
>             Hi Mcruz
>
>               
>
>             [email-masked]  <mailto:[email-masked]>;[email-masked]  <mailto:[email-masked]>  Objet : Re: [Dime]
>
>             [email-masked]  <mailto:[email-masked]>  Cc :[email-masked]  <mailto:[email-masked]>  Objet : [Dime]
>
>             Reporter:[email-masked]  <mailto:[email-masked]>   |      Owner:  MCruz
>
>                Type:  defect                             |  Bartolomé
>
>             Ticket URL:<http://trac.tools.ietf.org/wg/dime/trac/ticket/54>  <http://trac.tools.ietf.org/wg/dime/trac/ticket/54>
>
>             dime<http://tools.ietf.org/wg/dime/>  <http://tools.ietf.org/wg/dime/>
>
>               
>

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Wed, 26 Mar 2014 04:13:40 +0000

Hello Steve,

Thanks for clarifying the IETF procedure. I'm not familiar with it, while I know the draft is mainly for 3GPP use, that's why we 3GPP delegates are deeply involved in this specific discussion. If most of 3GPP people think it is not so needed I couldn't understand why it shall be mandatory.

>From technical point of view, in the case realm based report type is not needed, nothing wrong without this AVP, and even better and cleaner.

And you ever said you have preference but ok with either way forward, i.e., make it mandatory or optional. Then let's move on with the draft as it is on this point, if you agree.

Best Regards,
Susan

From: Steve Donovan [mailto:[email-masked]]
Sent: Tuesday, March 25, 2014 8:39 PM
To: Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Susan,

We have not been following a process of determining consensus based on a majority of companies expressing a preference.  It is also the case that, in the IETF, companies do not contribute, individuals contribute.

In addition, if we did take a "vote" on this one, I'm not sure which side would actually have a majority.

We might need to change our process to speed things up, but right now we have been striving for true consensus where everyone agrees.  Note that this doesn't mean everyone agrees with the technical reasoning behind the decision.  There have been many cases where agreement is reached because it was more important to get something finished then to win a technical argument.

If we can't start moving a little faster then we will likely need to change to rough consensus, where the measure is that most everyone agrees.  However, in the IETF, even this is not a voting process.  If things are close to 50-50 in opinions then the correct process is to continue to discuss the technical merits of each alternative until rough consensus is reached.

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

---

From: <[email-masked]>
Date: Wed, 26 Mar 2014 06:43:46 +0000

As chair and temporary doc shepherd,

Please stop this thread for now.

As mandatory/required is ok for everyone (even if useless in certain case), let use it for now.

Lionel

"Shishufeng (Susan)" <[email-masked]> a écrit :

Hello Steve,

Thanks for clarifying the IETF procedure. I’m not familiar with it, while I know the draft is mainly for 3GPP use, that’s why we 3GPP delegates are deeply involved in this specific discussion. If most of 3GPP people think it is not so needed I couldn’t understand why it shall be mandatory.

>From technical point of view, in the case realm based report type is not needed, nothing wrong without this AVP, and even better and cleaner.

And you ever said you have preference but ok with either way forward, i.e., make it mandatory or optional. Then let’s move on with the draft as it is on this point, if you agree.

Best Regards,
Susan

Susan,

Regards,

Steve

As I know, majority companies expressed preference to keep the AVP as optional and keep the texts as they are. You have preference to have it explicitly but ok with either way. That’s how I assumed we reached consensus.

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Wed, 26 Mar 2014 06:55:31 +0000

Hello Lionel,

I don't understand it.

Please clarify if you care about other people's comments.

Best Regards,
Susan

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 2:44 PM
To: Steve Donovan; Jouni Korhonen; Shishufeng (Susan)
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Lionel

"Shishufeng (Susan)" <[email-masked]<mailto:[email-masked]>> a écrit :

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Wed, 26 Mar 2014 07:05:39 +0000

Hello Lionel,

Further clarification:

I don't agree with this, not ok to everyone as you said.

Best Regards,
Susan

From: Shishufeng (Susan) [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 2:56 PM
To: [email-masked]; Steve Donovan; Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

I don't understand it.

Best Regards,
Susan

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: <[email-masked]>
Date: Wed, 26 Mar 2014 07:35:18 +0000

Hi Susan,

I do care about comments from other but we need to move on.

My decision is based on the following: from a technical point of view, there is no issue if we define this AVP as required. From a protocol aspect, it is cleaner as a report ALWAYS applies to a given type. Default value was considered as sub-optimal by Jouni, Ben, Steve, Maria Cruz (who has triggered this issue) and myself.

Now, about the process, a 100% is not required to move forward. As it is not possible to get consensus on this issue, I use my prerogative to pick one solution, the one that seems to be the best solution at this stage, to be able to close the discussion at this stage and produce the draft that we need.

After, it is always possible to challenge again the content of the draft if there is still concern.

Benoit, the Area Director, is copied. It is not a putsch. Just administrative way agreed within IETF to be able to move forward a WG draft, which is the ultimate goal of everyone I think.

Regards,

Lionel.

De : Shishufeng (Susan) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 08:06
À : Shishufeng (Susan); MORAND Lionel IMT/OLN; Steve Donovan; Jouni Korhonen
Cc : [email-masked]
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Wed, 26 Mar 2014 08:03:34 +0000

Hello Lionel,

Thanks for your reply.

It is clear that majority companies involved in the discussion prefer to not have this AVP as mandatory. And Steve is ok with it as it is, and thus everyone is ok with it as optional. I'm wondering why you choose another way forward, and don't take opinion from majority companies into account, which is strange for me.

We talked much about it, and in some major cases, this AVP is useless. If needed, anyway an optional AVP has to be present, I don't see any problem with it. We did a lot like this in 3GPP spec. I don't understand how in this case it shall be mandatory if you also agree that it is not needed in some cases.

Best Regards,
Susan

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 3:35 PM
To: Shishufeng (Susan); Steve Donovan; Jouni Korhonen
Cc: [email-masked]; Benoit Claise
Subject: RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

To: [email-masked]<mailto:[email-masked]>; Steve Donovan; Jouni Korhonen

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Wed, 26 Mar 2014 08:31:35 +0000

Hi Susan,

Except your point of view that I respect, I haven't read anyone saying that they cannot accept to rely on a required AVP. And it is not yet confirmed that the AVP will be useless for 3GPP application. S6a does not represent the whole use cases in 3GPP and at least two operators think that they will use the concept of Realm-based report in their own network.
And even from your side, I understand that you consider useless in some cases this AVP but you don't really challenge the fact that the presence of this AVP in any report would cause an issue.

Based on this status, my preferred approach is the one proposed below.

Now, if there is strong concern about this AVP we can revert this decision but:
1/ there is no reason not to accept this working assumption
2/ moving back this AVP from required to optional will not fundamentally impact the solution.

Regards,

Lionel

De : Shishufeng (Susan) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 09:04
À : MORAND Lionel IMT/OLN; Steve Donovan; Jouni Korhonen
Cc : [email-masked]; Benoit Claise
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Wed, 26 Mar 2014 08:54:31 +0000

Hi Lionel,

You didn't answer me why you decide to propose a way not preferred by majority companies. I have strong concern on it. And for the 2/, we are not reverting anything, it is optional in the existing draft from the beginning.

Thanks if we can conclude on this issue and move on.

Best Regards,
Susan

Sent: Wednesday, March 26, 2014 4:32 PM

Hi Susan,

Regards,

Lionel

Cc : [email-masked]<mailto:[email-masked]>; Benoit Claise

Hello Lionel,

Thanks for your reply.

Best Regards,
Susan

Cc: [email-masked]<mailto:[email-masked]>; Benoit Claise

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Wed, 26 Mar 2014 09:19:12 +0000

Hi Susan,

I answered. You are not yet appointed as spokeswoman of the "majority of the companies" :)
And my comment is only based on what I have seen on the reflector.

Regards,

Lionel

Envoyé : mercredi 26 mars 2014 09:55

Hi Lionel,

Best Regards,
Susan

Hi Susan,

Regards,

Lionel

Hello Lionel,

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Wed, 26 Mar 2014 07:20:30 -0500

I disagree that the majority of individuals (companies don't apply here)
have a preference.  We have not established the view of a majority.

If we took a vote of individuals on this, I would vote for making it
explicit. 

I also support Lionel being able to make a decision.  We all need to be
flexible enough to accept that decision, especially when there is no
technical reason to disagree with the decision.

Steve

On 3/26/14 3:03 AM, Shishufeng (Susan) wrote:
>
> Hello Lionel,
>
>  
>
> Thanks for your reply.
>
>  
>
> It is clear that majority companies involved in the discussion prefer
> to not have this AVP as mandatory. And Steve is ok with it as it is,
> and thus everyone is ok with it as optional. I'm wondering why you
> choose another way forward, and don't take opinion from majority
> companies into account, which is strange for me.
>
>  
>
> We talked much about it, and in some major cases, this AVP is useless.
> If needed, anyway an optional AVP has to be present, I don't see any
> problem with it. We did a lot like this in 3GPP spec. I don't
> understand how in this case it shall be mandatory if you also agree
> that it is not needed in some cases.
>
>  
>
> Best Regards,
>
> Susan
>
>  
>
>  
>
> *From:[email-masked] [mailto:[email-masked]]
> *Sent:* Wednesday, March 26, 2014 3:35 PM
> *To:* Shishufeng (Susan); Steve Donovan; Jouni Korhonen
> *Cc:* [email-masked]; Benoit Claise
> *Subject:* RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP
>
>  
>
> Hi Susan,
>
>  
>
> My decision is based on the following: from a technical point of view,
> there is no issue if we define this AVP as required. From a protocol
> aspect, it is cleaner as a report ALWAYS applies to a given type.
> Default value was considered as sub-optimal by Jouni, Ben, Steve,
> Maria Cruz (who has triggered this issue) and myself.
>
>  
>
> Now, about the process, a 100% is not required to move forward. As it
> is not possible to get consensus on this issue, I use my prerogative
> to pick one solution, the one that seems to be the best solution at
> this stage, to be able to close the discussion at this stage and
> produce the draft that we need.
>
>  
>
> Benoit, the Area Director, is copied. It is not a putsch. Just
> administrative way agreed within IETF to be able to move forward a WG
> draft, which is the ultimate goal of everyone I think.
>
>  
>
> Regards,
>
>  
>
> Lionel.
>
>  
>
> *De :*Shishufeng (Susan) [mailto:[email-masked]]
> *Envoyé :* mercredi 26 mars 2014 08:06
> *À :* Shishufeng (Susan); MORAND Lionel IMT/OLN; Steve Donovan; Jouni
> Korhonen
> *Cc :* [email-masked] <mailto:[email-masked]>
> *Objet :* RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP
>
>  
>
> Hello Lionel,
>
>  
>
> Further clarification:
>
>  
>
> *From:*Shishufeng (Susan) [mailto:[email-masked]]
> *Sent:* Wednesday, March 26, 2014 2:56 PM
> *To:* [email-masked] <mailto:[email-masked]>;
> Steve Donovan; Jouni Korhonen
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]]
> *Sent:* Wednesday, March 26, 2014 2:44 PM
> *To:* Steve Donovan; Jouni Korhonen; Shishufeng (Susan)
> "Shishufeng (Susan)" <[email-masked] <mailto:[email-masked]>> a écrit :
>  
>
> Hello Steve,
>
>  
>
> Thanks for clarifying the IETF procedure. I'm not familiar with it,
> while I know the draft is mainly for 3GPP use, that's why we 3GPP
> delegates are deeply involved in this specific discussion. If most of
> 3GPP people think it is not so needed I couldn't understand why it
> shall be mandatory.
>
>  
>
> From technical point of view, in the case realm based report type is
> not needed, nothing wrong without this AVP, and even better and cleaner.
>
>  
>
> And you ever said you have preference but ok with either way forward,
> i.e., make it mandatory or optional. Then let's move on with the draft
> as it is on this point, if you agree.
>
>  
>
> Best Regards,
>
> Susan
>
>  
>
> *Sent:* Tuesday, March 25, 2014 8:39 PM
> We have not been following a process of determining consensus based on
> a majority of companies expressing a preference.  It is also the case
> We might need to change our process to speed things up, but right now
> we have been striving for true consensus where everyone agrees.  Note
> that this doesn't mean everyone agrees with the technical reasoning
> behind the decision.  There have been many cases where agreement is
> reached because it was more important to get something finished then
> to win a technical argument.
>
> continue to discuss the technical merits of each alternative until
> rough consensus is reached.
>
> Regards,
>
> Steve
>
>     As I know, majority companies expressed preference to keep the AVP
>     as optional and keep the texts as they are. You have preference to
>     have it explicitly but ok with either way. That's how I assumed we
>     reached consensus.
>
>      
>
>     Best Regards,
>
>     Susan
>
>      
>

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Wed, 26 Mar 2014 12:53:27 +0000

Hello Steve,

Ok, let's come back with technical discussion then.

-          First a not always needed AVP cannot justify why it shall be mandatory.

-          Secondly, in my view, having a not always needed AVP as mandatory cannot be less error prone. On the contrary, it would introduce more error cases. RFC 6733 defines a couple of error codes e.g. DIAMETER_MISSING_AVP 5005, DIAMETER_INVALID_AVP_VALUE 5004 and maybe others to deal with the possible error cases. All the handling with this AVP consumes the resource of both reporting nodes and reacting nodes. I don't see any benefit to have it.

Best Regards,
Susan

From: Steve Donovan [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 8:21 PM
To: Shishufeng (Susan); [email-masked]; Jouni Korhonen
Cc: [email-masked]; Benoit Claise
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

I disagree that the majority of individuals (companies don't apply here) have a preference.  We have not established the view of a majority.

If we took a vote of individuals on this, I would vote for making it explicit.

I also support Lionel being able to make a decision.  We all need to be flexible enough to accept that decision, especially when there is no technical reason to disagree with the decision.

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Wed, 26 Mar 2014 13:50:25 +0000

Hi,

Because it was not possible to make everyone happy, I made a decision. I think that this decision is valid and will not block anything.
To be fair, I think that the majority could accept both while few have a strong preference for optional or mandatory.  And I picked one.
Can we please discuss about something else or is it the most critical point to solve? I think that everyone is waiting for a version 02 before the end of this week.

Regards,

Lionel

De : Shishufeng (Susan) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 13:53
À : Steve Donovan; MORAND Lionel IMT/OLN; Jouni Korhonen
Cc : [email-masked]; Benoit Claise
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Thu, 27 Mar 2014 06:37:34 +0000

Hi Lionel,

If you cares, please clarify how this decision was made based on the newly ongoing technical discussion. I really don't understand a useless AVP in most cases has to be mandatory.

May I ask why not define every optional AVP as mandatory if the only point you made decision was that it will not block anything?

Best Regards,
Susan

Sent: Wednesday, March 26, 2014 9:50 PM

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

To: Shishufeng (Susan); [email-masked]<mailto:[email-masked]>; Jouni Korhonen

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Thu, 27 Mar 2014 09:31:15 +0000

Hi Susan,

In this specific case, the info carried by the AVP is not optional. You need this info in the algorithm as it will modify the behavior of the reacting node.
The current solution is to define a default value when not received.

I believe that at the protocol level, having this AVP in every request is cleaner than relying on default value when not present. The initial goal for such default value was to limit the number of AVPs transmitted over the interfaces. And I think that it is not so relevant according to the output of the other discussions and such optimization is not deemed required anymore.

Moreover, the default value today would be likely "Host" but this is only based on current working assumptions for some 3GPP interfaces. When used in some networks, Realm is perfectly valid as default value if the system is designed for that. I think that AT&T and Verizon have clearly expressed their requirements for that.

This reasoning leads to change the existing for Grouped AVP from:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

I would like to clarify that this discussion is totally independent of the M-bit setting of the AVP.

And about why not put the other AVPs as required in the Grouped AVP, it is because it is abvious that the other ones are linked to the reduction algo defined in this document. For other algos, you could find other AVPs (relying on the extensibility of this Grouped AVP) instead.

Let me know if the clarification is useful.

Regards,

Lionel

Envoyé : jeudi 27 mars 2014 07:38

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Thu, 27 Mar 2014 10:32:27 +0000

Hi Susan,

Please see below.

Lionel

Envoyé : jeudi 27 mars 2014 11:04

Hello Lionel,

-          I'm not talking the specific optional AVPs defined in this draft, but others e.g. defined in 3GPP specifications. We have a lot optional AVPs with default values.
[LM] in 3GPP there are introduced in existing applications and usually in commands. There is no other options to include them are purely optional.

-           my understanding, some cases an AVP is needed, some cases it is not needed, that's the key point to justify its optionality.
[LM] I agree that we don't have the same understanding here.

-          Apart from the benefit of less AVPs and less error cases with this AVP as optional, another key point is that the server(host) will never care about the AVP at all. It will never need to remember to put such an AVP into the message. Only agent needs to add such an AVP in case putting into realm report, this would make things much simpler from my point of view.
[LM] that is wrong to say "never". A server can have realm-based information that can be provided to reacting nodes. It is only depending of the server implementation and environment. For instance, if a realm is entirely dedicated to a type of server, a farm based implementation would provide such functionality, as discussed.

Further, the discussion on Realm is still ongoing and whether it can work well is still under investigation.
[LM] I think that the ongoing discussion is too tight to specific use cases, important ones for 3GPP I admit. However the whole goal of this work is to have something that it will work in any case. If there are some requirements for realm-based info, I don't see a specific reason to restrict the use of report type. And don't forget that new report types can be created in the future. So it is not restricted to Host vs realm.

The benefit to have it as optional is clear, and this would not bring any harm. I hope this can be reconsidered.
[LM] let see if there are other voice that could not accept the proposed approach.

Best Regards,
Susan

Sent: Thursday, March 27, 2014 5:31 PM

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Thu, 27 Mar 2014 10:03:51 +0000

Hello Lionel,

Best Regards,
Susan

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

---

From: "Shishufeng (Susan)" <[email-masked]>
Date: Thu, 27 Mar 2014 11:37:51 +0000

Hello Lionel,

Please see below.

Best Regards,
Susan

Sent: Thursday, March 27, 2014 6:32 PM

Hi Susan,

Please see below.

Lionel

Hello Lionel,

-          I'm not talking the specific optional AVPs defined in this draft, but others e.g. defined in 3GPP specifications. We have a lot optional AVPs with default values.
[LM] in 3GPP there are introduced in existing applications and usually in commands. There is no other options to include them are purely optional.
Susan: Not exactly, we have lots of optional AVPs from the first release.

-          Apart from the benefit of less AVPs and less error cases with this AVP as optional, another key point is that the server(host) will never care about the AVP at all. It will never need to remember to put such an AVP into the message. Only agent needs to add such an AVP in case putting into realm report, this would make things much simpler from my point of view.
[LM] that is wrong to say "never". A server can have realm-based information that can be provided to reacting nodes. It is only depending of the server implementation and environment. For instance, if a realm is entirely dedicated to a type of server, a farm based implementation would provide such functionality, as discussed.
Susan: In this case the server behaves more like an agent, not a pure server, i.e. the server provides agent functionality. In IETF, server and agent has clear difference.

Further, the discussion on Realm is still ongoing and whether it can work well is still under investigation.
[LM] I think that the ongoing discussion is too tight to specific use cases, important ones for 3GPP I admit. However the whole goal of this work is to have something that it will work in any case. If there are some requirements for realm-based info, I don't see a specific reason to restrict the use of report type. And don't forget that new report types can be created in the future. So it is not restricted to Host vs realm.
Susan: May I ask what's wrong with this not always needed AVP as optional?

The benefit to have it as optional is clear, and this would not bring any harm. I hope this can be reconsidered.
[LM] let see if there are other voice that could not accept the proposed approach.
Susan: Ok, but to be fair, maybe we can also ask who could not accept this AVP as optional. As I know, Steve could live with it as optional.

Best Regards,
Susan

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Thu, 27 Mar 2014 12:14:56 +0000

More than OK with your last statement.

De : Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Envoyé : jeudi 27 mars 2014 12:53
À : ext Shishufeng (Susan); MORAND Lionel IMT/OLN; Steve Donovan; Jouni Korhonen
Cc : [email-masked]
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

I can accept both (though I have a slight preference in favour of Susan).
Actually I think this is a so minor minor minor issue that it  could serve as a very good opportunity for people to show their willingness to give in, in order to make progress.

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Shishufeng (Susan)
Sent: Thursday, March 27, 2014 12:38 PM
To: [email-masked]; Steve Donovan; Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

Please see below.

Best Regards,
Susan

Hi Susan,

Please see below.

Lionel

Hello Lionel,

Best Regards,
Susan

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 27 Mar 2014 11:52:56 +0000

Ulrich

Hello Lionel,

Please see below.

Best Regards,
Susan

Hi Susan,

Please see below.

Lionel

Hello Lionel,

Best Regards,
Susan

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Thu, 27 Mar 2014 14:35:24 +0000

Hi

I refer to my yesterday previous mail.
People have expressed

-          A preference. On my side,  I have a preference for the existing text with  non mandatory  AVP. But I can accept the mandatory AVP as I already said

-          Or a strong concern in favor of one solution, this is the case of Susan. I asked if there were voice who have a strong concern  in favor of the mandatory AVP .  There were was no answer up to now  and I am not aware of voice with a strong concern  in favor of the mandatory .

Best regards

JJacques

À : ext Shishufeng (Susan); [email-masked]<mailto:[email-masked]>; Steve Donovan; Jouni Korhonen

Ulrich

Hello Lionel,

Please see below.

Best Regards,
Susan

Hi Susan,

Please see below.

Lionel

Hello Lionel,

Best Regards,
Susan

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Thu, 27 Mar 2014 14:26:09 +0000

Hi

-          Or a strong concern in favor of one solution, this is the case of Susan. I asked if there were voice who have a strong concern  in favor of the mandatory AVP .  There were was no answer and I am not aware of voice with a strong concern  in favor of the mandatory .

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Wiehe, Ulrich (NSN - DE/Munich)
Envoyé : jeudi 27 mars 2014 12:53
À : ext Shishufeng (Susan); [email-masked]; Steve Donovan; Jouni Korhonen
Cc : [email-masked]
Objet : Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Ulrich

Hello Lionel,

Please see below.

Best Regards,
Susan

Hi Susan,

Please see below.

Lionel

Hello Lionel,

Best Regards,
Susan

Hi Susan,

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]
To:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi,

Regards,

Lionel

Hello Steve,

Best Regards,
Susan

Steve

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.

---

From: David Mitton <[email-masked]>
Date: Thu, 27 Mar 2014 23:25:34 -0400

This is the second day with over a dozen messages over 100KB.
I thought this was going to be avoided.

Someone keeps generating HTML recaps the whole thread, which is  
redundant, and some how mostly white space.  Can we stop this?

Dave.