Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 26 Mar 2014 11:17:13 +0000

Hi

We had an initial   discussion when writing the  01 draft which  resulted in a non mandatory  AVP and a default value.
Then a ticket was produced to propose a mandatory AVP ; the author has a full right to produce such a ticket

People have then indicated their preference, and we were several (including me)  in favor to keep the draft  as it is, and some other expressed their preference for a mandatory AVP.
What is a bit surprising is how   the working assumption has moved from non mandatory AVP to mandatory AVP?

I also agree that a decision should be taken now on this topic, but  could it not be those who have a preference for the mandatory AVP, to finally say that the existing text  is acceptable or do they have a so strong concern to not keep the existing wording draft (I am not aware of such a concern), as Suzan has to keep the existing wording.

Best regards

JJacques

De : [email-masked] [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 11:07
À : Wiehe, Ulrich (NSN - DE/Munich); Maria Cruz Bartolome; TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

I think that you could say that you are OK with the working assumption for now.
But you are right. Let see if Susan will react again :)

Lionel

De : Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 11:04
À : MORAND Lionel IMT/OLN; Maria Cruz Bartolome; ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

I did so on 24.03.2014 17:30
Should I do again? (ignoring your request to stop the thread)

From: ext [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 10:57 AM
To: Wiehe, Ulrich (NSN - DE/Munich); Maria Cruz Bartolome; ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Subject: RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Thank you for your answer.

Please use the wg mailing list to express your view on this issue.

Lionel

De : Wiehe, Ulrich (NSN - DE/Munich) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 10:50
À : MORAND Lionel IMT/OLN; Maria Cruz Bartolome; ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Lionel,

I have a slight preference in favour of Susan's proposal (as indicated in the mail sent on 24.03.2014 17:30) but can accept your proposal.

I'm in favour of stopping this thread as you requested.

Best regards
Ulrich

From: ext [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 10:40 AM
To: Maria Cruz Bartolome; Wiehe, Ulrich (NSN - DE/Munich); ext TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Subject: RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi,

I don't want to block anyone but we need to move forward at least for publication of the v02.

If you can accept my proposal, please say it.
If you cannot accept the proposed working assumption, please say it. And if it is, please indicate what would be the technical issue that would cause implementation problem.

But don't let Susan speaking on behalf of you.

Regards,

lionel

De : DiME [mailto:[email-masked]] De la part de [email-masked]<mailto:[email-masked]>
Envoyé : mercredi 26 mars 2014 10:19
À : Shishufeng (Susan); Steve Donovan; Jouni Korhonen
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Susan,

I answered. You are not yet appointed as spokeswoman of the "majority of the companies" :)
And my comment is only based on what I have seen on the reflector.

Regards,

Lionel

De : Shishufeng (Susan) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 09:55
À : MORAND Lionel IMT/OLN; Steve Donovan; Jouni Korhonen
Cc : [email-masked]<mailto:[email-masked]>; Benoit Claise
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Lionel,

You didn't answer me why you decide to propose a way not preferred by majority companies. I have strong concern on it. And for the 2/, we are not reverting anything, it is optional in the existing draft from the beginning.

Thanks if we can conclude on this issue and move on.

Best Regards,
Susan

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 4:32 PM
To: Shishufeng (Susan); Steve Donovan; Jouni Korhonen
Cc: [email-masked]<mailto:[email-masked]>; Benoit Claise
Subject: RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Susan,

Except your point of view that I respect, I haven't read anyone saying that they cannot accept to rely on a required AVP. And it is not yet confirmed that the AVP will be useless for 3GPP application. S6a does not represent the whole use cases in 3GPP and at least two operators think that they will use the concept of Realm-based report in their own network.
And even from your side, I understand that you consider useless in some cases this AVP but you don't really challenge the fact that the presence of this AVP in any report would cause an issue.

Based on this status, my preferred approach is the one proposed below.

Now, if there is strong concern about this AVP we can revert this decision but:
1/ there is no reason not to accept this working assumption
2/ moving back this AVP from required to optional will not fundamentally impact the solution.

Regards,

Lionel

De : Shishufeng (Susan) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 09:04
À : MORAND Lionel IMT/OLN; Steve Donovan; Jouni Korhonen
Cc : [email-masked]<mailto:[email-masked]>; Benoit Claise
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

Thanks for your reply.

It is clear that majority companies involved in the discussion prefer to not have this AVP as mandatory. And Steve is ok with it as it is, and thus everyone is ok with it as optional. I'm wondering why you choose another way forward, and don't take opinion from majority companies into account, which is strange for me.

We talked much about it, and in some major cases, this AVP is useless. If needed, anyway an optional AVP has to be present, I don't see any problem with it. We did a lot like this in 3GPP spec. I don't understand how in this case it shall be mandatory if you also agree that it is not needed in some cases.

Best Regards,
Susan

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 3:35 PM
To: Shishufeng (Susan); Steve Donovan; Jouni Korhonen
Cc: [email-masked]<mailto:[email-masked]>; Benoit Claise
Subject: RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi Susan,

I do care about comments from other but we need to move on.

My decision is based on the following: from a technical point of view, there is no issue if we define this AVP as required. From a protocol aspect, it is cleaner as a report ALWAYS applies to a given type. Default value was considered as sub-optimal by Jouni, Ben, Steve, Maria Cruz (who has triggered this issue) and myself.

Now, about the process, a 100% is not required to move forward. As it is not possible to get consensus on this issue, I use my prerogative to pick one solution, the one that seems to be the best solution at this stage, to be able to close the discussion at this stage and produce the draft that we need.

After, it is always possible to challenge again the content of the draft if there is still concern.

Benoit, the Area Director, is copied. It is not a putsch. Just administrative way agreed within IETF to be able to move forward a WG draft, which is the ultimate goal of everyone I think.

Regards,

Lionel.

De : Shishufeng (Susan) [mailto:[email-masked]]
Envoyé : mercredi 26 mars 2014 08:06
À : Shishufeng (Susan); MORAND Lionel IMT/OLN; Steve Donovan; Jouni Korhonen
Cc : [email-masked]<mailto:[email-masked]>
Objet : RE: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

Further clarification:

I don't agree with this, not ok to everyone as you said.

Best Regards,
Susan

From: Shishufeng (Susan) [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 2:56 PM
To: [email-masked]<mailto:[email-masked]>; Steve Donovan; Jouni Korhonen
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hello Lionel,

I don't understand it.

Please clarify if you care about other people's comments.

Best Regards,
Susan

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, March 26, 2014 2:44 PM
To: Steve Donovan; Jouni Korhonen; Shishufeng (Susan)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

As chair and temporary doc shepherd,

Please stop this thread for now.

As mandatory/required is ok for everyone (even if useless in certain case), let use it for now.

Lionel

"Shishufeng (Susan)" <[email-masked]<mailto:[email-masked]>> a écrit :

Hello Steve,

Thanks for clarifying the IETF procedure. I'm not familiar with it, while I know the draft is mainly for 3GPP use, that's why we 3GPP delegates are deeply involved in this specific discussion. If most of 3GPP people think it is not so needed I couldn't understand why it shall be mandatory.

>From technical point of view, in the case realm based report type is not needed, nothing wrong without this AVP, and even better and cleaner.

And you ever said you have preference but ok with either way forward, i.e., make it mandatory or optional. Then let's move on with the draft as it is on this point, if you agree.

Best Regards,
Susan

From: Steve Donovan [mailto:[email-masked]]
Sent: Tuesday, March 25, 2014 8:39 PM
To: Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Susan,

We have not been following a process of determining consensus based on a majority of companies expressing a preference.  It is also the case that, in the IETF, companies do not contribute, individuals contribute.

In addition, if we did take a "vote" on this one, I'm not sure which side would actually have a majority.

We might need to change our process to speed things up, but right now we have been striving for true consensus where everyone agrees.  Note that this doesn't mean everyone agrees with the technical reasoning behind the decision.  There have been many cases where agreement is reached because it was more important to get something finished then to win a technical argument.

If we can't start moving a little faster then we will likely need to change to rough consensus, where the measure is that most everyone agrees.  However, in the IETF, even this is not a voting process.  If things are close to 50-50 in opinions then the correct process is to continue to discuss the technical merits of each alternative until rough consensus is reached.

Regards,

Steve
On 3/25/14, 2:00 AM, Shishufeng (Susan) wrote:
Hi Steve,

As I know, majority companies expressed preference to keep the AVP as optional and keep the texts as they are. You have preference to have it explicitly but ok with either way. That's how I assumed we reached consensus.

Best Regards,
Susan

From: Steve Donovan [mailto:[email-masked]]
Sent: Monday, March 24, 2014 8:26 PM
To: Shishufeng (Susan); Jouni Korhonen
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Susan,

We are in the middle of the discussion and have not yet reached consensus.

I agree with Jouni on making it explicit.  Either way, we should try to make a decision quickly.

Steve
On 3/23/14 10:59 PM, Shishufeng (Susan) wrote:

Hello Jouni,

I assume we had a lot of discussion on this and reached consensus to keep it as it is in the draft.

Best Regards,

Susan

-----Original Message-----

From: Jouni Korhonen [mailto:[email-masked]]

Sent: Saturday, March 22, 2014 10:38 AM

To: Steve Donovan

Cc: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Lets have it explicit then. Use '<' and '>' to make the position fixed.

- Jouni

On Mar 19, 2014, at 1:29 AM, Steve Donovan <[email-masked]><mailto:[email-masked]> wrote:

I'm ok with either direction but generally lean toward being explicit.

Do we have other opinions?

Steve

On 3/18/14 12:16 PM, Maria Cruz Bartolome wrote:

Hello,

I think the agreement tendency is the contrary: OC-Report-Type is not required, while default value is Host. i.e. it will remain as it is now in the draft.

This may be of some advantage for some applications that may only use Host, as long as they may never generate Realm reports.

If there is consensus on this, I will go with this.

Best regards

/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan

Sent: martes, 18 de marzo de 2014 17:47

To: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

All,

Do we have consensus that the OC-Report-Type AVP is required?

If so then one change would be as indicated in the syntax definition proposed by Lionel.  We would also remove wording on the default value.

Jouni,

How do we indicate a fixed position for an AVP?

I presonally don't see this as critical but we can add this requirement if there is consensus.

Regards,

Steve

On 2/28/14 10:27 AM, Jouni Korhonen wrote:

Hi,

How having the AVP could be less error prone if it has a default

value and the receiver knows exactly how to proceed when the AVP is

not present?

If a node does not include it when it should, the implementation is

broken. Wouldn't a broken node be able to put wrong report type into

the AVP even if the AVP is mandatory?

Anyway, if it is my statement keeping issue #54 still open, consider

it resolved from my side. I am OK making the OC-Report-Type AVP as

required/mandatory AVP. Should we also consider it having a fixed

position just after the OC-Sequence-Number AVP as well since it is

going to in every OC-OLR?

- Jouni

On Feb 21, 2014, at 11:47 AM, Maria Cruz Bartolome <[email-masked]><mailto:[email-masked]> wrote:

Hello all,

I understand JJ point of view, but I still tend to prefer to make it mandatory, since I think this is less error-prone, since the only node that knows the requested Report-Type is the reporting, if for any reason a reporting is omitting it (since it is optional), it will be always interpreted as HOST, but this type may be wrong.

I think DEFAULT values should never be error-prone, but used in "general cases", as a simplification, like e.g. a default for the Validity-Duration. Default Validity-Duration will never be an "error", it could be not the best value (compared with another value perfectly tuned to reporting node overload situation) but never the use of a Default value should lead to an erroneous behavior.

Best regards

/MCruz

-----Original Message-----

From: DiME [mailto:[email-masked]] On Behalf Of Ben Campbell

Sent: viernes, 14 de febrero de 2014 23:13

To: Jouni Korhonen

Cc: [email-masked]<mailto:[email-masked]>

Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

I actually prefer making it mandatory. The cost of adding it is trivial--even more so for a reporting node that only supports the default. The value of having it is less opportunity for interop errors.

On Feb 13, 2014, at 6:05 AM, Jouni Korhonen <[email-masked]><mailto:[email-masked]> wrote:

Agree that it is a small optimization, which I put there because at

the beginning there seemed to be a lot of worry on every extra AVP

;-)

I prefer having the AVP optional but with a default value just like

it is now. We have the same for the reduction percentage and the

validity time as well.

- Jouni

On Feb 13, 2014, at 10:55 AM, "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]><mailto:[email-masked]> wrote:

Hi Mcruz

The current description indicates that when not present the OLR is of type Host, which was fine for me and keeps my preference.

We may have  deployments where Realm OLR is not used, or where statistically the HOST type is the most frequent, so to have the grouped OLR-AVP containing a minimum of AVPs minimizes parsing. I agree it is a small optimization.

Best regards

JJacques

-----Message d'origine-----

De : DiME [mailto:[email-masked]] De la part de

[email-masked]<mailto:[email-masked]> Envoyé : mercredi 12 février 2014 15:46 À :

[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]> Objet : Re: [Dime]

[dime] #54: OC-Report-Type as mandatory AVP

Hi Maria Cruz,

I'm assuming that you mean "required" instead of "mandatory", right?

So instead of:

OC-OLR ::= < AVP Header: TBD2 >

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Reduction-Percentage ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

OC-OLR ::= < AVP Header: TBD2 >

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Reduction-Percentage ]

           [ OC-Validity-Duration ]

         * [ AVP ]

And I'm fine with this proposal.

Cheers,

Lionel

-----Message d'origine-----

De : DiME [mailto:[email-masked]] De la part de dime issue

tracker Envoyé : mercredi 12 février 2014 15:26 À :

[email-masked]<mailto:[email-masked]> Cc : [email-masked]<mailto:[email-masked]> Objet : [Dime]

[dime] #54: OC-Report-Type as mandatory AVP

#54: OC-Report-Type as mandatory AVP

Now in chapter 4.6:

 The default value of the OC-Report-Type AVP is 0 (i.e. the host

report).

This AVP is always required, right? Then, I think it is more precise that  we define this AVP as mandatory.

--

-----------------------------------------------+---------------------

-----------------------------------------------+---

-----------------------------------------------+---

Reporter:  [email-masked]<mailto:[email-masked]>  |      Owner:  MCruz

  Type:  defect                             |  Bartolomé

Priority:  major                              |     Status:  new

Component:  draft-docdt-dime-ovli              |  Milestone:

Severity:  Active WG Document                 |    Version:  1.0

                                            |   Keywords:

-----------------------------------------------+---------------------

-----------------------------------------------+---

-----------------------------------------------+---

Ticket URL: <http://trac.tools.ietf.org/wg/dime/trac/ticket/54><http://trac.tools.ietf.org/wg/dime/trac/ticket/54>

dime <http://tools.ietf.org/wg/dime/><http://tools.ietf.org/wg/dime/>

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_____________________________________________________________________

____________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_______________________________________________

DiME mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Wed, 26 Mar 2014 11:25:59 +0000

Hello,
I can accept both proposals as mentioned before.
Cheers
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Sent: miércoles, 26 de marzo de 2014 12:17
To: [email-masked]
Subject: Re: [Dime] [dime] #54: OC-Report-Type as mandatory AVP

Hi

Best regards

JJacques

Lionel

Lionel

Hi Lionel,

Best regards
Ulrich

Hi,

Regards,

lionel

Hi Susan,

Regards,

Lionel

Hi Lionel,

Best Regards,
Susan

Hi Susan,

Regards,

Lionel

Hello Lionel,

Thanks for your reply.

Best Regards,
Susan

Hi Susan,

Regards,

Lionel.

Hello Lionel,

Further clarification:

Best Regards,
Susan

Hello Lionel,

I don't understand it.

Best Regards,
Susan

Lionel

Hello Steve,

Best Regards,
Susan

Susan,

Regards,

Steve

Best Regards,
Susan

Susan,

Steve

Hello Jouni,

Best Regards,

Susan

-----Original Message-----

To: Steve Donovan

- Jouni

Steve

Hello,

Best regards

/MCruz

All,

Jouni,

Regards,

Steve

Hi,

not present?

- Jouni

Hello all,

Best regards

/MCruz

-----Original Message-----

To: Jouni Korhonen

;-)

validity time as well.

- Jouni

Hi Mcruz

Best regards

JJacques

-----Message d'origine-----

Hi Maria Cruz,

So instead of:

           < OC-Sequence-Number >

           [ OC-Report-Type ]

           [ OC-Validity-Duration ]

         * [ AVP ]

You would prefer:

           < OC-Sequence-Number >

           { OC-Report-Type }

           [ OC-Validity-Duration ]

         * [ AVP ]

Cheers,

Lionel

-----Message d'origine-----

Now in chapter 4.6:

report).

--

  Type:  defect                             |  Bartolomé

                                            |   Keywords:

DiME mailing list

Thank you.

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

DiME mailing list

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.

Thank you.