Subject: Re: [Dime] Issue#32 status

From: Steve Donovan <[email-masked]>
Date: Sat, 01 Mar 2014 17:08:06 -0600

agreed

On 2/28/14 9:37 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:
> I think so; not required, not desired.
>
> -----Original Message-----
> From: ext Jouni Korhonen [mailto:[email-masked]] 
> Sent: Friday, February 28, 2014 4:30 PM
> To: Wiehe, Ulrich (NSN - DE/Munich)
> Cc: [email-masked]
> Subject: Re: [Dime] Issue#32 status
>
>
> Going back in history..
>
> On Feb 19, 2014, at 5:33 PM, "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]> wrote:
>
>> #32: Sequence-Number Time-Stamp values within OC-OLR
>>  
>> I understand that we agreed the following principles:
>>  
>> Sequence-Number is of type Time, however the value need not correspond to the point in time of generation.
>>  
>> When generated, a new sequence number must be  greater than any sequence number previously generated by the same node (including over a reboot of that node)
>>  
>> When received, a sequence number is used to detect outdates/replays/freshness.
>>  
>> Sequence numbers of expired OLRs MUST NOT be remembered by reacting nodes.
>>  
>>  
>> I did not understand the requirement for globally uniqueness as introduced by Jouni.
>> Can Jouni please explain.
> Originated from here:
> http://www.ietf.org/mail-archive/web/dime/current/msg06600.html
>
> So requiring global uniqueness is not desired anymore? 
>
> - Jouni
>
>
>
>>  
>> Ulrich
>>  
>>  
>>  
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dime
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 3 Mar 2014 09:13:38 +0000

Hi Jouni,

if d is the maximum validity duration a reporting node ever sent, then d is sufficiently long.
(there may be better i.e. shorter estimations but those would be subject to more complex conditions)  

Ulrich

-----Original Message-----
From: ext Jouni Korhonen [mailto:[email-masked]] 
Sent: Friday, February 28, 2014 7:22 PM
To: Steve Donovan; Wiehe, Ulrich (NSN - DE/Munich)
Cc: Ben Campbell; [email-masked] list
Subject: Re: [Dime] Issue#32 status

A question.. how much is "a sufficiently long period of no overload"?
I'd like to see some guidance or minimum values documented.

- Jouni

On Feb 25, 2014, at 6:36 PM, Steve Donovan <[email-masked]> wrote:

> Ulrich,
> 
> Yes, with that period being long enough for the reporting node to be confident that all previously sent overload reports have expired.
> 
> Steve
> 
> On 2/25/14 10:21 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:
>> Steve, Ben,
>> 
>> for my clarification, your proposal is to say
>> 
>> ***
>> Sequence number is of type Unsigned64.
>> 
>> When generated, a new sequence number must be greater than the sequence number contained in the active overload report to which it applies (including over reboot of that node).  Note: this allows sequence numbers to start at 1 for the initial occurrence of an overload condition at a reporting node.
>> ***
>> 
>> If so, what is meant by "initial occurrence of an overload condition"?
>> 
>> I guess it means something like moving from no overload to overload after a sufficiently long periode of no overload
>> 
>> Please clarify
>> 
>> Ulrich
>> 
>> 
>> From: DiME [
>> mailto:[email-masked]
>> ] On Behalf Of ext Steve Donovan
>> Sent: Tuesday, February 25, 2014 4:02 PM
>> To: Ben Campbell
>> Cc: 
>> [email-masked]
>>  list
>> I agree with the suggested change.
>> 
>> Steve
>> On 2/24/14 5:00 PM, Ben Campbell wrote:
>> + 1, except as noted:
>> 
>> On Feb 24, 2014, at 2:33 PM, Steve Donovan 
>> <[email-masked]>
>>  wrote:
>> 
>> Ulrich,
>> 
>> Would you agree to the following to replace the first two statements:
>> 
>> Sequence number is of type Unsigned64.
>> 
>> When generated, a new sequence number must be greater than the sequence number contained in the active overload report to which it applies (including over reboot of that node).  Note: this allows sequence numbers to start at 1 for any occurrence of overload at a reporting node.  This, I think, allows us to ignore wraparound issues as wraparound will never happen.  Unless we are worried about a server staying in overload for billions of years (assuming reports with a ten minute validity period refreshed every five minutes).
>> 
>> s/ any occurrence of overload / the initial occurrence of an overload condition
>> 
>> 
>> The other two statements are good.
>> 
>> Steve
>> 
>> 
>> 
>> 
>> 
>