Subject: [Dime] About DCCA

From: devoss ind <[email-masked]>
Date: Wed, 7 May 2014 19:22:45 +0530

Hi,

I have a question regarding the way multiplier is calculated in case of
credit pool concept of DCCA. Can we find any formulae for it. I went thru
the complete RFC4006 for it, but could not find the exact derivation for
it. Please help me.

Regards,
Devoss

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 08 May 2014 09:15:35 +0300

You might want to ask the original authors. At least one of them is 
still around, see a mail from today: 
http://www.ietf.org/mail-archive/web/dime/current/msg07437.html

- Jouni

5/7/2014 4:52 PM, devoss ind kirjoitti:
> credit pool concept of DCCA. Can we find any formulae for it. I went
> thru the complete RFC4006 for it, but could not find the exact
> derivation for it. Please help me.
>
>
> Regards,
> Devoss
>
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: Marco Stura <[email-masked]>
Date: Fri, 9 May 2014 05:38:47 +0000

Hi Devoss,

I guess you are referring to credit pooling, right?

At the time when we worked on DCCA we thought to just include examples illustrating how it works, the examples could be used to derive how multiplier can be calculated. But we didn’t want to specify any formula other than the one necessary to implement the credit pooling concept.

It is assumed that the credit control server has access to the rating parameters and uses those as input when computing the multiplier. The multiplier can then be calculated using any formula with the rating value as input. In the examples we have in RFC 4006 we simply used rating_value * 10 or rating_value *100 to make calculations easy, but can be anything more complex to make it difficult for the client to guess the actual rating parameters.

For example could be M == ROUND(rating_value*RAND()*1255 )

It’s just an example, but it’s really up to implementers what formula to use.

Hope this helps.

BR,
Marco

From: DiME [mailto:[email-masked]] On Behalf Of devoss ind
Sent: Wednesday, May 07, 2014 4:53 PM
To: [email-masked]
Subject: [Dime] About DCCA

Hi,
I have a question regarding the way multiplier is calculated in case of credit pool concept of DCCA. Can we find any formulae for it. I went thru the complete RFC4006 for it, but could not find the exact derivation for it. Please help me.

Regards,
Devoss

________________________________

The information in this email and any attachments thereto may contain information that is confidential, protected by intellectual property rights, and may be legally privileged. It is intended solely for the addressee(s). Access to this email by anyone else is unauthorized. Any use, disclosure, copying, or distribution of the information contained herein by persons other than the designated addressee is unauthorized and may be unlawful. If you are not the intended recipient, you should delete the message immediately from your system. If you believe that you have received this email in error, please contact the sender. Any views expressed in this email and its attachments are those of the individual sender except where the sender expressly states them to be the views of Ooredoo.