Subject: [Dime] DOIC #43

From: Steve Donovan <[email-masked]>
Date: Fri, 18 Jul 2014 11:54:02 +0200

Here is the text from issue 43:

----

In section 3.1.4, under "Intra-Session Requests" indicates that session 
ending requests should be throttled less aggressively. While I agree 
that's a good idea in general, I think that's a mater of local policy, 
and not up to DOIC to specify.

It would be better to indicate that prioritization under overload is up 
to local policy, and list prioritizing of session-ending requests as an 
example of a potential local policy.

----

And here is the text in the draft that introduces the discussion on 
potential handling of each type of request:

----

The request classes identified in Section 3.7.3 have implications on
    decisions about which requests should be throttled first.  The
    following list of request treatment regarding throttling is provided
    as guidelines for application designers when implementing the
    Diameter overload control mechanism described in this document.  The
    exact behavior regarding throttling is a matter of local policy,
    unless specifically defined for the application.

----

I believe that existing text addresses the concern expressed in the 
problem report and that the issue can be closed with no changes.

Regards,

Steve

---

From: Ben Campbell <[email-masked]>
Date: Fri, 18 Jul 2014 09:30:26 -0500

I don't agree on this one.

The wording of the text at least for intra-session requests is not consistent with the "these are just guidelines" disclaimer. Like it or not, people tend to  skip over disclaimer text.  (This sort of thing comes up all the time on gen-art reviews. In my personal opinion, If the disclaimer is for CYA purposes, it makes sense to state it once like we currently do. But if you want people to actually read it and internalize it, it needs to be intrinsic to the text.)

For example, language of the form of "Session terminating requests should be throttled less aggressively..." should be more of the form of "Implementors and operators may wish to throttle ... less agressively."

On Jul 18, 2014, at 4:54 AM, Steve Donovan <[email-masked]> wrote:

> In section 3.1.4, under "Intra-Session Requests" indicates that session ending requests should be throttled less aggressively. While I agree that's a good idea in general, I think that's a mater of local policy, and not up to DOIC to specify.
> 
> It would be better to indicate that prioritization under overload is up to local policy, and list prioritizing of session-ending requests as an example of a potential local policy.
> 
> ----
> 
> And here is the text in the draft that introduces the discussion on potential handling of each type of request:
> 
> ----
> 
> I believe that existing text addresses the concern expressed in the problem report and that the issue can be closed with no changes.
> 
> Regards,
> 
> Steve
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime