Subject: [Dime] Proposed modification for section 3

From: <[email-masked]>
Date: Thu, 13 Nov 2014 02:48:23 +0000

According to the proposed modification of the definition of the Report-Type AVP (see proposal for section 6.6), it would be easier to use the values defined for Report-type and make the link with host/realm-routed.
Moreover, host-routed and realm-routed is defined at the beginning of the spec, so no need to repeat.
Finally, I propose to avoid the use of "server" when not required.

let me know if it is acceptable.

Regards,

Lionel

*******************
OLD:

   A report of type host is sent to indicate the overload of a specific
   server for the application-id indicated in the transaction.  When
   receiving an OLR of type host, a reacting node applies overload
   abatement to what is referred to in this document as host-routed
   requests.  This is the set of requests that the reacting node knows
   will be served by a particular host, either due to the presence of a
   Destination-Host AVP, or by some other local knowledge on the part of
   the reacting node.  The reacting node applies overload abatement on
   those host-routed requests which the reacting node knows will be
   served by the server that matches the Origin-Host AVP of the received
   message that contained the received OLR of type host.

   A report type of realm is sent to indicate the overload of all
   servers in a realm for the application-id.  When receiving an OLR of
   type realm, a reacting node applies overload abatement to what is
   referred to in this document as realm-routed requests.  This is the
   set of requests that are not host-routed as defined in the previous
   paragraph.

NEW:

   A report of type "HOST_REPORT" is sent to indicate the overload of a specific
   host, identified by the Origin-Host AVP of the message containing the OLR,
   for the application-id indicated in the transaction. When receiving an OLR of
   type "HOST_REPORT", a reacting node applies overload abatement to host-routed
   requests (see definition in section 2) sent for this application to a specific host that
   matches the Origin-Host AVP to which applies the received OLR.

   A report of type "REALM_REPORT" is sent to indicate the overload of
   a realm for the application-id. The overloaded realm is identified by the
   Destination-Realm AVP of the message containing the OLR.
   When receiving an OLR of type "REALM_REPORT", a reacting node applies
   overload abatement to realm-routed requests (see definition in section 2)
   sent for this application.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Thu, 13 Nov 2014 08:32:28 -1000

Agreed.

Changed with some wordsmithing:

    A report of type "HOST_REPORT" is sent to indicate the overload of a
    specific host, identified by the Origin-Host AVP of the message
    containing the OLR, for the application-id indicated in the
    transaction.  When receiving an OLR of type "HOST_REPORT", a reacting
    node applies overload abatement treatment to host-routed requests
    (see definition in Section 2) sent for this application to the
    overloaded host.

    A report of type "REALM_REPORT" is sent to indicate the overload of a
    realm for the application-id indicated in the transaction.  The
    overloaded realm is identified by the Destination-Realm AVP of the
    message containing the OLR.  When receiving an OLR of type
    "REALM_REPORT", a reacting node applies overload abatement treatment
    to realm-routed requests (see definition in Section 2) sent for this
    application to the overloaded realm.

Steve

On 11/12/14, 4:48 PM, [email-masked] wrote:
>
> According to the proposed modification of the definition of the 
> Report-Type AVP (see proposal for section 6.6), it would be easier to 
> use the values defined for Report-type and make the link with 
> host/realm-routed.
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Thu, 13 Nov 2014 18:43:48 +0000

Ok

Envoyé depuis mon Sony Xperia SP d'Orange

---- Steve Donovan a écrit ----

Agreed.

Steve

On 11/12/14, 4:48 PM, [email-masked]<mailto:[email-masked]> wrote:
According to the proposed modification of the definition of the Report-Type AVP (see proposal for section 6.6), it would be easier to use the values defined for Report-type and make the link with host/realm-routed.
Moreover, host-routed and realm-routed is defined at the beginning of the spec, so no need to repeat.
Finally, I propose to avoid the use of "server" when not required.

Regards,

Lionel

*******************
OLD:

NEW:

_______________________________________________
DiME mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dime