Subject: [Dime] Handling of mandatory sub-avps

From: Steve Donovan <[email-masked]>
Date: Mon, 22 Dec 2014 10:57:34 -0600

All,

The following is an open issue from Ben's suggested editorial changes 
that still needs to be addressed.

Regards,

Steve
>> -- 4.3, para 4:
>>
>> We should clarify that this is talking about mandatory to understand for DOIC, but not for the enclosing transaction.
> SRD> i'm not clear on what you are suggesting.

We need to be clear that receiving a DOIC avp with a mandatory AVP that you don't understand means you ignore the DOIC AVPs, but does not cause the Diameter transaction to fail. Or was it your intent to allow an application to say that if you get a DOIC avp that you can't process, you have to fail the Diameter transaction?

>   Do you have suggested wording?

Depends on the answer to the question above.

---

From: Ben Campbell <[email-masked]>
Date: Mon, 22 Dec 2014 18:15:50 -0600

My opinion is that any DOIC error (i.e. something wrong in OC-S-F or OC-OLR) should never cause an error or other failure of the enclosing transaction. Normally the only way DOIC should affect a transaction is via abatement.

I would grudgingly accept the ability for a Diameter application spec to say that the application must not be used without DOIC (and potentially certain DOIC features.), as long as such a requirement was explicit (including explicit on _how_ it should fail), but I think that's a different use case.

> On Dec 22, 2014, at 10:57 AM, Steve Donovan <[email-masked]> wrote:
> 
> All,
> 
> The following is an open issue from Ben's suggested editorial changes that still needs to be addressed.
> 
> Regards,
> 
> Steve
>>> -- 4.3, para 4:
>>> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 23 Dec 2014 02:33:41 +0000

NO, WRONG

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 23 Dec 2014 02:42:14 +0000

To be clear, ignore what one does not understand.

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of DOLLY, MARTIN C
Sent: Monday, December 22, 2014 9:34 PM
To: Ben Campbell; Steve Donovan
Cc: [email-masked]
Subject: Re: [Dime] Handling of mandatory sub-avps

*** Security Advisory: This Message Originated Outside of AT&T ***.
Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.

NO, WRONG

---

From: Ben Campbell <[email-masked]>
Date: Mon, 22 Dec 2014 22:34:22 -0600

Martin, I think we are violently agreeing. A DOIC "failure" doesn't impact the Diameter transaction.

> On Dec 22, 2014, at 8:42 PM, DOLLY, MARTIN C <[email-masked]> wrote:
>

---

From: Steve Donovan <[email-masked]>
Date: Mon, 29 Dec 2014 10:33:31 -0600

Ben,

As you suggesting that just the AVP that isn't understood is ignored or 
the entire grouped AVP it is part of is ignored?  If the "sub-avp" is 
marked as mandatory then it would seem that the entire grouped AVP 
should be ignored.

Steve