Subject: [Dime] Ulrich suggested change number 2

From: Steve Donovan <[email-masked]>
Date: Mon, 08 Dec 2014 16:58:28 -0600

Ulrich,

For the second suggested change:

Section 3.2, 6th paragraph:
Existing text:
    The OC-Feature-Vector AVP will contain an indication of support for
    the loss overload abatement algorithm defined in this specification
    (see Section 5).  This ensures that there is at least one commonly
    supported overload abatement algorithm between the reporting node and
    the reacting node(s) in the path of the request.

Comment: I agree that within a given path between client and server there may
be more than one reacting nodes. But a given reporting node on that path does
not have more than one adjacent reacting nodes on that given path to which it
sends OLRs. I don't say that the existing text is wrong, but it is misleading.
What we want to say here is that any given pair of adjacent reacting and reporting
nodes will have at least one commonly supported algorithm.

Proposal: It is proposed to replace the last line of the paragraph with:
    The adjacent reacting node on the path of the request.

It's more than just about the adjacent reaction nodes.  It is important 
that all reacting nodes in the path of the request have at least one 
common abatement algorithm.

I don't see the need for the suggested change.

Regards,

Steve

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 9 Dec 2014 14:08:23 +0000

Steve,

please see inline.

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Steve Donovan
Sent: Monday, December 08, 2014 11:58 PM
To: [email-masked]
Subject: [Dime] Ulrich suggested change number 2

Ulrich,

Proposal: It is proposed to replace the last line of the paragraph with:
   The adjacent reacting node on the path of the request.
It's more than just about the adjacent reaction nodes.  It is important that all reacting nodes in the path of the request have at least one common abatement algorithm. 
<Ulrich>I do not agree. It is important that a pair of two adjacent reacting and reporting nodes (A,S) have at least one commonly supported algorithm, so that the reporting node can always select an algorithm supported by the adjacent reacting node. There may be another (non-adjacent) reacting node in the path (C), but its not important for C and S (which are not adjacent) to have a commonly supported algorithm.
C---A---S
It is important that C and A have a commonly supported algorith, as C and A are adjacent;
It is important that A and S have a commonly supported algorith, as A and S are adjacent;
It is true but not important (and nothing that needs to be ensured) that C and S have a commonly supported algorithm (indeed S could eventually select an algorithm not supported by C);</Ulrich>
It is true but not important that C, A and S have a commonly supported algorithm.

Regards,

Steve

---

From: Steve Donovan <[email-masked]>
Date: Wed, 10 Dec 2014 06:34:10 -0600

Ulrich,

How about changing the last sentence to:

"This ensures that there is at least one commonly supported overload 
abatement algorithm supported by all DOIC nodes in the path of the request."

Regards,

Steve

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 10 Dec 2014 15:53:27 +0000

Steve,

How about something like this:

"This ensures that a reporting node allways supports at least one of the advertized abatement algorithms received in a request messages."

Regards
Ulrich

-----Original Message-----
From: ext Steve Donovan [mailto:[email-masked]] 
Sent: Wednesday, December 10, 2014 1:34 PM
To: Wiehe, Ulrich (NSN - DE/Munich); [email-masked]
Subject: Re: [Dime] Ulrich suggested change number 2

Ulrich,

Regards,

Steve

---

From: Steve Donovan <[email-masked]>
Date: Thu, 11 Dec 2014 07:54:01 -0600

I'm ok with this, as long as always is spelled correctly. :-)

Steve