Subject: [Dime] DOIC WGLC: Sequence Number uniqueness

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2014 23:13:30 -0600

Section 6.4, paragraph 2 says the following:

" The sequence number is only required to be unique between two DOIC nodes."

Is that limitation useful? What about agents that pass it OLRs without change?

Thanks!

Ben.

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Dec 2014 08:27:25 +0200

Then they pass the SN unmodified, obviously. I rather have it explicitly 
mentioned that e.g. an agent can modify the SN without that causing the 
debate whether it is correct or not. Do you have a specific case in mind 
where it could cause issues?

- jouni

---

From: Ben Campbell <[email-masked]>
Date: Wed, 17 Dec 2014 00:35:33 -0600

I'm not worried so much about nodes changing it. I'm just wondering if that is the right scope of uniqueness. I'm not sure why "between any two nodes" is relevant. Or even if "uniqueness" is relevant. 

It's a sequence number that gets incremented, not a unique ID per se.

So, here's an example: A reporting node sends both realm reports and host reports to the same reacting node. If the sequence number has to be unique between two nodes, does that mean that the realm report and host reports must never have the same sequence number? If we start the sequence at zero and increment for each change (as is recommended elsewhere), they are highly likely to have the same sequence number at some point in time.

I think the _real_ requirement is that the sequence number not repeat  for non-identical OLRs over the lifetime of a particular OCS instance.

> On Dec 17, 2014, at 12:27 AM, Jouni Korhonen <[email-masked]> wrote:
> 
> 
> Then they pass the SN unmodified, obviously. I rather have it explicitly mentioned that e.g. an agent can modify the SN without that causing the debate whether it is correct or not. Do you have a specific case in mind where it could cause issues?
> 
> - jouni
>

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Dec 2014 09:00:56 +0200

Good point. I would be OK with that change.

- Jouni

---

From: Steve Donovan <[email-masked]>
Date: Wed, 17 Dec 2014 08:40:26 -0600

So the proposal is to change:

"The sequence number is only required to be unique between two DOIC nodes."

To:

"The sequence number must not repeat for non-identical OLRs over the 
lifetime of a particular OCS instance. "?

While true, I'm not sure that we even need that statement.

I propose that we just remove the first sentence and not replace it with 
anything.

Steve

On 12/17/14, 1:00 AM, Jouni Korhonen wrote:
>> I'm not worried so much about nodes changing it. I'm just wondering 
>> if that is the right scope of uniqueness. I'm not sure why "between 
>> any two nodes" is relevant. Or even if "uniqueness" is relevant.
>>
>> So, here's an example: A reporting node sends both realm reports and 
>> host reports to the same reacting node. If the sequence number has to 
>> be unique between two nodes, does that mean that the realm report and 
>> host reports must never have the same sequence number? If we start 
>> the sequence at zero and increment for each change (as is recommended 
>> elsewhere), they are highly likely to have the same sequence number 
>> at some point in time.
>>
>> I think the _real_ requirement is that the sequence number not 
>> repeat  for non-identical OLRs over the lifetime of a particular OCS 
>> instance.
>>
>>
>>> Then they pass the SN unmodified, obviously. I rather have it 
>>> explicitly mentioned that e.g. an agent can modify the SN without 
>>> that causing the debate whether it is correct or not. Do you have a 
>>> specific case in mind where it could cause issues?
>>>
>>> - jouni
>>>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: Ben Campbell <[email-masked]>
Date: Wed, 17 Dec 2014 10:31:30 -0600

> On Dec 17, 2014, at 8:40 AM, Steve Donovan <[email-masked]> wrote:
> 
> "The sequence number must not repeat for non-identical OLRs over the lifetime of a particular OCS instance. "?
> 
> I propose that we just remove the first sentence and not replace it with anything.

I'm okay with that. I think the other bits are sufficiently explained elsewhere.