Subject: [Dime] Ulrich's suggested change #11

From: Steve Donovan <[email-masked]>
Date: Tue, 09 Dec 2014 07:39:52 -0600

Ulrich,

For your  suggested change #11:

Section 4.1.3, 6th paragraph:
Existing text:
    As with a Diameter endpoint taking on reporting node behavior, a
    Diameter Agent MUST only include the OC-Supported-Features AVP in
    answer messages for transactions where the request message received
    by the Diameter Agent had an OC-Supported-Features AVP.
Comments: "MUST only do x for condition y" could mean:
a) "MUST do x for condition y and MUST NOT do x for conditions other than y", or
b) "MUST do x and nothing else for condition y, and nothing is specified for conditions other than y".
Proposal: Replace the paragraph with:
    As with a Diameter endpoint taking on reporting node behavior, a
    Diameter Agent MUST NOT include the OC-Supported-Features AVP in
    answer messages for transactions where the request message received
    by the Diameter Agent had no OC-Supported-Features AVP.

I support this change.

Regards,

Steve

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Wed, 10 Dec 2014 15:09:26 +0000

Fine

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: martes, 09 de diciembre de 2014 14:40
To: [email-masked]
Subject: [Dime] Ulrich's suggested change #11

Ulrich,

Existing text:

Regards,

Steve

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Dec 2014 18:21:08 -0600

Agreed. "MUST only" is actually one of my pet peeves for 2119 language abuse. I'm mortified to have missed that one :-)

> On Dec 10, 2014, at 9:09 AM, Maria Cruz Bartolome <[email-masked]> wrote:
> 
> Fine
>  
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime