Subject: Re: [Dime] Updates to DOIC -05

From: Steve Donovan <[email-masked]>
Date: Tue, 02 Dec 2014 12:49:36 -0600

Lionel,

The two paragraphs together now say the following:

    When a reporting node sends an OLR, it effectively delegates any
    necessary throttling to downstream nodes.  If the reporting node also
    locally throttles the same set of messages, the overall number of
    throttled request may be higher than intended.  Therefore, if a
    reporting node needs to apply local throttling on a set of messages
    that match or overlap with existing OCS entries, it needs to consider
    the impact of throttling by downstream nodes.

    However, when the reporting node sends an OLR downstream, it might
    still need to apply other abatement methods such as diversion.  The
    reporting node might also need to throttle requests for reasons other
    than overload.  For example, an agent or server might have a
    configured rate limit for each client, and throttle requests that
    exceed that limit, even if such requests had already been candidates
    for throttling by downstream nodes.

Do you see the need for further clarification?

Steve

On 11/25/14, 12:26 PM, [email-masked] wrote:
> I'm OK with the idea of the text proposed by Ben.
> I would just make clear that throttling is applicable to the fact of sending/forwarding requests (cf. definition). A reporting node may apply local throttling if it is an agent. But if it is a server, it can either drop the exceeded number of requests (no response sent to the downstream) or send a specific DIAMETER-TOO-BUSY response. I think that this clarification is somehow missing in the document.
>
> Regards,
>
> Lionel
>
> -----Message d'origine-----
> De : Steve Donovan [mailto:[email-masked]]
> Envoyé : mardi 25 novembre 2014 15:07
> À : Ben Campbell; MORAND Lionel IMT/OLN
> Cc : Wiehe, Ulrich (NSN - DE/Munich); [email-masked]; Maria Cruz Bartolome
> Objet : Re: [Dime] Updates to DOIC -05
>
> I'm ok with Ben's wording and will make the change unless I hear objections on the list.
>
> Steve
>
> On 11/21/14, 5:01 PM, Ben Campbell wrote:
>> On reflection, I think there might be a subtlety here. The resulting offered-load may still exceed the reporting node's current capacity. This can be true even if it's sent an OLR (and thus has related OCS). As mentioned in the surrounding node needs to still be able to protect itself, possibly by throttling. Therefore, I propose the sentence take the form of non-normative guidance. For example:
>>
>> "When a reporting node sends an OLR, it effectively delegates any necessary throttling to downstream nodes.  If the reporting node also locally throttles the same set of messages, the overall number of throttled request may be higher than intended. Therefore, if a reporting node needs to apply local throttling on a set of messages that match or overlap with existing OCS entries, it needs to consider the impact of throttling by downstream nodes."
>>
>>    
>>> On Nov 17, 2014, at 2:38 AM, [email-masked] wrote:
>>>
>>> I can live with the text proposed by Ulrich. But what is wrong with:
>>>
>>> " Therefore, the reporting node SHOULD NOT apply throttling to the set of messages to which an active OCS applies." ?
>>>
>>> Envoyé depuis mon Sony Xperia SP d'Orange
>>>
>>> ---- Maria Cruz Bartolome a écrit ----
>>>
>>>
>>>> Section 4.2.3, 13th paragraph, 2nd sentence:
>>>> Existing text: Therefore, the reporting node SHOULD NOT apply throttling to the set of messages to which the OLR applies.
>>>> Proposed text: Therefore, the reporting node SHOULD NOT apply throttling to the set of messages to which the sent OLR applies.
>>>>
>>>> [LM] I would say that the reporting node will not remember the previously sent OLR, but will take care that there is an active OCS.
>>> SRD> I'm ok with Ulrich's change.
>>>
>>> [LM] and this is incorrect but not fundamental. The reporting node does not have to "remember" a previously sent OLR. What it will do is to refer to existing OCS to know that throttling should not be applied. An OCS is a consequence of an sent OLR but it is not an OLR itself. But not fundamental here.
>>>
>>> [MCruz] I am ok with Ulrich's change. It does not mean that the reporting node needs to "remember" a previously sent OLR, though. The change only proposes to "identify" which OLR we refer to.
>>>
>>> Best regards
>>> /MCruz
>>>
>>>
>>> _____________________________________________________________________
>>> ____________________________________________________
>>>
>>> Ce message et ses pieces jointes peuvent contenir des informations
>>> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
>>> exploites ou copies sans autorisation. Si vous avez recu ce message
>>> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>>>
>>> This message and its attachments may contain confidential or
>>> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
>>> If you have received this email in error, please notify the sender and delete this message and its attachments.
>>> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
>>> Thank you.
>>>
>>> _______________________________________________
>>> DiME mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dime
>
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
>
>

---

From: Jouni <[email-masked]>
Date: Wed, 3 Dec 2014 11:47:49 +0200

I would be OK with this text.

- Jouni

> On 02 Dec 2014, at 20:49, Steve Donovan <[email-masked]> wrote:
> 
> Lionel,
> 
>> De : Steve Donovan [
>> mailto:[email-masked]
>> ] 
>> Cc : Wiehe, Ulrich (NSN - DE/Munich); 
>> [email-masked]
>> ; Maria Cruz Bartolome

---

From: <[email-masked]>
Date: Wed, 3 Dec 2014 10:25:03 +0000

Hi Steve,

   When a reporting node sends an OLR, it effectively delegates any
   necessary throttling to downstream nodes.  If the reporting node also
   locally throttles the same set of messages, the overall number of
   throttled request may be higher than intended.  Therefore, if a
s/throttled request/throttled requests
   reporting node needs to apply local throttling on a set of messages
   that match or overlap with existing OCS entries, it needs to consider
   the impact of throttling by downstream nodes.
s/throttling by/throttling performed by

question: what is the meaning of overlap here? Can we just kept "match"

I can live the text above.
But I would suggest to change the third sentence of the first paragraph as follow:

   Therefore, before applying local message throttling, a  reporting node
   needs to check if these messages match existing OCS entries, indicating
   that these messages have survived to the throttling applied by 
   downstream nodes that have received the related OLR.

And to make the link the first paragraph and the second one, I would propose:

   However, even if the set of messages match existing OCS entries, the 
   reporting node can still apply other abatement methods such as diversion.  
  [etc.]

Regards,

Lionel

-----Message d'origine-----
De : Jouni [mailto:[email-masked]] 
Envoyé : mercredi 3 décembre 2014 10:48
À : Steve Donovan
Cc : MORAND Lionel IMT/OLN; Ben Campbell; [email-masked]
Objet : Re: [Dime] Updates to DOIC -05

- Jouni

>> Envoyé : mardi 25 novembre 2014 15:07 À : Ben Campbell; MORAND Lionel 
>> IMT/OLN Cc : Wiehe, Ulrich (NSN - DE/Munich); [email-masked] ; Maria 
>> Cruz Bartolome Objet : Re: [Dime] Updates to DOIC -05
>> 
>>>> ___________________________________________________________________
>>>> __ ____________________________________________________
>>>> 
>>>> confidentielles ou privilegiees et ne doivent donc pas etre 
>>>> diffuses, exploites ou copies sans autorisation. Si vous avez recu 
>>>> ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>>>>

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 3 Dec 2014 10:29:00 +0000

Dear all

I am not against the new proposed texts from Steve or Ben to clarify this topic.

My point is that, when  the reporting node has sent an OLR requiring  a traffic reduction , there is first a reaction time before receiving reduced traffic, and second even if the traffic has been reduced, it can still exceed the capacity of the reporting node  that has no other choice than to throttle the received reduced traffic (if no diversion). This can happen when the traffic at the source (reacting node) before throttling is increasing quickly, so the traffic reduced  according to the received OLR may  remain too high .  Then, if the reporting node has nevertheless to do some throttle, it will certainly react by new OLRs requiring a higher traffic reduction from the reacting nodes. This is a dynamic process, where the reporting node adjust the  traffic  reduction it requires according to what it receives .

As Ben  I also think this is a guidance , and I think it is good to bring some guidance.

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : mardi 2 décembre 2014 19:50
À : [email-masked]; Ben Campbell
Cc : [email-masked]
Objet : Re: [Dime] Updates to DOIC -05

Lionel,

Steve

On 11/25/14, 12:26 PM, [email-masked]<mailto:[email-masked]> wrote:

Regards,

Lionel

-----Message d'origine-----

Cc : Wiehe, Ulrich (NSN - DE/Munich); [email-masked]<mailto:[email-masked]>; Maria Cruz Bartolome

Steve

On Nov 17, 2014, at 2:38 AM, [email-masked]<mailto:[email-masked]> wrote:

---- Maria Cruz Bartolome a écrit ----

Best regards

/MCruz

Thank you.

DiME mailing list

[email-masked]<mailto:[email-masked]>

Thank you.

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Wed, 3 Dec 2014 12:19:27 +0000

Dear all

To continue on my remark , I would complement the Steve's text with " can update the reduction of traffic it requires from the reacting nodes(s) by sending new overload reports" as hereafter:

   Therefore, if a

   that match existing OCS entries, it needs to consider

   the impact of throttling by downstream nodes and can update the reduction of traffic it requires from the reacting nodes(s) by sending new overload reports.

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de TROTTIN, JEAN-JACQUES (JEAN-JACQUES)
Envoyé : mercredi 3 décembre 2014 11:29
À : Steve Donovan; [email-masked]; Ben Campbell
Cc : [email-masked]
Objet : Re: [Dime] Updates to DOIC -05

Dear all

Best regards

JJacques

De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : mardi 2 décembre 2014 19:50
À : [email-masked]<mailto:[email-masked]>; Ben Campbell
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Dime] Updates to DOIC -05

Lionel,

Steve

Regards,

Lionel

-----Message d'origine-----

Steve

---- Maria Cruz Bartolome a écrit ----

Best regards

/MCruz

Thank you.

DiME mailing list

Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Wed, 03 Dec 2014 11:22:29 -0600

I have attempted to address both Lionel's and Jean-Jacques' suggestions 
with the following text:

    When a reporting node sends an OLR, it effectively delegates any
    necessary throttling to downstream nodes.  If the reporting node also
    locally throttles the same set of messages, the overall number of
    throttled requests may be higher than intended.  Therefore, before
    applying local message throttling, a reporting node needs to check if
    these messages match existing OCS entries, indicating that these
    messages have survived throttling applied by downstream nodes that
    have received the related OLR.

    However, even if the set of messages match existing OCS entries, the
    reporting node can still apply other abatement methods such as
    diversion.  The reporting node might also need to throttle requests
    for reasons other than overload.  For example, an agent or server
    might have a configured rate limit for each client, and throttle
    requests that exceed that limit, even if such requests had already
    been candidates for throttling by downstream nodes.  The reporting
    node also has the option to send new OLRs requesting greater
    reductions in traffic, reducing the need for local throttling.

Steve

On 12/3/14, 6:19 AM, TROTTIN, JEAN-JACQUES (JEAN-JACQUES) wrote:
>
> Dear all
>
> To continue on my remark , I would complement the Steve's text with " 
> can update the reduction of traffic it requires from the reacting 
> nodes(s) by sending new overload reports" as hereafter:
>
>   
>     Therefore, if a
> *De :*DiME [mailto:[email-masked]] *De la part de* TROTTIN, 
> JEAN-JACQUES (JEAN-JACQUES)
> *Envoyé :* mercredi 3 décembre 2014 11:29
> *À :* Steve Donovan; [email-masked]; Ben Campbell
> *Cc :* [email-masked]
> *Objet :* Re: [Dime] Updates to DOIC -05
>
> Dear all
>
> My point is that, when  the reporting node has sent an OLR requiring 
>  a traffic reduction , there is first a reaction time before receiving 
> reduced traffic, and second even if the traffic has been reduced, it 
> can still exceed the capacity of the reporting node  that has no other 
> choice than to throttle the received reduced traffic (if no 
> diversion). This can happen when the traffic at the source (reacting 
> node) before throttling is increasing quickly, so the traffic reduced  
> according to the received OLR may  remain too high .  Then, if the 
> reporting node has nevertheless to do some throttle, it will certainly 
> react by new OLRs requiring a higher traffic reduction from the 
> reacting nodes. This is a dynamic process, where the reporting node 
> adjust the  traffic  reduction it requires according to what it receives .
>
> *De :*DiME [mailto:[email-masked]] *De la part de* Steve Donovan
> *Envoyé :* mardi 2 décembre 2014 19:50
> *À :* [email-masked] <mailto:[email-masked]>; Ben 
> Campbell
> *Cc :* [email-masked] <mailto:[email-masked]>
> *Objet :* Re: [Dime] Updates to DOIC -05
>
> Lionel,
>
>     Cc : Wiehe, Ulrich (NSN - DE/Munich);[email-masked]  <mailto:[email-masked]>; Maria Cruz Bartolome
>
>             On Nov 17, 2014, at 2:38 AM,[email-masked]  <mailto:[email-masked]>  wrote:
>
>               
>
>             [email-masked]  <mailto:[email-masked]>
>

---

From: <[email-masked]>
Date: Wed, 3 Dec 2014 17:49:38 +0000

I'm fine with the modified text.

Lionel

De : Steve Donovan [mailto:[email-masked]]
Envoyé : mercredi 3 décembre 2014 18:22
À : TROTTIN, JEAN-JACQUES (JEAN-JACQUES); MORAND Lionel IMT/OLN; Ben Campbell
Cc : [email-masked]
Objet : Re: [Dime] Updates to DOIC -05

I have attempted to address both Lionel's and Jean-Jacques' suggestions with the following text:

Steve

   Therefore, if a

Best regards

JJacques

À : Steve Donovan; [email-masked]<mailto:[email-masked]>; Ben Campbell

Dear all

Best regards

JJacques

Lionel,

Steve

Regards,

Lionel

-----Message d'origine-----

Steve

---- Maria Cruz Bartolome a écrit ----

Best regards

/MCruz

Thank you.

DiME mailing list

Thank you.

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Thu, 4 Dec 2014 07:09:00 +0000

Steve's text  is also fine for me.

Best regards

JJacques

De : [email-masked] [mailto:[email-masked]]
Envoyé : mercredi 3 décembre 2014 18:50
À : Steve Donovan; TROTTIN, JEAN-JACQUES (JEAN-JACQUES); Ben Campbell
Cc : [email-masked]
Objet : RE: [Dime] Updates to DOIC -05

Lionel

Steve

   Therefore, if a

Best regards

JJacques

Dear all

Best regards

JJacques

Lionel,

Steve

Regards,

Lionel

-----Message d'origine-----

Steve

---- Maria Cruz Bartolome a écrit ----

Best regards

/MCruz

Thank you.

DiME mailing list

Thank you.

Thank you.

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Wed, 10 Dec 2014 15:09:18 +0000

Dear all,

I have the following proposal, for first paragraph
Now:

Therefore, before

   applying local message throttling, a reporting node needs to check if
   these messages match existing OCS entries,

Proposal

Therefore, before

   applying local message throttling, a reporting node MAY check if
   these messages match existing OCS entries,

I think the reporting node may or not check whether the received messages match a "delegated" active OCS. This is a processing consuming task that could be avoided if the reporting node uses different criteria to choose messages to drop/reject. This is up to  implementation.

Best regards
/MCruz

From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: miércoles, 03 de diciembre de 2014 18:22
To: TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]; Ben Campbell
Cc: [email-masked]
Subject: Re: [Dime] Updates to DOIC -05

Steve

   Therefore, if a

Best regards

JJacques

Dear all

Best regards

JJacques

Lionel,

Steve

Regards,

Lionel

-----Message d'origine-----

Steve

---- Maria Cruz Bartolome a écrit ----

Best regards

/MCruz

Thank you.

DiME mailing list

Thank you.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Dec 2014 17:46:20 -0600

> On Dec 10, 2014, at 9:09 AM, Maria Cruz Bartolome <[email-masked]> wrote:
> 
> Dear all,
>  
> I think the reporting node may or not check whether the received messages match a “delegated” active OCS. This is a processing consuming task that could be avoided if the reporting node uses different criteria to choose messages to drop/reject. This is up to  implementation.

I am okay with it being up to the implementation. I think the point of the warning is to let implementers know they need to consider this. 

But I wonder why you want to add 2119 language when it didn't have it before?

> To continue on my remark , I would complement the Steve’s text with “ can update the reduction of traffic it requires from the reacting nodes(s) by sending new overload reports” as hereafter:    
>  
>    Therefore, if a

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 12 Dec 2014 08:04:19 +0000

2119 language is not required in my opinion, as long as the message is transmitted.
Cheers
/MCruz

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: jueves, 11 de diciembre de 2014 0:46
To: Maria Cruz Bartolome
Cc: Steve Donovan; TROTTIN, JEAN-JACQUES (JEAN-JACQUES); [email-masked]; [email-masked]
Subject: Re: [Dime] Updates to DOIC -05

> De : DiME [mailto:[email-masked]] De la part de TROTTIN, 
> JEAN-JACQUES (JEAN-JACQUES) Envoyé : mercredi 3 décembre 2014 11:29 À 
> : Steve Donovan; [email-masked]; Ben Campbell Cc : 
> [email-masked] Objet : Re: [Dime] Updates to DOIC -05
>  
> Dear all
>  
> Envoyé : mardi 2 décembre 2014 19:50 À : [email-masked]; Ben 
> Campbell Cc : [email-masked] Objet : Re: [Dime] Updates to DOIC -05
>  
> Lionel,
> 
> De : Steve Donovan [mailto:[email-masked]] Envoyé : mardi 25 
> novembre 2014 15:07 À : Ben Campbell; MORAND Lionel IMT/OLN Cc : 
> Wiehe, Ulrich (NSN - DE/Munich); [email-masked]; Maria Cruz Bartolome 
> ______________________________________________________________________
> ___________________________________________________
>

---

From: Steve Donovan <[email-masked]>
Date: Tue, 16 Dec 2014 08:12:31 -0600

How about the following:

Therefore, before
    applying local message throttling, a reporting node needs to check if
    these messages are covered by an active overload occurrence,

Regards,

Steve