Subject: [Dime] DOIC WGLC: Requirement for OC-Feature-Vector values

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2014 23:02:25 -0600

Section 4.3 requires all extensions with "new normative behaviors" to define a new feature bit for OC-Feature-Vector.

I still think that's too strong a requirement. If a new feature is backwards-compatible, then we may well not really need a feature bit. For example, SIP doesn't define a new feature tag for every new header. Also, keep in mind this is   a field of 1 bit flags. We only get 64 of those.

I propose we change this to say that "any non-backwards compatible" feature requires a new feature bit.

Thanks!

/Ben.

---

From: Steve Donovan <[email-masked]>
Date: Wed, 17 Dec 2014 08:48:14 -0600

I'm ok with this change.

Steve

On 12/16/14, 11:02 PM, Ben Campbell wrote:
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>