Subject: [Dime] Ulrich suggested change number 1

From: Steve Donovan <[email-masked]>
Date: Mon, 08 Dec 2014 16:54:48 -0600

Ulrich,

I'll deal with each of your suggestion in a separate email to help 
ensure that nothing is missed.

For your first suggestion:

Section 3, last paragraph:
Existing text:
    While a reporting node sends OLRs to "adjacent" reacting nodes, nodes
    that are "adjacent" for DOIC purposes may not be adjacent from a
    Diameter, or transport, perspective.  For example, one or more
    Diameter agents that do not support DOIC may exist between a given
    pair of reporting and reacting nodes, as long as those agents pass
    unknown AVPs through unchanged.  The report types described in this
    document can safely pass through non-supporting agents.  This may not
    be true for report types defined in future specifications.

Comment: while this is all not wrong, the existing text may convey the erring
impression that there cannot be a DOIC supporting agent on the path between a
reporting node and an adjacent reacting node.

Proposal: It is proposed to add the following sentence at the end of the paragraph:
    Another example is where one or more Diameter agents that do support
    DOIC may exist between a given pair of reporting and reacting nodes,
    as long as those agents pass OC-specific AVPs through unchanged.

I don't agree with the suggested change, as the DOIC supporting agents 
might need to change the OC-specific AVPs.  I also don't understand how 
the paragraph implies that there cannot be DOIC supporting agents in the 
path of the request.  It is talking specifically about the case where 
there agents do not support DOIC are in the path.  The remainder of the 
document makes it clear that there can be agents that do support DOIC in 
the path of a transaction.

I don't see the need for a change here.

Regards,

Steve

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 9 Dec 2014 13:16:38 +0000

Steve,

please see inline.

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Steve Donovan
Sent: Monday, December 08, 2014 11:55 PM
To: [email-masked]
Subject: [Dime] Ulrich suggested change number 1

Ulrich,

I'll deal with each of your suggestion in a separate email to help ensure that nothing is missed.

Proposal: It is proposed to add the following sentence at the end of the paragraph:
   Another example is where one or more Diameter agents that do support
   DOIC may exist between a given pair of reporting and reacting nodes,
   as long as those agents pass OC-specific AVPs through unchanged.
I don't agree with the suggested change, as the DOIC supporting agents might need to change the OC-specific AVPs.
<Ulrich> I agree that in some cases DOIC supporting agents need to change the OC-specific AVPs. However, there are also cases where DOIC supporting agents do not need to change OC-specific AVPs.</Ulrich>
  I also don't understand how the paragraph implies that there cannot be DOIC supporting agents in the path of the request.
<Ulrich> It does not imply that. Rather it may convey the erring impression that there cannot be a DOIC supporting agent on the path between a 
reporting node and an adjacent reacting node.</Ulrich>
   It is talking specifically about the case where there agents do not support DOIC are in the path.
<Ulrich> No, my understanding is that the paragraph is talking specifically about what "adjacent for DOIC purposes" means. One valid example is given (reporting node and reacting node are "adjacent for DOIC purposes" if one or more agents that do not support DOIC but pass unsupported AVPs through unchanged exist between reporting node and reacting node) and I do not propose to remove that. However, there is another important valid example (reporting node and reacting node are "adjacent for DOIC purposes" if one or more DOIC supporting agents that pass OC-specific AVPs through unchanged exist between reporting node and reacting node), and the proposal is to add text to cover this example. </Ulrich>
The remainder of the document makes it clear that there can be agents that do support DOIC in the path of a transaction.
<Ulrich> that is not my point. The point is to clearly state that there can be DOIC supporting agents that pass through OC-specific AVPs unchanged on the path between reporting node and reacting node, and in this case the reporting and reacting nodes are still regarded "adjacent for DOIC purposes".</Ulrich>  

I don't see the need for a change here.
<Ulrich> I'm not proposing a modification but an addition. This addition provides useful clarification and in no way is harmful</Ulrich>

Regards,

Steve

---

From: Steve Donovan <[email-masked]>
Date: Wed, 10 Dec 2014 06:29:46 -0600

Ulrich,

I think I see the source of confusion.  It is meant to talk about 
sending to adjacent DOIC nodes but it uses the words reacting and 
reporting nodes.  I suggest changing the paragraph to the following, 
removing the concept of reporting and reacting nodes from the description.

    While a DOIC node sends OLRs to "adjacent" DOIC nodes, nodes
    that are "adjacent" for DOIC purposes may not be adjacent from a
    Diameter, or transport, perspective.  For example, one or more
    Diameter agents that do not support DOIC may exist between a given
    pair of DOIC nodes, as long as those agents pass
    unknown AVPs through unchanged.  The report types described in this
    document can safely pass through non-supporting agents.  This may not
    be true for report types defined in future specifications.

Regards,

Steve

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Wed, 10 Dec 2014 15:09:21 +0000

Steve, Ulrich,

I agree with proposed changed by Ulrich.
I am in line with his explanations below.

Best regards
/MCruz

Ulrich,

Comment: while this is all not wrong, the existing text may convey the erring impression that there cannot be a DOIC supporting agent on the path between a reporting node and an adjacent reacting node. 

<Ulrich> It does not imply that. Rather it may convey the erring impression that there cannot be a DOIC supporting agent on the path between a reporting node and an adjacent reacting node.</Ulrich>
<Ulrich> No, my understanding is that the paragraph is talking specifically about what "adjacent for DOIC purposes" means. One valid example is given (reporting node and reacting node are "adjacent for DOIC purposes" if one or more agents that do not support DOIC but pass unsupported AVPs through unchanged exist between reporting node and reacting node) and I do not propose to remove that. However, there is another important valid example (reporting node and reacting node are "adjacent for DOIC purposes" if one or more DOIC supporting agents that pass OC-specific AVPs through unchanged exist between reporting node and reacting node), and the proposal is to add text to cover this example. </Ulrich> The remainder of the document makes it clear that there can be agents that do support DOIC in the path of a transaction.

Regards,

Steve

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Dec 2014 17:50:26 -0600

> On Dec 10, 2014, at 6:29 AM, Steve Donovan <[email-masked]> wrote:
> 
> Ulrich,
> 
> I think I see the source of confusion.  It is meant to talk about sending to adjacent DOIC nodes but it uses the words reacting and reporting nodes.  I suggest changing the paragraph to the following, removing the concept of reporting and reacting nodes from the description.
> 

I like this approach.

I also note that, for a given transaction, the black-box behavior of a supporting-agent that passes OC AVPs unchanged id identical to that of an a non-supporting agent.

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 11 Dec 2014 09:55:10 +0000

Ben, Steve,

the confusion I think comes from the following:
1. the paragraph seems to try to define what "adjacent for DOIC purposes" means, but gives only one example and leaves it open whether other examples exist.
e.g.: Are two DOIC nodes adjacent for DOIC purposes when there is a DOIC supporting agent (that passes OC-specific AVPs through unchanged) on the path between them?
2. The paragraph says that OLRs are sent to nodes that are "adjacent for DOIC purpose". It's not clear whether the intention is to say 
a) OLRs are sent to adjacent DOIC nodes rather than to adjacent Diameter nodes, or
b) OLRs are sent to adjacent DOIC nodes rather than to non-adjacent DOIC nodes.
And it's not clear whether OLRs are also sent to DOIC nodes that are not adjacent for DOIC purposes.

In a configuration like this:

C-----A1------A2------S

where C, A1 and S support DOIC and A2 does not support DOIC but passes unknown AVPs through unchanged we need to distinguish two cases:
1)  A1 passes OC-specific AVPs through unchanged
In this case C and S are adjacent for DOIC purposes, hence S sends OLRs to C.
2)  A1 modifies/replaces OC-specific AVPs
In this case C and A1 are adjacent for DOIC purpose and A1 and S are adjacent for DOIC purpose, hence S ends OLRs to A1 and A1 sends OLRs to C.

Regards
Ulrich

-----Original Message-----
From: ext Ben Campbell [mailto:[email-masked]] 
Sent: Thursday, December 11, 2014 12:50 AM
To: Steve Donovan
Cc: Wiehe, Ulrich (NSN - DE/Munich); [email-masked]
Subject: Re: [Dime] Ulrich suggested change number 1

I like this approach.

---

From: Steve Donovan <[email-masked]>
Date: Thu, 11 Dec 2014 07:50:16 -0600

Ulrich,

The paragraph is only trying to state that DOIC works through non 
supporting Diameter Agents, which is one of the requirements.

Furthermore, adjacent means "next to".  In your example, C and A1 are 
adjacent DOIC nodes and A1 and S are adjacent DOIC nodes.  C and S are 
never adjacent DOIC nodes because there is a DOIC node between them.

We could simplify the paragraph by saying "DOIC works through non 
supporting Diameter Agents that properly pass unknown AVPs unchanges."  
Maybe that would do away with the confusion about what adjacent means.

Steve

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 15 Dec 2014 17:36:11 +0000

Steve,

I'm fine with the intention and with the proposed simplification, avoiding misinterpretations like
"DOIC nodes sent OLRs only to DOIC nodes that are next to it" and allowing DOIC nodes to send OLRs to DOIC nodes that are not next to it.

Ulrich

-----Original Message-----
From: ext Steve Donovan [mailto:[email-masked]] 
Sent: Thursday, December 11, 2014 2:50 PM
To: Wiehe, Ulrich (NSN - DE/Munich); ext Ben Campbell
Cc: [email-masked]
Subject: Re: [Dime] Ulrich suggested change number 1

Ulrich,

Steve