Subject: [Dime] Ulrich's suggested change #8

From: Steve Donovan <[email-masked]>
Date: Tue, 09 Dec 2014 07:14:06 -0600

Ulrich,

For your suggested change number 8:

Section 4.1.2, 8th paragraph:
Existing text:
    For an ongoing overload condition, a reporting node MUST NOT change
    the selected algorithm during the period of time that it is in an
    overload condition and, as a result, is sending OC-OLR AVPs in answer
    messages.

Comment: As a result of an ongoing overload condition the reporting node is
sending OC-OLR AVPs containing no validity duration or a validity duration
different from zero in answer messages.

Proposal: Replace the paragraph with:
    For an ongoing overload condition, a reporting node MUST NOT change
    the selected algorithm during the period of time that it is in an
    overload condition and, as a result, is sending OC-OLR AVPs
    containing no validity duration or a validity duration different
    from zero in answer messages.

I don't see the need for the change.  The selected algorithm should not 
change for all overload reports relating to an overload condition, 
including overload reports with a validity duration of zero.

Regards,

Steve

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 9 Dec 2014 15:30:35 +0000

Steve,

please see inline.

Ulrich

From: DiME [mailto:[email-masked]] On Behalf Of ext Steve Donovan
Sent: Tuesday, December 09, 2014 2:14 PM
To: [email-masked]
Subject: [Dime] Ulrich's suggested change #8

Ulrich,

Proposal: Replace the paragraph with:
   For an ongoing overload condition, a reporting node MUST NOT change
   the selected algorithm during the period of time that it is in an
   overload condition and, as a result, is sending OC-OLR AVPs
   containing no validity duration or a validity duration different
   from zero in answer messages.
I don't see the need for the change.  The selected algorithm should not change for all overload reports relating to an overload condition, including overload reports with a validity duration of zero.
<Ulrich> Isn't it so that when the overload condition ends (i.e. is no longer ongoing), the reporting node starts sending OLRs with validity duration of zero (for a long enough period of time)? (see end of section 4.2.1.4) 
The question now is whether the change of algorithm is allowed during this (long enough) period, or only after that period. I don't have a strong view. But this was not my point.
My point is that the current text seems to suggest that an overload condition is ongoing as long as OC-OLR AVPs are sent in answer messages, and I think that is not true. </Ulrich>

Regards,

Steve

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Dec 2014 16:57:46 -0600

> On Dec 9, 2014, at 9:30 AM, Wiehe, Ulrich (NSN - DE/Munich) <[email-masked]> wrote:
> 
> Steve,
> 
> please see inline.
> 
> Ulrich
> 
> 

I think the proscription should last until the reporting node is (at least reasonably) sure that all reacting nodes have removed the OCS. The original text comes closer to that than Ulrich's proposal, but I wonder if we shouldn't cast this in similar terms as we do for the part about resending zero duration OLRs.

---

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 11 Dec 2014 13:16:59 +0000

Ben,
would the following proposed text address your concern:

   A reporting node MUST NOT change the selected algorithm during the period
   of time that starts when entering an overload condition and ends when it
   is ensured that any non-expired reacting node's OCS entry created as a
   result of the overload condition in the reporting node is deleted.

In addition, is it so that outside that period the algorithm change can occur arbitrarily?
e.g. is it ok to change the algorithm in every second answer message while outside the period?
Or, is it ok to send rate while outside the period and send loss once the overload condition is entered?
Note that section 3.2. says:

   Reacting nodes can use the indicated overload abatement algorithm to
   prepare for possible overload reports

Should we recommend not to change the algorithm too often while outside the periode where change is prohibited?

Regards
Ulrich

---

From: Ben Campbell <[email-masked]>
Date: Thu, 11 Dec 2014 12:29:44 -0600

> On Dec 11, 2014, at 7:16 AM, Wiehe, Ulrich (NSN - DE/Munich) <[email-masked]> wrote:
> 
> Ben,

Yes, although I might suggest:

  "A reporting node MUST NOT change the selected algorithm during the period
  of time that starts when entering an overload condition and ends when the associated 
  OCS becomes invalid in all reacting nodes."
 
> Should we recommend not to change the algorithm too often while outside the periode where change is prohibited?

For "loss", it does not matter. But for algorithms that require reacting nodes to keep state, it might matter. In my opinion, reporting nodes
should not change the algorithm very often, and not without good reason. But I don't think that needs to be a normative requirement.

---

From: Steve Donovan <[email-masked]>
Date: Mon, 15 Dec 2014 10:43:19 -0600

I agree with Ben's wording and , given that there has been no objections 
raised, will update the document with that wording.  If there are 
objections I can make a followup change based on those objections.

Steve