Subject: [Dime] DOIC WGLC: loss algorithm behavior with expiring OLRs

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2014 23:07:40 -0600

Section 5.3 (paragraph 7) says that, for the loss algorithm, a reacting node should slowly ramp back up if an OLR expires. This seems to be for the general case of expiring loss-algorithm OLRs, since the case of expiring 100% reduction OLRs was dealt with in the preceding paragraphs.

We have guidance elsewhere that a _reporting_node_ should end an overload condition in a controlled fashion. If both the reacting node and reporting node are trying to do this, you may get unexpected behavior. It makes sense for the reacting node to ramp up slowly from 100% reduction, since the reporting node could not update the reduction percentage until expired. But for an percentage reduction that still allows non-trivial traffic, the reporting node should be gradually ramping down the reduction.

I propose we strike the entire paragraph from section 5.3.

---

From: Steve Donovan <[email-masked]>
Date: Wed, 17 Dec 2014 08:45:38 -0600

I agree.  In addition, the explanatory paragraph that follows should be 
moved to after the paragraph that discusses behavior after 100% reduction.

Steve

On 12/16/14, 11:07 PM, Ben Campbell wrote:
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: "TROTTIN, JEAN-JACQUES (JEAN-JACQUES)" <[email-masked]>
Date: Mon, 22 Dec 2014 21:54:29 +0000

Dear all

I think good to give guidance, so I ma not in favor to strike out the indicated text. 

I suggest to keep paragraphs but to re-structure them  by starting with a general statement.
Proposal: 

   When an active overload report expires, it is suggested that the
   reacting node progressively decrease the amount of traffic given
   abatement treatment, until the reduction is completely removed and no
   traffic is given abatement treatment.

      The goal of this behavior is to reduce the probability of overload
      condition thrashing where an immediate transition from 100%a high percentage
      reduction to 0% reduction results in the reporting node moving
      quickly back into an overload condition, so creating an oscillation

   If reacting node comes out of the 100 percent traffic reduction as a
   result of the overload report timing out, the following concerns are
   RECOMMENDED to be applied.  The reacting node sending the traffic
   should be conservative and, for example, first send "probe" messages
   to learn the overload condition of the overloaded node before
   converging to any traffic amount/rate decided by the sender.  Similar
   concerns apply in all cases when the overload report times out unless
   the previous overload report stated 0 percent reduction.

Best regards

JJacques 

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : mercredi 17 décembre 2014 15:46
À : [email-masked]
Objet : Re: [Dime] DOIC WGLC: loss algorithm behavior with expiring OLRs

I agree.  In addition, the explanatory paragraph that follows should be moved to after the paragraph that discusses behavior after 100% reduction.

Steve