Subject: [Dime] Ben's suggested change on Definitions

From: "Wiehe, Ulrich (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 15 Jan 2015 09:57:45 +0000

Ben wrote:
--Definitions:

I think we've made it too easy for the reader to confuse "abatement mechanisms" with "abatement algorithms". For example, "Abatement Algorithm" starts with "An extensible mechanism..." and "Diversion" starts with "An overload abatement mechanism...". A new reader will likely think that Diversion is a kind of abatement algorithm. I propose the following the following for "Abatement Algorithm":

"An extensible _method_ requested by reporting nodes and used by reacting nodes to determine which requests receive abatement treatment"

For "Diversion":

"An abatement _treatment_ mechanism, where..."

And for "Throttling":

"An abatement treatment mechanism that limits..."

<Ulrich> I agree with the principle. On reflection, isn't it so that "Abatement Algorithm  is a method (not necessarily an _extensible_ method - what is extensible is the set of advertized abatement algorithms)  advertized by reacting nodes and selected by reporting nodes for use at reacting nodes to determine whether a given  requests (which matches application id and request type and destination) is subject to abatement treatment?

---

From: Steve Donovan <[email-masked]>
Date: Thu, 15 Jan 2015 07:12:10 -0600

I'm ok with the changes.

Steve

On 1/15/15 3:57 AM, Wiehe, Ulrich (NSN - DE/Munich) wrote:
> Ben wrote:
> --Definitions:
> I think we've made it too easy for the reader to confuse "abatement 
> mechanisms" with "abatement algorithms". For example, "Abatement 
> Algorithm" starts with "An extensible mechanism..." and "Diversion" 
> starts with "An overload abatement mechanism...". A new reader will 
> likely think that Diversion is a kind of abatement algorithm. I 
> propose the following the following for "Abatement Algorithm":
> "An extensible _method_ requested by reporting nodes and used by 
> reacting nodes to determine which requests receive abatement treatment"
> For "Diversion":
> <Ulrich> I agree with the principle. On reflection, isn’t it so that 
> “Abatement Algorithm  is a method (not necessarily an _/extensible/_ 
> method – what is extensible is the set of advertized abatement 
> algorithms)  advertized by reacting nodes and selected by reporting 
> nodes for use at reacting nodes to determine whether a given  requests 
> (which matches application id and request type and destination) is 
> subject to abatement treatment?
>
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime