Subject: [Dime] sequence number warp-around detection in draft-ietf-dime-ovli

From: <[email-masked]>
Date: Wed, 26 Aug 2015 07:31:38 +0000

Hi,

The draft draft-ietf-dime-ovli has been approved by IESG but a final comment needs to be taken into account before publication.

About the sequence number wrap-around detection, it is said in section 5.2.1.3:

   If the reacting node determines that the sequence number has rolled
   over then the reacting node MUST update the matching OCS entry.  This
   can be determined by recognizing that the number has changed from
   something close to the maximum value in the OC-Sequence-Number AVP to
   something close to the minimum value in the OC-Sequence-Number AVP. 

It was commented that "something close to" could be more explicit/predictive.

Steve has proposed the following clarification:

    If the reacting node determines that the sequence number has rolled
    over then the reacting node MUST update the matching OCS entry. This
    can be determined by recognizing that the number has changed from
    a value within 1% of the maximum value in the OC-Sequence-Number AVP to
    a value within 1% of the minimum value in the OC-Sequence-Number AVP.

could you please confirm that the proposed clarification is acceptable?

regards,

Lionel

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Aug 2015 16:52:36 -0700

While I do not really see the necessity for this clarification I am _OK_ 
with the proposed text change.

- Jouni

8/26/2015, 12:31 AM, [email-masked] kirjoitti:
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dime
>

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Thu, 27 Aug 2015 08:42:42 -0500

Same here. I'm ok with the change.

Jean

On 8/26/15 6:52 PM, Jouni Korhonen wrote:
>
> While I do not really see the necessity for this clarification I am 
> _OK_ with the proposed text change.
>
> - Jouni
>
>> The draft draft-ietf-dime-ovli has been approved by IESG but a final 
>> comment needs to be taken into account before publication.
>>
>> Ce message et ses pieces jointes peuvent contenir des informations 
>> confidentielles ou privilegiees et ne doivent donc
>> pas etre diffuses, exploites ou copies sans autorisation. Si vous 
>> avez recu ce message par erreur, veuillez le signaler
>> a l'expediteur et le detruire ainsi que les pieces jointes. Les 
>> messages electroniques etant susceptibles d'alteration,
>> This message and its attachments may contain confidential or 
>> privileged information that may be protected by law;
>> If you have received this email in error, please notify the sender 
>> and delete this message and its attachments.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 27 Aug 2015 14:52:29 +0100

Great. I've added an RFC editor note to that effect [1]
so there's no need to submit a new version.

If nobody objects by the end of tomorrow, I'll send the
approval announcement and the RFC editors will make the
change as they are processing this one.

Thanks,
S.

[1] https://datatracker.ietf.org/doc/draft-ietf-dime-ovli/writeup/

---

From: <[email-masked]>
Date: Thu, 27 Aug 2015 13:59:41 +0000

Thank you, Stephen.

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Stephen Farrell
Envoyé : jeudi 27 août 2015 15:52
À : A. Jean Mahoney; [email-masked]
Objet : Re: [Dime] sequence number warp-around detection in draft-ietf-dime-ovli

Great. I've added an RFC editor note to that effect [1] so there's no need to submit a new version.

If nobody objects by the end of tomorrow, I'll send the approval announcement and the RFC editors will make the change as they are processing this one.

Thanks,
S.

On 27/08/15 14:42, A. Jean Mahoney wrote:
>>> ____________________________________________________________________
>>> _____________________________________________________
>>>
>>>
>>> confidentielles ou privilegiees et ne doivent donc pas etre 
>>> diffuses, exploites ou copies sans autorisation. Si vous avez recu 
>>> ce message par erreur, veuillez le signaler a l'expediteur et le 
>>> detruire ainsi que les pieces jointes. Les messages electroniques 
>>> etant susceptibles d'alteration, Orange decline toute responsabilite 
>>> si ce message a ete altere, deforme ou falsifie. Merci.
>>>
>>> privileged information that may be protected by law; they should not 
>>> be distributed, used or copied without authorisation.
>>> As emails may be altered, Orange is not liable for messages that 
>>> have been modified, changed or falsified.
>>> Thank you.
>>>