Subject: Re: [Dime] Use of SourceID AVP in Agent Overload and Load control drafts

From: Maria Cruz Bartolome <[email-masked]>
Date: Fri, 6 May 2016 10:14:34 +0000

Hello Lionel, all,

I think there is not a need to define two AVPs, when in fact the purpose of the AVP in both case is the same, i.e. identify the Diameter node that inserts this AVP. Then, that diameter node is considered as the source of the Load information (if inserted in Load AVP) or the Overload Information (if inserted in OC-OLR AVP).

If the problem you want to solve is the dependency of one draft to another, I will propose to simply progress first the one that we consider is more relevant, according to last emails it seems that Load is progressing faster, then we can simply have the definition of the SourceID AVP in the Load draft. Then, this definition should be generic enough, to allow a direct applicability to Agent Overload draft.

Would that work for you?
Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: viernes, 22 de abril de 2016 15:29
To: [email-masked]
Subject: [Dime] Use of SourceID AVP in Agent Overload and Load control drafts

Hi,

At the last IETF meeting, we have discussed the interdependence between the load control and the Agent Overload draft regarding the use of the SourceID AVP.

First of all, there is some inconsistency in the agent overload draft. The AVP is sometimes named OC-SourceID AVP and sometimes OC-SourcedID. This needs to be fixed.

Now, if we look at the definition of the OC-SourceID in the agent overload draft , we find:

6.3.  OC-SourceID

   The [OC-]SourceID AVP (AVP code TBD2) is of type DiameterIdentity and is
   inserted by the DOIC node that either indicates support for this
   feature (in the OC-Supported-Features AVP) or that generates an OC-
   OLR AVP with a report type of peer.

   It contains the Diameter Identity of the inserting node.  This is
   used by other DOIC nodes to determine if the a peer indicated support
   this feature or inserted the peer report.

This definition is interesting and should be kept from my point of view. I think that having an AVP identifying the source of DOIC node is a good point and this should remain.
I would be then in favor to define two separate AVPs, one identifying a OC source, another identifying a Load source.
I propose to keep "OC-SourceID" for the first one and "Load-SourceID" for the second one.

Additional advantage: if this approach is agreed, there is no need to link both drafts anymore.

Does it sound acceptable?

I will initiate issues aligned with this proposal. According to the conclusion of this discussion, they can be accepted or rejected later.

Regards,

Lionel

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Steve Donovan <[email-masked]>
Date: Fri, 6 May 2016 10:49:51 -0500

I prefer to fix the definition in the agent overload draft and progress 
it first or in parallel with the load draft.  We need to finish all of 
these drafts and the agent overload draft is the oldest.  This shouldn't 
slow the load draft if we do things in parallel.

Steve