Subject: [Dime] RFC 4006 bis - IMEI

From: "Gardella, Maryse (Nokia - FR)" <[email-masked]>
Date: Thu, 30 Jun 2016 16:58:36 +0000

All,

As part of the updates to RFC 4006 I propose to consider the IMEI also when refering to IMEISV, otherwise it is not clear if User-Equipment-Info-Type value O can be used for IMEI. 

In section 8.50. User-Equipment-Info-Type AVP in RFC4006,the following is specified: 
  
 IMEISV                          0
      The identifier contains the International Mobile Equipment
      Identifier and Software Version in the international IMEISV format
      according to 3GPP TS 23.003 [3GPPIMEI].

Which I propose to be updated as follows:  

IMEI(SV)                          0
      The identifier contains the International Mobile Equipment
      Identifier and Software Version in the international IMEISV format, 
	or the International Mobile Equipment Identifier in the international IMEI format 
      according to 3GPP TS 23.003 [3GPPIMEI]. 

Differentiation between IMEI (15 digits) and IMEISV (16 digits) is based on AVP length, would this work?

BR
Maryse

---

From: Dave Dolson <[email-masked]>
Date: Thu, 30 Jun 2016 17:38:52 +0000

Maryse,

If I understand correctly, you are proposing overloading a type, distinguishing the types only by length.

Is there precedent for the overloading you propose, such as a 3GPP standard or de facto standard usage that you can cite?

Otherwise, IANA may assign new values for new types, and we aren't short on space:
http://www.iana.org/assignments/aaa-parameters/aaa-parameters.xhtml#aaa-parameters-41

-Dave

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Gardella, Maryse (Nokia - FR)
Sent: Thursday, June 30, 2016 12:59 PM
To: [email-masked]
Subject: [Dime] RFC 4006 bis - IMEI

All,

  
 IMEISV                          0

IMEI(SV)                          0

BR
Maryse

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime