Subject: [Dime] New I-D Submitted: draft-bertz-dime-predictunits

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Wed, 6 Jul 2016 16:56:08 +0000

All,

I have uploaded a new I-D for consideration.  It permits a Diameter Client, upon authorization for Service usage, to receive a prediction (estimation) of the unit load.  This is intended to assist Clients in estimating load of authorized usage.

https://datatracker.ietf.org/doc/draft-bertz-dime-predictunits/

Thank you.

Lyle

________________________________
Learn more on how to switch to Sprint and save 50% on most Verizon, AT&T or T-Mobile rates. See sprint.com/50off<http://sprint.com/50off> for details.

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: Yuval Lifshitz <[email-masked]>
Date: Thu, 21 Jul 2016 22:20:35 +0000

Thanks for clarifying.
The load on the client (at least in clients I know) is measured with: # concurrent subscribers, # concurrent flows, bits/sec, packets/sec.
I assume that the server could estimate (based on past experience) the above, but as you mentioned below, they are all time based. Even # concurrent flows is driven by time, as we are not interested in the total amount of lows the user had, but only how many it had at the same time.
In addition, don't think that the server could be estimating the cpu impact on the client.

From: Bertz, Lyle T [CTO] [mailto:[email-masked]]
Sent: Thursday, July 21, 2016 5:11 PM
To: Yuval Lifshitz
Subject: Re: New I-D Submitted: draft-bertz-dime-predictunits

kk,

Sends units back to the client like a G-S-U or U-S-U so that it can get an estimate of load.  However, I would suspect it will send back multiple values representing different dimensions (the *[AVP] cop out).   One thing I struggled with and have asked some for advice on is whether it should be given a time range and respond from Server to Client as a list?

e.g. [ uses X Mbps, Y% CPU, 3K packets from T1 to T2 ], [ uses A Mbps, B% CPU, C packets from T2 to T3 ]

it definitely needs improvement

________________________________
From: Yuval Lifshitz <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, July 21, 2016 9:48 AM
To: Bertz, Lyle T [CTO]
Cc: Yuval Lifshitz
Subject: RE: New I-D Submitted: draft-bertz-dime-predictunits

Hi,
I really don't understand this one. How is load translated to bytes, time etc? How would the server know how much the user is going to consume?
In general would be good to understand the usecase behind.

From: DiME [mailto:[email-masked]] On Behalf Of Bertz, Lyle T [CTO]
Sent: Wednesday, July 06, 2016 6:56 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dime] New I-D Submitted: draft-bertz-dime-predictunits

All,

Thank you.

Lyle