Subject: [Dime] New I-D: draft-bertz-dime-perflowmbr-00

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Wed, 6 Jul 2016 16:30:49 +0000

All,

I have added a new I-D for consideration.  It permits setting *per flow* maximum bit rates.  This can serve in some applications, e.g. video throttling, to limit features such as resolutions as opposed to requiring deeper inspection.

https://datatracker.ietf.org/doc/draft-bertz-dime-perflowmbr/

Thank you.

Lyle

________________________________
Learn more on how to switch to Sprint and save 50% on most Verizon, AT&T or T-Mobile rates. See sprint.com/50off<http://sprint.com/50off> for details.

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: Dave Dolson <[email-masked]>
Date: Wed, 6 Jul 2016 16:42:46 +0000

Lyle,
This document doesn't define a "flow". What did you have in mind as a definition?

It sounds like you are thinking of a TCP or UDP connection? So if the intent were to limit video rates, each TCP or UDP connection would be granted the specified rate?

-Dave

From: DiME [mailto:[email-masked]] On Behalf Of Bertz, Lyle T [CTO]
Sent: Wednesday, July 06, 2016 12:31 PM
To: [email-masked]
Subject: [Dime] New I-D: draft-bertz-dime-perflowmbr-00

All,

Thank you.

Lyle

---

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Wed, 6 Jul 2016 16:44:14 +0000

Hmm.

Should say IP flow (5-tuple) but that may be in the wrong location.

From: Dave Dolson [mailto:[email-masked]]
Sent: Wednesday, July 06, 2016 11:43 AM
To: Bertz, Lyle T [CTO] <[email-masked]>; [email-masked]
Subject: RE: New I-D: draft-bertz-dime-perflowmbr-00

Lyle,

-Dave

From: DiME [mailto:[email-masked]] On Behalf Of Bertz, Lyle T [CTO]
Sent: Wednesday, July 06, 2016 12:31 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dime] New I-D: draft-bertz-dime-perflowmbr-00

All,

Thank you.

Lyle

---

From: Dave Dolson <[email-masked]>
Date: Wed, 6 Jul 2016 16:48:10 +0000

OK, I see in Security Considerations.

For your use-case, is it acceptable that a client could open two 5-tuple connections to achieve double the rate?

From: Bertz, Lyle T [CTO] [mailto:[email-masked]]
Sent: Wednesday, July 06, 2016 12:44 PM
To: Dave Dolson; [email-masked]
Subject: RE: New I-D: draft-bertz-dime-perflowmbr-00

Hmm.

From: Dave Dolson [mailto:[email-masked]]
Sent: Wednesday, July 06, 2016 11:43 AM
To: Bertz, Lyle T [CTO] <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: New I-D: draft-bertz-dime-perflowmbr-00

Lyle,

-Dave

All,

Thank you.

Lyle

---

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Wed, 6 Jul 2016 16:55:12 +0000

Yes, if you are using the IPFilterRule or RFC 5777 Filter-Rule as it is tied to the Protocol field.  I also intended for this not to conflict with multi-path based protocols.

If you are applying these attributes to another kind of Rule, e.g. 3GPP ADC Rule, then sticking to the L3 is still fine.  However, if you want to use it for the Application level flow this document would need to be changed and we'd need to incorporate it in the draft.  Is that something I should look at for this document.  More work would be needed to clarify interaction with multipath and other protocols though.

From: Dave Dolson [mailto:[email-masked]]
Sent: Wednesday, July 06, 2016 11:48 AM
To: Bertz, Lyle T [CTO] <[email-masked]>; [email-masked]
Subject: RE: New I-D: draft-bertz-dime-perflowmbr-00

From: Bertz, Lyle T [CTO] [mailto:[email-masked]]
Sent: Wednesday, July 06, 2016 12:44 PM
To: Dave Dolson; [email-masked]<mailto:[email-masked]>
Subject: RE: New I-D: draft-bertz-dime-perflowmbr-00

Hmm.

Lyle,

-Dave

All,

Thank you.

Lyle

---

From: Yuval Lifshitz <[email-masked]>
Date: Wed, 6 Jul 2016 17:30:17 +0000

* maybe good to mention how these rates work with the overall rates defined for all flows of the filter
* types in section 4 should be Unsigned32 

From: DiME [mailto:[email-masked]] On Behalf Of Bertz, Lyle T [CTO]
Sent: Wednesday, July 06, 2016 7:55 PM
To: Dave Dolson; [email-masked]
Subject: Re: [Dime] New I-D: draft-bertz-dime-perflowmbr-00

Hmm.

Lyle,

-Dave

All, 

Thank you.

Lyle

________________________________________
Learn more on how to switch to Sprint and save 50% on most Verizon, AT&T or T-Mobile rates. See sprint.com/50off for details. 
________________________________________