Subject: [Dime] Proposed resolutions of LOAD discussion

From: Steve Donovan <[email-masked]>
Date: Tue, 16 Aug 2016 09:50:23 -0500

All,

I have outlined proposed solutions for the issues raised in the 
discussion around the Diameter Load draft.

Please let me know if I've missed anything from the discussion.

Regards,

Steve

Primary Issues:

1) Use of DNS SRV weighted value as format for LOAD value.

This was discussed and agreed to early in the process.  It has the 
advantage that Diameter nodes can use a combination of values received 
via the DNS SRV interface and dynamic values received through the 
Diameter LOAD interface.  While I agree that it isn't as intuitive as a 
straight percentage value, I don't see this as compelling enough of a 
reason to change a decision the working group has already made.

2) Need to add wording that the calculated LOAD value needs to be based 
on overall available capacity.

I agree with Maria Cruz's comment that we need to add wording indicating 
that the calculated LOAD value needs to reflect available capacity.  To 
this end, I propose adding the following to section 6.1 (this is based 
on wording proposed by Maria Cruz):

The calculated LOAD value MUST reflect the Diameter nodes capacity 
relative to the total available capacity across the Diameter nodes to 
which requests can be routed.  This could be either a set of Diameter 
endpoints or a set of Diameter agents, depending on the type of the LOAD 
report.  The method for determining the total available capacity is 
outside of the scope of this document.

    Note: The LOAD value should be calculated in a way that reflects the 
available load independently of the weight of each
    server.  This allows the Diameter node that routes a request, 
including nodes doing server selection and agents routing
    requests, to accurately compare values from different nodes.  Any 
specific LOAD value needs to identify  the same
    amount of available capacity, regardless the Diameter node that 
calculates the value.

The mechanism used to calculate the LOAD value that fulfills this 
requirement is an implementation decision.

3) Wording in Appendix A.

Before we reword Appendix A, we need to decide if it is still needed.  
It was valuable in helping to generate the solution but I'm not 
convinced it is still needed in the document.  Is there objection to 
removing this section?

---

From: Maria Cruz Bartolome <[email-masked]>
Date: Thu, 25 Aug 2016 09:31:45 +0000

Hello Steve,

Thanks for the proposals, see below
Best regards
/MCruz

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: martes, 16 de agosto de 2016 16:50
To: [email-masked]
Subject: [Dime] Proposed resolutions of LOAD discussion

All,

I have outlined proposed solutions for the issues raised in the discussion around the Diameter Load draft.

Regards,

Steve

Primary Issues:

This was discussed and agreed to early in the process.  It has the advantage that Diameter nodes can use a combination of values received via the DNS SRV interface and dynamic values received through the Diameter LOAD interface.  While I agree that it isn't as intuitive as a straight percentage value, I don't see this as compelling enough of a reason to change a decision the working group has already made.
[MCruz] I still think using SRV values is error prone and anti-intuitive, but I can live with this if you really think it is not possible to re-evaluate this now.

2) Need to add wording that the calculated LOAD value needs to be based on overall available capacity.

I agree with Maria Cruz's comment that we need to add wording indicating that the calculated LOAD value needs to reflect available capacity.  To this end, I propose adding the following to section 6.1 (this is based on wording proposed by Maria Cruz):

The calculated LOAD value MUST reflect the Diameter nodes capacity relative to the total available capacity across the Diameter nodes to which requests can be routed.  This could be either a set of Diameter endpoints or a set of Diameter agents, depending on the type of the LOAD report.  The method for determining the total available capacity is outside of the scope of this document.

    Note: The LOAD value should be calculated in a way that reflects the available load independently of the weight of each
    server.  This allows the Diameter node that routes a request, including nodes doing server selection and agents routing
    requests, to accurately compare values from different nodes.  Any specific LOAD value needs to identify  the same
    amount of available capacity, regardless the Diameter node that calculates the value.

The mechanism used to calculate the LOAD value that fulfills this requirement is an implementation decision.

[MCruz] Some comments to proposed text:
" The calculated LOAD value MUST reflect the Diameter nodes capacity relative to the total available capacity across the Diameter nodes to which requests can be routed. ": I think it may be misleading what is the "total available capacity across nodes".
See proposal:
" The calculated LOAD value MUST reflect each Diameter node capacity relative to the maximum available capacity for a Diameter node to which requests can be routed.  "

Before we reword Appendix A, we need to decide if it is still needed.  
It was valuable in helping to generate the solution but I'm not convinced it is still needed in the document.  Is there objection to removing this section?

[MCruz] I prefer this to remain, it provides some hints that may be valuable for first time readers. 

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Steve Donovan <[email-masked]>
Date: Tue, 30 Aug 2016 11:59:09 +0800

Maria Cruz,

Thanks for your comments.  See my replies inline.

Regards,

Steve

> [MCruz] I still think using SRV values is error prone and anti-intuitive, but I can live with this if you really think it is not possible to re-evaluate this now.
SRD> I haven't seen any argument that using the SRV values doesn't 
work.  As such, I prefer to not change this at this stage of the process.
> " The calculated LOAD value MUST reflect each Diameter node capacity relative to the maximum available capacity for a Diameter node to which requests can be routed."
SRD> This wording could imply that the LOAD value carries load 
information for multiple Diameter nodes.  How about the following:

"The calculated LOAD value MUST reflect the sending Diameter nodes 
capacity relative to the maximum available capacity for the sending 
Diameter node."

> [MCruz] I prefer this to remain, it provides some hints that may be valuable for first time readers.
SRD> I'd like to hear other opinions on this as there is work required 
to make the section consistent with the mechanism defined. Implementors 
will still have access to this information by reviewing the history of 
the process of writing the specification.

SRD> Are there schedule pressures in 3GPP to get this to RFC state?  If 
so, it will be faster to just remove this section.