Subject: [Dime] draft reply LS to 3GPP SA5 on RFC 4006..

From: Jouni Korhonen <[email-masked]>
Date: Fri, 5 Aug 2016 10:41:06 -0700

Folks,

Lionel and I have been drafting a reply LS to 3GPP SA5 (and CC CT3/CT4). 
This is the current draft. Comments are welcome. One question is (Lionel 
favours, I disagree ;) whether we should repeat the two questions 3GPP 
asked from us or assume they can look it up from the origial LS.

- Jouni & Lionel

-------------------------------------------------------------------------
The IETF DIME WG thanks the 3GPP SA5 WG for their LS and query regarding 
the IETF RFC 4006 (https://datatracker.ietf.org/liaison/1470/).

The IETF DIME WG has discussed both options raised in the LS from 3GPP 
SA5 and the decision was made to update of the IETF RFC 4006 (the option 
1). The aim of this update is to align the Diameter Credit-Control 
application specification with the IETF RFC 6733, fix existing known 
issues in the current specification and comply with the recommendations 
given in the IETF RFC 7423 on the design of Diameter application. The 
time line for the completion of the RFC 4006 update is set to November 2017.

As a reminder, the IETF RFC 3588 does not define a new Diameter base 
protocol but is a new version of the specification defining the Diameter 
base protocol. The IETF RFC 3588 is obsoleted by the IETF RFC 6733, as 
defined in the IETF RFC 2223:

    Obsoleted-by

       To be used to refer to the newer document(s) that replaces the
       older document.

In the present case, any document using the IETF RFC 3588 as reference 
for the Diameter base protocol should be updated to refer to the new 
IETF RFC 6733. Therefore, as a general guideline, the IETF DIME WG 
recommends 3GPP WGs to follow this recommendation in their 
specifications when applicable.
-------------------------------------------------------------------------

---

From: Yuval Lifshitz <[email-masked]>
Date: Sun, 7 Aug 2016 05:53:52 +0000

Did you mean?

" As a reminder, the IETF RFC 6733 does not define a new Diameter base protocol but is a new version of the specification defining the Diameter base protocol."

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Friday, August 05, 2016 8:41 PM
To: [email-masked]
Subject: [Dime] draft reply LS to 3GPP SA5 on RFC 4006..

Folks,

Lionel and I have been drafting a reply LS to 3GPP SA5 (and CC CT3/CT4). 
This is the current draft. Comments are welcome. One question is (Lionel favours, I disagree ;) whether we should repeat the two questions 3GPP asked from us or assume they can look it up from the origial LS.

- Jouni & Lionel

-------------------------------------------------------------------------
The IETF DIME WG thanks the 3GPP SA5 WG for their LS and query regarding the IETF RFC 4006 (https://datatracker.ietf.org/liaison/1470/).

The IETF DIME WG has discussed both options raised in the LS from 3GPP
SA5 and the decision was made to update of the IETF RFC 4006 (the option 1). The aim of this update is to align the Diameter Credit-Control application specification with the IETF RFC 6733, fix existing known issues in the current specification and comply with the recommendations given in the IETF RFC 7423 on the design of Diameter application. The time line for the completion of the RFC 4006 update is set to November 2017.

As a reminder, the IETF RFC 3588 does not define a new Diameter base protocol but is a new version of the specification defining the Diameter base protocol. The IETF RFC 3588 is obsoleted by the IETF RFC 6733, as defined in the IETF RFC 2223:

    Obsoleted-by

In the present case, any document using the IETF RFC 3588 as reference for the Diameter base protocol should be updated to refer to the new IETF RFC 6733. Therefore, as a general guideline, the IETF DIME WG recommends 3GPP WGs to follow this recommendation in their specifications when applicable.
-------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Sun, 7 Aug 2016 13:55:40 +0000

Of course :)

Lionel

Le 7 août 2016 07:54, Yuval Lifshitz <[email-masked]> a écrit :
Did you mean?

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Friday, August 05, 2016 8:41 PM
To: [email-masked]
Subject: [Dime] draft reply LS to 3GPP SA5 on RFC 4006..

Folks,

- Jouni & Lionel

    Obsoleted-by

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Gardella, Maryse (Nokia - FR)" <[email-masked]>
Date: Tue, 9 Aug 2016 07:30:49 +0000

Hi,

I would also favor having the two questions from the 3GPP LS repeated as per suggestion below:

"The IETF DIME WG has discussed both options raised in the LS from 3GPP SA5:
*             Is IETF RFC 4006 planned to be updated in order to rely on IETF RFC 6733 as the new Diameter Base protocol?
*             If not, are there any recommendations from IETF on how to address the implicit reference to IETF RFC 3588 as Diameter Base Protocol for 3GPP SA5 Diameter Online charging through use of IETF RFC 4006?
and the decision was made to update of the IETF RFC 4006 as per the first option."

Beside this, I am not sure to understand the sentence below in the context of this LS:
"In the present case, any document using the IETF RFC 3588 as reference for the Diameter base protocol should be updated to refer to the new IETF RFC 6733. Therefore, as a general guideline, the IETF DIME WG recommends 3GPP WGs to follow this recommendation in their specifications when applicable". Especially what is intended to be conveyed  behind "In the present case"?

Maryse

From: DiME [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: dimanche 7 août 2016 15:56
To: Yuval Lifshitz; [email-masked]; [email-masked]
Subject: [Dime] RE : Re: draft reply LS to 3GPP SA5 on RFC 4006..

Of course :)

Lionel
Le 7 août 2016 07:54, Yuval Lifshitz <[email-masked]<mailto:[email-masked]>> a écrit :
Did you mean?

-----Original Message-----
From: DiME [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Friday, August 05, 2016 8:41 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dime] draft reply LS to 3GPP SA5 on RFC 4006..

Folks,

- Jouni & Lionel

    Obsoleted-by

_______________________________________________
DiME mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dime

_______________________________________________
DiME mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dime

Thank you.