Subject: [Dime] RFC4006bis: new Redirect-Address- AVPs should be using Address type

From: Dave Dolson <[email-masked]>
Date: Fri, 3 Mar 2017 20:44:12 +0000

The draft of RFC4006bis (https://tools.ietf.org/id/draft-ietf-dime-rfc4006bis-01.txt)
introduces new AVPs Redirect-Address-IPv4Address and Redirect-Address-IPv6Address.
These are currently defined as textual. I.e., "dotted decimal" and "RFC5952".

I would like to propose these instead be defined to use the more compact and less ambiguous binary address format.

Specifically, I would like to ask this group if these two fields can be consolidated into one field,
Name: Redirect-Address-IpAddress
Type: Address, per https://tools.ietf.org/html/rfc6733#section-4.3.1

-Dave

---

From: Yuval Lifshitz <[email-masked]>
Date: Sat, 4 Mar 2017 09:18:24 +0000

Hi Dave,
I think this makes sense. Reason I added these a UTF8 is to enable easier transition from the existing Redirect-Server-Address which is UTF8) to the newly proposed Redirect-Address-IPv4Address and Redirect-Address-IPv6Address AVP.
However, since there are new AVPs, not part of a standard yet, it is probably good time to change them.

Yuval

From: DiME [mailto:[email-masked]] On Behalf Of Dave Dolson
Sent: Friday, March 03, 2017 10:44 PM
To: [email-masked]
Subject: [Dime] RFC4006bis: new Redirect-Address- AVPs should be using Address type

-Dave

---

From: Dave Dolson <[email-masked]>
Date: Tue, 7 Mar 2017 19:44:31 +0000

OK, I'll make this change.

-----Original Message-----
From: Yuval Lifshitz 
Sent: Saturday, March 04, 2017 4:18 AM
To: Dave Dolson; [email-masked]
Cc: Yuval Lifshitz
Subject: RE: [Dime] RFC4006bis: new Redirect-Address- AVPs should be using Address type

Hi Dave,

Yuval

-Dave