Subject: [Dime] RFC4006bis: Using IPv4-mapped-IPv6 addresses in Redirect-Address-IPv6Address

From: Dave Dolson <[email-masked]>
Date: Fri, 3 Mar 2017 20:44:15 +0000

I've been reviewing https://tools.ietf.org/id/draft-ietf-dime-rfc4006bis-01.txt

One thing I noticed is that nothing is said about whether it is acceptable to use IPv4-mapped-IPv6 addresses in IPv6 AVPs.
https://tools.ietf.org/html/rfc4291#section-2.5.5.2

Briefly, an IPv6 address like ::ffff:c000:201 (also written ::ffff.192.0.2.1) is used to represent an IPv4 address.
This simplifies the number of AVPs required, simplifies software, and makes IPv6 a first-class citizen.

I'd like to ask this group if we can add language to explicitly permit ipv4-mapped-ipv6 addresses in RFC4006bis.

-Dave

---

From: Dave Dolson <[email-masked]>
Date: Tue, 7 Mar 2017 19:43:57 +0000

I didn't hear any opinions on this, and since RFC5952 mentions IPv4-mapped-IPv6, I think it is appropriate.

From: DiME [mailto:[email-masked]] On Behalf Of Dave Dolson
Sent: Friday, March 03, 2017 3:44 PM
To: [email-masked]
Subject: [Dime] RFC4006bis: Using IPv4-mapped-IPv6 addresses in Redirect-Address-IPv6Address

-Dave