Subject: [Dime] I-D Action: draft-ietf-dime-group-signaling-08.txt

From: [email-masked]
Date: Mon, 13 Mar 2017 14:18:15 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Diameter Maintenance and Extensions of the IETF.

        Title           : Diameter Group Signaling
        Authors         : Mark Jones
                          Marco Liebsch
                          Lionel Morand
	Filename        : draft-ietf-dime-group-signaling-08.txt
	Pages           : 26
	Date            : 2017-03-13

Abstract:
   In large network deployments, a single Diameter node can support over
   a million concurrent Diameter sessions.  Recent use cases have
   revealed the need for Diameter nodes to apply the same operation to a
   large group of Diameter sessions concurrently.  The Diameter base
   protocol commands operate on a single session so these use cases
   could result in many thousands of command exchanges to enforce the
   same operation on each session in the group.  In order to reduce
   signaling, it would be desirable to enable bulk operations on all (or
   part of) the sessions managed by a Diameter node using a single or a
   few command exchanges.  This document specifies the Diameter protocol
   extensions to achieve this signaling optimization.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dime-group-signaling/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dime-group-signaling-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dime-group-signaling-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Misha Zaytsev <[email-masked]>
Date: Tue, 14 Mar 2017 12:19:31 +0300

Hi All,

Am I right saying that the intention of this draft is to logically group
multiple sessions?
And there is no aim to physically bundle several session-related
requests/answers into one?

If so, this approach may decrease processing on communicating nodes (but
that will depend on implementation), but will not "reduce signaling" among
the involved parties.

Please clarify this point?

Thanks a lot in advance!

/Misha

---

From: Marco Liebsch <[email-masked]>
Date: Tue, 14 Mar 2017 12:16:20 +0000

Hi Misha,

the draft specifies how to assign sessions to session groups, correct. It also specifies how to
apply a command (request/response) to a session group. In case the group holds 10 sessions,
Diameter peers exchange only a single instead of 10 commands, hence can help to reduce
signaling load between Diameter peers.

I hope that clarifies your question.

marco

From: Misha Zaytsev [mailto:[email-masked]]
Sent: Dienstag, 14. März 2017 10:20
To: [email-masked]; Marco Liebsch; [email-masked]; ext [email-masked]
Subject: Re: [Dime] I-D Action: draft-ietf-dime-group-signaling-08.txt

Hi All,
Am I right saying that the intention of this draft is to logically group multiple sessions?
And there is no aim to physically bundle several session-related requests/answers into one?
If so, this approach may decrease processing on communicating nodes (but that will depend on implementation), but will not "reduce signaling" among the involved parties.
Please clarify this point?
Thanks a lot in advance!
/Misha