Subject: [Dime] Question about the changes from RFC3588

From: Misha Zaytsev <[email-masked]>
Date: Sun, 2 Jul 2017 16:05:13 +0300

Hi All,

In RFC3588, ch. 2.1:

When connecting to a peer and either zero or more transports are
specified, SCTP SHOULD be tried first, followed by TCP.

In RFC6733, ch. 2.1:

When connecting to a peer and either zero or more transports are
specified, TLS SHOULD be tried first, followed by DTLS, then by TCP,
and finally by SCTP.

What was the reason behind to change the order between TCP and SCTP?
Could anyone help to sort out this point?

Thanks a lot in advance!

/Misha

---

From: <[email-masked]>
Date: Mon, 17 Jul 2017 14:52:53 +0000

Hi,

I was not able to point to a specific email exchange or discussion on this topic. But I think the change of order between TCP and SCTP is only due to the context of publication.

At the time of RFC3588, it was assumed that SCTP would be largely deployed and available.
Working on the RFC6733 (RFC3588-bis), if you want to deploy Diameter in a secure way, (TLS/)TCP based implementations were still much more available than (DTLS/)SCTP. So if any recommendation was useful at this time, it was natural to propose to start with TCP first and then SCTP.

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Misha Zaytsev
Envoyé : dimanche 2 juillet 2017 15:05
À : [email-masked]
Objet : [Dime] Question about the changes from RFC3588

Hi All,

In RFC3588, ch. 2.1:

and finally by SCTP.

Thanks a lot in advance!

/Misha

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.