Subject: [Dime] Association between origin-host and source IP address

From: Ajinkya Joshi <[email-masked]>
Date: Fri, 8 Sep 2017 19:47:32 +0530

Hello,

It is clear from the RFC that, each diameter implementation maintains a
peer table, which is keyed on origin-host of the peer.
But, it's not clear that on receiving incoming diameter request (non
capability exchange), is diameter node suppose to match source IP address
of incoming request with the source IP address of original transport
association between these nodes?
e.g. Consider that there two transport connection established between A1
<-> B1 and A2 <-> B1, Where A1,A2, and B1 are diameter hosts. Suppose, A2
sends a diameter request to B1, with origin-host as "A1", is B1 suppose to
reject such requests?

-- 
Regards,
Ajinkya Joshi

---

From: Yuval Lifshitz <[email-masked]>
Date: Sun, 10 Sep 2017 06:08:50 +0000

Hi Ajinkya,
The spec is silent about this because this is not required. The peers and routing tables are meant to help the Diameter host to find the right peer through which the message is to be sent, not to filter incoming messages.
In addition, use of IP addresses to identify Diameter hosts may be problematic – address of a host may change, multiple hosts could be behind one IP address, etc.

Regards,

Yuval

From: DiME [mailto:[email-masked]] On Behalf Of Ajinkya Joshi
Sent: Friday, September 08, 2017 5:18 PM
To: [email-masked]
Subject: [Dime] Association between origin-host and source IP address

Hello,

It is clear from the RFC that, each diameter implementation maintains a peer table, which is keyed on origin-host of the peer.
But, it's not clear that on receiving incoming diameter request (non capability exchange), is diameter node suppose to match source IP address of incoming request with the source IP address of original transport association between these nodes?
e.g. Consider that there two transport connection established between A1 <-> B1 and A2 <-> B1, Where A1,A2, and B1 are diameter hosts. Suppose, A2 sends a diameter request to B1, with origin-host as "A1", is B1 suppose to reject such requests?

--
Regards,
Ajinkya Joshi