Subject: Re: [dispatch] draft-elwell-dispatch-identity-reqs-00 posted

From: Victor Pascual Avila <[email-masked]>
Date: Tue, 21 Jul 2009 18:17:00 +0200

As mentioned in the below message, the authors would appreciate
feedback as to whether this is helpful and going in the right
direction.

Thanks,
-Victor

2009/6/29 Elwell, John <[email-masked]>:
> There was an extensive discussion at IETF#74 on SIP Identity, where a good many views were put forward. The only consensus seemed to be to continue to discuss the topic.
>
> One of the themes during that discussion was to focus more on requirements, which the authors have attempted to do in this new draft:
> http://www.ietf.org/internet-drafts/draft-elwell-dispatch-identity-reqs-00.txt
>
> We would appreciate feedback as to whether this is helpful and going in the right direction, as well as detailed comments.
>
> I had hoped to do this a lot earlier, to trigger a discussion in time to get something set up for DISPATCH at IETF#75, but I failed, and also I failed to talk to the many of you who have interest in the topic and expressed opinions in the past. But since the deadline is approaching, I thought it best to post the draft and let discussion continue on that basis.
>
> John
>

---

From: Michael Procter <[email-masked]>
Date: Wed, 22 Jul 2009 09:10:14 +0100

Hi John,

> We would appreciate feedback as to whether this is helpful and going in the right direction, as well as detailed comments.

I think you have identified some useful fundamental properties of
caller/callee id in your requirements.  My only query is about Req 6:
"meeting similar requirements to those above" seems a little
ambiguous.  Did you intend for the calling user to receive the same
level of assurance concerning the providence of the callee ID, or
would you expect a lower level to be sufficient?

Best regards,

Michael

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 22 Jul 2009 09:31:43 +0100

Michael,

Thanks for your comment. The intention was indeed to have the same level
of assurance. I am not sure how to reword it (without reproducing all
the previous requirements and adapting them to the connected identity
case).

John

> -----Original Message-----
> From: Michael Procter [mailto:[email-masked]] 
> Sent: 22 July 2009 09:10
> To: Elwell, John
> Cc: [email-masked]
> Subject: Re: [dispatch] draft-elwell-dispatch-identity-reqs-00 posted
> 
> Hi John,
> 
> > We would appreciate feedback as to whether this is helpful 
> and going in the right direction, as well as detailed comments.
>

---

From: Michael Procter <[email-masked]>
Date: Wed, 22 Jul 2009 10:05:22 +0100

> the previous requirements and adapting them to the connected identity

Ah.  I see your problem.  Reproducing them is certainly one option,
one that at least is explicit!

How about:

   REQ6 - It MUST be possible for a calling user to receive connected
   user identification meeting corresponding requirements to those above for
   caller identification.

But it may be just me reading more flexibility into 'similar' than I should.

Michael

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 22 Jul 2009 10:30:21 +0100

OK, if there is interest in a further rev of this, I will make that
change.

John 

> Sent: 22 July 2009 10:05