Subject: Re: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 5 Aug 2009 08:15:57 +0200

Hi Francois,

As you mentioned earlier, it could make sense to allow it in 199.

Regards,

Christer 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Francois Audet
Sent: Tuesday, July 21, 2009 8:34 PM
To: [email-masked]; Gonzalo Camarillo
Cc: [email-masked]
Subject: Re: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04

and explain why 3XX, 2XX and 1XX don't make sense. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, July 20, 2009 22:03
> To: [email-masked]; Audet, Francois (SC100:3055)
> Cc: Worley, Dale (BL60:9D30); [email-masked]
> Subject: AW: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04
> 
> Hi Gonzalo,
> Thank you for your comments.
> You are correct. The used cases within the document shows where ISUP 
> causes will be included.
> I think in such cases we should clearly state that SIP Reason should 
> be excluded within SIP responses, to avoid contradictions.
> 
> Then I will include that only within 4xx/5xx/6xx Responses the Reason 
> header with an Q.850 Cause makes sense.
> 
> There are requirements and three used cases described within the draft 
> so I hope that fits.
> 
> Best Regards
> 
> Roland
> -----Ursprüngliche Nachricht-----
> Von: Gonzalo Camarillo [mailto:[email-masked]]
> Gesendet: Montag, 20. Juli 2009 11:41
> An: Francois Audet
> Cc: Dale Worley; [email-masked]; Jesske, Roland
> Betreff: Re: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04
> 
> Hi,
> 
> as Francois suggests, a document specifying the use of Reason header 
> fields in responses needs to specify those things (see Francois' list 
> below). Additionally, you should think of whether or not Reason header 
> fields in responses can carry SIP status codes and what happens if 
> they are different to the status code of the response.
> 
> In short, the document cannot simply say that now it is OK to use 
> Reason in responses. It needs to address the different situations a 
> typical implementation may face.
> 
> Cheers,
> 
> Gonzalo
> 
> 
> Francois Audet wrote:
> > Again, the spec is very clear that it IS allowed.
> > 
> > I believe the wishy-washy text about "status code
> explicitly allowing
> > it" was meant to exclude responses that were not appropriate, and 
> > restricing it to effectively error responses.
> > 
> > At the time this was written, I believe we were not clear on which 
> > codes were supposed to be appropriate or not.
> > 
> > Seems to me:
> > - Any Error response code should be allowed.
> > - I don't think 2XX makes sense.
> > - 3XX is controversial (as per the email quoted by Roland): 
> seems to me it
> >   would be quite useful
> > - Provisional is interesting... Sounds like 199 error
> response to me...
> > 
> >> -----Original Message-----
> >> From: Worley, Dale (BL60:9D30)
> >> Sent: Thursday, July 16, 2009 10:09
> >> To: Audet, Francois (SC100:3055)
> >> Cc: [email-masked]; [email-masked]
> >> Subject: RE: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04
> >>
> >> On Thu, 2009-07-16 at 12:48 -0400, Audet, Francois
> (SC100:3055) wrote:
> >>> Hi Roland,
> >>>
> >>> You use case is very common.  
> >>>
> >>> I believe you are incorrect in saying that "reasons are
> >> currently not
> >>> allowed in responses. Neither conditionally nor allowed".
> >>>
> >>> RFC 3326 says in 1.0:
> >>>   "[...] it can appear in any request
> >>>    within a dialog, in any CANCEL request and in any
> response whose
> >>>    status code explicitly allows the presence of this
> header field."
> >>>
> >>> To be honest, I believe Q.850 codes are much more common in
> >> Responses
> >>> than in requests.
> >> Googling
> >>
> >>      "sip/2.0" reason "q.850"
> >>
> >> turns up numerous examples of SIP responses using the
> Reason header
> >> in the forbidden manner.
> >>
> >> I'd say that your draft formally allows what people are
> already doing.
> >>
> >> Dale
> >>
> >>
> >>
> > _______________________________________________
> > dispatch mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/dispatch
> > 
> 
> 
_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 5 Aug 2009 10:54:34 -0500

Yes, I think so. 

> From: Christer Holmberg [mailto:[email-masked]] 
> Sent: Tuesday, August 04, 2009 23:16
> To: Audet, Francois (SC100:3055); [email-masked]; 
> Gonzalo Camarillo
> Cc: [email-masked]
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Francois Audet

---

From: <[email-masked]>
Date: Thu, 6 Aug 2009 12:28:43 +0200

Hi Christer and Francois,
I have added a sentence under section Overall Applicability:

The appearance of the Reason header is applicable to final responses 4xx, 5xx and 6xx and in addition for 199 Responses. 

Is this proper enough? Or do you have more in mind?

BR,

Roland

-----Ursprüngliche Nachricht-----
Von: Francois Audet [mailto:[email-masked]] 
Gesendet: Mittwoch, 5. August 2009 17:55
An: Christer Holmberg; Jesske, Roland; Gonzalo Camarillo
Cc: [email-masked]
Betreff: RE: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04

Yes, I think so.

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 6 Aug 2009 19:50:08 +0200

Hi,
 
>Is this proper enough? Or do you have more in mind?

I am ok with the proposed with the text. Maybe you should say "for provisional 199 responses". 

I guess it would be good to add a reference to the 199 spec also.

Regards,

Christer 

-----Ursprüngliche Nachricht-----
Von: Francois Audet [mailto:[email-masked]]
Gesendet: Mittwoch, 5. August 2009 17:55
An: Christer Holmberg; Jesske, Roland; Gonzalo Camarillo
Cc: [email-masked]
Betreff: RE: [dispatch] draft-jesske-sipping-etsi-ngn-reason-04

Yes, I think so.

---

From: "Francois Audet" <[email-masked]>
Date: Tue, 11 Aug 2009 16:16:11 -0500

Yep, sounds good. 

> Sent: Thursday, August 06, 2009 10:50
> To: [email-masked]; Audet, Francois (SC100:3055); 
> Gonzalo Camarillo
> Cc: [email-masked]
> >The appearance of the Reason header is applicable to final 
> responses 4xx, 5xx and 6xx and in addition for 199 Responses.
> >
> > To: Audet, Francois (SC100:3055); [email-masked]; Gonzalo 
> > Camarillo
> > Cc: [email-masked]