Subject: [dispatch] draft-ietf-sip-body-handling-06

From: Anders Kristensen <[email-masked]>
Date: Wed, 26 Aug 2009 21:45:28 -0700

Couple of nits on draft-ietf-sip-body-handling-06...

Sec 3.2:

    Consequently, UAs SHOULD use the binary transfer
    encoding for all payloads in SIP, including binary payloads.  The
    only case where a UA MAY use a different encoding is when
    transferring application data between applications that only handle a
    different encoding (e.g., base64).

The two sentences are disagreeing. Assuming the first sentence is 
correct (which I believe it is) then the example in the second sentence 
is not in fact the *only* case where a UA may use a different transfer 
encoding.

4.3:

    However, [RFC2046] states that a 'multipart' media type
    with a single body part is useful in some circumstances (e.g., for
    sending non-text media types).

Why even mention this. It's irrelevant for SIP, right?

8.2:

    The UA
    SHOULD also set the 'handling' parameter of all the top-level body
    part within the 'multipart/alternative' to 'optional'.

and then below it:

    The UA MUST use the same disposition type for the 'multipart/
    alternative' body and all its top-level body parts.

These two statements also seem to be in conflict with each other when 
the multipart/alternative has handling=required.

Thanks,
Anders

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 30 Aug 2009 20:54:18 +0200

This document is currently in AUTH48 in the RFC Editor Queue.

Furthermore, any discussions should be on [email-masked]

regards

Keith 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Anders Kristensen
> Sent: Thursday, August 27, 2009 5:45 AM
> To: [email-masked]
> Subject: [dispatch] draft-ietf-sip-body-handling-06
> 
> The two sentences are disagreeing. Assuming the first 
> sentence is correct (which I believe it is) then the example 
> in the second sentence is not in fact the *only* case where a 
> UA may use a different transfer encoding.
> 
> 
> 4.3:
> 
> These two statements also seem to be in conflict with each 
> other when the multipart/alternative has handling=required.
> 
> 
> Thanks,
> Anders
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>