Subject: Re: [dispatch] Domain Registration Draft draft-kaplan-dispatch-domain-registration

From: Bernard Aboba <[email-masked]>
Date: Sat, 17 Oct 2009 12:48:34 -0700

Dean Willis said:

"From a standards perspective, that's a really weak answer. If it's
already widely deployed and works just fine, why should we standardize
it?"

To be clear, the mechanism described in draft-kaplan-dispatch-domain-registration is *not* widely deployed.  However, there are other "implicit registration" approaches that are.  These include approaches implemented in SMB PBXes (not documented to my knowledge), as well as an approach proposed in 3GPP (documented).  

The SMB approach (which is implemented in Asterisk, Response Point and other SMB products) appears identical to an RFC 3261 reqistration request and response on the wire.  However, its effect at the service provider end is quite different.  Typically the state at the service provider after completion of the registration exchange is as if the provider had received "virtual" registration requests for each line, and had responded to them (although multiple responses are not seen on the wire).  However, the exact manner in which the "virtual" registration requests are synthesized from the actual registration request is determined by the service provider, and may differ between providers.  For example, the registration request from which the "virtual registrations" are derived may first be subject to transformations such as those used in "far end nat traversal".  As a result, a given registration request may not be transformed into the same set of "virtual registration" requests by every service provider.

---

From: François AUDET <[email-masked]>
Date: Sat, 17 Oct 2009 16:20:50 -0700

Correct, since the draft actually doesn't actually define a mechanism.

Implicit domain registration (with an arbitrary AOR) is widely  
deployed, both inside enterprises, as well as between an enterprise  
and a service provider.

And not just for SMB.

On Oct 17, 2009, at 12:48 , Bernard Aboba wrote:

> already widely deployed and works just fine, why should we  
> standardize it?"
>
> To be clear, the mechanism described in draft-kaplan-dispatch-domain- 
> registration is *not* widely deployed.  However, there are other  
> "implicit registration" approaches that are.  These include  
> approaches implemented in SMB PBXes (not documented to my  
> knowledge), as well as an approach proposed in 3GPP (documented).
>
> The SMB approach (which is implemented in Asterisk, Response Point  
> and other SMB products) appears identical to an RFC 3261  
> reqistration request and response on the wire.  However, its effect  
> at the service provider end is quite different.  Typically the state  
> at the service provider after completion of the registration  
> exchange is as if the provider had received "virtual" registration  
> requests for each line, and had responded to them (although multiple  
> responses are not seen on the wire).  However, the exact manner in  
> which the "virtual" registration requests are synthesized from the  
> actual registration request is determined by the service provider,  
> and may differ between providers.  For example, the registration  
> request from which the "virtual registrations" are derived may first  
> be subject to transformations such as those used in "far end nat  
> traversal".  As a result, a given registration request may not be  
> transformed into the same set of "virtual registration" requests by  
> every service provider.
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch