Subject: [dispatch] Domain Registration: semantics of REGISTER

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 15 Oct 2009 16:25:01 -0400

Two people have now commented that using a REGISTER method for the purposes of Domain Registration changes the semantics of REGISTER.  My answer to that is "maybe", and "so what?".  The reason we'd like an options-tag is specifically because this *is* an extension, and we'd like to keep it clean/separate from "normal" REGISTERs.

There are *some* semantics of REGISTER that *are* identical:
1) The REGISTER is providing reachability information for subsequent SIP request routing purposes.
2) The REGISTER includes additional reachability detail in Path and SIP-Outbound-related fields.
3) The duration of the information has a lifetime (i.e., expires).
4) The information in the To-URI identifies the target to be reached.
5) The REGISTER's response may include additional detail for subsequent routing purposes through a Service-Route header field.

But, it's also different in that:
a) The reachability information pertains to a whole domain, not just one AoR.
b) The document, as written, defines a new, separate logical table from that of AoR's, which gets updated instead.
c) The document, as written, defines a Route-header-based routing mechanism using that table, instead of request-uri replacement a la 3261.

At the end of the day, sure we could go write up a new event-package and use PUBLISH to do this thing instead (because one could argue REGISTER is just a specific form of a PUBLISH for the "aor-location" package).  But then we'd have to get SIP-outbound, Path, Service-Route, and so on for this new PUBLISH package.  And what would be the point?  How would that make it more or less interoperable?

-hadriel

---

From: Dean Willis <[email-masked]>
Date: Thu, 15 Oct 2009 16:49:16 -0500

> a) The reachability information pertains to a whole domain, not just  

As the use case has been explained to me, it's not even a domain that  
it pertains to; it's a mass off direct-inward-dial telephone numbers.

Note that REGISTER never worked right for telephone numbers anyhow --  
we kludged it by faking phone numbers inside SIP URIs.

--
Dean

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 15 Oct 2009 18:16:55 -0400

Inline...

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Thursday, October 15, 2009 5:49 PM
> To: Hadriel Kaplan
> Cc: [email-masked]
> Subject: Re: [dispatch] Domain Registration: semantics of REGISTER
> 
> 

The biggest use-case is undoubtedly for phone numbers.  I would argue that's the biggest use-case for any extension/use of REGISTER and INVITEs, and for SIP in general really, currently.

But luckily it doesn't matter.  The Domain Registration really is providing reachability for the domain, no matter its use-case.  If you send a SIP request to "sip:[email-masked]" to ssp.com, and enterprise.com had Registered its reachability info into ssp.com, then ssp.com will route the request to enterprise.com using that Registered info.

Obviously for DID numbers which are AoR's of another domain (like the SSP's domain), the SSP can have local policy retargeting rules for all those DID's which retarget them to another domain, like the Enterprise's.  That's just normal 3261, nothing to see there.  

-hadriel