Subject: [dispatch] Requesting DISPATCH advice on draft-haluska-sipping-directory-assistance-09

From: "Haluska, John J" <[email-masked]>
Date: Mon, 26 Oct 2009 16:08:15 -0400

Hello All,

We've been discussing with Cullen an AD-sponsored path for draft-haluska-sipping-directory-assistance.  Having received an extensive review from Spencer Dawkins (thanks Spencer), one comment was that we should consider breaking up the 100+ page document into several more manageable documents, potentially organized into e.g.,

                - a description of the services
                - a description of standards gaps
                - a set of call flows
                - a set of best current practices

Cullen suggested that we talk to the DISPATCH working group to see what kind of split makes sense, he was thinking that possibly some material (e.g., protocol gaps) might have the potential to become the basis of future work in DISPATCH or other working groups.

We'd definitely appreciate any advice on this from the DISPATCH working group. A pointer to the announcement for the latest revision (-09) of the document is provided below.

Again the input we're looking for is advice on splitting up the document.

Thanks much,

John Haluska

 = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =
From: [email-masked]
To: [email-masked]
Reply-to: [email-masked]
Subject: I-D Action:draft-haluska-sipping-directory-assistance-09.txt
X-RSN: 1/0/935/27107/30454
X-HREF: http://www.ietf.org/ibin/c5i?mid=6&rid=49&k1=935&k2=30454

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title : Considerations for Information Services and Operator Services Using SIP
Author(s) : J. Haluska, et al.
Filename : draft-haluska-sipping-directory-assistance-09.txt
Pages : 109
Date : 2009-10-23

Information Services are services whereby information is provided in
response to user requests, and may include involvement of a human or
automated agent. A popular existing Information Service is Directory
Assistance (DA). Moving ahead, Information Services providers
envision exciting multimedia services that support simultaneous
voice and data interactions with full operator backup at any time
during the call. Information Services providers are planning to
migrate to SIP based platforms, which will enable such advanced
services, while continuing to support traditional DA services.

Operator Services are traditional PSTN services which often involve
providing human or automated assistance to a caller, and often
require the specialized capabilities traditionally provided by an
operator services switch. Market and/or regulatory factors in some
jurisdictions dictate that some subset of Operator Services continue
to be provided going forward.

This document aims to identify how Operator and Information Services
can be implemented using existing or currently proposed SIP
mechanisms, to identity existing protocol gaps, and to provide a set
of Best Current Practices to facilitate interoperability. For
Operator Services, the intention is to describe how current operator
services can continue to be provided to PSTN based subscribers via a
SIP based operator services architecture. It also looks at how
current operator services might be provided to SIP based subscribers
via such an architecture, but does not consider the larger question
of the need for or usefulness or suitability of each of these
services for SIP based subscribers.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-haluska-sipping-directory-assistance-09.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

*****
Click below to download the attachment(s) in this message:
Attachment: draft_haluska_sipping_directory_assistance_09.txt<http://www.ietf.org/bin/c5i?mid=6&gid=0&rid=8&k1=935&file=i-d-announce.30454.1.txt> (1K)

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 26 Oct 2009 16:25:58 -0400

Haluska, John J wrote:
> Hello All,
> 
>  
> 
> We’ve been discussing with Cullen an AD-sponsored path for 
> draft-haluska-sipping-directory-assistance.  Having received an 
> extensive review from Spencer Dawkins (thanks Spencer), one comment was 
> that we should consider breaking up the 100+ page document into several 
> more manageable documents, potentially organized into e.g.,
> 
>  
> 

That kind of a split sounds sensible to me.
It also strikes me that this is starting to sound like a Bliss kind of 
thing.

	Thanks,
	Paul

> Cullen suggested that we talk to the DISPATCH working group to see what 
> kind of split makes sense, he was thinking that possibly some material 
> (e.g., protocol gaps) might have the potential to become the basis of 
> future work in DISPATCH or other working groups.
> 
>  
> 
> We’d definitely appreciate any advice on this from the DISPATCH working 
> group. A pointer to the announcement for the latest revision (-09) of 
> the document is provided below.
> 
>  
> 
> Again the input we’re looking for is advice on splitting up the document.
> 
>  
> 
>  
> 
> Thanks much,
> 
>  
> 
> John Haluska
> 
>  
> 
>  
> 
>  
> 
>  
> 
>  
> 
> Attachment: draft_haluska_sipping_directory_assistance_09.txt 
> <http://www.ietf.org/bin/c5i?mid=6&gid=0&rid=8&k1=935&file=i-d-announce.30454.1.txt> 
> (1K) 
> 
> 
> ------------------------------------------------------------------------
> 
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 26 Oct 2009 15:43:02 -0500

One minor addition to John's summary - I had some concerns about handling people 100+ page documents, but I've gotten 100+ page documents as a Gen-ART reviewer. I'm remembering PIM (which I got) and NFS4 (which I did NOT get) as case studies...

My larger concern was that some of the material was clearly descriptive text (INFO), some was tagged as BCP, and some was headed towards protocol gap analysis and solution (PS) - I thought a document split would help reviewers focus on the kind of review that's needed for specific parts of the proposal.

So please do provide feedback on possible splits, and whether this is helpful - nobody wants to make a serious editorial pass if it's not necessary!

Thanks,

Spencer
  ----- Original Message ----- 
  From: Haluska, John J 
  To: [email-masked] 
  Cc: [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; Haluska, John J 
  Sent: Monday, October 26, 2009 3:08 PM
  Subject: Requesting DISPATCH advice on draft-haluska-sipping-directory-assistance-09 

  Hello All,

                  - a set of call flows

   

  Thanks much,

  John Haluska

   

   

   

   

  ***** 
  Click below to download the attachment(s) in this message: 
  Attachment: draft_haluska_sipping_directory_assistance_09.txt (1K)

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 27 Oct 2009 14:13:07 +0100

When I see all the things that this includes, much of it normative in  
behavior, I don't think AD sponsoring is a route we should take.

Cullen <RAI AD>

On Oct 26, 2009, at 21:08 , Haluska, John J wrote:

> Hello All,
>
> We’ve been discussing with Cullen an AD-sponsored path for draft- 
> haluska-sipping-directory-assistance.  Having received an extensive  
> review from Spencer Dawkins (thanks Spencer), one comment was that  
> we should consider breaking up the 100+ page document into several  
> Cullen suggested that we talk to the DISPATCH working group to see  
> what kind of split makes sense, he was thinking that possibly some  
> material (e.g., protocol gaps) might have the potential to become  
> the basis of future work in DISPATCH or other working groups.
>
> We’d definitely appreciate any advice on this from the DISPATCH  
> working group. A pointer to the announcement for the latest revision  
> (-09) of the document is provided below.
>