Subject: [dispatch] E2M: Find a proper home for draft-hoeneisen-e164-to-metadata-01.txt

From: Bernie Hoeneisen <[email-masked]>
Date: Tue, 15 Dec 2009 17:57:36 +0100 (CET)

Hi DISPATCH

E.164 to Metadata (E2M) defines a new DDDS application for all the 
services that do not fit into the original ENUM concept, but still are
relevant in today's deployments, such as 'cnam', 'unused' or 'send-n'.

draft-hoeneisen-e164-to-metadata decribes how E2M can resolve the 
issues with certain ENUM WG documents that are currently locked in the 
publication queue.

The sheperding AD (Cullen) does not see E2M happening in the ENUM WG, as 
he intends to shut down the ENUM WG. He advised me to send this proposal 
to the DISPATCH WG and task DISPATCH to find a proper home for this work.

Several people generally support to E2M proposal, however, some details of 
the E2M proposal still need more work.

So lets find soon a proper home for E2M!

cheers,
  Bernie

PS (to ENUM mailing list subscribers):
Since -01 the E2M discussion has moved from the ENUM to the DISPATCH 
mailing list. Those of you who are only subscribed to the ENUM mailing 
list, please subscribe also to the DISPATCH mailing list 
<https://www.ietf.org/mailman/listinfo/dispatch> and send your comments to 
<[email-masked]> (only).

PPS (to those of you, who reply to this email):
Please remove <[email-masked]> from the destination list of your replies to 
avoid crossposting.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
Sent: Monday, December 14, 2009 4:45 PM
To: [email-masked]
Subject: I-D ACTION:draft-hoeneisen-e164-to-metadata-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

 	Title		: E.164 to Metadata (E2M) Dynamic Delegation
Discovery System (DDDS) Application
 	Author(s)	: B. Hoeneisen
 	Filename	: draft-hoeneisen-e164-to-metadata-01.txt
 	Pages		: 14
 	Date		: 2009-12-14

This document proposes a new Dynamic Delegation Discovery System
    (DDDS) Application to map E.164 numbers to metadata.

    It discusses the use of the Domain Name System (DNS) for resolving
    E.164 numbers into metadata to provide information about E.164
    numbers in cases where E.164 Number to URI Mapping (ENUM) can not be
    used.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hoeneisen-e164-to-metadata-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Richard Shockey" <[email-masked]>
Date: Tue, 15 Dec 2009 12:50:58 -0500

And as the ENUM WG co-chair (for now) I wholeheartedly support this idea.

>  From: [email-masked] [mailto:[email-masked]] On Behalf
>  Of Bernie Hoeneisen
>  Sent: Tuesday, December 15, 2009 11:58 AM
>  To: IETF DISPATCH list
>  Cc: IETF ENUM list
>  Subject: [Enum] E2M: Find a proper home for draft-hoeneisen-e164-to-
>  metadata-01.txt
>  
>  Hi DISPATCH
>  
>  _______________________________________________
>  enum mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/enum

---

From: Bernie Hoeneisen <[email-masked]>
Date: Tue, 15 Dec 2009 19:36:32 +0100 (CET)

Hi Tony

Thanks for bringing this up.

I am all for coordination with other SDOs, if there are 
(inter-)dependencies, overlap, similar work or whatsover.

However, I fail to see the relevance of the ITU-T SG 17 with respect to 
the E2U proposal. Could you please explain a bit more what you believe 
are the touch points of E2U and ITU-T SG 17 (in particular IdM)?

cheers,
  Bernie

On Tue, 15 Dec 2009, Tony Rutkowski wrote:

> Hi Bernie,
>
> Since Rec. ITU-T E.164 is ITU-T's standard and they
> are significantly engaged in IdM standards activities in
> SG17, this should probably be coordinated with them.
> Although it might be regarded as apostasy by some IETFers,
> it might even be done together with them.
>
> cheers,
> tony
>
>> Hi DISPATCH
>> 
>> E.164 to Metadata (E2M) defines a new DDDS application for all the services 
>> that do not fit into the original ENUM concept, but still are
>> draft-hoeneisen-e164-to-metadata decribes how E2M can resolve the issues 
>> with certain ENUM WG documents that are currently locked in the publication 
>> queue.
>> 
>> The sheperding AD (Cullen) does not see E2M happening in the ENUM WG, as he 
>> intends to shut down the ENUM WG. He advised me to send this proposal to 
>> the DISPATCH WG and task DISPATCH to find a proper home for this work.
>>

---

From: Tony Rutkowski <[email-masked]>
Date: Tue, 15 Dec 2009 13:11:46 -0500

Hi Bernie,

cheers,
tony

> The sheperding AD (Cullen) does not see E2M happening in the ENUM WG, 
> as he intends to shut down the ENUM WG. He advised me to send this 
> proposal to the DISPATCH WG and task DISPATCH to find a proper home 
> for this work.
>
> Several people generally support to E2M proposal, however, some 
> details of the E2M proposal still need more work.
>
> <https://www.ietf.org/mailman/listinfo/dispatch> and send your 
> comments to <[email-masked]> (only).
>
>
> Please remove <[email-masked]> from the destination list of your 
> replies to avoid crossposting.
>
>
>
>

---

From: Tony Rutkowski <[email-masked]>
Date: Tue, 15 Dec 2009 14:10:11 -0500

Hi Bernie,

SG17 is the home within ITU-T (among other things)
of security metadata work.  This includes, for example,
pointers from OIDs to metadata where a variant of ENUM
is being used in conjunction with that namespace.

There is an active sub-group dedicated to Identity Management
known as Q.10/17.  Substantial discussions have occurred over
the past two  years on how an IdM trusted interoperability model
(now adopted as X.1250) that includes obtaining metadata
associated with network application identifiers like E.164.
This has included SG2 which is explicitly responsible for
E.164, and international cnam capabilities.  Toward this end,
we are collaborating with the CAB Forum to adopt the
EVcert specification as an ITU-T standard to enhance the
trust in provider metadata, among other things.

I've copied the chair and co-chairs that group, Abbie
Barbir and Dick Brackney, respectively.  Ultimately this
is their call at the ITU-T end.

Hope this helps,
--tony

On 12/15/2009 1:36 PM, Bernie Hoeneisen wrote:
> However, I fail to see the relevance of the ITU-T SG 17 with respect 
> to the E2U proposal. Could you please explain a bit more what you 
> believe are the touch points of E2U and ITU-T SG 17 (in particular IdM)?
>
> cheers,
>  Bernie
>
>
>>> issues with certain ENUM WG documents that are currently locked in 
>>> the publication queue.
>>>
>>> The sheperding AD (Cullen) does not see E2M happening in the ENUM 
>>> WG, as he intends to shut down the ENUM WG. He advised me to send 
>>> this proposal to the DISPATCH WG and task DISPATCH to find a proper 
>>> home for this work.
>>>
>>> mailing list. Those of you who are only subscribed to the ENUM 
>>> mailing list, please subscribe also to the DISPATCH mailing list

---

From: "Richard Shockey" <[email-masked]>
Date: Tue, 15 Dec 2009 14:35:18 -0500

Thanks Tony ... I appreciate this note. Its just one more justification for
properly advancing this e2m concept.

>  From: [email-masked] [mailto:[email-masked]] On
>  Behalf Of Tony Rutkowski
>  Sent: Tuesday, December 15, 2009 2:10 PM
>  To: Bernie Hoeneisen
>  Cc: Georges Sebek; IETF DISPATCH list; abbie barbir; Richard Brackney
>  Subject: Re: [dispatch] [Enum] E2M: Find a proper home for draft-
>  hoeneisen-e164-to-metadata-01.txt
>  
>  Hi Bernie,
>  
>  dispatch mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/dispatch

---

From: "abbie barbir" <[email-masked]>
Date: Wed, 16 Dec 2009 03:23:13 -0500

Hi
Tony many thanks for the e-mail
I would welcome this activity to be submitted and discussed in Q10/17

Please let me know how I can be of any further help
Regards
Abbie

-----Original Message-----
From: Richard Shockey [mailto:[email-masked]] 
Sent: December-15-09 2:35 PM
To: [email-masked]; 'Bernie Hoeneisen'
Cc: 'Georges Sebek'; 'IETF DISPATCH list'; 'abbie barbir'; 'Richard
Brackney'; 'Cullen Jennings'
Subject: RE: [dispatch] [Enum] E2M: Find a proper home for
draft-hoeneisen-e164-to-metadata-01.txt

>  >>> implementation to automatically retrieve the ASCII version of the

No virus found in this incoming message.
Checked by AVG - www.avg.com 
Version: 9.0.716 / Virus Database: 270.14.105/2562 - Release Date: 12/14/09
14:40:00