Subject: [dispatch] Session recording charter proposal

From: Gonzalo Camarillo <[email-masked]>
Date: Sun, 06 Dec 2009 14:06:42 +0200

Folks,

the proponents of the session recording topic have updated their charter 
proposal per the discussions in Hiroshima (see attachment). We intend to 
discuss this charter with our ADs shortly. Let us know if you have any 
comments on the updated charter.

Thanks,

Gonzalo
DISPATCH co-chair

Session Recording Protocol - Working Group Charter

The Session Recording Protocol (SRP) working group is chartered to define a SIP-based protocol 
for controlling a session (media) recorder.

Session recording is a critical requirement in many business communications environments such 
as call centers and financial trading floors.  In some of these environments, all calls must 
be recorded for regulatory and compliance reasons.  In others, calls may be recorded for quality 
control, business analytics, or consumer protection.  Recording is typically done by sending a 
copy of the media to the recording devices.  The working group will determine requirements and 
produce a specification for a protocol that will manage delivery of media from an end-point that 
originates media, or that has access to it, to a recording device. PBX and recording vendors 
today implement proprietary, incompatible mechanisms to facilitate recording. A standard protocol 
will reduce the complexity and cost of providing such recording services.

The Session Recording problem presents certain unique requirements that are not addressed in the 
current SIP protocol specification. These include requirements such as the need for a distinction 
between the session that is being recorded versus the session that has been established for recording.

Privacy and security of conversations are significant concerns. The working group will make sure 
that any protocol specified addresses these concerns and provides mechanisms to alert users to 
the fact that a session they are particpating in is being recorded.

The working group must take care that the session recording requirments and protocol does not 
conflict with the IETF statement on wiretapping contained in RFC 2804.

The SRP Working Group will thoroughly identify use cases, provide example system architectures 
and deployment scenarios, and define requirements.

The scope of the activity includes:

  * Recorder Control
  * Session metadata content and format
  * Security mechanisms, including transport and media encryption
  * Privacy concerns, including end-user notification
  * Negotiation of recording media streams

The group will define these issues and rationalize with IETF standards and practices. This includes 
encryption, NAT traversal, SIP-enabled firewalls, authorization, and security.

The group will produce:

  * Updated Requirements, Use Cases, Architecture draft
  * Specification for Session Recording Protocol

Timeline:

   Apr 2010   Use Cases and Requirements to IESG as Informational Draft

   Nov 2010   Architecture to IESG as Informational Draft

   Nov 2010   Submit protocol draft to IESG as standards track

---

From: Francois AUDET <[email-masked]>
Date: Sun, 6 Dec 2009 07:12:47 -0800

Looks good to me.

On Dec 6, 2009, at 4:06, Gonzalo Camarillo <[email-masked] 
 > wrote:

> Folks,
>
> the proponents of the session recording topic have updated their  
> charter proposal per the discussions in Hiroshima (see attachment).  
> We intend to discuss this charter with our ADs shortly. Let us know  
> if you have any comments on the updated charter.
>
> Thanks,
>
> Gonzalo
> DISPATCH co-chair
>
>
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Victor Pascual Avila <[email-masked]>
Date: Sun, 6 Dec 2009 16:50:46 +0100

+1
-Victor

On Sunday, December 6, 2009, Francois AUDET <[email-masked]> wrote:
>
> Looks good to me.
>
>
> On Dec 6, 2009, at 4:06, Gonzalo Camarillo <[email-masked]> wrote:
>
>
> Folks,
>
> the proponents of the session recording topic have updated their charter proposal per the discussions in Hiroshima (see attachment). We intend to discuss this charter with our ADs shortly. Let us know if you have any comments on the updated charter.
>
> Thanks,
>
> Gonzalo
> DISPATCH co-chair
>
>
>
>

-- 
Victor Pascual Ávila

---

From: Peter Musgrave <[email-masked]>
Date: Mon, 7 Dec 2009 08:05:13 -0500

n++;

Peter

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Mon, 07 Dec 2009 12:49:10 -0600

> n++;

/me fails at coming up with an even-cleverer metaphor for expressing
agreement

n++;

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
skype: kpfleming | jabber: [email-masked]
Check us out at www.digium.com & www.asterisk.org