Subject: Re: [dispatch] Revised proposed charter for Combining SIP and XMPP

From: <[email-masked]>
Date: Fri, 8 Jan 2010 13:25:16 +0100

Hello,

I had an offline email exchange with Roni during which he mentioned that he would be fine with the charter text as it currently stands.

The other concern that was raised by Emil was on using shared credentials for SIP and XMPP authentication. My conclusion seemed to be that the current charter text would be ok, but we can still document such a feature during the protocol specification phase if that is deemed useful.

If my understanding is correct, and unless there are other comments to the charter proposal, it is good to go. Please let us know asap if there is still something you would like to comment.

Regards,
Simo

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On
>Behalf Of ext Roni Even
>Sent: 17 December, 2009 14:58
>To: Veikkolainen Simo (Nokia-D/Helsinki); [email-masked]
>Cc: [email-masked]
>Subject: Re: [dispatch] Revised proposed charter for Combining SIP and
>XMPP
>
>Simo,
>The other user has two endpoints, one is a video conferencing appliance
>and
>the other is a PC running XMPP client. The user will register his XMPP
>and
>SIP capability using the two endpoints in the infrastructure
>Roni
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of [email-masked]
>> Sent: Thursday, December 17, 2009 2:34 PM
>> To: [email-masked]; [email-masked]
>> Cc: [email-masked]
>> Subject: Re: [dispatch] Revised proposed charter for Combining SIP and
>> XMPP
>>
>> Roni,
>>
>> >> A "dual stack" SIP/XMPP client should be able to talk SIP to a SIP-
>> >only
>> >> endpoint and XMPP to an XMPP-only endpoint. What is that you need
>in
>> >> addition to this?
>> >The dual stack client need to know that these two clients are the
>same
>> >user. For example start a XMPP chat and add the SIP video call. This
>> is
>> >not advertised by the remote XMPP client but by the infrastructure.
>> >
>> >From the other direction (two systems) it will involve starting chat
>> >from XMPP and adding SIP video to the call by the XMPP client for
>> >example by telling the other side or the SIP server to call the his
>> SIP
>> >client on the appliance.
>> >
>>
>> Let me see if I understood you correctly. It sounds you are looking
>for
>> two use cases:
>>
>> 1) to add SIP voice/video or XMPP chat from an integrated endpoint
>even
>> though the other endpoint is SIP-only or XMPP-only
>>
>> 2) to add SIP voice/video or XMPP chat from a XMPP-only or SIP-only
>> endpoint, respectively.
>>
>> For 2), I don't see how that is possible without changes in the client
>> side.
>>
>> For 1), you would need to be able, from a "dual stack" endpoint, to
>> tell the XMPP server to start an XMPP session, or the SIP server to
>> make a SIP call to the same user you already have a SIP or XMPP
>session
>> with. While probably doable, this is not what we had in mind for this
>> work.
>>
>> Simo
>> _______________________________________________
>> dispatch mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dispatch
>
>_______________________________________________
>dispatch mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dispatch

---

From: Emil Ivov <[email-masked]>
Date: Fri, 08 Jan 2010 13:43:35 +0100

Hey Simo,

[email-masked] написа:
> Hello,
> 
> I had an offline email exchange with Roni during which he mentioned
> that he would be fine with the charter text as it currently stands.
> 
> The other concern that was raised by Emil was on using shared
> credentials for SIP and XMPP authentication. My conclusion seemed to
> be that the current charter text would be ok, but we can still
> document such a feature during the protocol specification phase if
> that is deemed useful.

This was also my understanding and it would indeed address my concern.

Cheers,
Emil

> 
> If my understanding is correct, and unless there are other comments
> to the charter proposal, it is good to go. Please let us know asap if
> there is still something you would like to comment.
> 
> Regards, Simo
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of ext Roni Even Sent:
>> 17 December, 2009 14:58 To: Veikkolainen Simo (Nokia-D/Helsinki);
>> [email-masked] Cc: [email-masked] Subject: Re:
>> [dispatch] Revised proposed charter for Combining SIP and XMPP
>> 
>> Simo, The other user has two endpoints, one is a video conferencing
>> appliance and the other is a PC running XMPP client. The user will
>> register his XMPP and SIP capability using the two endpoints in the
>> infrastructure Roni
>> 
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of
>>> [email-masked] Sent: Thursday, December 17, 2009
>>> 2:34 PM To: [email-masked]; [email-masked] Cc:
>>> [email-masked] Subject: Re: [dispatch] Revised proposed
>>> charter for Combining SIP and XMPP
>>> 
>>> Roni,
>>> 
>>>> From the other direction (two systems) it will involve starting
>>>> chat from XMPP and adding SIP video to the call by the XMPP
>>>> client for example by telling the other side or the SIP server
>>>> to call the his
>>> SIP
>>>> client on the appliance.
>>>> 
>>> 2) to add SIP voice/video or XMPP chat from a XMPP-only or
>>> SIP-only endpoint, respectively.
>>> 
>>> For 2), I don't see how that is possible without changes in the
>>> client side.
>>> 
>>> For 1), you would need to be able, from a "dual stack" endpoint,
>>> to tell the XMPP server to start an XMPP session, or the SIP
>>> server to make a SIP call to the same user you already have a SIP
>>> or XMPP
>> session
>>> with. While probably doable, this is not what we had in mind for
>>> this work.
>>> 
>>> Simo _______________________________________________ dispatch
>>> mailing list [email-masked] 
>> _______________________________________________ dispatch mailing
>> list [email-masked] 

-- 
Emil Ivov, Ph.D.                               67000 Strasbourg,
Project Lead                                   France
SIP Communicator
[email-masked]                     PHONE: +33.1.77.62.43.30
http://sip-communicator.org                    FAX:   +33.1.77.62.47.31