Subject: [dispatch] Charter Proposal: Verification Involving PSTN Reachability (VIPR)

From: Cullen Jennings <[email-masked]>
Date: Tue, 1 Jun 2010 10:55:16 -0600

I've been talking to a lot of people about the VIPR drafts  - here is a first cut of a proposal for a WG that could do this. I'm sure the charter proposal needs a bunch of work but I wanted to get the discussion rolling on the list. 

Thanks, Cullen 

(PS - this is sent in my individual contributor role. Take all my posts about VIPR to be in my individual role not my co-chair role)

-------------------------------------------------------

ViPR Charter Proposal (Version 0)

WG Name:  Verification Involving PSTN Reachability (VIPR)

There are two globally deployed address spaces for communications that more than a billion people use on a daily basis. They are phone numbers and DNS rooted address such as web servers and email addresses. The federation design of SIP is primarily designed for email style addresses yet a large percentage of SIP deployments primarily use phone numbers for identifying users. The goal of this working group is to allows people to use SIP to federate over the the internet while still using phone numbers to identify the person they wish to communicate with. 

The VIPR WG will address this problem by developing a peer to peer based approach to finding SIP domains that claim to be responsible for a given phone number and the WG will design validation protocols to ensure a reasonable likelihood that a given domain actually is responsible for the phone number. One initial validation protocol will be based on a domain being able to prove it received a particular phone call over the PSTN based on both sides knowing the start and stop times of that call. Other validation schemes, such as examining fingerprints or watermarking of PSTN media, to show that a domain received a particular PSTN phone call may be considered by the working group. To help mitigate SPAM over SIP issues, the WG will define an token based authorization scheme so that domain using SIP to federate can choose to check that incoming SIP calls are from a domain that successfully validated a phone number. 

The problem statement and some possible starting points for solutions are further desired in the following internet drafts which shall form the bases of the WG documents:
draft-rosenberg-dispatch-vipr-overview
draft-rosenberg-dispatch-vipr-reload-usage
draft-rosenberg-dispatch-vipr-pvp
draft-rosenberg-dispatch-vipr-sip-antispam

The working group will carefully coordinate with the security area, O&M area, as well as the appropriate RAI WG including sipcore and p2psip.

---

From: "Muthu ArulMozhi Perumal (mperumal)" <[email-masked]>
Date: Tue, 1 Jun 2010 23:42:06 +0530

|The goal of this working group is to allows people to use SIP to
|federate over the the internet while still using phone numbers to 
|identify the person they wish to communicate with.

Do we want to use phone numbers as the only way to identify persons or
allow people to use phone numbers as one of the ways to identify
persons?

If it is the later, should we reword "still using phone numbers to
identify" as "still allowing phone numbers to identify"?

thanks,
Muthu           

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On
Behalf
|Of Cullen Jennings (fluffy)
|Sent: Tuesday, June 01, 2010 10:25 PM
|To: DISPATCH list
|Subject: [dispatch] Charter Proposal: Verification Involving
|PSTNReachability (VIPR)
|
|
|I've been talking to a lot of people about the VIPR drafts  - here is a
|first cut of a proposal for a WG that could do this. I'm sure the
charter
|proposal needs a bunch of work but I wanted to get the discussion
rolling on
|the list.
|
|Thanks, Cullen
|
|(PS - this is sent in my individual contributor role. Take all my posts
|about VIPR to be in my individual role not my co-chair role)
|
|-------------------------------------------------------
|
|ViPR Charter Proposal (Version 0)
|
|WG Name:  Verification Involving PSTN Reachability (VIPR)
|
|There are two globally deployed address spaces for communications that
more
|than a billion people use on a daily basis. They are phone numbers and
DNS
|rooted address such as web servers and email addresses. The federation
|design of SIP is primarily designed for email style addresses yet a
large
|percentage of SIP deployments primarily use phone numbers for
identifying
|users. The goal of this working group is to allows people to use SIP to
|federate over the the internet while still using phone numbers to
identify
|the person they wish to communicate with.
|
|The VIPR WG will address this problem by developing a peer to peer
based
|approach to finding SIP domains that claim to be responsible for a
given
|phone number and the WG will design validation protocols to ensure a
|reasonable likelihood that a given domain actually is responsible for
the
|phone number. One initial validation protocol will be based on a domain
|being able to prove it received a particular phone call over the PSTN
based
|on both sides knowing the start and stop times of that call. Other
|validation schemes, such as examining fingerprints or watermarking of
PSTN
|media, to show that a domain received a particular PSTN phone call may
be
|considered by the working group. To help mitigate SPAM over SIP issues,
the
|WG will define an token based authorization scheme so that domain using
SIP
|to federate can choose to check that incoming SIP calls are from a
domain
|that successfully validated a phone number.
|
|The problem statement and some possible starting points for solutions
are
|further desired in the following internet drafts which shall form the
bases
|of the WG documents:
|draft-rosenberg-dispatch-vipr-overview
|draft-rosenberg-dispatch-vipr-reload-usage
|draft-rosenberg-dispatch-vipr-pvp
|draft-rosenberg-dispatch-vipr-sip-antispam
|
|The working group will carefully coordinate with the security area, O&M
|area, as well as the appropriate RAI WG including sipcore and p2psip.
|
|
|_______________________________________________
|dispatch mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/dispatch

---

From: Peter Musgrave <[email-masked]>
Date: Tue, 1 Jun 2010 14:28:17 -0400

Hi Cullen,

Does the charter need to say anything explicitly about not relying on
any of the work which uses ENUMs in DNS as a way of associating SIP
endpoints and IP addresses?

AFAIK ViPR is about *using* a SIP call to determine a path to the
endpoint (however that happens to work).

Does the charter need to stipulate that the mapping from a PSTN number
to a SIP device is a one-to-one mapping? Does there need to be text
about how multiple endpoints which are behind a border device (and all
appear as the same PSTN number) are to be handled?.

ViPR so far describes an "edge-device" approach. Is the charter
restricted to this approach?

Thanks,

Peter Musgrave

On Tue, Jun 1, 2010 at 12:55 PM, Cullen Jennings <[email-masked]> wrote:
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 01 Jun 2010 15:08:55 -0400

> endpoint (however that happens to work).

As I understand it, the new WG is about coming up with technique(s) that 
work and are deployable in the real world. While in principle public 
ENUM could be used for this, in practice it isn't deployed and so isn't 
really usable. The technique of using a pstn call to determine the path 
is one technique that is demonstrably deployable.

> appear as the same PSTN number) are to be handled?.

IIUC, its likely to be a server responsible for a phone number AOR that 
will participate in ViPR, rather than individual phone devices. 
Certainly there can be additional routing after a ViPR call reaches that 
server. Typically there will only be one of those, or a cooperative 
cluster of them sharing the same DNS name or ip address. That is really 
no different than normal sip routing to AORs.

Also, AFAIK it doesn't have to be 1:1.
Multiple claims can be made for ownership of a phone number. If calls to 
them can be verified, then they can all be valid candidates for calls to 
that number. (However, this will logistically be hard to accomplish.)

	Thanks,
	Paul

---

From: Deepanshu Gautam <[email-masked]>
Date: Wed, 02 Jun 2010 15:49:33 +0800

Should there be a set of deliverables  what this WG is intending for? Or the
draft mentioned are actually the deliverables for this WG.

>The goal of this working group is to allows people to use SIP to federate
over the the internet while still using phone numbers to identify the person
they wish to communicate with.

I would suggest to emphasize(for clarity) that the federation being refered
here is the *across-domain* federation (although, some wise guys can figure
it out with *over the interent* :-))

Does charter have to say that, some extensions(headers, option-tag, ...) to
SIP are invisioned e.g for transfering a piece-of-information meant to
authorize particular domain to contact a particuar phone number?

Regards
Deepanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Cullen Jennings
Sent: 2010年6月2日 0:55
To: DISPATCH list
Subject: [dispatch] Charter Proposal: Verification Involving PSTN
Reachability (VIPR)

I've been talking to a lot of people about the VIPR drafts  - here is a
first cut of a proposal for a WG that could do this. I'm sure the charter
proposal needs a bunch of work but I wanted to get the discussion rolling on
the list. 

Thanks, Cullen 

(PS - this is sent in my individual contributor role. Take all my posts
about VIPR to be in my individual role not my co-chair role)

There are two globally deployed address spaces for communications that more
than a billion people use on a daily basis. They are phone numbers and DNS
rooted address such as web servers and email addresses. The federation
design of SIP is primarily designed for email style addresses yet a large
percentage of SIP deployments primarily use phone numbers for identifying
users. The goal of this working group is to allows people to use SIP to
federate over the the internet while still using phone numbers to identify
the person they wish to communicate with. 

The VIPR WG will address this problem by developing a peer to peer based
approach to finding SIP domains that claim to be responsible for a given
phone number and the WG will design validation protocols to ensure a
reasonable likelihood that a given domain actually is responsible for the
phone number. One initial validation protocol will be based on a domain
being able to prove it received a particular phone call over the PSTN based
on both sides knowing the start and stop times of that call. Other
validation schemes, such as examining fingerprints or watermarking of PSTN
media, to show that a domain received a particular PSTN phone call may be
considered by the working group. To help mitigate SPAM over SIP issues, the
WG will define an token based authorization scheme so that domain using SIP
to federate can choose to check that incoming SIP calls are from a domain
that successfully validated a phone number. 

The problem statement and some possible starting points for solutions are
further desired in the following internet drafts which shall form the bases
of the WG documents:
draft-rosenberg-dispatch-vipr-overview
draft-rosenberg-dispatch-vipr-reload-usage
draft-rosenberg-dispatch-vipr-pvp
draft-rosenberg-dispatch-vipr-sip-antispam

The working group will carefully coordinate with the security area, O&M
area, as well as the appropriate RAI WG including sipcore and p2psip.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 2 Jun 2010 12:29:53 -0600

Good catch - we certainly want it to just be one of many ways. 

> |about VIPR to be in my individual role not my co-chair role)

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 02 Jun 2010 11:31:07 -0700

> (PS - this is sent in my individual contributor role. Take all my posts about VIPR to be in my individual role not my co-chair role)

VAP is not listed here.  Is it an oversight or is it because the WG will work
only on interoperability between ViPR servers?

> The working group will carefully coordinate with the security area, O&M area, as well as the appropriate RAI WG including sipcore and p2psip. 

I think something should said about the fact that ViPR requires SIP over (D)TLS
and SRTP, as it is, IMO, an important characteristic of ViPR.

Also there is perhaps a need to define a minimal subset of SIP extensions and
media capabilities for ViPR.

Thanks.

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 2 Jun 2010 12:35:34 -0600

I kept trying to write something about the relation of ViPR to ENUM but it kept coming out sounding like public ENUM had failed - which was not really what I wanted to say so I eventually deleted it. If someone had some good text about ENUM, would be nice to add it. 

I view infrastructure and carrier ENUM as somewhat unrelated to this but public ENUM is related. However, ENUM talks about how to query the database, but it is somewhat silent on how data gets in the database. How does the database authorize that someone is authoritative for a number and can put write a record into the ENUM database. VIPR is more about that side of the problem. 

And +1 to Paul's answers of the other questions ....

Cullen Jennings

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 2 Jun 2010 14:49:36 -0400

How about:

"The essential characteristic of ViPR is establishing authentication
by PSTN reachability and not by e.g. direct reference to ENUM
databases or other assertions of PSTN number ownership. Elements such
as public ENUM may be employed indirectly as part of assessing the
PSTN reachability but no direct interaction with ENUM will be
required. "

Peter

---

From: Jean-Francois Mule <[email-masked]>
Date: Wed, 2 Jun 2010 14:59:53 -0600

Hi,

   I support this proposed work to be taken by IETF under a new working group.  There are certainly concrete deliverables that would merit IETF consensus to spur multi-vendor interoperability.

  A few comments below, mostly to help bash the proposed charter.

Jean-Francois.

> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Cullen Jennings
> Sent: Tuesday, June 01, 2010 10:55 AM
> To: DISPATCH list
> I've been talking to a lot of people about the VIPR drafts  - here
> is a first cut of a proposal for a WG that could do this. I'm sure
> the charter proposal needs a bunch of work but I wanted to get the
> discussion rolling on the list.
> 
> Thanks, Cullen
> 
> (PS - this is sent in my individual contributor role. Take all my
> posts about VIPR to be in my individual role not my co-chair role)
> 
> There are two globally deployed address spaces for communications
> that more than a billion people use on a daily basis. They are
> phone numbers and DNS rooted address such as web servers and email
> addresses. The federation design of SIP is primarily designed for
                 ^^^^^^^^^^^^^^^^^^^^^^^^
Given some folks talk about SIP federations in the context of speermint (http://tools.ietf.org/html/rfc5486#section-5) and I don't think this is what you mean here, this choice of terms may not be the best.  As much as some folks disagree on the worthiness of the output of speermint, at least SIP federations are described there.  Would recommend clarifying this somehow.
 
> email style addresses yet a large percentage of SIP deployments
> primarily use phone numbers for identifying users. The goal of this
> working group is to allows people to use SIP to federate over the
                                       ^^^^^^^^^^^^^^^^^^^
my understanding is that those people would not only use SIP but some other smarts to put some stuff in DHTs to enable PSTN reachability verification. This implies that the solution solely relies on SIP.  May want to expand or clarify, or else qualify the sentence further.

> the internet while still using phone numbers to identify the person

> The VIPR WG will address this problem by developing a peer to peer
> based approach to finding SIP domains that claim to be responsible
                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
That may open a rathole: what does it mean to be responsible for a given phone number (worst case, Rich Shockey will chime in and will muddy this more, or John Elwell will claim this should have been in speermint but it cannot be found there...).

Do you mean any SIP Service Provider (http://tools.ietf.org/html/rfc5486#section-3.9) on the signaling path of a SIP invite or dialog-initiating request for that telephone number?  Do you mean the SIP domain responsible for the last hop before the SIP UA? Both?  Or is it the latter with the pre-requisite that PSTN connectivity is required somehow?

> for a given phone number and the WG will design validation
> protocols to ensure a reasonable likelihood that a given domain
> actually is responsible for the phone number. One initial
> validation protocol will be based on a domain being able to prove
> it received a particular phone call over the PSTN based on both
> sides knowing the start and stop times of that call. Other
This last sentence is advocating one specific solution.  
I think the VIPR drafts are powerful and this may be part of a working solution.  But at this stage in the WG charter definition, would it be preferable to say something like:
	Some validation protocols may be based on additional knowledge gathered around a SIP call, for example, the ability to prove a call was received over the PSTN based on start and stop times.

It leave things open and welcomes other proposals.  It also does not preclude the validation protocol you have documented.

> validation schemes, such as examining fingerprints or watermarking
> of PSTN media, to show that a domain received a particular PSTN
> phone call may be considered by the working group. 
These are additional examples that must be part of the same bucket as the one before imo.  Currently it reads that PSTN+start+stop is the initial one, others may be considered later.  
I have no preference and like the elegance of the approach in some the VIPR drafts.  But the charter should make clear that the WG will decide this.

> To help mitigate
> SPAM over SIP issues, the WG will define an token based
> authorization scheme so that domain using SIP to federate can
> choose to check that incoming SIP calls are from a domain that
> successfully validated a phone number.
Same here, you state a solution to a pb.  I would prefer to have a requirement in the charter that mandates the WG comes up with a method to help mitigate SPIT by ensuring that a domain using SIP can validate incoming calls are indeed from a domain that successfully validated the TN.

> The problem statement and some possible starting points for
> solutions are further desired in the following internet drafts
> which shall form the bases of the WG documents:
> The working group will carefully coordinate with the security area,
> O&M area, as well as the appropriate RAI WG including sipcore and
> p2psip.
> 
>

---

From: Jean-Francois Mule <[email-masked]>
Date: Wed, 2 Jun 2010 15:01:57 -0600

> endpoints and IP addresses?

I don't think the charter should exclude anything that may be used in some context as validation schemes.  

Jean-François

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 2 Jun 2010 17:02:26 -0400

>Hi,
>
>  I support this proposed work to be taken by IETF under a new working group.  There are certainly concrete deliverables that would merit IETF consensus to spur multi-vendor >interoperability.

+1

---

From: Jean-Francois Mule <[email-masked]>
Date: Wed, 2 Jun 2010 15:04:23 -0600

Paul wrote:
> really usable. 

To Patrick's point on the ENUM WG list on 5/19, it depends what you mean by ENUM here.
There are probably a lot of SIP calls routed in networks today (and SMS-MMS) that use some kind of ENUM protocol implementations.

Jean-François

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 02 Jun 2010 17:14:48 -0400

> There are probably a lot of SIP calls routed in networks today (and SMS-MMS) that use some kind of ENUM protocol implementations.

I did explicitly say *public* ENUM.
I realize other variants of ENUM are in use, but they aren't relevant to 
*this* problem statement, and I think what I said is true for *public* ENUM.

Its possible that this could result in a grab bag of techniques. 
Potentially public ENUM could be tried, and used if there is a workable 
entry, while some of the more complex techniques could be tried if there 
is no workable entry in public ENUM.

	Thanks,
	Paul

---

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Wed, 2 Jun 2010 17:20:25 -0400

I've improved the wording in various places and carefully removed any presumptions regarding the specific solution to be delivered:

ViPR Charter Proposal (a revision)

There are two globally deployed address spaces for communications that
more than a billion people use on a daily basis:  E.164 phone numbers
and DNS-rooted address (such as web servers and email addresses). The
federation design of SIP is primarily designed for email-style
addresses, yet a large percentage of SIP deployments primarily use
phone numbers for identifying users. The goal of this working group is
to allow people to use SIP to federate over the the Internet while
still using phone numbers to identify the person they wish to
communicate with.

The VIPR WG will address this problem by developing one or more
peer-to-peer based approaches to determining and validating the SIP
URI(s) that are equivalent to a given phone number, without requiring
reference to a global, accurate database.

One approach to be considered will be based on a domain being able to
prove it received a particular phone call over the PSTN, based on both
sides knowing the start and stop times of that call.  This approach is
described in:

Other validation techniques (such as examining fingerprints or
watermarking of PSTN media) may be considered by the working group.

To help mitigate SPAM over SIP issues, the WG also define one or more
authorization schemes allowing a recipient to verify that an
incoming SIP call is from a source that has previously executed a
validation protocol with the recipient.

The working group will carefully coordinate with the security area,
O&M area, and the appropriate RAI WGs (including sipcore and p2psip).

Dale

---

From: Jean-Francois Mule <[email-masked]>
Date: Wed, 2 Jun 2010 16:25:13 -0600

> >> As I understand it, the new WG is about coming up with
> technique(s)
> >> that
> >> ENUM could be used for this, in practice it isn't deployed and
> so
> >> isn't
> >> really usable.
> >
> > There are probably a lot of SIP calls routed in networks today
> (and SMS-MMS) that use some kind of ENUM protocol implementations.
> 
You're right.

> is no workable entry in public ENUM.

Yes.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 06 Jun 2010 09:16:46 -0700

>>  I support this proposed work to be taken by IETF under a new working group.  There are certainly concrete deliverables that would merit IETF consensus to spur multi-vendor >interoperability.

I also support this work.

- -- 
Marc Petit-Huguenin

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 15 Jun 2010 11:23:13 -0600

Thanks - I changed that a little bit and put it in the updated version.

Cullen Jennings

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 15 Jun 2010 11:23:31 -0600

> only on interoperability between ViPR servers?

I could go either way on VAP. On one hand, the minimal thing we need to standardize to have interoperability between domain is just the above stuff without VAP. On the other hand, VAP is a very simple way to modularize what is happening inside a domain. VAP allows information about PSTN call to be given to the server doing the VIPR stuff and allows the VIPR server to tell routing engines and PBX inside the domain about new routes. 

I'd be interested in hearing what other thing. It's easy to add something like VAP to the charter.

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 15 Jun 2010 11:23:40 -0600

Hi - many thanks for the great comments - few comments inline but I agree with all your points and tried to update the charter appropriately. 

>> posts about VIPR to be in my individual role not my co-chair role)

yah - agree. "Federation" means a lot of things but conflicting with speermint terminology seems like a bad plan. I'll try and rephrase in terms of "inter domain calling" 

>> working group is to allows people to use SIP to federate over the

yep ... I think this works for more than just SIP

>> based approach to finding SIP domains that claim to be responsible

It's was deliberately a bit vague. The real goal is to get the best approximation we can of the administrative domain who controls the phone that rings when you dial that number. The whole concept of ownership of a phone number is so muddled that trying to use owner is clearly useless. It's very unclear if my cell phone number is owned by me (I can LNP to wherever I want and Cisco lets me take on termination of my employment), to Cisco (they pay the bill), to AT&T, to Neustar, or to some government, or any of the other parties that could cause it not to work. I think the best definition we can come up with of responsible is an administrative domain that is always involved in the call signaling of a PSTN call to that phone number. I tired to clear up in the charter a bit but this is going to need a bunch of people to help fine tune text. 

> It leave things open and welcomes other proposals.  It also does not preclude the validation protocol you have documented.

Fair enough - I changed draft charter to you suggested text.  If we think there is a reasonable chance that we might not do this start/stop time validations, then this change makes sense but if we are pretty certain we will do this approach, then I generally prefer making the charters as specific as possible. 

> I have no preference and like the elegance of the approach in some the VIPR drafts.  But the charter should make clear that the WG will decide this.

OK

> Same here, you state a solution to a pb.  I would prefer to have a requirement in the charter that mandates the WG comes up with a method to help mitigate SPIT by ensuring that a domain using SIP c…

Ok - changed to say that.

---

From: Peter Musgrave <[email-masked]>
Date: Tue, 15 Jun 2010 15:38:47 -0400

Since the charter is just pointing to these as starting points I vote
to include VAP. I see it as a reasonable starting point.

Peter Musgrave

---

From: Roni Even <[email-masked]>
Date: Wed, 16 Jun 2010 01:23:18 +0300

Hi Cullen,
I think that other standard body should be consulted like ITU. The reason is
that I see that one assumption is to use the PSTN numbering plan using also
the caller id. My experience is that this is not information that can be
reliable when going between PSTN service providers and it gets worse on
international calls. 
Roni Even

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Cullen Jennings
> Sent: Tuesday, June 01, 2010 7:55 PM
> To: DISPATCH list
> first cut of a proposal for a WG that could do this. I'm sure the
> charter proposal needs a bunch of work but I wanted to get the
> more than a billion people use on a daily basis. They are phone numbers
> and DNS rooted address such as web servers and email addresses. The
> federation design of SIP is primarily designed for email style
> addresses yet a large percentage of SIP deployments primarily use phone
> numbers for identifying users. The goal of this working group is to
> allows people to use SIP to federate over the the internet while still
> using phone numbers to identify the person they wish to communicate
> with.
> 
> based approach to finding SIP domains that claim to be responsible for
> a given phone number and the WG will design validation protocols to
> ensure a reasonable likelihood that a given domain actually is
> responsible for the phone number. One initial validation protocol will
> be based on a domain being able to prove it received a particular phone
> call over the PSTN based on both sides knowing the start and stop times
> of that call. Other validation schemes, such as examining fingerprints
> or watermarking of PSTN media, to show that a domain received a
> particular PSTN phone call may be considered by the working group. To
> help mitigate SPAM over SIP issues, the WG will define an token based
> authorization scheme so that domain using SIP to federate can choose to
> check that incoming SIP calls are from a domain that successfully
> validated a phone number.
> 
> The problem statement and some possible starting points for solutions
> are further desired in the following internet drafts which shall form
> the bases of the WG documents:

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 15 Jun 2010 15:28:44 -0700

> I'd be interested in hearing what other thing. It's easy to add something like VAP to the charter. 

I do not plan to implement VAP and so will not be able to contribute on this
protocol if the WG choose to work on it.  So for what I am concerned, VAP does
not need to be in the charter, and I think that resources will be better spent
working of stuff that directly affects interoperability (and with SIP in the
equation there will be no shortage of interop issue).

This said, the VAP I-D is a mandatory reading to understand the behavior of a
ViPR server, so there will be at least a need to split the VAP protocol from the
ViPR server behavior.

- -- 
Marc Petit-Huguenin