Subject: Re: [dispatch] ReasonIn responses(draft-jesske-dispatch-reason-in-responses-02)

From: Ian Elz <[email-masked]>
Date: Thu, 24 Jun 2010 13:50:05 +0000 (GMT)

Dale,

The Q.850 cause values are standardised across the ISUP network. As ISUP is used to interconnect the PSTN and PLMN worldwide the values are universal.

The fact that the Reason header will indicate a protocol of "Q.850" 

The only thing that is not considered in this draft is that there may be 'location' and 'diagnostic' information associated the cause values.

The Location indicates if the release cause comes from teh user, private networl, public network, transit network etc.

The Diagnostics provides additional information as to why the realease occured and other information which may be cause specific.

This additional information is not usually used and I don't believe that it is the intention of this draft to expand the Reason header to carry the additional information. Any information which is required will need to be mapped by other mechanism between the ISUP and SIP networks, e.g. CCBS possible indicator.

Ian Elz

From: [email-masked] [[email-masked]] 
On Behalf Of "WORLEY, Dale R (Dale)" <[email-masked]>

________________________________
    From: [email-masked] [[email-masked]] 
On Behalf Of DOLLY, MARTIN C (ATTLABS) [[email-masked]]

    ISUP, though there is an overlap with ISDN

    If from ISDN, then there is an interworking ISDN-->ISUP-->SIP
_______________________________________________

One thing I haven't seen discussed is what is the meaning of carrying the 
ISUP release code transparently if there is more than one variety of 
ISUP, if the same release code has different meanings in different PSTN 
networks.  In a perfect world, SIP would carry not only the ISUP release code, but some identification of the *system* of ISUP release codes 
that it was drawn from.

Dale

---

From: <[email-masked]>
Date: Thu, 24 Jun 2010 15:57:48 +0200

Hi Ian,
the location field for the Reason header was discussed in the past. But it was decided not to include to many information. My impression is that the location field is not used often for services or other network feature. The only value would be for O&M reasons where more information is given. So your analysis in the last sentence is correct.
 
This draft is not extending the Reason header it is only specifying the use of the Reason Header within responses.
 
Best Regards
 
Roland

Mit freundlichen Grüßen 
Roland Jesske 

Deutsche Telekom Netzproduktion GmbH 
Fixed Mobile Engineering Deutschland 
Roland Jesske 
Heinrich-Hertz-Straße 3-7, 64295 Darmstadt 
+49 6151 628-2766 (Tel.) 
+49 521 9210-3753  (Fax) 
+49 171 8618-445  (Mobil) 
E-Mail: [email-masked] <mailto:[email-masked]>  
www.telekom.com <http:www.telekom.com>   

Erleben, was verbindet. 

Deutsche Telekom Netzproduktion GmbH 
Aufsichtsrat: Dr. Steffen Roehn (Vorsitzender) 
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, Klaus Peren 
Handelsregister: Amtsgericht Bonn HRB 14190 
Sitz der Gesellschaft: Bonn 
USt-IdNr. DE 814645262 

Große Veränderungen fangen klein an - Ressourcen schonen und nicht jede E-Mail drucken. 

Von: Ian Elz [mailto:[email-masked]] 
Gesendet: Donnerstag, 24. Juni 2010 15:50
An: [email-masked]; WORLEY, Dale R (Dale)
Cc: DOLLY, MARTIN C (ATTLABS); Tom Taylor; Jesske, Roland
Betreff: Re: [dispatch] ReasonIn responses(draft-jesske-dispatch-reason-in-responses-02)

Dale,

Ian Elz

From: [email-masked] [[email-masked]] On Behalf Of "WORLEY, Dale R (Dale)" <[email-masked]>

    From: [email-masked] [[email-masked]] On Behalf Of DOLLY, MARTIN C (ATTLABS) [[email-masked]]

One thing I haven't seen discussed is what is the meaning of carrying the ISUP release code transparently if there is more than one variety of ISUP, if the same release code has different meanings in different PSTN networks.  In a perfect world, SIP would carry not only the ISUP release code, but some identification of the *system* of ISUP release codes that it was drawn from.

Dale

---

From: "Calme, James A (Jim)" <[email-masked]>
Date: Thu, 24 Jun 2010 09:30:32 -0500

Ian,

It is not true that cause values are "universal". I can agree that Q.850 is the starting point, but there are many countries that define their own national extensions.

Just consider the US network as one example. The US ANSI ISUP standard T1.113 defines a number of cause values in addition to Q.850. In some cases the values overlap with Q.850 definitions and in other cases they are making use of unused values. For the ANSI specific values the Cause Indicator coding standards is set to 10 to indicate that the value is based on a national standard. Both Q.850 and ANSI-specific values are used within US networks.

With this is mind, where RFC 3326 defines the protocol as
protocol          =  "SIP" / "Q.850" / token
for US networks the value "ANSI" is introduced as a token value.

So there are networks where Reason header protocol values other than just "Q.850" are being used to represent ISUP cause values.

Regards,
Jim

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ian Elz
Sent: Thursday, June 24, 2010 8:50 AM
To: [email-masked]; WORLEY, Dale R (Dale)
Cc: DOLLY, MARTIN C (ATTLABS); [email-masked]
Subject: Re: [dispatch] ReasonIn responses(draft-jesske-dispatch-reason-in-responses-02)

Dale,

Ian Elz

From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] On Behalf Of "WORLEY, Dale R (Dale)" <[email-masked]>
________________________________
    From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] On Behalf Of DOLLY, MARTIN C (ATTLABS) [[email-masked]<mailto:[email-masked]>]

Dale

---

From: Ian Elz <[email-masked]>
Date: Thu, 24 Jun 2010 23:04:51 +0000 (GMT)

Jim,

I agree.

The protocol specifies meaning of the cause provided. I should have quoted Q.850 as an example as it is the one specifically mentioned in RFC3326.

Any other specified protocol will have its own values.

It is up to the PSTN-SIP gateway to understand the specified protocol and the mapping of the cause values for that protocol.

Cheers

Ian

________________________________
From: "Calme, James A (Jim)" <[email-masked]>
To: Ian Elz <[email-masked]>; "[email-masked]" <[email-masked]>; "WORLEY, Dale R (Dale)" <[email-masked]>
Cc: "DOLLY, MARTIN C (ATTLABS)" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Thu, 24 June, 2010 15:30:32
Subject: RE: [dispatch] ReasonIn responses(draft-jesske-dispatch-reason-in-responses-02)

Ian,
 
It is not true that cause values are “universal”.
I can agree that Q.850 is the starting point, but there are many countries that
define their own national extensions.
 
Just consider the US network as
one example. The US ANSI ISUP standard T1.113 defines a number of cause values
in addition to Q.850. In some cases the values overlap with Q.850 definitions
and in other cases they are making use of unused values. For the ANSI specific
values the Cause Indicator coding standards is set to 10 to indicate that the
value is based on a national standard. Both Q.850 and ANSI-specific values are
used within US networks.
 
With this is mind, where RFC 3326 defines
the protocol as
protocol         
=  "SIP" / "Q.850" / token
for US networks the value “ANSI”
is introduced as a token value.
 
So there are networks where Reason header protocol
values other than just “Q.850” are being used to represent ISUP
cause values.
 
Regards,
Jim

From:[email-masked] [mailto:[email-masked]] On Behalf Of Ian Elz
Sent: Thursday, June 24, 2010 8:50
AM
To: [email-masked]; WORLEY,
Dale R (Dale)
Cc: DOLLY, MARTIN C (ATTLABS); [email-masked]
Subject: Re: [dispatch] ReasonIn responses(draft-jesske-dispatch-reason-in-responses-02)
 
Dale,

The Q.850 cause values are standardised across the ISUP network. As ISUP is
used to interconnect the PSTN and PLMN worldwide the values are universal.

The only thing that is not considered in this draft is that there may be
'location' and 'diagnostic' information associated the cause values.

The Location indicates if the release cause comes from teh user, private
networl, public network, transit network etc.

The Diagnostics provides additional information as to why the realease occured
and other information which may be cause specific.

This additional information is not usually used and I don't believe that it is
the intention of this draft to expand the Reason header to carry the additional
information. Any information which is required will need to be mapped by other
mechanism between the ISUP and SIP networks, e.g. CCBS possible indicator.

Ian Elz

From: [email-masked] [[email-masked]] On
Behalf Of "WORLEY, Dale R (Dale)" <[email-masked]>

    From: [email-masked] [[email-masked]] On
Behalf Of DOLLY, MARTIN C (ATTLABS) [[email-masked]]

    If from ISDN, then there is an interworking
ISDN-->ISUP-->SIP
_______________________________________________

One thing I haven't seen discussed is what is the meaning of carrying the ISUP
release code transparently if there is more than one variety of ISUP, if the
same release code has different meanings in different PSTN networks.  In a
perfect world, SIP would carry not only the ISUP release code, but some
identification of the *system* of ISUP release codes that it was drawn from.

Dale