Subject: Re: [dispatch] WG Review: Call Control UUI for SIP (cuss)

From: Cullen Jennings <[email-masked]>
Date: Thu, 8 Jul 2010 21:35:02 -0600

On Jul 3, 2010, at 7:33 AM, Alan Johnston wrote:

> Many of us have worked hard on this approach over many years, and you have been involved in this at every step of the way, in both SIPPING and DISPATCH.  For you to just try to block even the formation of a working group to address this at this eleventh hour is just not right.

For better or worse, the AD's voice do strongly impact others thinking on the many subjects at IETF. As an individual contributor, my review in IETF LC pretty much my current thoughts on it. However, if I had sent that same review when I was an AD this charter would have been very unlikely to get a fair shake at moving forward so I just would not have sent that email while I was AD. The ADs often can't express their own opinions because and instead have to just try and measure community consensus and go with that even if it does not match what they think is best. Really this is the first chance I've had to express an opinion on this where I was not one of the RAI AD. 

There discussion that has happened since my initial review has made me wish I had said a bit more about SIP-T in my first email. I'm not really proposing that someone should have to implement all of ISUP processing and SIP-T just to pass around the UUI field but from a thought experiment point of view, this does not sound like it is going to provide anything that we would not get if we did implement SIP-T to pass this data. It seems this will have all the limitations of SIP-T combined with the interoperability limitations of UUI in ISDN. I want to be clear, I'm not trying to stop us from doing some work that helps supports uses cases such as the one Laura sent to the list. I just don't see this charter as leading to any improvement in interoperability. If we agree that in theory we could more or less do this with SIP-T thought that is not a practical path from an implementation point of view, then I can see a path of some middle ground. If we don't agree on that then we probably need to think about what we need to add to the charter regardless of if I agree with or not that high lights the additional part of this problem that makes it so SIP-T can't solve it. 

The other things that has happened in this discussion is that I was assuming that the proponents of this felt that proxies needed to modify the data. From the email that came out it's became clear that not everyone believed that. If there was consensus on changing this such that UUI information is not meant for proxies, then I can start to see ways to rewrite the charter to have it reflect what I think people want to do. If the consensus is proxies need to look at this, I have a hard time seeing how it is not involved in call control.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 14 Jul 2010 18:10:48 +0300

Hi,

thanks for your comments on the charter proposal. Per the comments
received, we will modify bullet 5 as follows so that it is clearer:

OLD:
5. SIP elements may need to apply policy about passing and screening
   the information.

NEW:
5. SIP elements may need to apply policy about passing and filtering
   UUI.  The included application, encoding, semantics, and content
   information will allow endpoint or intermediary SIP elements to
   allow or block UUI based on the type and originator, not based on
   the actual UUI data, which may be end-to-end encrypted by the
   application.

Further discussions on this topic should happen on the mailing list of
this WG.

Cheers,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 14 Jul 2010 11:25:58 +0300

Hi,

OLD:

NEW:

Cheers,

Gonzalo

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 15 Jul 2010 08:06:00 -0600

I don't think this resolves the issue. The issue is if this information is used for a call control. Basically do proxies need to be able to look at this to make decision about what they are going to do. We at least need a Yes/No answer to this question from the proponents of this work and the charter to make that clear. 

On Jul 14, 2010, at 2:25 AM, Gonzalo Camarillo wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 15 Jul 2010 17:32:02 +0300

Hi Cullen,

the charter already says that the information "may be end-to-end
encrypted by the application". Therefore, proxies will not make any
decision (related or unrelated to call control) based on its contents
because the contents may simply not be available to the proxy.

Do you want the charter to be even more explicit about this?

Thanks,

Gonzalo

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 15 Jul 2010 17:31:39 +0200

At least from my perspective (which is from supporting the capabilities of the ISDN User-to-User service) the answer is No. This is information above the SIP layer in an application, and to look at the contents, one must come out above the SIP layer into that application. 

It could be conditional that the SIP message itself is not processed if the information is not there, and the SIP request therefore rejected, but this has nothing to do with the contents. And personally, I do not believe that bit will every happen at a proxy, but will be at the recipient UA.

regards

Keith

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Cullen Jennings
> Sent: Thursday, July 15, 2010 3:06 PM
> To: Gonzalo Camarillo
> Cc: DISPATCH list; IESG IESG; IETF-Discussion list
> Subject: Re: [dispatch] WG Review: Call Control UUI for SIP (cuss)
> 
> 
> I don't think this resolves the issue. The issue is if this 
> information is used for a call control. Basically do proxies 
> need to be able to look at this to make decision about what 
> they are going to do. We at least need a Yes/No answer to 
> this question from the proponents of this work and the 
> charter to make that clear. 
> 
> 
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 15 Jul 2010 11:27:32 -0600

OK - that removes a large part of the issues I raised. Let me see if I can propose some text that we could all agree on.

Cullen

PS - Just to be clear these emails are all in my individual contributor role. That was clear when it was IETF LC comment but given this is all cross posted to dispatch, just wanted to be clear.

On Jul 15, 2010, at 8:07 AM, DOLLY, MARTIN C (ATTLABS) wrote:

> Cullen the answer to your question is No.
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Cullen Jennings
> Sent: Thursday, July 15, 2010 10:06 AM
> To: Gonzalo Camarillo
> Subject: Re: WG Review: Call Control UUI for SIP (cuss)
> 
> 
> I don't think this resolves the issue. The issue is if this information
> is used for a call control. Basically do proxies need to be able to look
> at this to make decision about what they are going to do. We at least
> need a Yes/No answer to this question from the proponents of this work
> and the charter to make that clear. 
> 
> 

Cullen Jennings

---

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Thu, 15 Jul 2010 13:40:35 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Cullen Jennings [[email-masked]]

>From the discussion, it seems that proxies will not make call control decisions based on the *contents* of UUI, but they may make call control decisions (specifically, rejection) based on the *presence* of UUI.  So whether the anser is Yes or No depends on exactly how you phrase the question.

Dale