Subject: [dispatch] Investigation about supporting Lawful interception's X1(Target Setting):

From: [email-masked]
Date: Fri, 16 Jul 2010 14:52:10 +0800

Hi Hadriel & other SBC vendors,

Firstly, I'd like to explain that only handover interfaces(H1/H2/H3) are 
national law specific, internal architecture and interface for 
network(such as IMS/NGN) should be allowed to be defined by IETF(such as 
RFC3924 Architecture for Lawful Intercept).

Recent, I paid attention to IMS/NGN's lawful interception interworking. 
And I found that some SBCs do not support Lawful interception's X1(Target 
Setting). Then, we usually need to deploy another network element(such as 
P-CSCF of IMS) to do the control/triggering work for SBC, but the 
control/triggering interface is private interface(Infact, 3GPP/ETSI has no 
standard for LI relating SBC). 

I'd like to know how your equipment handle this issue? And you can use the 
naming in this figure(from RFC3924 Architecture for Lawful Intercept) as 
reference.

Thanks,

Gao

                       +--------------------+               +-----+
                          |  LI Administration |     HI1(a)    |     |
                          |      Function      |<--------------|     |
                          +--------------------+               |     |
                                 |                             |     |
                                 | MD Provisioning             |     |
                                 | Interface(b)                | LEA |
                                 v                             |     |
   +-----------+           +--------------------+              |     |
   |           |<---(c)----|                    |              |     |
   |  IRI IAP  |--IRI(e)-->|      Mediation     |----HI2(g)--->|     |
   |           |           |      Device (MD)   |              |     |
   +-----------+           |                    |----HI3(h)--->|     |
                           +--------------------+              +-----+
                                |         ^
                      Intercept |         | Intercepted
                     Request(d) |         | Content(f)
                                |         |
                                v         |
                              +--------------------+
                        User  |       Content      |  User
                      ------->|         IAP        |-------->
                      Content +--------------------+  Content

===================================
 Zip    : 210012
 Tel    : 87211
 Tel2   :(+86)-025-52877211
 e_mail : [email-masked]
===================================

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 16 Jul 2010 11:15:53 -0400

Hey Gao,
The IETF does not define or work on Lawful Intercept protocols (partly because they're national-law specific).  RFC 3924 was only an informational, and maybe even only an individual document published by the RFC Editor, not an IETF document (see the IESG note in the RFC).  It's confusing because technically the RFC Editor is not part of the IETF, and the IETF is just one particular user/customer/client of the RFC Editor - the IETF asks the RFC Editor to publish documents, but so can others.

Regardless, your question is probably better directed to the SIP Implementors list ([email-masked]<mailto:[email-masked]>) or even better: to individual people at the respective SBC vendors, and not DISPATCH, since it isn't really germane to DISPATCH.  (As for my employer's SBC's, they do support the X1 interface if you have the right software version)

-hadriel

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 16, 2010 2:52 AM
To: DISPATCH list; Hadriel Kaplan
Subject: [dispatch] Investigation about supporting Lawful interception's X1(Target Setting):

Firstly, I'd like to explain that only handover interfaces(H1/H2/H3) are national law specific, internal architecture and interface for network(such as IMS/NGN) should be allowed to be defined by IETF(such as RFC3924 Architecture for Lawful Intercept).

Recent, I paid attention to IMS/NGN's lawful interception interworking. And I found that some SBCs do not support Lawful interception's X1(Target Setting). Then, we usually need to deploy another network element(such as P-CSCF of IMS) to do the control/triggering work for SBC, but the control/triggering interface is private interface(Infact, 3GPP/ETSI has no standard for LI relating SBC).

I'd like to know how your equipment handle this issue? And you can use the naming in this figure(from RFC3924 Architecture for Lawful Intercept) as reference.

Thanks,

Gao

---

From: [email-masked]
Date: Mon, 19 Jul 2010 14:01:27 +0800

Hey Hadriel，

Thanks for your response. Some comments inlines.

Hadriel Kaplan <[email-masked]> 写于 2010-07-16 23:15:53:

> Hey Gao,
> The IETF does not define or work on Lawful Intercept protocols (partly 
because
> they’re national-law specific). 

Yes, that's spirit of IETF. But I think only Handover interfaces(H1/H2/H3) 
should be under this restriction. But this is a big question. 
As you have give me useful information, I think I can do the investigation 
by the way you recommended.

Thanks again,

Gao

> RFC 3924 was only an informational,
> and maybe even only an individual document published by the RFC 
> Editor, not an IETF document (see the IESG note in the RFC).  It’s 
> confusing because technically the RFC Editor is not part of the 
> IETF, and the IETF is just one particular user/customer/client of 
> the RFC Editor – the IETF asks the RFC Editor to publish documents, 
> but so can others.
> 
> Regardless, your question is probably better directed to the SIP 
> Implementors list ([email-masked]) or even 
> better: to individual people at the respective SBC vendors, and not 
> DISPATCH, since it isn’t really germane to DISPATCH.  (As for my 
> employer’s SBC’s, they do support the X1 interface if you have the 
> right software version)
> 
> -hadriel
>