Subject: Re: [dispatch] Proposal for Session ID charter

From: [email-masked]
Date: Fri, 30 Jul 2010 21:34:50 +0800

Hi Toto

> Short of the IETF solution, the 3GPP invented its own "session-id" 
> for the following application:

I hasn't seen any normative(TS) solution about this "Replaces" problem in 
3GPP. If you have found it, please show it to me.

Gao

===================================
 Zip    : 210012
 Tel    : 87211
 Tel2   :(+86)-025-52877211
 e_mail : [email-masked]
===================================

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: [email-masked]
Date: Fri, 30 Jul 2010 21:53:41 +0800

Hi Toto,

> 1. Assume UA-a has a voice dialog with UA-b (over access network X),
> and there is a B2BUA between them.
> 2. During the voice dialog, the UA-a roams into access network Y. 
> There is a "small" overlap between networks X and Y (i.e. X*Y), and 
> the UA-a is a dual-radio device (it can simultaneously transmit in X and 
Y).
> 3. While in X*Y, UA-a establishes a second dialog (over Y), and 
> indicates to the UA-b that this dialog replaced the original dialog 
> (by specifying the dialog-id between the UA-a and B2BUA). It also 
> terminates the original dialog over the network X.
> 4. Obviously, the "handoff" fails, since the original dialog between
> the UA-a and the B2BUA has different dialog-id then the dialog 
> between the B2BUA and the UA-b.
>  
> Hence, the need for some "session-id" that consists of concatenated 
dialogs. 

By my understanding, current 3GPP's dual radio PS-PS Access transfer is 
also based on SCC-AS. Then the Replaces header is not used in this 
situation.

Currently, 3GPP has a Replaces problem in conference call flow, but I 
think it can be solved by solutions without any *dialog correlation header
*.

Thanks,

Gao