Subject: Re: [dispatch] How to proceed with "Reason in responses"

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 03 Aug 2010 11:30:29 +0300

Hi,

to be clear, process-wise if DISPATCH decides this work should be done,
I can AD sponsor it. The decision on whether or not this work should be
done needs to be made by DISPATCH... and that is what Roland is asking
about.

Cheers,

Gonzalo

On 30/07/2010 11:53 AM, [email-masked] wrote:
> Dear all,
> The drafts for the "Reason header in Responses"
> 
> _http://tools.ietf.org/html/draft-jesske-dispatch-req-reason-in-responses-01_
> 
> 
> _http://tools.ietf.org/html/draft-jesske-dispatch-reason-in-responses-02_
> 
> Where discussed over the last coupe of months. The interest of people
> was not enthusiastic but it was there.
> 
> So now I would like to ask the group how to proceed. Is there enough
> interest that we proceed with this drafts within dispatch as a Working
> Group Item.
> 
> Or have the people the feeling that I should go for an individual draft,
> where Gonzalo offered me to sponsor it.
> 
> Opinions?
> 
> Thank you and Best Regards
> 
> Roland
> 
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Aug 2010 10:54:15 +0200

Hi,

I definately think this work needs to be done.

Who makes it, and who sponsors it, I don't have any strong opinons about :)

Regards,

Christer

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: 3. elokuuta 2010 11:30
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [dispatch] How to proceed with "Reason in responses"
> 
> Hi,
> 
> to be clear, process-wise if DISPATCH decides this work 
> should be done, I can AD sponsor it. The decision on whether 
> or not this work should be done needs to be made by 
> DISPATCH... and that is what Roland is asking about.
> 
> Cheers,
> 
> Gonzalo
> 
> > Or have the people the feeling that I should go for an individual 
> > draft, where Gonzalo offered me to sponsor it.
> > 
> > Opinions?
> > 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 3 Aug 2010 05:33:52 -0400

+1  

(and the requirements draft should be merged into the solution, instead of being two separate drafts)

-hadriel

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Christer Holmberg
> Sent: Tuesday, August 03, 2010 4:54 AM
> 
> Hi,

---

From: Laura Liess <[email-masked]>
Date: Tue, 3 Aug 2010 11:43:32 +0200

+1

Laura

---

From: "Belling, Thomas (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Aug 2010 13:54:21 +0200

+1

Thomas

---------------------------------- 
Dr. Thomas Belling 
3GPP Standardisation
Nokia Siemens Networks 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Laura Liess
Sent: Tuesday, August 03, 2010 11:44 AM
To: Hadriel Kaplan
Cc: [email-masked]; Gonzalo Camarillo; [email-masked]
Subject: Re: [dispatch] How to proceed with "Reason in responses"

+1

Laura

>> Who makes it, and who sponsors it, I don't have any strong opinons 
>> about :) Regards, Christer
>>
>> > to be clear, process-wise if DISPATCH decides this work should be 
>> > done, I can AD sponsor it. The decision on whether or not this work

>> > should be done needs to be made by DISPATCH... and that is what 
>> > Roland is asking about.
>> >
>> > Cheers,
>> >
>> > Gonzalo
>> >
>> > _http://tools.ietf.org/html/draft-jesske-dispatch-req-reason-in-res
>> > pon
>> > > ses-01_
>> > >
>> > >
>> > >
>> > _http://tools.ietf.org/html/draft-jesske-dispatch-reason-in-respons
>> > es-
>> > > 02_
>> > >

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Aug 2010 14:30:53 +0200

+1

I would like to support this work as well

Christian

-----Original Message-----

+1

Laura

2010/8/3 Hadriel Kaplan <[email-masked]>:
>> about :)
_http://tools.ietf.org/html/draft-jesske-dispatch-req-reason-in-respon
>> > > ses-01_
_http://tools.ietf.org/html/draft-jesske-dispatch-reason-in-responses-

---

From: Enrico Marocco <[email-masked]>
Date: Tue, 3 Aug 2010 14:58:02 +0200

The problem this work provides a fix for is very real and service 
providers interoperating with PSTN really need to have it fixed. Since 
the solution is pretty simple, AD sponsorship seems the best way to go 
to me.

Enrico

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 5 Aug 2010 21:24:57 +0200

+1, with preference for a single document.

John 

> [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
> Sent: 03 August 2010 10:34
> To: Christer Holmberg; Gonzalo Camarillo; [email-masked]
> Cc: [email-masked]
> (and the requirements draft should be merged into the 
> solution, instead of being two separate drafts)
> 
> -hadriel
> 
> [mailto:[email-masked]] On

---

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Fri, 6 Aug 2010 14:14:33 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of [email-masked] [[email-masked]]

Where discussed over the last coupe of months. The interest of people was not enthusiastic but it was there.

So now I would like to ask the group how to proceed. Is there enough interest that we proceed with this drafts within dispatch as a Working Group Item.

Or have the people the feeling that I should go for an individual draft, where Gonzalo offered me to sponsor it.
________________________________________

Definitely this should go forward.

But I think that this needs to be a standards-track RFC in order to be a normative extension of RFC 3326 (specification of the Reason header).

Otherwise, given that this work is not controversial (e.g., many of us did not initially realize that an RFC was needed), it would be more efficient to submit it as an individual draft.

Dale

---

From: "Hutton, Andrew" <[email-masked]>
Date: Fri, 6 Aug 2010 22:21:53 +0200

Hi,

I believe this work needs to be done and preferable as one RFC (I.e. merge requirements and solution ).

Whether it is AD sponsored or a WG document I don't have a strong view.

Regards
Andy

> Sent: 03 August 2010 09:30
> To: [email-masked]
> Cc: [email-masked]
> should be done,

---

From: Shida Schubert <[email-masked]>
Date: Mon, 9 Aug 2010 16:55:46 +0900

We too as a service provider needs this draft.

 I don't see much point in creating a WG for this draft, 
so I agree with Enrico that having it progressed as AD 
sponsored is the way to go. 

 Lastly, I would rather see single document 
(merging req/solution), as some mentioned than two.

 Regards
  Shida

On Aug 3, 2010, at 9:58 PM, Enrico Marocco wrote:

> The problem this work provides a fix for is very real and service providers interoperating with PSTN really need to have it fixed. Since the solution is pretty simple, AD sponsorship seems the best way to go to me.
> 
> Enrico
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 9 Aug 2010 11:35:09 +0200

Hi,

I agree. If it can't be done within an existing WG I would vote for AD sponsored.

Regards,

Christer 

> [mailto:[email-masked]] On Behalf Of Shida Schubert
> Sent: 9. elokuuta 2010 10:56
> To: Enrico Marocco
> Cc: [email-masked]
>  I don't see much point in creating a WG for this draft, so I 
> agree with Enrico that having it progressed as AD sponsored 
> is the way to go. 
> 
>  Lastly, I would rather see single document (merging 
> req/solution), as some mentioned than two.
> 
>  Regards
>   Shida
> 
> > The problem this work provides a fix for is very real and 
> service providers interoperating with PSTN really need to 
> have it fixed. Since the solution is pretty simple, AD 
> sponsorship seems the best way to go to me.
> > 
> > Enrico
> > 
> >>> Where discussed over the last coupe of months. The interest of 
> >>> people was not enthusiastic but it was there.
> >>> 
> >>> interest that we proceed with this drafts within dispatch as a 
> >>> Working Group Item.
> >>>

---

From: <[email-masked]>
Date: Tue, 10 Aug 2010 16:08:04 +0200

Dear all,
Thank you for the feedback. I have no problem in merging again the requirements with the procedures, but it must be clear that everybody is OK with this.

After IETF 76 it was asked to split the document before going ahead.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: Elwell, John [mailto:[email-masked]] 
Gesendet: Donnerstag, 5. August 2010 21:25
An: Hadriel Kaplan; Christer Holmberg; Gonzalo Camarillo; Jesske, Roland
Cc: [email-masked]
Betreff: RE: [dispatch] How to proceed with "Reason in responses"

John