Subject: Re: [dispatch] Does RTC-WEB need to pick a signaling protocol?

From: Dean Willis <[email-masked]>
Date: Mon, 14 Mar 2011 23:37:06 -0500

Oh hell no....

Really, what we need are the primitives that make a web app able to do things like slurp data from a microphone and send it someplace useful. We might also need interfaces to A/V streams (maybe even RTP), and mixers. We need those primitives exposed to things like Javascript. What we don't need is an API that turns every browser into a generic SIP UA capable of being reused in haphazard fashion, such that everybody and his chihuahua reskins their "SIP browser phone" with CSS, and every browser swells to the size of the Hindenberg just before the fatal spark.

--
Dean

---

From: Dean Willis <[email-masked]>
Date: Mon, 14 Mar 2011 23:47:33 -0500

Well, THAT was an interesting time-warp.  Sorry about that. But I guess the sentiment still stands even if the mail was stuck in my outbox for a while...

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 14 Mar 2011 23:12:43 -0700

No problem.  The message is indeed timeless.  Feel free to resend it every week or so ;)

> From: [email-masked]
> Date: Mon, 14 Mar 2011 23:47:33 -0500
> To: [email-masked]
> CC: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [RTW] [dispatch] Does RTC-WEB need to pick a signaling protocol?
> 
> 
> _______________________________________________
> RTC-Web mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/rtc-web