Subject: [dispatch] Draft new version: draft-holmberg-rtcweb-ucreqs-01

From: Christer Holmberg <[email-masked]>
Date: Mon, 14 Mar 2011 13:03:00 +0100

Hi,

We've submitted a new version of the ucreqs draft.

The new version contains fixes and additions based on comments given on the previous version on the list.

The draft can be found at: http://www.ietf.org/id/draft-holmberg-rtcweb-ucreqs-01.txt

Regards,

Christer

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 17 Mar 2011 11:24:44 +0100

Hi,

I think this is useful input.

A few comments.

1. A5 "The web application MUST be able to control the media format (codec) to be used for the streams sent to a peer".   

It should also be able to control the codec used for the received stream (i.e. control what if offered to the peer).

2. A8 "The web application MUST be able to pause/unpause the sending of a stream to a peer".

I think it should be able to set/change the direction of the stream(s) which in SDP terms means sendonly/recvonly/sendrecv/inactive. 
 
3. A12 "The web application MUST be informed when a stream from a peer is no longer received". 

The web application MUST also be informed when a stream from a peer starts to be received. This probably also needs to take account of some early media scenarios when multiple streams could potentially be received from multiple peers. The application needs to be able to control which streams are rendered. This also impacts the browser requirements as obviously the browser needs to be able to detect when the stream starts etc.

Regards
Andy

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 14 March 2011 12:03
> To: [email-masked]; [email-masked]
> Subject: [RTW] Draft new version: draft-holmberg-rtcweb-ucreqs-01
> 
> 
> Hi,
> 
> The new version contains fixes and additions based on 
> comments given on the previous version on the list.
> 
> The draft can be found at: 
> http://www.ietf.org/id/draft-holmberg-rtcweb-ucreqs-01.txt
> 
> Regards,
> 
> Christer
> _______________________________________________
> RTC-Web mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/rtc-web
>