Subject: [dispatch] Charter Proposal - Remote Call/Device Control WG

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Tue, 20 Sep 2011 14:36:43 -0400

Hi,

The following is a charter proposal for a Remote Call/Device Control WG.

We would appreciate it if you review it and provide us with your feedback.

Thanks,

Rifaat

-------

Remote Call/Device Control WG

The Session Initiation Protocol (SIP) [RFC3261] provides users with the ability to initiate, manage, and terminate multimedia sessions.

A SIP application is a program running on a SIP network element that provides some value-added function to a user.

Many deployments have SIP applications in the SIP signaling path that get involved in the setup and management of these multimedia sessions.

Third-Party Application might also be interested in interacting with User Agents and the setup of multimedia sessions.

Some of these applications need a mechanism to remotely invoke some actions or/and monitor the invocation of actions on a SIP User Agent.

SIP allows for the invocation of actions on a remote User Agent using the REFER method.

The actions that can be invoked by the REFER method are limited, and there is a need for more actions by some SIP applications.

The purpose of this WG is to evaluate the various available mechanisms or proposed mechanism and recommend one or more of them,

or define a new mechanism if none of the available are good enough to address this need.

The work group will need to address the following:

* Clearly answer the following questions:

   a. What is "call control"?

   b. What is "device control"?

* Will the new mechanism address "call control", "device control" or both?

* Will the new mechanism be a SIP or a non-SIP based mechanism?

* If a non-SIP mechanism is used, how to deal with the fact that some of these

  actions already covered by the SIP REFER method and widely used in the industry

* Define a model for the actions

* Define a scope for the actions

* Define a set of initial actions that can be later extended, if needed.

* Others?

---

From: Simon Pietro Romano <[email-masked]>
Date: Wed, 21 Sep 2011 19:24:33 +0200

Hi Rifaat and all,

as one of the main supporters of the SPLICES attempts at addressing 
these issues, I cannot refrain myself from strongly supporting your 
initiative. Reading through the charter, I see that you have clear in 
your mind the main issues that came out from our past discussions in the 
IETF (with special regard to the meeting we had in Quebec City). With 
respect to this, I would suggest not to mix call control with device 
control, unless we want to open a never-ending discussion.

Cheers,

Simon

Il 20/09/2011 20:36, Shekh-Yusef, Rifaat (Rifaat) ha scritto:
> The Session Initiation Protocol (SIP) [RFC3261] provides users with 
> the ability to initiate, manage, and terminate multimedia sessions.
>
> A SIP application is a program running on a SIP network element that 
> provides some value-added function to a user.
>
> Many deployments have SIP applications in the SIP signaling path that 
> get involved in the setup and management of these multimedia sessions.
>
> Third-Party Application might also be interested in interacting with 
> User Agents and the setup of multimedia sessions.
>
> Some of these applications need a mechanism to remotely invoke some 
> actions or/and monitor the invocation of actions on a SIP User Agent.
>
> The actions that can be invoked by the REFER method are limited, and 
> there is a need for more actions by some SIP applications.
>
> The purpose of this WG is to evaluate the various available mechanisms 
> or proposed mechanism and recommend one or more of them,
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Thu, 22 Sep 2011 12:19:37 -0400

Hi Simon,

>With respect to this, I would suggest not to mix call control with device control, unless we want to open a never-ending discussion.
I was not trying to suggest that the same protocol would be used for call & device control, quite the opposite. Is that your concern?
Or you are saying that the WG should deal with only either call control OR device control, but not both?

Regards,
Rifaat

From: Simon Pietro Romano [mailto:[email-masked]]
Sent: Wednesday, September 21, 2011 1:25 PM
To: Shekh-Yusef, Rifaat (Rifaat)
Cc: [email-masked]
Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG

Hi Rifaat and all,

as one of the main supporters of the SPLICES attempts at addressing these issues, I cannot refrain myself from strongly supporting your initiative. Reading through the charter, I see that you have clear in your mind the main issues that came out from our past discussions in the IETF (with special regard to the meeting we had in Quebec City). With respect to this, I would suggest not to mix call control with device control, unless we want to open a never-ending discussion.

Cheers,

Simon

Hi,

Thanks,

Rifaat

-------

* Others?

dispatch mailing list

[email-masked]<mailto:[email-masked]>

--

                            _\\|//_

                            ( O-O )

                    Simon Pietro Romano

                e-mail: [email-masked]<mailto:[email-masked]>

                         oooO

                          \ (    (   )

                           \_)    ) /

                                 (_/

---

From: Adam Roach <[email-masked]>
Date: Thu, 22 Sep 2011 12:35:01 -0500

On 9/22/11 11:19, Sep 22, Shekh-Yusef, Rifaat (Rifaat) wrote:
>
> Hi Simon,
>
> >With respect to this, I would suggest not to mix call control with 
> device control, unless we want to open a never-ending discussion.
> I was not trying to suggest that the same protocol would be used for 
> call & device control, quite the opposite. Is that your concern?
>

I think you need to work through use cases first, and then determine 
whether they can all be accomplished through call control alone. Or 
through just device control. Or if you need a combination of both to 
satisfy the use cases that people interested in this work have in mind.

In other words, I think it would be foolish to charter a working group 
with an answer, and then work towards finding questions that fit the answer.

/a

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 22 Sep 2011 14:33:24 -0400

> From: Shekh-Yusef, Rifaat (Rifaat) [[email-masked]]
> 

I think this is a valuable effort to proceed with.  I'm not deeply
concerned with the details of the charter, because we can (and
probably will) adjust them later.  But I think that we now know, at
the highest level, the critical questions that must be investigated.
What is needed next is an environment where we can explore use cases,
functionality, proposed mechanisms, and implementation consequences --
that is, a working group.

Dale

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Thu, 22 Sep 2011 16:36:29 -0400

>In other words, I think it would be foolish to charter a working group with an answer, and then work towards finding questions that fit the answer.
The current charter is mainly a list of open questions; I do not see any answers in there. Do you?

Rifaat

From: Adam Roach [mailto:[email-masked]]
Sent: Thursday, September 22, 2011 1:35 PM
To: Shekh-Yusef, Rifaat (Rifaat)
Cc: Simon Pietro Romano; [email-masked]
Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG

I think you need to work through use cases first, and then determine whether they can all be accomplished through call control alone. Or through just device control. Or if you need a combination of both to satisfy the use cases that people interested in this work have in mind.

In other words, I think it would be foolish to charter a working group with an answer, and then work towards finding questions that fit the answer.

/a

---

From: Adam Roach <[email-masked]>
Date: Thu, 22 Sep 2011 15:41:36 -0500

> any answers in there. Do you?

I was responding to your query regarding pursuing "call control OR 
device control, but not both."

Basically, my statement was: "If you're considering such a change to the 
charter text, stop."

/a

> Rifaat
>
> *From:*Adam Roach [mailto:[email-masked]]
> *Sent:* Thursday, September 22, 2011 1:35 PM
> *To:* Shekh-Yusef, Rifaat (Rifaat)
> *Cc:* Simon Pietro Romano; [email-masked]
> *Subject:* Re: [dispatch] Charter Proposal - Remote Call/Device Control WG
>

---

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 22 Sep 2011 22:57:45 +0200

Hi Rifaat,

> call & device control, quite the opposite. Is that your concern?
No.
> control OR device control, but not both?
Yes. My impression is that call control would be feasible, while device 
control is a can of worms.

Simon
>
> Regards,
>
> Rifaat
>
> *From:*Simon Pietro Romano [mailto:[email-masked]]
> *Sent:* Wednesday, September 21, 2011 1:25 PM
> *Cc:* [email-masked]
> your mind the main issues that came out from our past discussions in 
> the IETF (with special regard to the meeting we had in Quebec City). 
> [email-masked]  <mailto:[email-masked]>
>                   e-mail:[email-masked]  <mailto:[email-masked]>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 22 Sep 2011 17:11:55 -0400

> control is a can of worms.

And yet, call control is at least in part a solved problem, while many 
of the scenarios of interest seem to require some degree of device control.

	Thanks,
	Paul

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Thu, 22 Sep 2011 19:16:53 -0400

My query was to try to understand Simon's question; that does not necessarily mean that I agree with that statement or that I will change the charter proposal because of that.

Rifaat

________________________________
From: Adam Roach [[email-masked]]
Sent: Thursday, September 22, 2011 4:41 PM
To: Shekh-Yusef, Rifaat (Rifaat)
Cc: Simon Pietro Romano; [email-masked]
Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG

I was responding to your query regarding pursuing "call control OR device control, but not both."

Basically, my statement was: "If you're considering such a change to the charter text, stop."

/a

Rifaat

Cc: Simon Pietro Romano; [email-masked]<mailto:[email-masked]>

/a

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Thu, 22 Sep 2011 19:29:49 -0400

Simon,

There are different ideas out there on how to best address the remote call/device control, and the charter was put like this to allow the WG to discuss all these ideas and then decide on the best way going forward.

Regards,
 Rifaat

________________________________
From: Simon Pietro Romano [[email-masked]]
Sent: Thursday, September 22, 2011 4:57 PM
To: Shekh-Yusef, Rifaat (Rifaat)
Cc: [email-masked]
Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG

Hi Rifaat,

I was not trying to suggest that the same protocol would be used for call & device control, quite the opposite. Is that your concern?
No.
Or you are saying that the WG should deal with only either call control OR device control, but not both?
Yes. My impression is that call control would be feasible, while device control is a can of worms.

Simon

Regards,
Rifaat

Cc: [email-masked]<mailto:[email-masked]>

Hi Rifaat and all,

Cheers,

Simon

Hi,

Thanks,

Rifaat

-------

* Others?

dispatch mailing list

--

                            _\\|//_

                            ( O-O )

                    Simon Pietro Romano

                         oooO

                          \ (    (   )

                           \_)    ) /

                                 (_/

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 23 Sep 2011 23:39:54 +0000

I don't mean to argue for or against this work in any way, but the charter seems very odd to me.
> * Will the new mechanism address "call control", "device control" or both?  

Those types of questions are usually answered *before* a WG is chartered, as far as I can recall.  Otherwise it's like saying one of the goals of the Working Group is to define it's own scope.  Well... usually the IETF wants to know the scope before creating a WG.

Also, for some topics DISPATCH needs a "mini-BOF" at a face-to-face IETF meeting, with a presentation(s) on the problem and possible solutions, and the chairs ask for hands on who's interested in the work and would be willing to contribute and such.  Are you planning on doing that for the Taipei meeting? 

-hadriel

---

From: Mary Barnes <[email-masked]>
Date: Mon, 26 Sep 2011 09:40:06 -0500

On Fri, Sep 23, 2011 at 6:39 PM, Hadriel Kaplan <[email-masked]>wrote:

> Those types of questions are usually answered *before* a WG is chartered,
> as far as I can recall.  Otherwise it's like saying one of the goals of the
> Working Group is to define it's own scope.  Well... usually the IETF wants
> to know the scope before creating a WG.
>
> Also, for some topics DISPATCH needs a "mini-BOF" at a face-to-face IETF
> meeting, with a presentation(s) on the problem and possible solutions, and
> the chairs ask for hands on who's interested in the work and would be
> willing to contribute and such.  Are you planning on doing that for the
> Taipei meeting?
>
> -hadriel
>

[MB] Yes, that is the intent of the agenda time for this topic in DISPATCH.
 [/MB]

> > The Session Initiation Protocol (SIP) [RFC3261] provides users with the
> ability to initiate, manage, and terminate multimedia sessions.
> > Many deployments have SIP applications in the SIP signaling path that get
> involved in the setup and management of these multimedia sessions.
> > Third-Party Application might also be interested in interacting with User
> Agents and the setup of multimedia sessions.
> > The purpose of this WG is to evaluate the various available mechanisms or
> proposed mechanism and recommend one or more of them,

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Tue, 27 Sep 2011 08:34:28 -0400

Our intention with the original SIP Action Referral proposal and later on with the INVOKE method proposal was to extend the Remote *Call* Control mechanism defined by the REFER method.
During the discussion of these proposals some people showed interest in a Remote *Device* Control, but it was clear that the line between Remote Call Control and Remote Device Control is blurry.
Different people have different ideas on how to address these needs:
  * One mechanism over SIP should address both Call and Device control
  * SIP should be used for Call control and a non-SIP mechanism for Device control
  * non-SIP mechanism should be used for both Call and Device control

That is the reason for the questions stated below.

In any case, I would welcome any suggestions on how to improve the text of this charter proposal.

Regards,
 Rifaat

> -----Original Message-----
> From: Hadriel Kaplan [mailto:[email-masked]]
> Sent: Friday, September 23, 2011 7:40 PM
> Those types of questions are usually answered *before* a WG is chartered, as
> far as I can recall.  Otherwise it's like saying one of the goals of the
> Working Group is to define it's own scope.  Well... usually the IETF wants to
> know the scope before creating a WG.
> 
> meeting, with a presentation(s) on the problem and possible solutions, and the
> chairs ask for hands on who's interested in the work and would be willing to
> contribute and such.  Are you planning on doing that for the Taipei meeting?
> 
> -hadriel
> 
> 
> 
> > Some of these applications need a mechanism to remotely invoke some actions
> or/and monitor the invocation of actions on a SIP User Agent.
> > The actions that can be invoked by the REFER method are limited, and there
> is a need for more actions by some SIP applications.

---

From: "Richard Shockey" <[email-masked]>
Date: Tue, 27 Sep 2011 12:23:33 -0400

WOW cool ! 

The CIA-  National Security Agency  MI5/MI6  Russian FSB working group.  Is
this going to be coordinated with RTC-WEB where there are no privacy
security controls on the browser UA? 

 

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Mary Barnes
Sent: Monday, September 26, 2011 10:40 AM
To: Hadriel Kaplan
Cc: [email-masked]
Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG

On Fri, Sep 23, 2011 at 6:39 PM, Hadriel Kaplan <[email-masked]>
wrote:

I don't mean to argue for or against this work in any way, but the charter
seems very odd to me.
I could be totally wrong, but I don't think WG charters usually have goals

-hadriel

---

From: Daryl Malas <[email-masked]>
Date: Tue, 27 Sep 2011 16:22:23 -0600

I agree with Hadriel's comments/questions.  --Daryl

On 9/23/11 5:39 PM, "Hadriel Kaplan" <[email-masked]> wrote:

>I could be totally wrong, but I don't think WG charters usually have
>goals like the first two you have listed:
>as far as I can recall.  Otherwise it's like saying one of the goals of
>the Working Group is to define it's own scope.  Well... usually the IETF
>wants to know the scope before creating a WG.
>
>meeting, with a presentation(s) on the problem and possible solutions,
>and the chairs ask for hands on who's interested in the work and would be