Subject: [dispatch] Charter Proposal: SIP-XMPP Mapping

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 15 Feb 2013 15:37:36 -0700

Charter Proposal: SIP-XMPP Mapping
DISPATCH WG
IETF 86, Orlando

Problem Statement

The IETF has defined two signalling technologies that can be used
for multimedia session negotiation, instant messaging, presence,
file transfer, capabilities discovery, notifications, and other types of
real-time functionality:

o  The Session Initiation Protocol (SIP), along with various SIP
   extensions developed within the SIP for Instant Messaging and
   Presence Leveraging Extensions (SIMPLE) Working Group.

o  The Extensible Messaging and Presence Protocol (XMPP), along
   with various XMPP extensions developed by the IETF as well as by
   the XMPP Standards Foundation.

SIP has been focused primarily on media session negotiation (e.g. audio
and video), whereas XMPP has been focused primarily on messaging and
presence.  As a result, the technologies are mostly complementary.
However, there is also some overlap between SIP and XMPP, since there
are SIP extensions for messaging, presence, groupchat, file transfer
(etc.) and there are XMPP extensions for multimedia session negotiation.
This overlap has practical implications, since some deployed services
use SIP for both media and (broadly) messaging, whereas other deployed
services use XMPP for both messaging and media.  When such services wish
to exchange information, they often need to translate their native
protocol (either SIP or XMPP) to the other protocol (either XMPP or
SIP).

Implementers needing to perform such protocol mappings have often worked
out their own heuristics for doing so.  Unfortunately, these heuristics
are not always consistent, which can lead to interoperability problems.

Objectives

To make it easier for implementers to enable interworking between
SIP-based systems and XMPP-based systems, several Internet-Drafts have
defined guidelines for protocol mapping between SIP and XMPP, starting
with draft-saintandre-xmpp-simple-00 in early 2004.  The current
documents are:

draft-saintandre-sip-xmpp-core
draft-saintandre-sip-xmpp-presence
draft-saintandre-sip-xmpp-im
draft-saintandre-sip-xmpp-chat
draft-saintandre-sip-xmpp-groupchat

These documents are quite stable and the authors have received feedback
from a number of implementers over the years.  However, implementers do
not always know about these documents because they are Internet-Drafts
and sometimes have expired.  Thus it would be helpful to polish them off
and publish them as RFCs (and perhaps other documents in the same series,
covering topics like media signalling, capabilities discovery, and file
transfer).

Deliverables

1. Address mapping and error handling
2. Presence mapping
3. Mapping for single instant messages
4. Mapping for one-to-one text chat sessions
5. Mapping for multi-user text chat sessions

Any additional work would require a recharter.

Milestones

To be determined.

###

---

From: "Christou, Christos [USA]" <[email-masked]>
Date: Tue, 19 Feb 2013 02:32:22 +0000

Peter,

I definitely support this work since reviewing and finalizing these documents will be critical to enabling the interworking between these two important protocols.  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Friday, February 15, 2013 5:38 PM
To: DISPATCH
Subject: [External] [dispatch] Charter Proposal: SIP-XMPP Mapping

Problem Statement

The IETF has defined two signalling technologies that can be used for multimedia session negotiation, instant messaging, presence, file transfer, capabilities discovery, notifications, and other types of real-time functionality:

SIP has been focused primarily on media session negotiation (e.g. audio and video), whereas XMPP has been focused primarily on messaging and presence.  As a result, the technologies are mostly complementary.
However, there is also some overlap between SIP and XMPP, since there are SIP extensions for messaging, presence, groupchat, file transfer
(etc.) and there are XMPP extensions for multimedia session negotiation.
This overlap has practical implications, since some deployed services use SIP for both media and (broadly) messaging, whereas other deployed services use XMPP for both messaging and media.  When such services wish to exchange information, they often need to translate their native protocol (either SIP or XMPP) to the other protocol (either XMPP or SIP).

Implementers needing to perform such protocol mappings have often worked out their own heuristics for doing so.  Unfortunately, these heuristics are not always consistent, which can lead to interoperability problems.

Objectives

To make it easier for implementers to enable interworking between SIP-based systems and XMPP-based systems, several Internet-Drafts have defined guidelines for protocol mapping between SIP and XMPP, starting with draft-saintandre-xmpp-simple-00 in early 2004.  The current documents are:

These documents are quite stable and the authors have received feedback from a number of implementers over the years.  However, implementers do not always know about these documents because they are Internet-Drafts and sometimes have expired.  Thus it would be helpful to polish them off and publish them as RFCs (and perhaps other documents in the same series, covering topics like media signalling, capabilities discovery, and file transfer).

Deliverables

1. Address mapping and error handling
2. Presence mapping
3. Mapping for single instant messages
4. Mapping for one-to-one text chat sessions 5. Mapping for multi-user text chat sessions

Milestones

To be determined.

###

_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Ben Campbell <[email-masked]>
Date: Tue, 19 Feb 2013 14:49:37 -0600

I also support moving this forward.

---

From: Simon Pietro Romano <[email-masked]>
Date: Wed, 20 Feb 2013 09:19:37 +0100

I strongly support this work.

Simon

> Any additional work would require a recharter.

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento Ë l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Lorenzo Miniero <[email-masked]>
Date: Wed, 20 Feb 2013 11:04:31 +0100

Me too, especially considering there's a strong basis of pre-existing
work to start from.

L.

Il giorno Wed, 20 Feb 2013 09:19:37 +0100
Simon Pietro Romano <[email-masked]> ha scritto:

> > file transfer, capabilities discovery, notifications, and other
> > types of real-time functionality:
> > 
> > SIP has been focused primarily on media session negotiation (e.g.
> > audio and video), whereas XMPP has been focused primarily on
> > messaging and presence.  As a result, the technologies are mostly
> > complementary. However, there is also some overlap between SIP and
> > XMPP, since there are SIP extensions for messaging, presence,
> > groupchat, file transfer (etc.) and there are XMPP extensions for
> > multimedia session negotiation. This overlap has practical
> > implications, since some deployed services use SIP for both media
> > and (broadly) messaging, whereas other deployed services use XMPP
> > for both messaging and media.  When such services wish to exchange
> > information, they often need to translate their native protocol
> > (either SIP or XMPP) to the other protocol (either XMPP or SIP).
> > 
> > Implementers needing to perform such protocol mappings have often
> > worked out their own heuristics for doing so.  Unfortunately, these
> > heuristics are not always consistent, which can lead to
> > interoperability problems.
> > 
> > Objectives
> > 
> > SIP-based systems and XMPP-based systems, several Internet-Drafts
> > have defined guidelines for protocol mapping between SIP and XMPP,
> > starting with draft-saintandre-xmpp-simple-00 in early 2004.  The
> > current documents are:
> > 
> > These documents are quite stable and the authors have received
> > feedback from a number of implementers over the years.  However,
> > implementers do not always know about these documents because they
> > are Internet-Drafts and sometimes have expired.  Thus it would be
> > helpful to polish them off and publish them as RFCs (and perhaps
> > other documents in the same series, covering topics like media
> > signalling, capabilities discovery, and file transfer).
> > 
> > Deliverables
> > 
>                     				Simon Pietro
> Romano Universita' di Napoli Federico II
> 		    <<Molti mi dicono che lo scoraggiamento Ë l'alibi
> degli idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
>                			                     oooO
> 					                 \
> (            (   ) \_)          ) /

-- 
Lorenzo Miniero, COB

Meetecho s.r.l.
Web Conferencing and Collaboration Tools
http://www.meetecho.com

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 20 Feb 2013 22:42:44 +0200

I do support this proposal

/Sal

-- 
Salvatore Loreto, PhD
www.sloreto.com

---

From: Emil Ivov <[email-masked]>
Date: Wed, 20 Feb 2013 21:46:32 +0100

Mapping SIP to XMPP is something I personally view as very important and
this proposal seems very reasonable and well targeted at addressing the
issue.

Emil

-- 
https://jitsi.org

---

From: Michael Lundberg <[email-masked]>
Date: Wed, 20 Feb 2013 15:55:23 -0500

I strongly support this proposal!

Michael

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Wed, 20 Feb 2013 22:03:25 +0100

> this proposal seems very reasonable and well targeted at addressing the

+1.

--
Saúl Ibarra Corretgé
AG Projects

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 21 Feb 2013 14:37:36 -0700

On 2/15/13 3:37 PM, Peter Saint-Andre wrote:

<snip/>

> The current documents are:
> 
> draft-saintandre-sip-xmpp-core draft-saintandre-sip-xmpp-presence 
> draft-saintandre-sip-xmpp-im draft-saintandre-sip-xmpp-chat 
> feedback from a number of implementers over the years.

Another document is draft-saintandre-sip-xmpp-media (republished last
night). It and the groupchat spec are a bit less polished, but I think
they can be cleaned up fairly quickly (and it seems that I'll have a
new co-author on one or both of them to get these done). Just FYI...

Peter

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/