Subject: [dispatch] Use of BFCP or MSRP over datachannel or websocket

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 28 Mar 2013 12:35:43 +0000

>From what I have seen of the discussion so far, there appears to be a body of support that there is a use case for both BFCP and MSRP over websocket, for use in a non-rtcweb environment.

If when we get to the rtcweb environment we allow this, and also allow a usage over datachannel version, we essentially have two solutions in the market place.

If that occurs, what guidance will we give to a rtcweb developer as to which to implement?

Or do we envisage that only one will be allowed (and if so which) in an rtcweb environment?

Regards

Keith

---

From: Mary Barnes <[email-masked]>
Date: Thu, 28 Mar 2013 09:58:24 -0500

I don't think it's the job of dispatch or BFCPbis WG to define or even
make recommendations for RTCWEB.  That choice is up to the RTCWEB WG
and it shouldn't be influencing this work.  There are applications
other than RTCWEB that can and will make use of BFCPbis over
websockets.  I really don't understand why we are getting so hung up
on this - it's the BFCP messages themselves that are important - how
one chooses to transport is up to the application.

Mary.

On Thu, Mar 28, 2013 at 7:35 AM, DRAGE, Keith (Keith)
<[email-masked]> wrote:
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 29 Mar 2013 00:10:45 +0800

> If when we get to the rtcweb environment we allow this, and also allow a usage over datachannel version, we essentially have two solutions in the market place.

Two choices for the rtcweb developer and *four* for the sip developer!!!
And sip developers might find themselves gatewayed to rtcweb applications.

> Or do we envisage that only one will be allowed (and if so which) in an rtcweb environment?

That is the dilemma! Less is better.

	Thanks,
	Paul

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Thu, 28 Mar 2013 17:50:27 +0100

> Or do we envisage that only one will be allowed (and if so which) in an rtcweb environment?

What do you consider to be a "rtcweb developer"?

The developers of the webrtc browsers? They do not need to implement 
anything.
The developers of server side webrtc products (i.e. conference servers)? 
Been one of them, I can tell you that websockets is my preferred option.
The developers of  a service using webrtc? They will either use (not 
implement) datachannels if no server component is involved or whatever 
their server provides otherwise.

As someone else in the list pointed out, the main thing is to be define 
the JSON serialization of the BCFP messages and let anyone choose their 
preferred transport. Even BFCP over MSRP over websockets could be used.. :P

Best regards
Sergio

---

From: "Parthasarathi R" <[email-masked]>
Date: Sun, 31 Mar 2013 22:22:27 +0530

The compelling reason for this draft is RTCWeb. In case of non-RTCWeb, 
TCP Shall be used which avoids the overhead introduced due to 
WebSocket. Please clarify in case WebSocket has some specific 
advantage over TCP in non-RTCWeb environment.

In case dispatch or BFCPbis are not the right WG to make recommendation, 
then let us discuss in RTCWeb WG itself. Also, Please suggest if any 
other mailing list like ([email-masked]) is the right place to discuss.

Thanks
Partha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mary Barnes
> Sent: Thursday, March 28, 2013 8:28 PM
> To: DRAGE, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [dispatch] Use of BFCP or MSRP over datachannel or
> websocket
> 
> > From what I have seen of the discussion so far, there appears to be a
> body of support that there is a use case for both BFCP and MSRP over
> websocket, for use in a non-rtcweb environment.
> >
> > If when we get to the rtcweb environment we allow this, and also
> allow a usage over datachannel version, we essentially have two
> solutions in the market place.
> >