Subject: [dispatch] New versions of draft-montemurro-gsma-imei-urn and draft-allen-dispatch-imei-urn-as-instanceid

From: Andrew Allen <[email-masked]>
Date: Mon, 8 Jul 2013 18:10:30 +0000

New versions of draft-montemurro-gsma-imei-urn and draft-allen-dispatch-imei-urn-as-instanceid were recently submitted

http://www.ietf.org/internet-drafts/draft-montemurro-gsma-imei-urn-15.txt
The diff from version 14 is at:

http://www.ietf.org/rfcdiff?url2=draft-montemurro-gsma-imei-urn-15

http://www.ietf.org/internet-drafts/draft-allen-dispatch-imei-urn-as-instanceid-10.txt
The diff from version 9 is at:
http://www.ietf.org/rfcdiff?url2=draft-allen-dispatch-imei-urn-as-instanceid-10

These versions reflect the PROTO review comments.

The following significant changes have been made:

draft-montemurro-gsma-imei-urn:

1.       Corrections to the ABNF based on output from Bill Fenner's tool:

http://tools.ietf.org/tools/bap/abnf.cgi.
and also corrected an error that would have resulted in a superfluous "=" in the case of a parameter without a value.
Also the IMEI ABNF has been linked together with the URN ABNF for a single complete ABNF.

2.       The section regarding binary encoding of the IMEI has been rewritten and clarified.

3.       The dates of the referenced 3GPP specifications have been updated to the latest versions.

4.       Various editorial and formatting corrections have been made.

draft-allen-dispatch-imei-urn-as-instanceid:

1.       The MSC Server for SR-VCC has been included in the text - this is another element in the 3GPP architecture that for the purposes of the draft performs similar functions to the MSC Server for ICS which was already mentioned.

2.       The UAC and UAS sections have been modified with reference to sending of responses removed from the UAC section and the requirement for an RFC for inclusion of an instance-id containing the IMEI in a Non-REGISTER or non-Emergency session related response also added to the UAS section.

5.       An IANA considerations section has been added (even though there is nothing for IANA to do) since this is required.

6.       The dates of the referenced 3GPP specifications have been updated to the latest versions.

7.       Various editorial and formatting corrections have been made.

I would especially like to thank James Yu for the extensive review of both drafts and his comments which uncovered several issues and greatly contributed to the readability of the documents.

The only outstanding issue I am aware of is Keith Drage's comment of May 25th which asks why RFC required and not specification required for inclusion of an instance-id containing the IMEI in a Non-REGISTER or non-Emergency session related response. I have asked Cullen to respond to this as it was his request to require additional RFCs for any future expansion of the usage.

Thanks
Andrew

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Fri, 26 Jul 2013 16:16:05 +0000

FWIW … I reviewed theses changes and they all looked good to me.

On Jul 8, 2013, at 12:10 PM, Andrew Allen <[email-masked]> wrote:

> and also corrected an error that would have resulted in a superfluous “=” in the case of a parameter without a value.
> 1.       The MSC Server for SR-VCC has been included in the text – this is another element in the 3GPP architecture that for the purposes of the draft performs similar functions to the MSC Server for ICS which was already mentioned.
>  
> The only outstanding issue I am aware of is Keith Drage’s comment of May 25th which asks why RFC required and not specification required for inclusion of an instance-id containing the IMEI in a Non-REGISTER or non-Emergency session related response. I have asked Cullen to respond to this as it was his request to require additional RFCs for any future expansion of the usage.
>  
> Thanks
> Andrew
>  
>  
> This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful. _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch