Subject: [dispatch] FW: New Version Notification for draft-klatsky-dispatch-ipv6-impact-ipv4-01.txt

From: "Klatsky, Carl" <[email-masked]>
Date: Tue, 9 Jul 2013 18:30:04 +0000

Hi,

On behalf of the authors of this draft, a new version has been uploaded to address comments raised here on the dispatch list.  Additional feedback on this version if the draft is requested.

Thanks & Regards,
 
Carl Klatsky
Comcast

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, July 09, 2013 2:02 PM
To: Olle E.Johansson; Gonzalo Salgueiro; Rifaat Shekh-Yusef; Klatsky, Carl; Andrew Hutton
Subject: New Version Notification for draft-klatsky-dispatch-ipv6-impact-ipv4-01.txt

A new version of I-D, draft-klatsky-dispatch-ipv6-impact-ipv4-01.txt
has been successfully submitted by Carl Klatsky and posted to the IETF repository.

Filename:	 draft-klatsky-dispatch-ipv6-impact-ipv4
Revision:	 01
Title:		 Interoperability Impacts of IPv6 Interworking with Existing IPv4 SIP Implementations
Creation date:	 2013-07-09
Group:		 Individual Submission
Number of pages: 10
URL:             http://www.ietf.org/internet-drafts/draft-klatsky-dispatch-ipv6-impact-ipv4-01.txt
Status:          http://datatracker.ietf.org/doc/draft-klatsky-dispatch-ipv6-impact-ipv4
Htmlized:        http://tools.ietf.org/html/draft-klatsky-dispatch-ipv6-impact-ipv4-01
Diff:            http://www.ietf.org/rfcdiff?url2=draft-klatsky-dispatch-ipv6-impact-ipv4-01

Abstract:
   This document captures potential impacts to IPv4 SIP implementations
   when interworking with IPv6 SIP implementations.  Although some
   amount of interworking translation will occur at the network and
   application layers, an IPv4 SIP application may still encounter a SIP
   message with some IPv6 values in it, resulting in unforeseen error
   conditions.  Such potential scenarios will be identified in this
   document so that SIP application developers can define solutions to
   handle these cases.  Note, this document is not intended to be an
   exhaustive list, rather to provide an overview of some of the more
   commonly encountered potential scenarios.

The IETF Secretariat

---

From: "Neelakantan, Neel" <[email-masked]>
Date: Fri, 12 Jul 2013 05:07:43 +0000

The updates look good.  The goal is to enhance the interoperability between combination of IPv4 and IPv6 entities.

For IPv4 guidelines,

It will be good idea to talk about the impact of call forking involving combination of  IPv4/IPV6.  One case come to mind is

Say UAC is IPv4  only, call gets forked by SIP Proxy to few IPv4 and IPv6 only endpoints.  When the provisional responses are received from IPv6 only, the UAC should potentially disconnect (BYE) the early dialogs to prevent any incompatibility due to ipv4/ipv6.   Not doing so, may lead to failure, if IPv6 endpoint sends 200 OK.  The SIP proxy in the middle would start CANCEL other forks.

For IPv6 guidelines,

The offer/answer does not include IP Address in negotiation aspects and doesn’t distinguish IPv4/IPv6.  If the dual stack IPv4/IPv6 UAS receives an INVITE from IPv4 endpoint, based on Contact information, it should respond using the offer (IPv4/IPv6) in media/c= for better interoperability.

The IPv4 endpoint should be able to parse a IPv6 SIP fields.  It is worthwhile add reference for IPV6 Torture test cases for IPV6/IPv4 interoperability. (RFC 5118).

Thanks,
Neel.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Klatsky, Carl
> Sent: Tuesday, July 09, 2013 1:30 PM
> To: [email-masked]'
> Subject: [dispatch] FW: New Version Notification for draft-klatsky-dispatch-
> ipv6-impact-ipv4-01.txt
> 
> Hi,
> 
> On behalf of the authors of this draft, a new version has been uploaded to
> address comments raised here on the dispatch list.  Additional feedback on
> this version if the draft is requested.
> 
> Thanks & Regards,
> 
> Carl Klatsky
> Comcast
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Neelakantan, Neel" <[email-masked]>
Date: Fri, 12 Jul 2013 14:14:30 +0000

I see ipv6/ipv4 no different than say PRACK or any other option tags that is used for both endpoints (UAC/UAS) to support the feature.  Probably something along the lines of Supported: ipv6/ipv4 would help better interoperability.  For example, a IPv4 endpoint which implemented Require/Supported handling might better respond to IPv6 SDP.

Thanks,

Neel

________________________________________
From: Neelakantan, Neel
Sent: Friday, July 12, 2013 12:07 AM
To: Klatsky, Carl; [email-masked]'
Subject: RE: [dispatch] FW: New Version Notification    for     draft-klatsky-dispatch-ipv6-impact-ipv4-01.txt

For IPv4 guidelines,

For IPv6 guidelines,

Thanks,
Neel.