Subject: [dispatch] Fwd: New Version Notification for draft-johansson-sip-dual-stack-01.txt

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 30 Jul 2013 13:24:03 +0200

Hi!

Gonzalo and I have updated our draft that updates RFC 3263 so that DNS lookups are done for both
IPv4 and IPv6 at the same time. Changes in this version are:

- Slightly re-organized the document content layout
- Expanded and added some clarity to the text dealing with the "DNS Procedures in a Dual-Stack Network"
- Added some language to the Security Considerations section
- Made editorial, grammatical and idnits fixes throughout

We do think this belongs in SIPcore and have discussed this with the chairs of that wg, whcih both seems to agree.

/Olle

Vidarebefordrat brev:

> Från: [email-masked]
> Ämne: New Version Notification for draft-johansson-sip-dual-stack-01.txt
> Datum: 30 juli 2013 13:21:20 CEST
> Till: Olle E. Johansson <[email-masked]>, Gonzalo Salgueiro <[email-masked]>
> 
> 
> A new version of I-D, draft-johansson-sip-dual-stack-01.txt
> has been successfully submitted by Olle E. Johansson and posted to the
> IETF repository.
> 
> Filename:	 draft-johansson-sip-dual-stack
> Revision:	 01
> Title:		 Locating Session Initiation Protocol (SIP) Servers in a Dual-Stack IP Network
> Creation date:	 2013-07-30
> Group:		 Individual Submission
> Number of pages: 6
> URL:             http://www.ietf.org/internet-drafts/draft-johansson-sip-dual-stack-01.txt
> Status:          http://datatracker.ietf.org/doc/draft-johansson-sip-dual-stack
> Htmlized:        http://tools.ietf.org/html/draft-johansson-sip-dual-stack-01
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-johansson-sip-dual-stack-01
> 
> Abstract:
>   RFC 3263 defines how a Session Initiation Protocol (SIP)
>   implementation, given a SIP Uniform Resource Identifier (URI), should
>   locate the next hop SIP server using Domain Name System (DNS)
>   procedures.  The specification repeatedly states that the
>   implementation should look up IPv4 or IPv6 addresses.  This is not a
>   suitable solution and one that can cause severely degraded user
>   experience dual-stack clients, as detailed in the Happy Eyeballs
>   specification.  This document specifies amended procedures for dual-
>   stack SIP implementations so that they look up both IPv4 and IPv6
>   addresses.  This way, the SIP implementation can find the preferred
>   network path and protocol with an improved chance of successfully
>   reaching the desired service.  This document also clarifies DNS SRV
>   usage for single-stack clients.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

---
* Olle E Johansson - [email-masked]
* Cell phone +46 70 593 68 51, Office +46 8 96 40 20, Sweden

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 30 Jul 2013 16:27:09 +0200

> We do think this belongs in SIPcore and have discussed this with the chairs of that wg, whcih both seems to agree.

Sorry for forgetting to rename the document to reflect the wg... Still learning the process, but obviously very slowly...

/O